Subject: Re: [Sip] B2B-UA's provide an unsolveable identity problem (was RE: submission of a new I-D: "Dialog Event foRIdentityVErification")

From: Jiri Kuthan <[email-masked]>
Date: Mon, 03 Nov 2008 12:52:27 +0100

I personally don't think that the matter of a B2BUA is a showstopping
one -- a B2BUA, which is a largely underspecified element, can  be still
built in a way that DERIVE will work. (by not mangling callid, by 
responding
on UAS's behalf....)

I think it would be reasonable to mention when DERIVE fails though ....

-jiri

Attila Sipos wrote:
>>> i strongly disagree.  b2bua is just an ua.  if you you build or deploy
>>> such boxes, it is your headache, not sip wg's.
> 
> I agree with Juha here.
> 
> Every attempt at fixing identity problems (and they have been clever
> solutions) has been hindered with the "but it won't work with B2BUAs"
> argument.
> 
> The problem is not "it won't work with B2BUAs" - the  problem is that
> B2BUA identity and security problems are unsolveable anyway. A B2BUA
> cannot be forced to do anything because even if you said "it must do
> this and that", a B2BUA can do what it wants anyway (I'm sure we've all
> seen this).  Even if B2BUAs agreed to do certain things, one would
> always enf up with something else that gets B2B'ed.
> 
> It is no different to trying to solve the problem of 2 telephones taped
> together.
> 
> You can only trust things up to a certain boundary.  And the boundaries
> of SIP are the UAs.  The best that SIP can do is to control what happens
> between a UA and another UA (and proxies in between) and that's it.
> 
> Regards,
> 
> Attila
> 
> 
>  
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Juha Heinanen
> Sent: 31 October 2008 06:31
> To: Elwell, John
> Cc: [email-masked]; Dan Wing
> Subject: Re: [Sip] submission of a new I-D: "Dialog Event
> foRIdentityVErification"
> 
> Elwell, John writes:
> 
>  > > I support draft-kuthan-sip-derive-00, and hope the WG can devote  >
>> time and energy to improving and standardizing it to work well  > >
> across a variety of networks.
>  > [JRE] I agree. This must include networks that contain B2BUAs/SBCs.
> 
> i strongly disagree.  b2bua is just an ua.  if you you build or deploy
> such boxes, it is your headache, not sip wg's.  it is enough that this
> work is based on rfc3261 components.
> 
> -- juha
> 
> 
> _______________________________________________
> Sip mailing list  https://www.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol Use
> [email-masked] for questions on current sip Use
> [email-masked] for new developments on the application of sip
> _______________________________________________
> Sip mailing list  https://www.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> 
_______________________________________________
Sip mailing list  https://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Elwell, John" <[email-masked]>
Date: Thu, 06 Nov 2008 08:03:02 +0000

Just catching up on this thread. Basically there are some things that
many B2BUAs/SBCs do for good reason, e.g., media steering, which was
discussed at the last IETF. We need to come up with a solution to e2e
identity that works through B2BUAs that, because of the role they play
(as demanded by their customers, presumably), cannot comply with RFC
3261 rules for proxies. In other words, a solution that a well-meaning
B2BUA vendor could comply with. Of course, we can't deal with the B2BUA
that deliberately sets out to stop e2e identity working.

John  

> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Jiri Kuthan
> Sent: 03 November 2008 11:52
> To: Attila Sipos
> Cc: [email-masked]; Elwell, John; Dan Wing
> Subject: Re: [Sip] B2B-UA's provide an unsolveable identity 
> problem (was RE: submission of a new I-D: "Dialog Event 
> foRIdentityVErification")
>

---

From: Henry Sinnreich <[email-masked]>
Date: Thu, 06 Nov 2008 08:52:31 -0600

John,

> Of course, we can't deal with the B2BUA

This is a key point indeed and I fully agree.

Just don't stop at the need for e2e identity.
It's for everything else as well!

No need to repeat here on why...

All these efforts to accommodate B2BUA are a Faustian bargain that's coming
back for payment - with the soul of IP. Too bad such accommodation efforts
are still going on in the SIP related WGs.

Henry

On 11/6/08 2:03 AM, "Elwell, John" <[email-masked]> wrote:

>> Behalf Of