Subject: [Sip] Query on draft-ietf-sip-body-handling-04- Can required multipart/mixed contain required body part

From: "Rockson Li (zhengyli)" <[email-masked]>
Date: Tue, 4 Nov 2008 13:14:33 +0800

Hi folks,
 
sec 7.2 of draft-ietf-sip-body-handling-04
 
      Also per the previous rules, a 'multipart/mixed' body whose
      handling is required can contain only body parts whose handling is
      optional.
 
I wonder why required multipart/mixed can NOT contain required body
part?
I think it's just same meaning repeated once, should be fine.
 
any thoughts?
 
thanks
-Rockson
_______________________________________________
Sip mailing list  https://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Gonzalo Camarillo <[email-masked]>
Date: Tue, 18 Nov 2008 18:59:42 +0200

Hi,

> I wonder why required multipart/mixed can NOT contain required body part?

note that the verb is "can". That is, it is possible that all the body 
parts are optional... but that is not the only possibility. The 
possibility you mention (i.e., a required body part within a required 
multipart/mixed) is also possible. That paragraph you are referring to 
simply points out cases that may be surprising for readers, per earlier 
mailing list discussions, so that they are clearer.

Thanks,

Gonzalo