Subject: [Sip] what should be DERIVEd from the IETF?

From: Hadriel Kaplan <[email-masked]>
Date: Mon, 8 Dec 2008 16:56:54 -0500

Hi Jiri,
I can definitely see the pro's/con's of it, and think it's interesting as a BTNS trick; though probably not for my particular customer types per se.

But I actually have a very different question about the draft:
Why did you submit it to the IETF SIP WG?

By that I mean it should interoperate without any protocol changes AFAICT, and anyone can do it right now.  So if you just want to document it publicly as an option anyone can do anytime, why not just submit an Informational doc to SIPPING, or even just as an individual informational draft? (and avoid the hassle ;)

If you want it to work across all domains with their unique policies and such, and get people to comment on all the nuances they are worried about, well then that's a horse of a different color.  But I'm really just curious what you're trying to achieve, so I can know what types of comments you're looking for.

-hadriel
p.s. sorry if you answered that already - I may have missed it.
_______________________________________________
Sip mailing list  https://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Jiri Kuthan <[email-masked]>
Date: Wed, 10 Dec 2008 23:02:39 +0100

> By that I mean it should interoperate without any protocol changes AFAICT, and anyone can do it right now.  So if you just want to document it publicly as an option anyone can do anytime, why not j…

Hi Hadriel,

The interest for me is how can we create something that will
help against From spoofing and have a close-to-zero-introduction cost
with incentives for those paying it. Generally I think reverse
checks are quite effective in that (also due to the link to DNS name, which
establishes a relationship to a paying entity ... identity is not entirely
worthless).

I'm not yet really sure which would be the "best deployable 
reverse-checking"
mechanism, and thus neither what is the best place for working on it.
If it was sip/dialog-based as right now, SIPPING/BCP would seem 
appropriate to me.
But perhaps the initial debate will hint at DNS just to avoid the
SIP complexity at the loss of per-dialog granularity. I would be less
sure where to place it then.

-jiri