Subject: [Sip] Resubmitted INVITE request for 421 and 420

From: "Vavilapalli Srikanth-A19563" <[email-masked]>
Date: Thu, 4 Dec 2008 17:36:03 +0800

Hi
 
I have a doubt related to resubmitting of the INVITE request for
421/420. Can any one please clarify me?  
 
While re-submitting a INVITE request upon receiving a 421 Extension
Required/420 Bad Extension, Are there any recommendation of using the
same Call-Id/From tag of original INVITE request in the resubmitted
request? If so, is there any reason/use-case for such recommendation?
 
Regards
Srikanth
_______________________________________________
Sip mailing list  https://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "BONNAERENS Ben" <[email-masked]>
Date: Thu, 4 Dec 2008 10:48:15 +0100

Hi,
 
RFC3261 8.1.3.5 is pretty clear:
 
"   In all of the above cases, the request is retried by creating a new
   request with the appropriate modifications.  This new request
   constitutes a new transaction and SHOULD have the same value of the
   Call-ID, To, and From of the previous request, but the CSeq should
   contain a new sequence number that is one higher than the previous."
 
Best regards,
Ben.
 
Ps: Ask questions about the existing protocol at the sip-implementors
list

________________________________

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Vavilapalli Srikanth-A19563
Sent: donderdag 4 december 2008 10:36
To: [email-masked]
Subject: [Sip] Resubmitted INVITE request for 421 and 420

Hi

 
Regards
Srikanth

---

From: "Vavilapalli Srikanth-A19563" <[email-masked]>
Date: Thu, 4 Dec 2008 20:35:52 +0800

Thanks Ben
 
I have few more questions on this topic, but as u pointed I will
continue the discussion on sip-implementers list.

From: [email-masked] [mailto:[email-masked]] On Behalf Of
BONNAERENS Ben
Sent: Thursday, December 04, 2008 3:18 PM
To: [email-masked]
Subject: Re: [Sip] Resubmitted INVITE request for 421 and 420

Hi,

 
Best regards,
Ben.

Hi

 
Regards
Srikanth

---

From: "Dale Worley" <[email-masked]>
Date: Thu, 04 Dec 2008 15:32:29 -0500

On Thu, 2008-12-04 at 17:36 +0800, Vavilapalli Srikanth-A19563 wrote:
> I have a doubt related to resubmitting of the INVITE request
> for 421/420. Can any one please clarify me?  
>  

If the UAC can modify the INVITE to not user or require the extension in
question, but nonetheless perform the "same" operation (in some sense),
then it would be reasonable for the UAC to re-submit the new INVITE
using the same Call-Id and an incremented CSeq.  (This is in parallel
with all other uses of re-submission.)

But I have never heard of a case where re-submission could be used to
recover from 420/421.

Dale