Subject: [Sip] INFO: Proposal - read this first

From: "Christer Holmberg" <[email-masked]>
Date: Sun, 7 Dec 2008 11:20:32 +0100

Ok,

Before you reply to my other e-mail related to INFO and multipart,
please read this proposal first:

1. We only allow a single info package per INFO message (I know that I
am the main reason that we are still discussing this, but I am willing
to give in in order to progress).

2. The info package description defines the "context", ie what SIP
headers and/or body parts (including C-T values for those body parts)
are associated with a specific info package.

   - NOTE: I assume that a SINGLE info package could specify the usage
of MULTIPLE body parts. Correct?

3. If someone adds additional body parts (e.g. geoloc) to an INFO
request, which is outside the context of the specific info package for
the INFO, it is outside the scope of the info package description (and
the info event specification) to define how it is handled (in the case
of geoloc, the geoloc description should describe how it is used, and
where it is used).

4. We remove all text about CID from the the Info event draft. Whoever
wants to work with that - write a separate draft.

I believe this should at least be alligned with Hadriel's ideas, right?

Regards,

Christer

_______________________________________________
Sip mailing list  https://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Hadriel Kaplan <[email-masked]>
Date: Sun, 7 Dec 2008 11:38:59 -0500

Yes exactly.
My idea was to essentially align it with how Event-packages are syntactically and semantically done for SUB/NOT/PUB.
They're different namespaces, but essentially "Info-Package:" is INFO's version of "Event:".
-hadriel

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Christer Holmberg
Sent: Sunday, December 07, 2008 5:21 AM
To: SIP List
Subject: [Sip] INFO: Proposal - read this first

Ok,

Before you reply to my other e-mail related to INFO and multipart, please read this proposal first:

1. We only allow a single info package per INFO message (I know that I am the main reason that we are still discussing this, but I am willing to give in in order to progress).

2. The info package description defines the "context", ie what SIP headers and/or body parts (including C-T values for those body parts) are associated with a specific info package.

   - NOTE: I assume that a SINGLE info package could specify the usage of MULTIPLE body parts. Correct?

3. If someone adds additional body parts (e.g. geoloc) to an INFO request, which is outside the context of the specific info package for the INFO, it is outside the scope of the info package description (and the info event specification) to define how it is handled (in the case of geoloc, the geoloc description should describe how it is used, and where it is used).

4. We remove all text about CID from the the Info event draft. Whoever wants to work with that - write a separate draft.

Regards,

Christer