Subject: [Sip] Two Media Stream in One call

From: Nitin Kapoor <[email-masked]>
Date: Thu, 10 Dec 2009 08:10:45 -0500

Hello All,

I am facing the issue with one of my customer where he is getting two media
streams in one call and they are using SBC(Nextone)

I checked the signaling traces and everything looks okay to me as well as
the RTP traces too.

As per the traces one  RTP packet is going from 64.156.174.71 and the other
is coming from 8.15.244.11.

Could you please let me know is it possible where i can have the two media
streams in one call when this is the not the conference call. And if this is
possible then what is the scenario where its possible.

Please find the attached traces for the same.

Thanks,
Nitin Kapoor
General Telecom

---

From: "Roni Even" <[email-masked]>
Date: Thu, 10 Dec 2009 15:32:38 +0200

Hi,

To know the answer you need to provide the SDP in the offer and answer.

If the offer/answer SDP defined two media streams, or N media streams this
is probably OK.

Roni Even

From: [email-masked] [mailto:[email-masked]] On Behalf Of Nitin
Kapoor
Sent: Thursday, December 10, 2009 3:11 PM
To: [email-masked]
Subject: [Sip] Two Media Stream in One call

Hello All,

Thanks,
Nitin Kapoor
General Telecom

---

From: "Christer Holmberg" <[email-masked]>
Date: Thu, 10 Dec 2009 14:53:34 +0100

Hi,

It is possible.

In theory this could be done with a single c- line, because SDP only talks about where media is to be sent - not where it comes from.

In reality, however, I assume this is a case where each m- line has its own c- line, each with a different IP address.

Regards,

Christer

-----Original Message-----
From: [email-masked] on behalf of Nitin Kapoor
Sent: Thu 12/10/2009 2:10 PM
To: [email-masked]
Subject: [Sip] Two Media Stream in One call
 
Hello All,

Thanks,
Nitin Kapoor
General Telecom

---

From: Nitin Kapoor <[email-masked]>
Date: Thu, 10 Dec 2009 10:46:56 -0500

> Hello,
>
> Below is the packet in UDP format, Could you please help me on this to
> understand this scenario. Also attached is the complete traces.
>
> INVITE sip:[email-masked]<[email-masked]>SIP/2.0
>
> Max-Forwards: 69
>
> Session-Expires: 3600;refresher=uac
>
> Supported: timer, 100rel
>
> To: <sip:[email-masked]<[email-masked]>
> >
>
> From: <sip:8003223223@tmsash1-15-sip>;tag=3468945569-250042
>
> Call-ID: [email-masked]
>
> CSeq: 1 INVITE
>
> Allow: INVITE, BYE, OPTIONS, CANCEL, ACK, REGISTER, NOTIFY, INFO, REFER,
> SUBSCRIBE, PRACK, UPDATE
>
> Via: SIP/2.0/UDP 8.15.244.10:5060
> ;branch=z9hG4bKf5de4d0e3c0860d122139e1e30a2995c
>
> Contact: <sip:[email-masked]:5060>
>
> Call-Info:
> <sip:8.15.244.10>;method="NOTIFY;Event=telephone-event;Duration=1000"
>
> Content-Type: application/sdp
>
> Content-Length: 124
>
>
>
> v=0
>
> o=mscasheq01 547500705 547500705 IN IP4 8.15.244.10
>
> s=sip call
>
> c=IN IP4 8.15.244.11
>
> t=0 0
>
> m=audio 19612 RTP/AVP 0
>
> SIP/2.0 100 Trying
>
> Via: SIP/2.0/UDP 8.15.244.10:5060
> ;branch=z9hG4bKf5de4d0e3c0860d122139e1e30a2995c
>
> From: <sip:8003223223@tmsash1-15-sip>;tag=3468945569-250042
>
> To: <sip:[email-masked]<[email-masked]>
> >
>
> Call-ID: [email-masked]
>
> CSeq: 1 INVITE
>
> Server: Sansay VSX 2.1
>
> Content-Length: 0
>
>
>
> SIP/2.0 180 Ringing
>
> Via: SIP/2.0/UDP 8.15.244.10:5060
> ;branch=z9hG4bKf5de4d0e3c0860d122139e1e30a2995c
>
> From: <sip:8003223223@tmsash1-15-sip>;tag=3468945569-250042
>
> To: <sip:[email-masked]<[email-masked]>
> >;tag=228209687-tdb1145808424
>
> Call-ID: [email-masked]
>
> CSeq: 1 INVITE
>
> Server: Sansay VSX 2.1
>
> Content-Length: 0
>
>
>
> SIP/2.0 200 OK
>
> Via: SIP/2.0/UDP 8.15.244.10:5060
> ;branch=z9hG4bKf5de4d0e3c0860d122139e1e30a2995c
>
> From: <sip:8003223223@tmsash1-15-sip>;tag=3468945569-250042
>
> To: <sip:[email-masked]<[email-masked]>
> >;tag=228209687-tdb1145808424
>
> Call-ID: [email-masked]
>
> CSeq: 1 INVITE
>
> Server: Sansay VSX 2.1
>
> Contact: <sip:[email-masked]:5060;transport=udp>
>
> Content-Type: application/sdp
>
> Content-Length:   158
>
>
>
> v=0
>
> o=sansay-VSX 10 10 IN IP4 64.156.174.71
>
> s=session controller
>
> c=IN IP4 64.156.174.71
>
> t=0 0
>
> m=audio 10766 RTP/AVP 0
>
> a=rtpmap:0 PCMU/8000
>
> a=ptime:20
>
> ACK sip:[email-masked]:5060;transport=udp SIP/2.0
>
> Max-Forwards: 69
>
> To: <sip:[email-masked]<[email-masked]>
> >;tag=228209687-tdb1145808424
>
> From: <sip:8003223223@tmsash1-15-sip>;tag=3468945569-250042
>
> Call-ID: [email-masked]
>
> CSeq: 1 ACK
>
> Allow: INVITE, BYE, OPTIONS, CANCEL, ACK, REGISTER, NOTIFY, INFO, REFER,
> SUBSCRIBE, PRACK, UPDATE
>
> Via: SIP/2.0/UDP 8.15.244.10:5060
> ;branch=z9hG4bK7208e1bfdd2962741dc3dee9d2576820
>
> Contact: <sip:[email-masked]:5060>
>
> Content-Length: 0
>
>
> Thanks,
> Nitin Kapoor
>
> 2009/12/10 Christer Holmberg <[email-masked]>
>
>
>> Hi,
>>
>> It is possible.
>>
>> In theory this could be done with a single c- line, because SDP only talks
>> about where media is to be sent - not where it comes from.
>>
>> In reality, however, I assume this is a case where each m- line has its
>> own c- line, each with a different IP address.
>>
>> Regards,
>>
>> Christer
>>
>>

---

From: "Roni Even" <[email-masked]>
Date: Thu, 10 Dec 2009 19:57:35 +0200

Hi,
I looked at the SDP you send, you are seeing two RTP streams, one for each
direction. Since both sides talk than you see one RTP steam from 8.15.244.11
in one direction to port 10766 and one from 64.156.174.71 going to the other
direction to port 19612

Roni Even

> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Christer Holmberg
> Sent: Thursday, December 10, 2009 3:54 PM
> To: Nitin Kapoor; [email-masked]
> Subject: Re: [Sip] Two Media Stream in One call
> 
> 
> Hi,
> 
> It is possible.
> 
> In theory this could be done with a single c- line, because SDP only
> talks about where media is to be sent - not where it comes from.
> 
> _______________________________________________
> Sip mailing list  https://www.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip

---

From: Nitin Kapoor <[email-masked]>
Date: Thu, 10 Dec 2009 13:03:07 -0500

Roni,

So is that the normal call.. I mean is it possible or you have seen any
issue into it..

Please help me on this.

Thanks,
Nitin Kapoor

2009/12/10 Roni Even <[email-masked]>

---

From: "Roni Even" <[email-masked]>
Date: Thu, 10 Dec 2009 20:33:10 +0200

This is a normal call, RTP is unidirectional and this is why you see two RTP
streams one from each side for each media channel.

Roni

From: Nitin Kapoor [mailto:[email-masked]] 
Sent: Thursday, December 10, 2009 8:03 PM
To: Roni Even
Cc: Christer Holmberg; [email-masked]
Subject: Re: [Sip] Two Media Stream in One call

Roni,

Please help me on this.

Thanks,
Nitin Kapoor

Hi,

Roni Even

---

From: Nitin Kapoor <[email-masked]>
Date: Wed, 16 Dec 2009 17:12:23 -0500

Hello Roni,

I still have the doubt.. the point you have mentioned that the the RTP is
the unidirectional and because of that it is showing me two RTP streams.

But if we are decoding the RTP packets and whenever i am trying to hear the
messages then i can see that both have the different conversion..which is
confusing me lot... because without CONFERENCE call how one call have two
different conversion or RTP stream  in one dialog...

Please correct me if i am wrong.

Thanks,
Nitin Kapoor

>  This is a normal call, RTP is unidirectional and this is why you see two
> RTP streams one from each side for each media channel.
>
> Roni
>
>
>
> *From:* Nitin Kapoor [mailto:[email-masked]]
> *Sent:* Thursday, December 10, 2009 8:03 PM
> *To:* Roni Even
> *Cc:* Christer Holmberg; [email-masked]
>
> *Subject:* Re: [Sip] Two Media Stream in One call
>
>
>
> Roni,
>

---

From: Nitin Kapoor <[email-masked]>
Date: Fri, 18 Dec 2009 16:55:32 -0500

Hello,

Can anyone help me out please on this.

Thanks,
Nitin Kapoor

2009/12/16 Nitin Kapoor <[email-masked]>

---

From: "Dale Worley" <[email-masked]>
Date: Fri, 18 Dec 2009 17:00:55 -0500

> Can anyone help me out please on this.

If we are to help, you will have to provide more information than you
have.  At a minimum, we need to see:

the SDP offer
the SDP answer
a description of each RTP stream you see, including its source address
and its destination address

Dale

---

From: Nitin Kapoor <[email-masked]>
Date: Fri, 18 Dec 2009 17:03:01 -0500

Dale,

I have the ethreal traces along with RTP stream... i can provide you
that..if that can help to debug the issue.

Thanks,
Nitin Kapoor

2009/12/18 Dale Worley <[email-masked]>

---

From: Nitin Kapoor <[email-masked]>
Date: Mon, 21 Dec 2009 06:04:25 -0500

Hello Amit,

Okay... but whenever i am trying to decode the RTP packets and trying to
hear the conversation of this.. it seems to be a different conversation...
and which is confusing me a lot.

Also if you think after hearing the conversation of this call...the call is
still normal then could you please elaborate some evidence on which behalf
its look okay to you...

Thanks for your help in advance...

Thanks,
Nitin Kapoor

2009/12/21 Amit Vijayvargiya <[email-masked]>

>  Dear Nitin,
>
>
>
> In these traces every thing seems fine & it’s a normal call. RTP Packets
> are bidirectional
>
>
>
> 64.156.174.71(10766)  ß--------à 8.15.244.11(19612)
>
>
>
> It should be a single conversation.
>
>
>
>
>
>
>
>  *Regards,*
> *Amit Vijayvargiya *
>   ------------------------------
>
> *Sent:* Monday, December 21, 2009 10:16 AM
> *To:* Amit Vijayvargiya
>
> *Cc:* Christer Holmberg
> Hello Amit,
> Please find the attached traces...
>
> Thanks,
> Nitin Kapoor
>
> 2009/12/19 Amit Vijayvargiya <[email-masked]>
>
> Hi Nitin,
>
>
>
> Can you share the ethereal trace of RTP packets.
>
>
>
>
> *Thanks & Regards,*
>
> *Amit Vijayvargiya *
>   ------------------------------
>
> *From:* [email-masked] [mailto:[email-masked]] *On Behalf Of *Nitin
> Kapoor
> *Sent:* Saturday, December 19, 2009 3:26 AM
>
>
> *To:* [email-masked]
> *Cc:* Christer Holmberg
>
>  ------------------------------
>
> This message and its attachments contain confidential information and may
> also contain legally privileged information. This message is intended solely
> for the named addressee. If you are not the addressee indicated in this
> message (or authorized to receive for addressee), you may not copy or
> deliver any part of this message or its attachments to anyone or use any
> part of this message or its attachments. Rather, you should permanently
> delete this message and its attachments (and all copies) from your system
> and kindly notify the sender by reply E-mail. Any content of this message
> and its attachments that does not relate to the official business of SPICE
> DIGITAL or its affiliates and/or subsidiaries must be taken not to have been
> sent or endorsed by any of them. Opinions and information in this E-mail
> that do not relate to the official business of SPICE DIGITAL., shall be
> understood as neither given nor endorsed by SPICE DIGITAL.. Any
> action/proceeding/opportunity upon the contents of this E-mail taken by not
> intended addressee shall attract liabilities both criminal and civil against
> such addressee.
>
> E-mail communications are not private and no warranty is made that e-mail
> communications are timely, secure or free from computer virus or other
> defect.
>
>
>
> ------------------------------
> This message and its attachments contain confidential information and may
> also contain legally privileged information. This message is intended solely
> for the named addressee. If you are not the addressee indicated in this
> message (or authorized to receive for addressee), you may not copy or
> deliver any part of this message or its attachments to anyone or use any
> part of this message or its attachments. Rather, you should permanently
> delete this message and its attachments (and all copies) from your system
> and kindly notify the sender by reply E-mail. Any content of this message
> and its attachments that does not relate to the official business of SPICE
> DIGITAL or its affiliates and/or subsidiaries must be taken not to have been
> sent or endorsed by any of them. Opinions and information in this E-mail
> that do not relate to the official business of SPICE DIGITAL., shall be
> understood as neither given nor endorsed by SPICE DIGITAL.. Any
> action/proceeding/opportunity upon the contents of this E-mail taken by not
> intended addressee shall attract liabilities both criminal and civil against
> such addressee.
>
> E-mail communications are not private and no warranty is made that e-mail
> communications are timely, secure or free from computer virus or other
> defect.
>