Subject: [Sip] Inquiry:SIP sending dialed digits in one-by-one digit format?

From: hadi motamedi <[email-masked]>
Date: Wed, 6 Jan 2010 06:11:52 +0000

Dear All
Can you please do me favor and let me know if it is technically
feasible to send the sip dialed digits in one-by-one-digit format ? I
mean if the subs dials say 6659983 we try to send it as 6,6,5,9,9,8,3
but not as 6659983 in just one package with sip invite .
Thank you in advance

---

From: "Prasath Elangovan -X (prelango - HCL at Cisco)" <[email-masked]>
Date: Wed, 6 Jan 2010 12:09:17 +0530

Hey Hadi,
 
You could do this via KPML Subscription package. Send invite with just 6
and remaining digits throught NOTIFY. 
 
Thanks, Prasath

________________________________

From: [email-masked] [mailto:[email-masked]] On Behalf Of
hadi motamedi
Sent: Wednesday, January 06, 2010 11:42 AM
To: [email-masked]
Subject: [Sip] Inquiry:SIP sending dialed digits in one-by-one digit
format?

Dear All

---

From: hadi motamedi <[email-masked]>
Date: Wed, 6 Jan 2010 06:54:54 +0000

On Wed, Jan 6, 2010 at 6:39 AM, Prasath Elangovan -X (prelango - HCL at
Cisco) <[email-masked]> wrote:

>  ------------------------------
> *From:* [email-masked] [mailto:[email-masked]] *On Behalf Of *hadi
> motamedi
> *Sent:* Wednesday, January 06, 2010 11:42 AM
> *To:* [email-masked]
> *Subject:* [Sip] Inquiry:SIP sending dialed digits in one-by-one digit
> format?
>
>
> Dear All

Sorry . Can you please do me favor and provide me with more details on this
?
Thank you

---

From: Vijay Tiwari <[email-masked]>
Date: Wed, 6 Jan 2010 12:29:03 +0530

Hello All

this KPML subscription package used for DTMF digits not for invite number in
request URI.

On Wed, Jan 6, 2010 at 12:09 PM, Prasath Elangovan -X (prelango - HCL at
Cisco) <[email-masked]> wrote:

> _______________________________________________
> Sip mailing list  https://www.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
>

-- 
They can because they think they can.

---

From: hadi motamedi <[email-masked]>
Date: Wed, 6 Jan 2010 07:08:27 +0000

On Wed, Jan 6, 2010 at 6:59 AM, Vijay Tiwari <[email-masked]>wrote:

> Hello All
>
> this KPML subscription package used for DTMF digits not for invite number
> in request URI.
>
>> *From:* [email-masked] [mailto:[email-masked]] *On Behalf Of
>> *hadi motamedi

Sorry. You mean KPML cannot implement this scenario ?

---

From: Vijay Tiwari <[email-masked]>
Date: Wed, 6 Jan 2010 15:32:48 +0530

Hello all

yes KPML is not implement into implement this scenario. its only for DTMF
digits.

Thanks
Vijay
On Wed, Jan 6, 2010 at 12:38 PM, hadi motamedi <[email-masked]> wrote:

>>   On Wed, Jan 6, 2010 at 12:09 PM, Prasath Elangovan -X (prelango - HCL
>> at Cisco) <[email-masked]> wrote:
>>
>>>   Hey Hadi,
>>>

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 06 Jan 2010 10:07:13 -0500

Vijay Tiwari wrote:
> Hello all
>  
> yes KPML is not implement into implement this scenario. its only for 
> DTMF digits.

It was not *intended* for this, but that doesn't mean it couldn't be 
used for this purpose. However there is no standard defined for doing so.

And its extremely unlikely that one would be defined, because it 
requires a different division of responsibility between components than 
the sip specs assume. Specifically, to do this, you have to turn the sip 
phone into a dumb device, akin to MGCP, with a master that does most of 
the work. You need to do this, because you must establish a session with 
*something* that will receive the digits, and then eventually decide 
when a full number has been entered, and then initiate a call.

	Thanks,
	Paul

> Thanks
> Vijay 
> On Wed, Jan 6, 2010 at 12:38 PM, hadi motamedi <[email-masked] 
> <mailto:[email-masked]>> wrote:
> 
> 
> 
>     On Wed, Jan 6, 2010 at 6:59 AM, Vijay Tiwari
>     <[email-masked] <mailto:[email-masked]>> wrote:
> 
>         Hello All
>          
>         this KPML subscription package used for DTMF digits not for
>         invite number in request URI.
> 
>         On Wed, Jan 6, 2010 at 12:09 PM, Prasath Elangovan -X (prelango
>         - HCL at Cisco) <[email-masked] <mailto:[email-masked]>>
>         wrote:
> 
>             Hey Hadi,
>              
>             You could do this via KPML Subscription package. Send invite
>             with just 6 and remaining digits throught NOTIFY.
>              
>             Thanks, Prasath
> 
>             ------------------------------------------------------------------------
>             *From:* [email-masked] <mailto:[email-masked]>
>             [mailto:[email-masked] <mailto:[email-masked]>]
>             *On Behalf Of *hadi motamedi
>             *To:* [email-masked] <mailto:[email-masked]>
>             *Subject:* [Sip] Inquiry:SIP sending dialed digits in
>             one-by-one digit format?
> 
>              
>             Dear All
>             Use [email-masked]
>             <mailto:[email-masked]> for questions on
>             current sip
>             Use [email-masked] <mailto:[email-masked]> for new
>             developments on the application of sip
> 
> 
> 
> 
>         -- 
> ------------------------------------------------------------------------
>

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 7 Jan 2010 10:23:01 +0100

Hi,

Are you referring to overlap dialling?

One way is to send additional digits in subsequent INVITEs, which is described in RFC 3578. Another way is to send the additional digits using INFO, once the INVITE has reached the *something* Paul is referring to.

Regards,

Christer

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Paul Kyzivat
Sent: 6. tammikuuta 2010 17:07
To: Vijay Tiwari
Cc: [email-masked]
Subject: Re: [Sip] Inquiry:SIP sending dialed digits in one-by-one digit format?

> yes KPML is not implement into implement this scenario. its only for 

It was not *intended* for this, but that doesn't mean it couldn't be used for this purpose. However there is no standard defined for doing so.

And its extremely unlikely that one would be defined, because it requires a different division of responsibility between components than the sip specs assume. Specifically, to do this, you have to turn the sip phone into a dumb device, akin to MGCP, with a master that does most of the work. You need to do this, because you must establish a session with
*something* that will receive the digits, and then eventually decide when a full number has been entered, and then initiate a call.

	Thanks,
	Paul

> This list is for NEW development of the core SIP Protocol Use 
> [email-masked] for questions on current sip Use 
> [email-masked] for new developments on the application of sip
_______________________________________________
Sip mailing list  https://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol Use [email-masked] for questions on current sip Use [email-masked] for new developments on the application of sip

---

From: Victor Pascual Avila <[email-masked]>
Date: Fri, 8 Jan 2010 11:50:01 +0100

Hi,

> but not as 6659983 in just one package with sip invite .

RFC3578 describes the overlap dialing. While some implement the
"Multiple Invite" method, some others implement the "In Dialog" method
as depicted by ETSI TS 124 229 V8.7.8 (2009-07). Please check Clause
4.9 and ANNEX N from that document (Note: it does NOT reference
RFC3578)

Cheers,
-- 
Victor Pascual Ávila

---

From: "Dale Worley" <[email-masked]>
Date: Wed, 06 Jan 2010 13:50:36 -0500

> but not as 6659983 in just one package with sip invite .

This is called "overlapped dialing", and there is a defined technique
for doing this.  The phone, when it receives the first digit, sends an
INVITE:

INVITE sip:6@domain SIP/2.0 -->

The proxy for the domain determines that additional digits are required,
and gives a 484 Address Incomplete response:

<-- SIP/2.0 484 Address Incomplete

When the user dials the second digit, the phone sends the accumulated
digits:

INVITE sip:66@domain SIP/2.0 -->

The proxy responds 484 again:

<-- SIP/2.0 484 Address Incomplete

This continues until the user enters a complete dial string.

However, this technique is not commonly used due to the high signaling
traffic it generates and the general difficulty having the proxy
determine whether or not the dial string is ended for all possible dial
strings.

A more common technique is to program the UA with a "dial pattern",
which is a regular expression that describes all valid dial strings.
E.g., three-digit extensions could be described "xxx", while "9 followed
by 7 digits" could be described "9xxxxxxx".  Also, the dial pattern
language usually allows a way of specifying variable-length strings via
"a series of digits terminated by a time-out":  "9xT".  This method
places the entire burden on the UA, but allows a mixture of fixed- and
variable-length strings in the dial plan.  Of course, the details vary
from one make of UA to another.

Dale