Subject: Re: [Sip] Changing route set in SIP outbound

From: Dean Willis <[email-masked]>
Date: Sat, 5 Feb 2011 00:06:01 -0600

On Jan 3, 2011, at 9:25 AM, Avshalom Houri wrote:

> Assume that the first SIP proxy that is part of the route set (in SIP outbound) 
> crashes and immediately restarts, or a backup proxy takes over. Is there any way to keep the dialog alive if either of the 
> endpoints senses this failure and recreates a connection or the dialog is doomed and needs to be 
> fully recreated again? The issue is that the route set includes the connection information, which is no longer valid. 

Well, if the proxies share credentials and an IP address by some HSRP-like magic, then the dialog might reasonably stay alive. This further requires either stateless operation or state sharing  ( embedded state; encoding it into the message headers is an example) between the proxies.

This is analogous to the route-set failover question in many a routing model: flow switching, MPLS, frame relay, ATM, or even Token-Ring. SIP has no magic to cure the fundamental issue. At best we can reduce it to a known problem.

--
Dean

---

From: "Worley, Dale R (Dale)" <[email-masked]>
Date: Mon, 7 Feb 2011 17:11:24 -0500

________________________________________
From: [email-masked] [[email-masked]] On Behalf Of Avshalom Houri [[email-masked]]

________________________________________

Here's an idea:  When an outbound REGISTER reaches the registrar, it records the ob URI that the edge proxy created in a hidden location in the registration.  As part of the Path, it inserts an ob URI that it creates that contains the registrar's hostport, and a representation of the SIP user-part and sip-instance.  Now, when a new INVITE is sent to the phone, or otherwise when the ob URI is used, the request goes to the registrar, which then forwards it to one or another of the real ob URIs for the phone.  Indeed, I think that the phone's GRUU can be used for the new ob URI.  All that lets the selection of the flow to use to reach the phone to be made on a request-by-request basis.

Dale