Subject: Re: [Sip] Different SDP Session Version in 183 & 200 OK

From: Nitin Kapoor <[email-masked]>
Date: Wed, 9 Mar 2011 02:24:42 -0500

Hello All,

Could any one please help me out on requested query as below.

Thanks,
Nitin

On Tue, Mar 8, 2011 at 4:48 PM, Nitin Kapoor <[email-masked]> wrote:

> Dear All,
>
> I have one call scenario where my termination is sending the SDP in 183 as
> well as in 200 OK also. As far as i know if we are getting SDP in 183
> session progress then my UAC can ignore the SDP in 200 OK. Also most of the
> time SDP is same.
>
> But here i noticed the slight difference of "Session Version". Here when my
> termination is sending 188 Session Progress with SDP is sending the SDP as
> below.
>
> I can see that  my Termination is incrementing  "*Session Version*" for
> SDP in 183 & 200 OK in same dialog..
>
> *183 with SDP*
>
> S_OWNER : o=TLPMSXP2 22660 *22660* IN IP4 69.90.230.210
> S_NAME : s=sip call
> S_CONNECT : c=IN IP4 69.90.230.217
> TIME : t=0 0
> M_NAME : m=audio 59072 RTP/AVP 18 4 8 98
>
> 200 OK with SDP:
>
> S_OWNER : o=TLPMSXP2 22660 *22661* IN IP4 69.90.230.210
> S_NAME : s=sip call
> S_CONNECT : c=IN IP4 69.90.230.217
> TIME : t=0 0
>
> Could anyone please let me know if that is okay to increment the session
> version and if any supported document is there?
>
> Thanks,
> Nitin
>

---

From: Nitin Kapoor <[email-masked]>
Date: Wed, 9 Mar 2011 04:33:27 -0500

Hello Ashish,

Here is the mline for both the messages.

183:

Media Description, name and address (m): audio 43888 RTP/AVP 18

200 OK:

Media Description, name and address (m): audio 43888 RTP/AVP 18

Thanks,
Nitin Kapoor

On Wed, Mar 9, 2011 at 3:25 AM, Ashish Saxena <[email-masked]>wrote:

> what is the mline of 200OK SDP.
>
> Regards
> Ashish Saxena
> (www.aricent.com)
> ________________________________________
> From: [email-masked] [[email-masked]] On Behalf Of Nitin
> Kapoor [[email-masked]]
> Sent: Wednesday, March 09, 2011 12:54 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: [Sip] Different SDP Session Version in 183 & 200 OK
>
> Hello All,
>
> On Tue, Mar 8, 2011 at 4:48 PM, Nitin Kapoor <[email-masked]
> <mailto:[email-masked]>> wrote:
> Dear All,
>
> I can see that  my Termination is incrementing  "Session Version" for SDP
> in 183 & 200 OK in same dialog..
>
> 183 with SDP
>
> S_OWNER : o=TLPMSXP2 22660 22660 IN IP4 69.90.230.210
> S_NAME : s=sip call
> S_OWNER : o=TLPMSXP2 22660 22661 IN IP4 69.90.230.210
> S_NAME : s=sip call
> "DISCLAIMER: This message is proprietary to Aricent and is intended solely
> for the use of the individual to whom it is addressed. It may contain
> privileged or confidential information and should not be circulated or used
> for any purpose other than for what it is intended. If you have received
> this message in error, please notify the originator immediately. If you are
> not the intended recipient, you are notified that you are strictly
> prohibited from using, copying, altering, or disclosing the contents of this
> message. Aricent accepts no responsibility for loss or damage arising from
> the use of the information transmitted by this email including damage from
> virus."
>

---

From: Nitin Kapoor <[email-masked]>
Date: Wed, 9 Mar 2011 08:20:11 -0500

Hi Sanjiv,

I do agree that "session-version" should increment by one from the previous
SDP when there is any modification is involved in SDP. But i haven't seen
any modification into the SDP of 183 & 200 OK/

Also, there was no SDP in ACK. If you need i can share the traces with you.

Thanks,
Nitin Kapoor

On Wed, Mar 9, 2011 at 5:30 AM, Jaiswal, Sanjiv (NSN - IN/Bangalore) <
[email-masked]> wrote:

> Hi Nitin,
>
>
> Every SDP with incremented session ( in this case 200 OK) is treated as
> new negotiation(offer).
> Whether ACK from other end contains SDP answer? If yes then session
> version is incremented there also?
>
>
> Regards
> Sanjiv
>
> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]] On Behalf Of ext
> Nitin Kapoor
> Sent: Wednesday, March 09, 2011 3:03 PM
> To: Ashish Saxena
> Cc: [email-masked]; [email-masked]
> Subject: Re: [Sip-implementors] [Sip] Different SDP Session Version in
> 183 &200 OK
>
> Hello Ashish,
>
> _______________________________________________
> Sip-implementors mailing list
> [email-masked]
> https://lists.cs.columbia.edu/cucslists/listinfo/sip-implementors
>

---

From: Vijay Tiwari <[email-masked]>
Date: Wed, 9 Mar 2011 22:42:20 +0530

Hello Nitin

Hope you are doing good, sorry i was able to respond that time. i saw are
mail and according to my understanding this value can be change if

"<sess-version> is  increased when a modification is made to the session
data."

it means that if any session data change between 183 and 200 ok message then
it is standard behavior

Thanks
Vijay

On Wed, Mar 9, 2011 at 12:54 PM, Nitin Kapoor <[email-masked]>wrote:

> On Tue, Mar 8, 2011 at 4:48 PM, Nitin Kapoor <[email-masked]>wrote:
>
>> Dear All,
>>
>> But here i noticed the slight difference of "Session Version". Here when
>> my termination is sending 188 Session Progress with SDP is sending the SDP
>> as below.
>>
> Sip mailing list  https://www.ietf.org/mailman/listinfo/sip
> This list is essentially closed and only used for finishing old business.
> Use [email-masked] for questions on how to develop a SIP
> implementation.
> Use [email-masked] for new developments on the application of sip.
> Use [email-masked] for issues related to maintenance of the core SIP
> specifications.
>

-- 
They can because they think they can.

---

From: Sudeesh Ravindran <[email-masked]>
Date: Thu, 10 Mar 2011 11:39:34 +0530

Hey Guys,

             Please tell me , how can i relieve from this site. All your
mails are delivers into my mail id to........ Please suggest the idea.

With regards,

Ji

On Wed, Mar 9, 2011 at 1042 PM, Vijay Tiwari <[email-masked]>wrote:

> it means that if any session data change between 183 and 200 ok message
> then it is standard behavior
>
>
> Thanks
> Vijay
>
>>> I have one call scenario where my termination is sending the SDP in 183
>>> as well as in 200 OK also. As far as i know if we are getting SDP in 183
>> Use [email-masked] for questions on how to develop a
>> SIP implementation.

---

From: "Jaiswal, Sanjiv (NSN - IN/Bangalore)" <[email-masked]>
Date: Wed, 9 Mar 2011 18:30:23 +0800

Hi Nitin,

Regards
Sanjiv

-----Original Message-----

Hello Ashish,

183:

200 OK:

Thanks,
Nitin Kapoor