Subject: Re: [sipcore] Review request: Dial String syntax for the "tel" URI Scheme

From: "Rosen, Brian" <[email-masked]>
Date: Fri, 17 Sep 2010 15:34:35 -0400

Would you please read RFC4966 and consider how that affects your draft?

Brian

On May 3, 2010, at 11:20 AM, Zehler, Peter wrote:

All,

This is a request for the list to review an Internet Draft that codifies the parameters for Dial Strings to be used in an rfc3966 compliant URL.  The requirements for this draft originated in the IEEE/ISTO Printer Working Group (PWG) <http://www.pwg.org>.  The PWG is a consortium printer and multi-function device manufacturers, print server developers, operating system providers and print management application developers.  Previous works of the PWG include the Printer MIB (rfc3805) and the Internet Printing Protocol (rfc2911, rfc2910 and others)  The Working Group in the PWG that I chair is addressing the modeling of Multifunction Devices.  In that effort an outbound facsimile (i.e. FaxOut) requires a way to encode Dial Strings in the URL for a destination facsimile device.

The draft title is "Dial String syntax for the "tel" URI Scheme" and it can be retrieved from <http://tools.ietf.org/html/draft-zehler-teldial-info-00>.   It proposes three “tel” URI schemes parameters that cover pre-dialing, post-dialing  and T.33 subaddressing.  The post-dialing and T.33 subaddressing are adopted from the now obsolete rfc2806 but updated for tfc3966 syntax.  Pre-dial was created to avoid obfuscation of the resource identified by the URI.  Rfc2806 allowed the pre-dial string to be included in the tel: URI.

In a comment on this Internet Draft on the URI Review list it was suggested that the RAI-area working groups that deals with SIP should be the place where the Dial String parameter semantics should be discussed.

I look forward to your comments,

Peter Zehler

Xerox Research Center Webster
Email: [email-masked]<mailto:[email-masked]>
Voice: (585) 265-8755
FAX: (585) 265-7441
US Mail: Peter Zehler
Xerox Corp.
800 Phillips Rd.
M/S 128-25E
Webster NY, 14580-9701

>
> -----Original Message-----
> From: IETF I-D Submission Tool [mailto:[email-masked]]
> Sent: Monday, April 26, 2010 4:06 PM
> To: Zehler, Peter
> Subject: New Version Notification for draft-zehler-teldial-info-00
>
>
> A new version of I-D, draft-zehler-teldial-info-00.txt has been successfully submitted by Peter Zehler and posted to the IETF repository.
>
> Filename:        draft-zehler-teldial-info
> Revision:        00
> Title:           Dial String syntax for the "tel" URI Scheme
> Creation_date:   2010-04-24
> WG ID:           Independent Submission
> Number_of_pages: 7
>
> Abstract:
> The "tel" URI (Uniform Resource Identifier) for Telephone Numbers
> [RFC3966] describes resources identified by telephone numbers.  These
> resources specify termination points within a public or private
> telephone network. The termination points are a globally or locally
> unique endpoint.  RFC3966 does not address the means by which the
> telephone URI can be used to reach termination point from a specific
> node in the telephone network.
>
> This document specifies the means by which the termination point is
> reached from a specific node in the telephone network. This document
> specifies how to encode the numbers, symbols and pauses required to
> traverse the phone network to reach the termination point in an RFC
> 3966 compliant "tel" URI.
>
>
>
> The IETF Secretariat.
>
>

Peter Zehler

Xerox Research Center Webster
Email: [email-masked]<mailto:[email-masked]>
Voice: (585) 265-8755
FAX: (585) 265-7441
US Mail: Peter Zehler
Xerox Corp.
800 Phillips Rd.
M/S 128-25E
Webster NY, 14580-9701

_______________________________________________
sipcore mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/sipcore

---

From: Brian Rosen <[email-masked]>
Date: Fri, 17 Sep 2010 16:13:28 -0400

A really funny sequence of events caused me to reply to this message from long ago.  Sorry for the confusion.

Brian
On Sep 17, 2010, at 3:34 PM, Rosen, Brian wrote:

>> Email: [email-masked]
>> Voice: (585) 265-8755
>> FAX: (585) 265-7441
>> US Mail: Peter Zehler
>> Xerox Corp.
>> 800 Phillips Rd.
>> M/S 128-25E
>> Webster NY, 14580-9701
>>  
>>  
>> > 
>> Email: [email-masked]
>> Voice: (585) 265-8755
>> FAX: (585) 265-7441
>> US Mail: Peter Zehler
>> Xerox Corp.
>> 800 Phillips Rd.
>> M/S 128-25E
>> Webster NY, 14580-9701
>>  
>> [email-masked]
> [email-masked]