Subject: [sipcore] Does SIP support "Reverse Charging" function?

From: [email-masked]
Date: Mon, 20 Sep 2010 08:55:43 +0800

Hi,

Background:
1. Reverse Charging is defined by ITU in I.256.3;
2. 3GPP's 22.173 and 24.173 have mentioned "Reverse Charging", but there's 
no specific definition.

Now, we(ZTE)'d like to implement the "Reverse Charging" in SIP network. 

Question:
"Reverse Charging" need some indication extension for SIP usage, I'd like 
to know how people think about this problem.

If this problem has been discussed here, sorry for that.

Thanks,

Gao

===================================
 Zip    : 210012
 Tel    : 87211
 Tel2   :(+86)-025-52877211
 e_mail : [email-masked]
===================================

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail is solely property of the sender's organization. This mail communication is confidential. Recipients named above are obligated to maintain secrecy and are not permitted to disclose the contents of this communication to others.
This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed. If you have received this email in error please notify the originator of the message. Any views expressed in this message are those of the individual sender.
This message has been scanned for viruses and Spam by ZTE Anti-Spam system.

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 20 Sep 2010 08:35:14 -0400

Hi Gao,

SIP doesn't have any builtin mechanisms to support charging *at all*, 
either forward or reverse.

Obviously there are systems that are doing charging, but that hasn't 
involved the ietf. I guess IMS has some mechanisms for that, but IIUC 
you are involved with IMS so probably know those better than I.

	Thanks,
	Paul

On 9/19/2010 8:55 PM, [email-masked] wrote:
> 2. 3GPP's 22.173 and 24.173 have mentioned "Reverse Charging", but
> there's no specific definition.
>
>
> "Reverse Charging" need some indication extension for SIP usage, I'd
> like to know how people think about this problem.
>
> _______________________________________________
> sipcore mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sipcore

---

From: [email-masked]
Date: Tue, 21 Sep 2010 08:57:13 +0800

Hi Paul,

I am agree with you that IETF do not care about the charging at function 
level. But other SIP based systems, such as IMS, usually do syntax level 
standardization for their SIP extension.

For example, the normal charging function defined in IMS, has it's syntax 
level standardization in RFC3455(P-Charging-Vector header).

But by my current understanding, IMS hasn't do any syntax or function 
level standardization for "Reverse Charging". So, my intention here is 
looking for some *defined SIP syntax*  for "Reverse Charging".

Thanks,

Gao

Paul Kyzivat <[email-masked]> 
2010-09-20 20:35

收件人
[email-masked]
抄送
[email-masked]
主题
Re: [sipcore] Does SIP support "Reverse Charging" function?

Hi Gao,

                 Thanks,
                 Paul

On 9/19/2010 8:55 PM, [email-masked] wrote:
> ZTE  Information  Security  Notice:  The  information  contained  in 
this  mail  is  solely  property  of  the  sender's  organization.  This 
mail  communication  is  confidential.  Recipients  named  above  are 
obligated  to  maintain  secrecy  and  are  not  permitted  to  disclose 
the  contents  of  this  communication  to  others.
> This  email  and  any  files  transmitted  with  it  are  confidential 
and  intended  solely  for  the  use  of  the  individual  or  entity  to 
whom  they  are  addressed.  If  you  have  received  this  email  in 
error  please  notify  the  originator  of  the  message.  Any  views 
expressed  in  this  message  are  those  of  the  individual  sender.

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Tue, 21 Sep 2010 13:14:06 +0200

P-Charging-Vector and P-Charging-Function-Addresses header fields are not specifically any form of charging.

P-Charging-Vector is about the exchange of identifiers that are used in accounting, and therefore charging, by some other system.

P-Charging-Function-Addresses is about where to send such accounting information when you have it.

As sucht he default model in IMS, which uses these, assumes no mechanism of charging at all. I agree that a model could be built (and is indeed built and deployed) that makes it calling user pays, but that is not inherent to the IMS itself. The online charging server does make a presupposition that it is calling user only that will be charged for IMS activity. Note that in many mobile situations (particularly roaming), both users pay, so how does reverse charging work in that case?

I would suggest that to do reverse charging, you need a charging model in the first place. That does not exist in IETF. Even in 3GPP, it would need additional work, because you would need to address signalling transactions to the entities performing the charging, rather than those collecting the data.

regards

Keith

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, September 21, 2010 1:57 AM
To: Paul Kyzivat
Cc: [email-masked]
Subject: Re: [sipcore] Does SIP support "Reverse Charging" function?

Hi Paul,

I am agree with you that IETF do not care about the charging at function level. But other SIP based systems, such as IMS, usually do syntax level standardization for their SIP extension.

For example, the normal charging function defined in IMS, has it's syntax level standardization in RFC3455(P-Charging-Vector header).

But by my current understanding, IMS hasn't do any syntax or function level standardization for "Reverse Charging". So, my intention here is looking for some *defined SIP syntax*  for "Reverse Charging".

Thanks,

Gao

2010-09-20 20:35

收件人
[email-masked]
抄送
[email-masked]
主题

Hi Gao,

                Thanks,
                Paul

---

From: [email-masked]
Date: Sat, 25 Sep 2010 13:10:49 +0800

Hi Keith,

> P-Charging-Vector and P-Charging-Function-Addresses header fields 
> are not specifically any form of charging.

Yes. So, I said that they are syntax level standardization for the SIP 
extension.
 
> I would suggest that to do reverse charging, you need a charging 
> model in the first place. That does not exist in IETF. Even in 3GPP,
> it would need additional work, because you would need to address 
> signalling transactions to the entities performing the charging, 
> rather than those collecting the data.

IMO, this work should do it's function level things in 3GPP and syntax 
level standardization for SIP extension in IETF.

I guess you(or ALU) would alos have reverse charging requirement for your 
deployed IMS network. Then, may us propose the requirement to the SA1 
group, and then, SIP extension work in IETF?

Thanks,

Gao

---

From: Christer Holmberg <[email-masked]>
Date: Sat, 25 Sep 2010 07:58:02 +0200

Hi,

>I guess you(or ALU) would alos have reverse charging requirement for your deployed IMS network. Then, may us propose the requirement to the SA1 group, and then, SIP extension work in IETF? 

The requirement already exists in SA1 (3GPP TS 22.173).

Regards,

Christer

---

From: [email-masked]
Date: Sat, 25 Sep 2010 14:01:16 +0800

Hi Christer,

Do you mean this section in 22.173:

It is quit raw, and I didn't see any further progress for this topic.

Thanks,

Gao

8.2.16  Reverse charging 
8.2.16.1        Definition
The reverse charging at communication set up time service allows the 
terminating party to be charged for the entire communication. Only usage 
based charges can be applied to the terminating party. The service shall 
be requested by the originating party at communication set up time. The 
terminating party must receive an explicit indication of a reverse charge 
communication request.
This service description is based on the service description described in 
[E-19].
8.2.16.2        Service interactions with other IMS supplementary services
None.
8.2.16.3        Interoperability with PSTN/ISDN
The IMS Multimedia Telephony service shall support the interoperability of 
Reverse Charging with the PSTN/ISDN and vice-versa. 

Christer Holmberg <[email-masked]> 
2010-09-25 13:58

收件人
"[email-masked]'" <[email-masked]>, "DRAGE, Keith (Keith)" 
<[email-masked]>
抄送
"[email-masked]" <[email-masked]>, "[email-masked]" 
<[email-masked]>
主题
RE: [sipcore] Does SIP support "Reverse Charging" function?

Hi,

Regards,

Christer

---

From: Christer Holmberg <[email-masked]>
Date: Sat, 25 Sep 2010 19:31:29 +0200

Hi,

I am not sure what more text you would need in 22.173.

What you need to do is to create a work item in CT1 in order to specify the protocol details.

Anyway, this is not the right forum to discuss this :)

Regards,

Christer

________________________________
From: [email-masked] [[email-masked]]
Sent: Saturday, September 25, 2010 9:01 AM
To: Christer Holmberg
Cc: DRAGE, Keith (Keith); [email-masked]; [email-masked]
Subject: RE: [sipcore] Does SIP support "Reverse Charging" function?

Hi Christer,

Thanks,

Gao

8.2.16        Reverse charging

8.2.16.1        Definition

The reverse charging at communication set up time service allows the terminating party to be charged for the entire communication. Only usage based charges can be applied to the terminating party. The service shall be requested by the originating party at communication set up time. The terminating party must receive an explicit indication of a reverse charge communication request.

This service description is based on the service description described in [E-19].

None.

The IMS Multimedia Telephony service shall support the interoperability of Reverse Charging with the PSTN/ISDN and vice-versa.

2010-09-25 13:58

收件人
        "[email-masked]'" <[email-masked]>, "DRAGE, Keith (Keith)" <[email-masked]>
抄送
        "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
主题
        RE: [sipcore] Does SIP support "Reverse Charging" function?

Hi,

Regards,

Christer

---

From: [email-masked]
Date: Sun, 26 Sep 2010 09:03:16 +0800

Hi Christer,

> Anyway, this is not the right forum to discuss this :)

Yes, function level work should be discussed in 3GPP. 

My original intention was to look for ready-made SIP extension for 
"Reverse Charging" function. As there's no such ready-made SIP extension, 
maybe we may create a work item in CT1 as you suggested.

"Reverse Charging" is a quit general usage for CS network, such as 
GSM/CDMA/PSTN. So I guess you(Ericsson)'s deployed IMS network should also 
have reverse charging requirement. Would you like to do the work together? 
:)

Thanks,

Gao