Subject: [sipcore] sipcore-rejected open issue: vCard

From: Eric Burger <[email-masked]>
Date: Thu, 6 Sep 2018 17:12:19 -0400

I realized that vCards have no integrity protection whatsoever, making them a questionable vehicle for something that has a potential for abuse.

I checked with the RAI ADs and calext chairs, and one option is to build secure vCards. There is some independent work already begun in that space that we can piggy-back on.

Another alternative is to add new headers to SIP to convey whom to contact to remediate blocked calls.

My inclination is to fix vCards, as that would be generally useful and there is already some modest demand for it. It would broaden the implementation base which should be a good thing for us.

Does anyone on the list *NOT* want to go the vCard route and instead create new SIP headers? Does anyone have a better idea? Note if we go the SIP header route, these new headers would need corresponding JWT’s as they have to be secured with a traceable signature authority chain.

---

From: Richard Shockey <[email-masked]>
Date: Thu, 06 Sep 2018 17:25:54 -0400

Eric I'm 100% with you on this.  Fix VCard. I can also think of several other potential uses such as Authenticated Identity via PASSPORT towards a NGN CNAM etc.   We looked at this in the SIP Forum ATIS NNI and may take it up in the future.

This is an excellent idea. 

— 
Richard Shockey

Shockey Consulting LLC

Chairman of the Board SIP Forum

www.shockey.us

www.sipforum.org

richard<at>shockey.us

Skype-Linkedin-Facebook –Twitter  rshockey101

PSTN +1 703-593-2683

On 9/6/18, 5:12 PM, "sipcore on behalf of Eric Burger" <[email-masked] on behalf of [email-masked]> wrote:

    

    Does anyone on the list *NOT* want to go the vCard route and instead create new SIP headers? Does anyone have a better idea? Note if we go the SIP header route, these new headers would need corresponding JWT’s as they have to be secured with a traceable signature authority chain.
    _______________________________________________
    sipcore mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/sipcore