Subject: RE: [Sipping] SIP-T and Segmentation

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Thu, 21 Jun 2001 19:50:46 +0100

For a full interworking between SIP and ISUP, I fully agree one must
reassemble the ISUP message before forwarding on an INVITE.

I am not sure the discussion is so simple when working ISUP --> SIP -->
ISUP.

This discussion seems to ignore the fact that the ISUP segmentation
mechanism was designed so that reassembly at ISUP transit switches was not
required. If I consider my SIP tunnel as an ISUP transit, why do I have to
reassemble the ISUP PDU if I have enough information to get to the other
side of the ISUP transit (SIP tunnel).

I believe the reason for this is so that onward routing of the signalling
message could occur while incoming packets were being received. A more
efficient transit switch in terms of signalling delay from one side to the
other could be constructed. However I am not an ISUP expert so I will leave
this to other people to discuss. 

Reassembly will always work, and may be simpler for implementations, but
that was not the way the ISUP segmentation mechanism was designed to work.

Keith

Keith Drage
Lucent Technologies
Tel: +44 1793 776249
Email: [email-masked]

> ----------
> From: 	Dean Willis[SMTP:[email-masked]]
> Sent: 	21 June 2001 19:16
> To: 	[email-masked]; Gonzalo Camarillo
> Cc: 	[email-masked]; 'Lueken Joachim'; [email-masked];
> [email-masked]; [email-masked]
> Subject: 	Re: [Sipping] SIP-T and Segmentation
> 
> Perhaps the receiver of an oversize SIP-ISUP message refragments it for
> its
> local link characteristics if needed?
> 
> --
> dean
> 
> ----- Original Message -----
> From: "Doug Hurtig" <[email-masked]>
> To: "Gonzalo Camarillo" <[email-masked]>
> Cc: <[email-masked]>; "'Lueken Joachim'"
> <[email-masked]>; <[email-masked]>; <[email-masked]>;
> <[email-masked]>
> Sent: Thursday, June 21, 2001 9:54 AM
> Subject: Re: [Sipping] SIP-T and Segmentation
> 
> 
> > Hi,
> >
> >   Segmentation can occur not just when a segmentation message is
> received
> but
> > also if the
> >   softswitch creates a message, or forwards a message after adding
> parameters.
> > Parameters
> >   such as user-to-user information and the access transport parameter
> can
> be
> > large and might
> >   cause the message to become too long.  Since ISUP requires that
> overlength
> > messages
> >   be segmentented I asked the question when this was not covered in the
> draft.
> >
> >   I totally agree that there is no need to segement when sending the
> message via
> > sip.  Just
> >   wanted to make sure that the receiver would be able to handle the
> overlength
> > ISUP
> >   message.
> >
> > Thanks for the help...
> >
> >
> > Gonzalo Camarillo wrote:
> >
> > > Hello,
> > >
> > > [email-masked] wrote:
> > > >
> > > > I agree 100% with what Joachim says here. In fact, I *thought* we
> > > > had included text to this effect in the draft, but searches through
> > > > all versions (current and previous) turn up nothing.
> > >
> > > We did not add anything because we thought that it was obvious that no
> > > INVITE had to be generated if the segment indicator was set. I do not
> > > quite understand why folks seem to like sending something which is
> > > incomplete in the INVITE (knowing that it is incomplete!) and then
> > > complete it with INFOs... as a rule, if we know that the information
> we
> > > have is not complete, we wait.
> > >
> > > > This should probably be mentioned in passing in the draft.
> > >
> > > Yes, we have to add some wording.
> > >
> > > Regards,
> > >
> > > Gonzalo
> > >
> > > >
> > > > /a
> > > >
> > > > > -----Original Message-----
> > > > > From: Lueken Joachim [mailto:[email-masked]]
> > > > > Sent: Wednesday, June 20, 2001 11:05 AM
> > > > > To: [email-masked]'
> > > > > Cc: [email-masked]'
> > > > > Subject: RE: [Sipping] SIP-T and Segmentation
> > > > >
> > > > >
> > > > > Hi Doug,
> > > > >
> > > > > In my opionion the ISUP should always wait for the remainder
> > > > > of the message, i.e. SGM belonging to this message. This
> > > > > could be done by investigating the 'simple segmentaion
> > > > > indicator" in the optional backward/forward call indicators
> > > > > parameters and setting timer T34, if applicable. Since
> > > > > segmentation is not very often used - only in exceptional
> > > > > cases for the IAM - call setup delay does not matter. As an
> > > > > advantage we always have the complete message in the SIP
> > > > > network. At the egress side of the SIP network the IAM is
> > > > > then segmented again, if required.
> > > > >
> > > > > Regards,
> > > > > Joachim Lueken
> > > > > Siemens AG
> > > > >
> > > > > > -----Original Message-----
> > > > > > From:       Doug Hurtig [SMTP:[email-masked]]
> > > > > > Sent:       Wednesday, June 20, 2001 2:03 AM
> > > > > > To: [email-masked]
> > > > > > Subject:    [Sipping] SIP-T and Segmentation
> > > > > >
> > > > > > Hi,
> > > > > >
> > > > > >   Does SIP-T support segmentation messages (sgm)?  If is
> > > > > the sgm sent in
> > > > > >   a second invite or is it included in the invite containg
> > > > > the ISUP message
> > > > > > which
> > > > > >   was segmented?
> > > > > >
> > > > > >   Any help on handling of over-length ISUP messages with
> > > > > SIP would be
> > > > > > appreciated.
> > > > > >
> > > > > > --
> > > > > > Regards,
> > > > > > Doug Hurtig
> > > > > >
> > > > > > Tekelec
> > > > > > 2425 N. Central Expressway
> > > > > > Richardson, Texas 75080
> > > > > >
> > > > > > [email-masked]
> > > > > > 972.301.1203
> > > > > >
> > > > > >
> > > > > >
> > > > > > _______________________________________________
> > > > > > Sipping mailing list
> > > > > > [email-masked]
> > > > > > http://www.ietf.org/mailman/listinfo/sipping
> > > > >
> > > > > _______________________________________________
> > > > > Sipping mailing list
> > > > > [email-masked]
> > > > > http://www.ietf.org/mailman/listinfo/sipping
> > > > >
> > > >
> > > > _______________________________________________
> > > > Sipping mailing list
> > > > [email-masked]
> > > > http://www.ietf.org/mailman/listinfo/sipping
> > >
> > > --
> > > Gonzalo Camarillo                    Phone :   +1 212 939 71 71
> > > Columbia University                  Mobile:  +358 40 702 35 35
> > > 472 Computer Science Building        Fax   :  +358  9 299 30 52
> > > 1214 Amsterdam Ave., Mail Code 0401  http://www.hut.fi/~gonzalo
> > > New York, NY 10027
> > > USA                              [email-masked]
> >
> >
> >
> >
> > _______________________________________________
> > Sipping mailing list
> > [email-masked]
> > http://www.ietf.org/mailman/listinfo/sipping
> >
> 
> 
> _______________________________________________
> Sipping mailing list  http://www.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments of core SIP
> 

_______________________________________________
Sipping mailing list  http://www.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Gonzalo Camarillo <[email-masked]>
Date: Mon, 25 Jun 2001 18:26:41 +0300

Hello,

> why do I have to

[snip]

> that was not the way the ISUP segmentation mechanism was designed to work.

Since reassembly works, let's keep it simple. I do not think we want to
spend time figuring out how to forward ISUP fragments in SIP. The gain
would not justify the added complexity.

Regards,

Gonzalo