Subject: RE: [Sipping] RFC 2976 INFO and CANCEL question

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 26 Jun 2001 01:05:59 -0400

> -----Original Message-----
> From: Kim Liu [mailto:[email-masked]]
> Sent: Monday, June 25, 2001 6:24 PM
> To: Adam Roach (EUS)
> Cc: [email-masked]
> Subject: Re: [Sipping] RFC 2976 INFO and CANCEL question
> 
> 
> > "Adam Roach (EUS)" wrote:
> 
> > 
> > This means that no matter how well the CANCEL seems to go, the
> > sending node **MUST** continue to retransmit the INFO until
> > a final response is received. You can rest comfortably knowing
> > that, if your 487 is lost, the other side will re-send
> > the INFO.
> > 
> 
> Are you implying that after sending the CANCEL, an 
> infinite number of INFOs should be sent until some sort of
> response is received?  

Infinite? Hardly. Its the same number that would be sent without CANCEL,
which is 11.

> How long should the recipient of
> the INFO store state on the INFO request given that his
> only indication that the response he sent was actually
> received by the sender is a cessation of INFO requests?

32s

> Without the equivalent of an ACK it would appear impossible
> to guarantee that both sides are assured of a mutual 
> understanding of what happened.

With non-INVITE, the UAS has no way to know if the UAC definitely got the
response. WIth INVITE, the UAC has no way to know if the UAS got the ACK.
Byzantine armies problem. Unsolvable.

-Jonathan R.
---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
Sipping mailing list  http://www.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Kim Liu <[email-masked]>
Date: Tue, 26 Jun 2001 08:07:22 -0400

> Byzantine armies problem. Unsolvable.

Lovely.  

Thanks.

Kim