Subject: RE: [Sipping] A question about the Music on Hold/Call Park inserv ice examplesdraft

From: Jonathan Rosenberg <[email-masked]>
Date: Sat, 16 Jun 2001 03:00:25 -0400

> -----Original Message-----
> From: Benedito, Ernesto [mailto:[email-masked]]
> Sent: Thursday, June 14, 2001 4:20 PM
> To: [email-masked]
> Subject: RE: [Sipping] A question about the Music on Hold/Call Park
> inservice examplesdraft
> 
> 
> Hi Folks,
> 
> My humble opinion on this. Well..I guess this e-mail is a 
> bunch of questions rather than an opinion.
> 
> 1- When using this B2BUA approach, what will happen with user 
> A's display? Will the UA on user A be able to show "on hold" 
> while the user is parked to the music server? I mean, 
> detecting 0.0.0.0 in the "c" field of the SDP (and the new 
> Invite) will allow the UA to notify the CC that it has to 
> show the "hold" message on the LCD (or display of the 
> device), but having a valid IP in the "c" header (as it would 
> happen in this case, the one from the music server), how does 
> A detects it is a hold and not a simple redirection of the 
> media stream?

Wow, this is a great question. I really like it since the answer is "yes,
the on-hold notification can be shown" ONLY if a UA that receives an INVITE
with held SDP DOESN't automatically respond with held SDP.

So, how would it work?

The holding user (user B) acts as a B2BUA. It sends an INVITE w/o SDP to the
music-on-hold server. It gets back a 200 OK with SDP. It modifies that SDP
to have a 0.0.0.0 in the c line. It takes that SDP, and sends that in a
re-INVITE to A. A responds 200 OK, and includes an SDP with a normal,
non-zero c line. B takes that SDP, and places it in the ACK to the
music-on-hold server. It also ACKs B.

From A's perspective, it got re-invited, and the stream is now on hold, so
it doesn't send anything, and it can tell the user they are on hold. But,
since the response had a normal receive address/port, it can receive the
music-on-hold from the media server. 

So, here we have a concrete case where things don't work right when a UA
responds to held SDP with held SDP.

-Jonathan R.

---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
Sipping mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/sipping

---

From: "Fairlie-Cuninghame, Robert" <[email-masked]>
Date: Mon, 18 Jun 2001 04:05:09 -0700

And a good reason why a UA should still play received media when put on
hold. 

Robert.

-----Original Message-----
From:	Jonathan Rosenberg [mailto:[email-masked]]
Sent:	Saturday, June 16, 2001 8:00 AM
To:	'Benedito, Ernesto'; [email-masked]
Subject:	RE: [Sipping] A question about the Music on Hold/Call Park
inserv ice examplesdraft

So, how would it work?

-Jonathan R.

---