Subject: RE: [Sipping] Loose Routing Proposal

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Mon, 10 Sep 2001 14:50:31 +0100

The issue is not DNS query time.

The issue is that two of the outbound proxies need to do calls to a separate
database (the HSS). The call from the I-CSCF is to provide information on
the best S-CSCF to serve that user. The call from the S-CSCF is to download
all the service capabilities that that user requires to the S-CSCF, and do
the authentication of that user. 

In 3GPP it was considered that these would provide too much delay from
hitting the send button on the terminal, and therefore the decision was made
that they needed to be done at registration time. Similar considerations
would also apply for an incoming call.

Keith

Keith Drage
Lucent Technologies
Tel: +44 1793 776249
Email: [email-masked]

> ----------
> From: 	Juha Heinanen[SMTP:[email-masked]]
> Sent: 	07 September 2001 17:30
> To: 	Miguel A. Garcia
> Cc: 	Rosen, Brian; 'Cullen Jennings'; [email-masked]
> Subject: 	Re: [Sipping] Loose Routing Proposal
> 
> Miguel A. Garcia writes:
> 
>  > This solution has been proposed to 3GPP, but didn't get quite much
>  > acceptance, based on some concerns with the extra load in other 
>  > network entities (e.g., HSS).
> 
> i have hard time accepting the load argument.  all internet applications
> make dns queries when started and i haven't notived any load problem
> although i claim that there are many times more dns queries in the
> internet than phone calls in the pstn. also, when number portability is
> implemented in the pstn, each phone call starts generating dns queries
> anyway.  further, i heard that even in 3gpp the query is made at the
> terminating end.
> 
> so to me it looks like the real reason is something else.  using these
> kind of vague load arguments it is useless to come to ietf and ask it to
> standardize an g3pp specific extension.  internet applications work
> using internet standardized support systems and if that is not
> acceptable to 3gpp then it is better that 3gpp folks stop wasting
> bandwidth on internet mailing lists.
> 
> -- juha
> 
> _______________________________________________
> Sipping mailing list  http://www1.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments of core SIP
> 

_______________________________________________
Sipping mailing list  http://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Juha Heinanen <[email-masked]>
Date: Mon, 10 Sep 2001 16:55:23 +0300

> The issue is not DNS query time.

why can't they use the svr record of the user's domain to find out the
best s-cscf?  that way the information could be stored in dns.

-- juha

---

From: Michael Hammer <[email-masked]>
Date: Mon, 10 Sep 2001 10:36:06 -0400

All,

Let me try and state the requirements regarding what needs to be known to
populate a Loose Route in an Invite:

1) The UAC needs to know the identity of its home inbound proxy, that may
dynamically assign a home serving proxy.

2) The visited network needs to know that a UAC is in its domain (to
accept and route inbound calls and perhaps to allow outbound calls) and
to assign a serving visited proxy.

3) The UAC needs to know the identity of the visited in/out-bound proxy
and visited serving proxy (one of which may control whether it gets out
of the local visited network).

4) The home network needs to know the identity of the serving proxy in
the visited network (to route terminating calls there).

It appears 1) is primarily a provisioning issue.

2) and 3) appear to require a Registration in the visited network.

4) would also appear to be the result of a Registration.

Why wouldn't this be a two-stage process upon power-on:

1:  Register in the visited network and retrieve the visited serving
and out-bound proxy.

2:  Register (with loose path through those two) to home inbound
proxy and retrieve the home serving proxy.

Note:  This could be done in one end-to-end flow, but the above
places the responsibility on the UAC.

From this point on, each element should have the data it needs to do
what it needs to do.  This doesn't seem that difficult.  Is
this process much different from how DHCP works?  Am I missing
anything here?

Mike

At 04:55 PM 9/10/2001 +0300, Juha Heinanen wrote:

> The issue is not DNS query time.

why can't they use the svr record of the user's domain to find out
the

-- juha

Sipping mailing list
http://www1.ietf.org/mailman/listinfo/sipping