Subject: RE: [Sipping] Loose Routing Proposal

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 12 Sep 2001 15:21:36 -0400

I'm not sure we should go so far.  The basic question, to me, is:
Is it reasonable for a supplier of service to force routing through
one or more proxies?

It seems to me that this should be possible.  You always have the 
choice of not using that service provider, but if you do, they may
want to require that you go through whatever proxy servers they
want you to.

The 3G problem gives us a wrinkle, because there are two service
providers.  To me, the key is that the service provider that I
subscribe to (home network) is NOT the first network in the
chain.  I don't think it's required that the UA route to the
home network, but I think it must be possible, using standard SIP
for the visited network to know what the home network proxy is,
and force the call to go through that proxy.

This is NOT a requirement peculiar to 3G, it's a requirement of
any interconnected networks that allow roaming.  3G is just the
obvious poster child.  You can imagine a wireline equivalent.

Brian

> -----Original Message-----
> From: Henning G. Schulzrinne [mailto:[email-masked]]
> Sent: Wednesday, September 12, 2001 3:09 PM
> To: Michael Hammer
> Cc: Juha Heinanen; [email-masked]
> Subject: Re: [Sipping] Loose Routing Proposal
> 
> 
> Announcements? This is signaling path, not media, so I don't see how
> announcements come into play.
> 
> In general, I think it might help us if we identify at least 
> examples of
> home outbound services. The ones I've heard about so far (short-cut
> dialing and outbound call filtering) seem interesting, but hardly
> something I can't live without.
> 
> In general, I thought Juha made the point that this should be at the
> discretion of the user. I may decide that sending my packets 
> through NYC
> when the servers are overloaded may not be worth the slight
> customization afforded by the home proxy. Why shouldn't this 
> be left to
> the end system and user?
> 
> 
> Michael Hammer wrote:
> > 
> > The only problem with this architecture is that the 3GPP 
> groups, I thought,
> > were going to have the "virtual home environment" operating 
> at the home
> > serving node.  If the visited node is to control the 
> features and services
> > (e.g. personalized announcements) of the subscriber in the 
> visited network,
> > then it must be possible to transfer that logic to the 
> visited system.  An
> > assumption is that the user's phone will contain all the 
> logic and data,
> > but I'm not sure if the format of the mobile phones (e.g. a 
> powerful enough
> > but small battery) will support that.
> > 
> > The alternative is commodotized rather than personalized 
> service.  Thoughts?
> > 
> > Mike
> > 
> > At 02:14 PM 9/12/2001 -0400, Henning G. Schulzrinne wrote:
> > >Juha Heinanen wrote:
> > > >
> > > > yes, the visited network needs to be able to 
> authenticate the caller,
> > > > but once that has succeeded, the subsciber should have 
> the choice to
> > > > make a call directly rather than being routed via the 
> "home" network.
> > >
> > >Also, I would imagine that the visited network would not 
> have to go back
> > >to the home network for authentication for every call. If 
> you know that
> > >[email-masked] is indeed a Telia customer, you don't have to ask two
> > >minutes later again.
> > >
> > >In addition, while off-line or semi-off-line micropayment 
> schemes aren't
> > >all that popular today, one could imagine that they might 
> catch on. So
> > >we shouldn't be designing an architecture that imposes unnecessary
> > >constraints just because today's billing system works a 
> certain way.
> > >--
> > >Henning Schulzrinne   http://www.cs.columbia.edu/~hgs
> > >
> > >_______________________________________________
> > >Sipping mailing list  http://www1.ietf.org/mailman/listinfo/sipping
> > >This list is for NEW development of the application of SIP
> > >Use [email-masked] for questions on current sip
> > >Use [email-masked] for new developments of core SIP
> 
> -- 
> Henning Schulzrinne   http://www.cs.columbia.edu/~hgs
> 
> _______________________________________________
> Sipping mailing list  http://www1.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments of core SIP
> 

_______________________________________________
Sipping mailing list  http://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Miguel A. Garcia" <[email-masked]>
Date: Fri, 14 Sep 2001 14:24:36 +0300

> Is it reasonable for a supplier of service to force routing through

I think this is a reasonable requirement. The main idea behind is
that you want to roam, but you don't want your services to roam
with you (as it happens in GSM). Therefore, the only way to guarantee
that your services are executed independently of your location, is
to route the signalling to the home network, invoke and perhaps
execute your services there, and then proceed with the the call.

If you don't want to use any service of your home network, then
you can always fall back to a SIP client connected to any packet
data network. Nobody is preventing this scenario.

/Miguel

-- 
Miguel-Angel Garcia                     Oy LM Ericsson AB
                                        Jorvas, Finland
mailto:[email-masked]     Phone:  +358 9 299 3553
mailto:[email-masked]        Mobile: +358 40 5140002