Subject: [Sipping] RE: Hearing and Speech Impaired User Requirements for SIP Communications (David R. Oran)

From: "Guido Gybels" <[email-masked]>
Date: Tue, 25 Sep 2001 17:24:54 +0100

Dave, you wrote::

<<I don't like the word "seamless" since I have no idea what it means.
Similarly for words like "transparent".>>

Actually, we had a discussion about this and we decided "transparant" was a no-no. Does this mean that there should be no user interaction required to set up relayed calls etc (as far as I can tell this is already possible through SIP, but I'm sure Jonathan or Henning could enlighten us!).

<<Saying this tends eliminate valid engineering tradeoffs in which the differences are noticeable by the hearing/speech impaired, but not inconvenient or limiting.>>

What does "Inconvenient" mean?? From the manufacturers point of view??? If "seamless" is difficult to define, surely "inconvenient" is. And I think the whole point of this effort is to have *no* limitations for disabled people imposed on them by the underlying protocol!

<<"Useful sessions must be establishable <snip>>>

Seems a reasonable addition, but I'd like to see a definition for "useful".
 
> This means that the caller should be able to add or remove 
> media streams (for example, add subtitling or re-route a 
> stream through a relay service) at any point during the 
> session without interrupting the call.
>
<<Why can't the callee do this? I suspect that was just an oversight in
the wording.>>

Agreed. Should we just say: "Any UA?"

<<Does it mean that a hearing/speech impaired must be able to use
intermediaries he trusts to hide these preferences from other end users,>>

I think that is really a mandatory requirement. Arnoud?

<<I don't see what SIP or SIPPING can do about this requirement>>

We should probably come up with a clearer distinction between what the requirements are for the underlying SIP protocol as opposed to the policies we want to enforce towards service providers and the services they offer. 

<<"User agents should be able to choose among relay and similar services
based on their capabilities (for example, whether a relay service
accepts a particular media stream), and any policy constraints they
impose (for example, charging for use). It should further be possible
for user agents to discover what alternative media are available and to
choose among them.>>

So, can we use SIP as it is to perform these kinds of tasks?? Any suggestions as how to actually implement it?

<<Further, I'm afraid I don't understand what it means to "be able to
identify the content of particular media streams">>

I think what it means is that a UA connecting to another UA should be able to determine what kind of media streams the other party is either transmitting or receiving as to determine to what streams it will want to connect, depending on the preferences settings. For instance: when a UA connects to the UA of a radio broadcasting company, the radio UA might tell the listener's UA that it provides both an audio and a text stream. In case the listener is a deaf person, he/she will have set up his preferences to receive incoming audio as text (for a regular voice call this means that the incoming speech stream will have to be rerouted through a relay service). So, in that case, the listener's UA will connect to the radio station's *text* stream, rather than the audio stream.

> For example, a caller wishing to listen to a radio program 
> (Radio 4) would be re-directed from the TypeTalk relay 
> service, and the radio station would provide information 
> about the availability of the audio stream through a text stream.
> 
<<This example, while valid, is a poor one for SIP, since this application
would be much better done with RTSP>>

Well, that is probably a really good reason to look at what *SIP* can/should do!!

<<(I suspect RTSP in fact already can do exactly what you propose here, but I'm not sure).>>

I'd be glad to get feedback from the others about this one!

<<I'm quite nervous about this part of the requirement>>

When resource constraints and resource management are coming up, I find that many people start getting nervous. But still, it *is* a real world issue, so I think it should be handled.

, since we don't do
it for any other preference. On the other hand, I don't see a problem
with asking for such capabilities.

> All communications involving interpreters, translators, and 
> relay services with deaf and speech-impaired users MUST be 
> confidential and secure.
> 
<<Ummmm...I don't think we can mandate this, especially in light of
conflicting requirements for legal intercept.>>

What legal intercept?? I don't really understand that comment and I'd like some clarification about it.

Guido

Guido Gybels
RNID, Head of ICT
[email-masked]
Tel +44(0)20-7294 3713
Fax +44(0)20-7296 8069
---
Royal National Institute for Deaf People
19-23 Featherstone Street
LONDON EC1Y 8 SL
Phone 020-7296 8000
TextPhone 020-7296 8001
Fax 020-7296 8199

************************************************************************
This email and any files transmitted with it are confidential
and intended solely for the use of the individual or entity to
whom they are addressed. Any views or opinions expressed
are solely those of the author and do not necessarily represent
RNID policy.

If you are not the intended recipient you are advised that any
use, dissemination, forwarding, printing or copying of this
email is strictly prohibited.

If you have received this email in error please notify the RNID
network manager by telephone on: +44 (0) 207 296 8098.
************************************************************************

_______________________________________________
Sipping mailing list  http://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Michael Hammer <[email-masked]>
Date: Tue, 25 Sep 2001 14:58:21 -0400

Guido,

Could you clarify:

[snip]

>For instance: when a UA connects to the UA of a radio broadcasting 
>company, the radio UA might tell the listener's UA that it provides both 
>an audio and a text stream. In case the listener is a deaf person, he/she 
>will have set up his preferences to receive incoming audio as text (for a 
>regular voice call this means that the incoming speech stream will have to 
>be rerouted through a relay service). So, in that case, the listener's UA 
>will connect to the radio station's *text* stream, rather than the audio 
>stream.

[snip]

Why would the listener want to expend resources (both network and relay) to 
translate what is already provided in text form at the source?  Would this 
result in two different versions of the text?  Wouldn't the user just tell 
the source, send me only the text stream?

Mike

---

From: "David R. Oran" <[email-masked]>
Date: Fri, 28 Sep 2001 18:51:44 -0400

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of Guido Gybels
> Sent: Tuesday, September 25, 2001 12:25 PM
> To: [email-masked]
> Subject: [Sipping] RE: Hearing and Speech Impaired User 
> Requirements for SIP Communications (David R. Oran)
> 
> 
> Dave, you wrote::
> 
> <<I don't like the word "seamless" since I have no idea what 
> it means. Similarly for words like "transparent".>>
> 
> Actually, we had a discussion about this and we decided 
> "transparent" was a no-no. 
Right. That's what I was saying above. Sorry if my wording confused you.

> Does this mean that there should 
> be no user interaction required to set up relayed calls etc 
> (as far as I can tell this is already possible through SIP, 
> but I'm sure Jonathan or Henning could enlighten us!).
> 
I think this is beyond the scope of what we can write requirements
about. I can certainly envision a SIP appliance meant to be used by both
impaired and non-impaired users and hence require some user action to
tell the system what behavior is desired. Similarly, I can't see any way
to avoid SOME extra machinery to control whether relay services are
needed or not, if only in deciding what to put in my SDP.

> <<Saying this tends eliminate valid engineering tradeoffs in 
> which the differences are noticeable by the hearing/speech 
> impaired, but not inconvenient or limiting.>>
> 
> What does "Inconvenient" mean?? From the manufacturers point 
> of view??? If "seamless" is difficult to define, surely 
> "inconvenient" is. 
Touché! Perhaps we can hold the SIP solution up to the standard of
existing legacy solutions, instead of some absolute which may either not
be achievable, or too disruptive of the other goals we need to achieve
with SIP.

> And I think the whole point of this effort 
> is to have *no* limitations for disabled people imposed on 
> them by the underlying protocol!
> 
Much as I agree with the spirit of this statement, I don't know how to
achieve this, since what is a limitation for a disabled person might not
be for a regular user, or vice versa. There are always tradeoffs. Is it
also a goal to not impose limitations for non-impaired users by
accommodating the needs of impaired users? If so, perhaps we should
state this explicitly.

> Seems a reasonable addition, but I'd like to see a definition 
I would define "useful" as providing a sufficient subset of the media
required by the user to be able to communicate.
  
> <<Why can't the callee do this? I suspect that was just an 
> oversight in the wording.>>
> 
Sure, ok.
 
> <<Does it mean that a hearing/speech impaired must be able to 
> use intermediaries he trusts to hide these preferences from 
> other end users,>>
> 
> We should probably come up with a clearer distinction between 
> what the requirements are for the underlying SIP protocol as 
> opposed to the policies we want to enforce towards service 
> providers and the services they offer. 
>
Yes, many of my anal comments are directed at this issue.
 
> <<"User agents should be able to choose among relay and 
> similar services based on their capabilities (for example, 
> whether a relay service accepts a particular media stream), 
> and any policy constraints they impose (for example, charging 
> for use). It should further be possible for user agents to 
> discover what alternative media are available and to choose 
> among them.>>
> 
> So, can we use SIP as it is to perform these kinds of tasks?? 
> Any suggestions as how to actually implement it?
> 
> <<Further, I'm afraid I don't understand what it means to "be 
> able to identify the content of particular media streams">>
> 
> I think what it means is that a UA connecting to another UA 
> should be able to determine what kind of media streams the 
> other party is either transmitting or receiving as to 
> determine to what streams it will want to connect, depending 
> on the preferences settings. 
Ah, that's not what I usually understand as "content". The words you use
here are quite good and would probably serve just fine as text of the
requirement.

> For instance: when a UA connects 
> to the UA of a radio broadcasting company, the radio UA might 
> tell the listener's UA that it provides both an audio and a 
> text stream. In case the listener is a deaf person, he/she 
> will have set up his preferences to receive incoming audio as 
> text (for a regular voice call this means that the incoming 
> speech stream will have to be rerouted through a relay 
> service). So, in that case, the listener's UA will connect to 
> the radio station's *text* stream, rather than the audio stream.
> 
> <<This example, while valid, is a poor one for SIP, since 
> this application would be much better done with RTSP>>
> 
Not sure I understand your comment here.

> When resource constraints and resource management are coming 
> up, I find that many people start getting nervous. But still, 
> it *is* a real world issue, so I think it should be handled.
> 
> , since we don't do
> it for any other preference. On the other hand, I don't see a 
> problem with asking for such capabilities.
> 
> <<Ummmm...I don't think we can mandate this, especially in 
> light of conflicting requirements for legal intercept.>>
> 
> What legal intercept?? I don't really understand that comment 
> and I'd like some clarification about it.
>
Wiretapping. If you say a relay has to be confidential and secure, that
means it can't be a point at which a wiretap is inserted.
 
> Guido
Hope this exchange gets us closer to closure on this stuff. It's
important.
Dave.

> and intended solely for the use of the individual or entity 
> to whom they are addressed. Any views or opinions expressed 
> are solely those of the author and do not necessarily 
> represent RNID policy.
> 
> If you are not the intended recipient you are advised that 
> any use, dissemination, forwarding, printing or copying of 
> this email is strictly prohibited.
> 
> If you have received this email in error please notify the 
> RNID network manager by telephone on: +44 (0) 207 296 8098.
> Use [email-masked] for questions on current 
> sip Use [email-masked] for new developments of core SIP
>

---

From: Henry Sinnreich <[email-masked]>
Date: Sun, 30 Sep 2001 05:41:25 -0500

Guido Gybels writes:
>Perhaps we can hold the SIP solution up to 
>the standard of existing legacy solutions

This logic would negate building the Internet and make us just continue
with circuit switched networks. It is fundamentally flawed, does not
apply in the IETF work. Interfacing with legacy systems is indeed a core
requirement, but our architecture is not legacy or we would not work in
the IETF.

To get this discussion on track, let us just focus in the WG on the
precise _technical_ requirements of SIP enabled systems for the hearing
disabled. 

Precise requirements that can be measured in lab and network
environments.

Thanks, Henry

> On Behalf Of David R. Oran
> Sent: Friday, September 28, 2001 5:52 PM
> To: 'Guido Gybels'; [email-masked]
> Subject: RE: [Sipping] RE: Hearing and Speech Impaired User