Subject: RE: [Sipping] Hearing and Speech Impaired User Requirements for S IP Communications

From: "Arnoud van Wijk (ELN)" <[email-masked]>
Date: Mon, 24 Sep 2001 12:35:31 +0200

Guido,
This is indeed correct. The reason that we are working on the requirements is also to ensure complete freedom of the services. The hearing impaired user should be able to select ANY service anytime and anywhere. And one service should seamlessly migrate to another (similar)service. For example, in case the radio station mentioned before. But also in case of roaming that a local relay service can take over te rest of the call, since it requires less resources (and is then cheaper/ faster/ less congestion etc).

To enable this I think that we may have to add an additional requirement(add to resource management):
When an end-user is logging on a network (first time or via moving from one operators domain to another operators domain), the user should be able to automatically poll for available services that are locally available. That is thus before querying the service itself on what they CAN provide (as stated in the quote below: 5. Resource management). 

The relay and other service providers should be able to communicate with each other to ensure proper and seamless handover of the services. For example that in this way a call is not interrupted and that the hearing impaired user is ensured that the e.g. relay does not drop out even for a few seconds. You can imagine then that during a signlanguage relay session, the interpreter can change from a female to a male suddenly (or perhaps temporarily a split screen..). Ofcourse, the hearing impaired user is allowed to keep the same relay service even when roaming and switching networks (but he or she has then to pay more for the connectivity probably).

"5. Resource Management
Requirement:
User Agents should be able to query relay and similar services about what they provide (for example, whether a relay service accepts a particular media stream) and the rules around their service (for example, cost), while these services should be able to feed this information back to User Agents. Relay services and User Agents should be able to identify the content of particular media streams."

Advantages: Quick and transparant switching between similar services if possible and desired.

cheers

Arnoud van Wijk

_______________________________________________________________
ERICSSON EUROLABS NETHERLANDS BV
Arnoud van Wijk
Fax: +31-161 247569
_______________________________________________________________

-----Original Message-----
From: Guido Gybels [mailto:[email-masked]]
Sent: vrijdag 21 sep 2001 18:15
To: [email-masked]
Subject: Re: [Sipping] Hearing and Speech Impaired User Requirements for
SIP Communications

Nathan, you wrote:

<<I assume requirement 5 means that the beneficiary of relay services can
define which relay service they want to use but that the relay service
itself can rule itself out of relaying in certain scenarios>>

That is how I understand it, yes. The reasoning behind this is exactly as you said: relay services like Typetalk for instance here in the UK (where human operators will translate spoken language to text and vice-versa) will definitely want to rule out specific uses, like in this case rerouting radio broadcast over the relay service. Remember, these services have limited resources and imagine large numbers of people listening to the radio over them!
More to the point: in a SIP world, the radio station should probably be providing for some text stream for their broadcasts, much like subtitling streams for television.
So, when a user agent tries to establish a connection to the radio station, the latter should provide some feedback about the availability of a text stream for its broadcast. That way, if the UA of the deaf listener has established as its preference that incoming audio should be converted to text (by default by invoking a relay service), the UA would notice that the radio station provides already for a text stream and connects "seamless" to it (see the first requirement as well).

Guido

Guido Gybels
RNID, Head of ICT
[email-masked]
Tel +44(0)20-7294 3713
Fax +44(0)20-7296 8069
---
Royal National Institute for Deaf People
19-23 Featherstone Street
LONDON EC1Y 8 SL
Phone 020-7296 8000
TextPhone 020-7296 8001
Fax 020-7296 8199

************************************************************************
This email and any files transmitted with it are confidential
and intended solely for the use of the individual or entity to
whom they are addressed. Any views or opinions expressed
are solely those of the author and do not necessarily represent
RNID policy.

If you are not the intended recipient you are advised that any
use, dissemination, forwarding, printing or copying of this
email is strictly prohibited.

If you have received this email in error please notify the RNID
network manager by telephone on: +44 (0) 207 296 8098.
************************************************************************

_______________________________________________
Sipping mailing list  http://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

_______________________________________________
Sipping mailing list  http://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Henry Sinnreich <[email-masked]>
Date: Mon, 24 Sep 2001 20:00:58 -0500

This is an excellent exchange on requirements. Would make the
distinction between:

1. Service requirements,
2. SIP protocol requirements.

Item #2 is a legitimate SIPPING WG item, while #1 is an implementaion
issue for the service provider, and to a large extent a
business/regulatory decision. Does everyone here agree with this
distinction?

Thanks, Henry

Henry Sinnreich
WorldCom
400 International Parkway
Richardson, Texas 75081
USA 

> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of Arnoud van Wijk (ELN)
> Sent: Monday, September 24, 2001 5:36 AM
> To: 'Guido Gybels'; [email-masked]
> Cc: [email-masked]
> Subject: RE: [Sipping] Hearing and Speech Impaired User 
> Requirements for S IP Communications
> 
> 
> Guido,
> This is indeed correct. The reason that we are working on the 
> requirements is also to ensure complete freedom of the 
> services. The hearing impaired user should be able to select 
> ANY service anytime and anywhere. And one service should 
> seamlessly migrate to another (similar)service. For example, 
> in case the radio station mentioned before. But also in case 
> of roaming that a local relay service can take over te rest 
> of the call, since it requires less resources (and is then 
> cheaper/ faster/ less congestion etc).
> 
> To enable this I think that we may have to add an additional 
> requirement(add to resource management): When an end-user is 
> logging on a network (first time or via moving from one 
> operators domain to another operators domain), the user 
> should be able to automatically poll for available services 
> that are locally available. That is thus before querying the 
> service itself on what they CAN provide (as stated in the 
> quote below: 5. Resource management). 
> 
> The relay and other service providers should be able to 
> communicate with each other to ensure proper and seamless 
> handover of the services. For example that in this way a call 
> is not interrupted and that the hearing impaired user is 
> ensured that the e.g. relay does not drop out even for a few 
> seconds. You can imagine then that during a signlanguage 
> relay session, the interpreter can change from a female to a 
> male suddenly (or perhaps temporarily a split screen..). 
> Ofcourse, the hearing impaired user is allowed to keep the 
> same relay service even when roaming and switching networks 
> (but he or she has then to pay more for the connectivity probably).
> 
> "5. Resource Management
> Requirement:
> User Agents should be able to query relay and similar 
> services about what they provide (for example, whether a 
> relay service accepts a particular media stream) and the 
> rules around their service (for example, cost), while these 
> services should be able to feed this information back to User 
> Agents. Relay services and User Agents should be able to 
> identify the content of particular media streams."
> 
> Subject: Re: [Sipping] Hearing and Speech Impaired User 
> Requirements for SIP Communications
> 
> 
> Nathan, you wrote:
> 
> <<I assume requirement 5 means that the beneficiary of relay 
> services can define which relay service they want to use but 
> that the relay service itself can rule itself out of relaying 
> in certain scenarios>>
> 
> That is how I understand it, yes. The reasoning behind this 
> is exactly as you said: relay services like Typetalk for 
> instance here in the UK (where human operators will translate 
> spoken language to text and vice-versa) will definitely want 
> to rule out specific uses, like in this case rerouting radio 
> broadcast over the relay service. Remember, these services 
> have limited resources and imagine large numbers of people 
> listening to the radio over them! More to the point: in a SIP 
> world, the radio station should probably be providing for 
> some text stream for their broadcasts, much like subtitling 
> streams for television. So, when a user agent tries to 
> establish a connection to the radio station, the latter 
> should provide some feedback about the availability of a text 
> stream for its broadcast. That way, if the UA of the deaf 
> listener has established as its preference that incoming 
> audio should be converted to text (by default by invoking a 
> relay service), the UA would notice that the radio station 
> provides already for a text stream and connects "seamless" to 
> it (see the first requirement as well).
> 
> Guido
> 
> 
> 
> Guido Gybels
> RNID, Head of ICT
> [email-masked]
> Tel +44(0)20-7294 3713
> Fax +44(0)20-7296 8069
> ---
> and intended solely for the use of the individual or entity 
> to whom they are addressed. Any views or opinions expressed 
> are solely those of the author and do not necessarily 
> represent RNID policy.
> 
> If you are not the intended recipient you are advised that 
> any use, dissemination, forwarding, printing or copying of 
> this email is strictly prohibited.
> 
> If you have received this email in error please notify the 
> RNID network manager by telephone on: +44 (0) 207 296 8098.
> Use [email-masked] for questions on current 
> sip Use [email-masked] for new developments of core SIP
> 
> Use [email-masked] for questions on current 
> sip Use [email-masked] for new developments of core SIP
>