Subject: [Sipping] RE: Quick Comments on publish-requirements-00

From: Steve Donovan <[email-masked]>
Date: Thu, 13 Sep 2001 17:29:46 -0400

> -----Original Message-----
> From: James Undery [mailto:[email-masked]]
> Sent: Monday, September 10, 2001 9:21 AM
> To: Steve Donovan; Sipping (E-mail)
> Subject: Quick Comments on publish-requirements-00
> 
> 
> Hi,
> 
> A few quick comments on this draft.
> 
> Section 5.1 "The extension MUST support the ability to 
> associate publication
> data contained in a message body with a service." If I understand this
> correctly, would this be better expressed as "The extension 
> MUST support the
> ability to associate publication data with a URI." i.e.
> pres:[email-masked] (presence) or 
> sip:[email-masked];methods="INVITE"
> (CPL, very simplistic going to fail).

Not necessarily.  It could be done with the URI, but it could also be done
with a header in a way that is analogous to the event header in the SIP
Events model.  As such, from a requirements perspective, I would rather
leave the requirement as stated.

> 
> Section 5.3 A potentially important addition is "publishing" 
> entity must be
> allowed to store data with soft state, even if the "source" 
> entity requests
> hard state. i.e. The ability to say you want me to store this 
> data forever,
> but, I am only going to store it for an hour, resend it then 
> if you want
> stored longer.

Excellent point.  I'll add this to the next version of the document.

> 
> <RandomBrainDump>
> The problem I had phrasing the above comment indicates some defined
> terminology might be useful. i.e. some bad examples of the 
> top of my head
> Author - An entity providing data for publication.
> Publisher - An entity that publishes data.
> Reader - An entity that requests data from a publisher.
> </RandomBrainDump>
> 
> James Undery
> 

_______________________________________________
Sipping mailing list  http://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 19 Sep 2001 00:33:27 -0400

> From: Steve Donovan [mailto:[email-masked]]
> Sent: Thursday, September 13, 2001 5:30 PM
> To: 'James Undery'; Steve Donovan; Sipping (E-mail)
> Subject: [Sipping] RE: Quick Comments on publish-requirements-00
> 
> 
> 
> 

I imagine this is for resource management purposes? I.e., a server that
doesn't want to maintain stuff for too long? 

I assume this introduces another requirement, for the server to tell the
client how long it is actually willing to keep the "hard" state for.

-Jonathan R.

---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

---

From: Steve Donovan <[email-masked]>
Date: Wed, 19 Sep 2001 10:57:25 -0400

<snip>
> I imagine this is for resource management purposes? I.e., a 
> server that doesn't want to maintain stuff for too long? 
> 
> I assume this introduces another requirement, for the server 
> to tell the client how long it is actually willing to keep 
> the "hard" state for.

That seems to be equivalent to James suggestion that the server be able to
indicate that it will store a hard state request as soft state, as the
difference between hard state and soft state is that soft state times out.

---
Steven R. Donovan
Architect                           dynamicsoft                         
mailto:[email-masked]     5100 Tennyson Parkway
sip:[email-masked]    Plano, Texas 75025
tel:+1-972-473-5469                 http://www.dynamicsoft.com