Subject: Re: [Sipping] Hearing and Speech Impaired User Requirements for SIP Communications

From: "Nathan Charlton" <[email-masked]>
Date: Fri, 21 Sep 2001 04:20:07 -0700

I assume requirement 5 means that the beneficiary of relay services can
define which relay service they want to use but that the relay service
itself can rule itself out of relaying in certain scenarios (in the case
below, a speach to text relay service doesn't want to relay the audio
stream from a radio station). The example radio station would be able to
define its own speach to text relay service if required.
Have I got this right. I think this needs more clarity.

Nathan

> 5. Resource Management
> Requirement:
> User Agents should be able to query relay and similar services about what
they provide (for example, whether a relay service accepts a particular
media stream) and the rules around their service (for example, cost), while
these services should be able to feed this information back to User Agents.
Relay services and User Agents should be able to identify the content of
particular media streams. 
> 
> For example, a caller wishing to listen to a radio program (Radio 4)
would be re-directed from the TypeTalk relay service, and the radio station
would provide information about the availability of the audio stream
through a text stream.

_______________________________________________
Sipping mailing list  http://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Guido Gybels" <[email-masked]>
Date: Fri, 21 Sep 2001 17:14:48 +0100

Nathan, you wrote:

<<I assume requirement 5 means that the beneficiary of relay services can
define which relay service they want to use but that the relay service
itself can rule itself out of relaying in certain scenarios>>

That is how I understand it, yes. The reasoning behind this is exactly as you said: relay services like Typetalk for instance here in the UK (where human operators will translate spoken language to text and vice-versa) will definitely want to rule out specific uses, like in this case rerouting radio broadcast over the relay service. Remember, these services have limited resources and imagine large numbers of people listening to the radio over them!
More to the point: in a SIP world, the radio station should probably be providing for some text stream for their broadcasts, much like subtitling streams for television.
So, when a user agent tries to establish a connection to the radio station, the latter should provide some feedback about the availability of a text stream for its broadcast. That way, if the UA of the deaf listener has established as its preference that incoming audio should be converted to text (by default by invoking a relay service), the UA would notice that the radio station provides already for a text stream and connects "seamless" to it (see the first requirement as well).

Guido

Guido Gybels
RNID, Head of ICT
[email-masked]
Tel +44(0)20-7294 3713
Fax +44(0)20-7296 8069
---
Royal National Institute for Deaf People
19-23 Featherstone Street
LONDON EC1Y 8 SL
Phone 020-7296 8000
TextPhone 020-7296 8001
Fax 020-7296 8199

************************************************************************
This email and any files transmitted with it are confidential
and intended solely for the use of the individual or entity to
whom they are addressed. Any views or opinions expressed
are solely those of the author and do not necessarily represent
RNID policy.

If you are not the intended recipient you are advised that any
use, dissemination, forwarding, printing or copying of this
email is strictly prohibited.

If you have received this email in error please notify the RNID
network manager by telephone on: +44 (0) 207 296 8098.
************************************************************************

---

From: "Guido Gybels" <[email-masked]>
Date: Tue, 25 Sep 2001 16:52:35 +0100

Arnoud, you wrote:

<<This is indeed correct. The reason that we are working on the requirements is also to ensure complete freedom of the services.>>

Well, we want SIP as a *protocol* to provide for the mechanisms that will allow service providers to create decent services. However, as Henry pointed out, and I agree with that, we should not confuse the issues. SIP as a protocol should be *able* to do what our requirements ask it to do. However, whether or not a service provider actually implements specific services is an entirely different matter.

<<But also in case of roaming that a local relay service can take over te rest of the call>>

So, SIP should provide the mechanism for letting these UA at both ends exchange the necessary information about availability, content, etc. (BTW, any suggestions from anybody how to do this in a standardised way??)

<<When an end-user is logging on a network (first time or via moving from one operators domain to another operators domain), the user should be able to automatically poll for available services that are locally available. That is thus before querying the service itself on what they CAN provide (as stated in the quote below: 5. Resource management). >>

I don't understand this. It seems this confuses what network operators and service providers should do. Isn't this just part of the way a service is implemented and therefor not directly related to SIP?

Guido

Guido Gybels
RNID, Head of ICT
[email-masked]
Tel +44(0)20-7294 3713
Fax +44(0)20-7296 8069
---