Subject: RE: [Sipping] Loose Routing Proposal

From: "Sean Olson (EUS)" <[email-masked]>
Date: Mon, 10 Sep 2001 09:52:26 -0500

Because the SRV record for a given domain
tells you almost nothing about the
capabilities for that SIP server, other
than a desired priority and the transport
protocol (UDP, TCP, etc.). The selection
of the home proxy in the 3GPP network may
be based on more complex criteria that are
not easily expressed by a SRV record. The problem
is more similar to the one addressed by SLP.

Furthermore,
the local outbound proxy in this case can
belong to another operator and is not in the
position to make the determination about
which home proxy should be used.  

From the 3GPP point of view, the SRV records
identify the I-CSCF which is used to route
terminating calls to the proper S-CSCF
("home proxy") for a given subscriber. 

The problem we are trying to address is
how to choose that S-CSCF in the first place.
This is not what the Path: header is solving.
Rather the Path: header is carrying the result
of this decision back to the local outbound
proxy so that it can route subsequent SIP 
requests.

/sean

>-----Original Message-----
>From: Juha Heinanen [mailto:[email-masked]]
>Sent: Monday, September 10, 2001 8:55 AM
>To: Drage, Keith (Keith)
>Cc: Miguel A. Garcia; Rosen, Brian; 'Cullen Jennings'; [email-masked]
>Subject: RE: [Sipping] Loose Routing Proposal
>
>
>Drage, Keith (Keith) writes:
>
> > The issue is not DNS query time.
>
>why can't they use the svr record of the user's domain to find out the
>best s-cscf?  that way the information could be stored in dns.
>
>-- juha
>
>_______________________________________________
>Sipping mailing list  http://www1.ietf.org/mailman/listinfo/sipping
>This list is for NEW development of the application of SIP
>Use [email-masked] for questions on current sip
>Use [email-masked] for new developments of core SIP
>

---

From: Juha Heinanen <[email-masked]>
Date: Mon, 10 Sep 2001 18:32:30 +0300

> is more similar to the one addressed by SLP.

right and once the call gets to the home "entry" proxy as identified by
the srv record, then that "entry" proxy routes the call further to the
right service proxy based on the information it knows about the
subcriber that is stored in its subscriber database.  the visited proxy
doesn't need to and should not know any internal stuff related to the
organization of the home network.

 > which home proxy should be used.  

right, it just selects the "entry" proxy based on dns srv records.

-- juha