Subject: RE: [Sipping] Loose Routing Proposal

From: "Rosen, Brian" <[email-masked]>
Date: Mon, 10 Sep 2001 11:53:53 -0400

I guess this is the root of my confusion also.
Juha is describing the only way I know to make a
truly scalable/reliable entity - you have
a redundant pair of processors that are the
"entry proxy".  Their ONLY job is to hand off the
work to one processor in a pool of worker processors.
We know that such systems work quite well, and 
specifically, we know that they work with millions
of (http for example) transactions.  The limit to 
scalability is the limit of the entry processor 
to do the dispatch, and the overhead of the extra level 
of indirection.  I can't conceive of any way you could
argue that for 3GPP an entry processor would not
scale far enough.  

It isn't clear to me that the worker processors
have to be official SIP proxy servers -- that is,
the interface between the entry processor and the
worker processor could be proprietary, or it could
be standard SIP; implementation choice.  

3GPP appears to be trying to use a mechanism that
people who think they have discovered a "better way"
to do this often try - they want to distribute the load
semi-dynamically, by assigning worker processors
to UAs at registration.  In my experience, this
rarely works well:
	The reliability model is much less robust
	Load is not usually balanced (in this case
		it is because the number of calls per
		worker processor is not directly
		related to the number of registrations
		because call frequency varies a lot)
	There is too much network knowledge spread
		in the net
Ever bookmark something like: 
"ww6.loser.com/interesting/page.htm"
only to discover that it failed when you came back to it?
Same idea.  

Brian

> -----Original Message-----
> From: Juha Heinanen [mailto:[email-masked]]
> Sent: Monday, September 10, 2001 11:33 AM
> To: Sean Olson (EUS)
> Cc: Drage, Keith (Keith); Miguel A. Garcia; Rosen, Brian; 'Cullen
> Jennings'; [email-masked]
> Subject: RE: [Sipping] Loose Routing Proposal
> 
> 
> Sean Olson (EUS) writes:
> 
>  > Because the SRV record for a given domain
>  > tells you almost nothing about the
>  > capabilities for that SIP server, other
>  > than a desired priority and the transport
>  > protocol (UDP, TCP, etc.). The selection
>  > of the home proxy in the 3GPP network may
>  > be based on more complex criteria that are
>  > not easily expressed by a SRV record. The problem
>  > is more similar to the one addressed by SLP.
> 
> right and once the call gets to the home "entry" proxy as 
> identified by
> the srv record, then that "entry" proxy routes the call further to the
> right service proxy based on the information it knows about the
> subcriber that is stored in its subscriber database.  the 
> visited proxy
> doesn't need to and should not know any internal stuff related to the
> organization of the home network.
> 
>  > Furthermore,
>  > the local outbound proxy in this case can
>  > belong to another operator and is not in the
>  > position to make the determination about
>  > which home proxy should be used.  
> 
> right, it just selects the "entry" proxy based on dns srv records.
> 
> -- juha
> 

_______________________________________________
Sipping mailing list  http://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Henning Schulzrinne <[email-masked]>
Date: Tue, 11 Sep 2001 01:29:01 +0900

To add an additional point: Compared to HTTP and SMTP, SIP (through SRV)
provides a much more flexible way to load-balance the entry points.
There is no need for TCP redirectors and other hacks such as low-TTL
DNS. Plus, stateless proxies were designed for exactly this purpose.
This is simple to debug, scalable, and easy to deploy. You can
essentially just add and drop servers, without major consequences.