Subject: [Sipping] Using SIP to signal 'DTMF'?

From: [email-masked]
Date: Fri, 4 Jan 2002 13:18:45 -0000

SIPPING experts,

Being relatively new to IETF standards, I'm guessing that this may have been
discussed before, so excuse me asking again:

Can SIP signalling be used to carry DTMF information?

More specifically, has it ever been considered that a SIP message could be
used to indicate to an entity that a 'keypad digit' has been pressed by a
user, allowing that entity to perform a suitable action?

For example (old favourite), the automated telephone banking line asks the
user to "press '1' to listen to account balance".  The user presses '1' on
their telephone keypad and this event is signalled to the far end using the
SIP signalling (as opposed to an actual DTMF tone being generated and sent
'in-band'). 

If this has been discussed before, I'd appreciate a summary of that
discussion.

Best Regards,

Duncan Mills
Vodafone UK Ltd.

---

From: "Agboh, Charles" <[email-masked]>
Date: Fri, 4 Jan 2002 14:28:13 +0100

http://www.cs.columbia.edu/~hgs/sip/faq.cgi?_highlightWords=dtmf&file=73

--Charles
>  -----Original Message-----
> From: 	[email-masked] 
> [mailto:[email-masked]] 
> Sent:	Friday, January 04, 2002 2:19 PM
> To:	[email-masked]
> Subject:	Using SIP to signal 'DTMF'?
> 
> SIPPING experts,
> 
> Being relatively new to IETF standards, I'm guessing that 
> this may have been discussed before, so excuse me asking again:
> 
> More specifically, has it ever been considered that a SIP 
> message could be used to indicate to an entity that a 'keypad 
> digit' has been pressed by a user, allowing that entity to 
> perform a suitable action?
> 
> For example (old favourite), the automated telephone banking 
> line asks the user to "press '1' to listen to account 
> balance".  The user presses '1' on their telephone keypad and 
> this event is signalled to the far end using the SIP 
> signalling (as opposed to an actual DTMF tone being generated 
> and sent 'in-band'). 
> 
> If this has been discussed before, I'd appreciate a summary 
> of that discussion.
> 
> Best Regards,
> 
> Duncan Mills
> Vodafone UK Ltd.
> 

_______________________________________________
Sipping mailing list  http://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Janeczko Jordan <[email-masked]>
Date: Fri, 4 Jan 2002 15:43:16 +0100

> Can SIP signalling be used to carry DTMF information?

Bert Culpepper also announced a new draft for an extension
of this topic on this mailing list at the end of December (see 
below).

Jordan
--------------------------------------------------
A great many people think they are thinking
when they are merely rearranging their prejudices.
                                   - William James
Jordan Janeczko          tel (+43-5)1707-45251
Siemens PSE              fax (+43-5)1707-56992

> From: Bert Culpepper [mailto:[email-masked]]
> Sent: Friday, December 21, 2001 8:04 PM
> To: 'SIPPING List'
> Subject: [Sipping] SIP Events Package for Keys
> 
> 
> Hello,
> 
> Myself and a couple of others have prepared an I-D defining an Events
> Package for Keys.  It's been submitted to the IETF but I 
> don't expect it to
> be announced until after the new year.  For those who wish to 
> have a look at
> the proposal, it's available at
> http://home.cfl.rr.com/bculpepper/draft-culpepper-sip-key-events-00.txt.
> 
> The hope is that this proposal will evolve into an internet 
> standard.  As
> DTMF has been used for user input in the PSTN, I feel an 
> alternative is
> needed for this function with SIP-based communications in IP 
> networks.  All
> comments are welcome.
> 
> Thanks,
> Bert

---

From: Gordon Ledgard <[email-masked]>
Date: Fri, 4 Jan 2002 10:20:42 -0500

Yeah... It was considered several times by several people, including some
folks
from this company (IPeria). To sum things up for you, the general consensus
is that
it is fundmaentally a flawed idea, even though it might seem at first blush
to be
a reasonable proposition. The big issue is that it gets SIP wrapped up in
media and
application signalling. The practical problem is that it becomes extremely
difficult
to synchronize the receipt of tones with the media stream. The other big
religeous
issue (with which I agree) is that it ties SIP to a particluar media type.

Are you familiar with the "2833" proposal that digitizes DTMF in an RTP
stream?
several companies have implemented it.

Gordon Ledgard
Principal Software Engineer
IPeria, Inc.

> Sent:	Friday, January 04, 2002 8:19 AM
> To:	[email-masked]
> Being relatively new to IETF standards, I'm guessing that this may have
> been discussed before, so excuse me asking again:
> 
> their telephone keypad and this event is signalled to the far end using
> the SIP signalling (as opposed to an actual DTMF tone being generated and
> sent 'in-band'). 
>

---

From: Fred Robinson <[email-masked]>
Date: Fri, 4 Jan 2002 09:26:00 -0700

Duncan,
Another reference for DTMF payload carriage........

http://www.ietf.org/rfc/rfc2833.txt?number=2833

Fred Robinson
Sr. Systems Engineer
SandCherry networks
http://www.sandcherry.com/
2845 Wilderness Pl.
Boulder, CO 80301
720.272.5201
[email-masked] 

http://www.ext.colostate.edu/psel/ps0004a.html

-----Original Message-----
From: Agboh, Charles [mailto:[email-masked]]
Sent: Friday, January 04, 2002 6:28 AM
To: [email-masked]'; [email-masked]
Subject: [Sipping] RE: Using SIP to signal 'DTMF'?

--Charles