Subject: [Sipping] how do we handle 911 call originated by SIP user?

From: "Info Van" <[email-masked]>
Date: Fri, 18 Jan 2002 10:09:34 -0500

hi,

for SIP->PSTN call, is there any ID or any other work-in-progress,
any suggestion, as to how do we handle SIP->911 calls ?? the problem
as i see it :-
1) SIP user can log on from any domain (and be a dial-up user who get's a new IP everytime)
2) SIP UA currently doesn't seem to have any MANDATORY "geographic-location" (not necessarily GPS based, but say "postal address based") location information that can be relayed onto the PSAP.
3) SIP user could be a mobile-IP user where finding out location and IP bindings i believe is very costly!! (not sure on that).

how do we plan to handle this ? i know this is a problem we've lived with in 2-2.5G Mobile networks (and found some solutions too), but i don't see any "triangulation" out here... obviously implementors, network operators would be mandated by FCC regs. to provide 911... so... how does the SIP-ASP (service provider) make sure that the UA's like Pingtel, HearMe or any other co. provide location info, without standardizing it...??

i'm sure this has been discussed (but not sure if it's been solved and taken care of) already... sorry for cross-posting, but i thought it right because i wasn't sure if this is a future-work, work-in-progress, or under-implementation (could be all the 3).

thanks for any/all inputs,
bdutta.

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Henning G. Schulzrinne" <[email-masked]>
Date: Fri, 18 Jan 2002 10:30:19 -0500

A new draft on this is in progress. I think there will be several stages
of solutions, depending on what kind of external infrastructure is
available or might be available in the future. I don't know if this is
an official work item of the SIPPING group yet.
-- 
Henning Schulzrinne   http://www.cs.columbia.edu/~hgs

---

From: "Odyssey" <[email-masked]>
Date: Fri, 18 Jan 2002 11:56:29 -0800

hi,

Why everyone still use some open source codes sip stack, debugging and
extending. For example, too many guys waste time on Voivda and Osip.
Actually, it is very easy to write your own stack with Java, Java RTP. I
have written my own stack fully compatiable with JAIN SIP. It will take you
no more than two months. Java JDNI support DNS lookup, Java security
package, Java JMF, all support you to write a SIP UA or server in no more
than two months.
Listen to me! I am trying to help you...

Best wishes,
Yours truly
_____________________________________
SCSA, SCNA, OCP 8/8i DBA, CCNA, SCJP, SCJD