Subject: Re: [Sipping] how do we handle 911 call originated by SIP user?

From: "Info Van" <[email-masked]>
Date: Fri, 18 Jan 2002 11:03:06 -0500

great. where (if any) discussions on this are taking place ?
one thing though... whatever infrastructure we have in future, (i am not sure what all is being considered), but we'd still be stuck with "legacy" SIP UA's... which might be difficult to upgrade (or too costly to upgrade with newer technology)...!! so i was thinking, isn't it better to make the solution free (or separate) from infrastructure (s.a. GPS for e.g.).

how about a simple solution s.a. (i know it's implementation and it's requirement would be something, not in line with IEFT work, maybe).

a user logging-in to a UA (before originating a SIP call), needs to supply (or select from a list, or say "YES" to an option to pick) a postal address (or geographic location), which says is stored by UA, (until it's revoked or expired) and conveyed in an INVITE in a MANDATORY header ?? say sometime like GeoLocation: or something !!!

thanks,
banibrata dutta.
---

On Fri, 18 Jan 2002 10:30:19  Henning G. Schulzrinne wrote:
>A new draft on this is in progress. I think there will be several stages
>of solutions, depending on what kind of external infrastructure is
>available or might be available in the future. I don't know if this is
>an official work item of the SIPPING group yet.
>-- 
>Henning Schulzrinne   http://www.cs.columbia.edu/~hgs

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: [email-masked]
Date: Fri, 18 Jan 2002 12:27:50 -0500

From:  Tom Gray@MITEL on 01/18/2002 12:27 PM

"Info Van" <[email-masked]> on 01/18/2002 11:03:06 AM

Please respond to [email-masked]

To:   [email-masked], "Henning G. Schulzrinne" <[email-masked]>
cc:   "SIP Implementors Group" <[email-masked]>, "SIP List"
      <[email-masked]>, "SIP" <[email-masked]>, "SIP-NG"
      <[email-masked]> (bcc: Tom Gray/Kan/Mitel)

Subject:  Re: [Sipping] how do we handle 911 call originated by SIP user?

great. where (if any) discussions on this are taking place ?
one thing though... whatever infrastructure we have in future, (i am not sure
what all is being considered), but we'd still be stuck with "legacy" SIP UA's...
which might be difficult to upgrade (or too costly to upgrade with newer
technology)...!! so i was thinking, isn't it better to make the solution free
(or separate) from infrastructure (s.a. GPS for e.g.).

how about a simple solution s.a. (i know it's implementation and it's
requirement would be something, not in line with IEFT work, maybe).

a user logging-in to a UA (before originating a SIP call), needs to supply (or
select from a list, or say "YES" to an option to pick) a postal address (or
geographic location), which says is stored by UA, (until it's revoked or
expired) and conveyed in an INVITE in a MANDATORY header ?? say sometime like
GeoLocation: or something !!!

thanks,
banibrata dutta.
---

---

From: [email-masked]
Date: Fri, 18 Jan 2002 12:32:37 -0500

From:  Tom Gray@MITEL on 01/18/2002 12:32 PM

 For a 911 system to be effective the user should not be involved in the
specifying a location. It has to be automatic or the system will not be trusted
to function properly. For example how could a visiting user be expected to
specify a location in a building that is unfamilar to him or in a town he has
not visited before.

thanks,
banibrata dutta.
---

---

From: "Rosen, Brian" <[email-masked]>
Date: Fri, 25 Jan 2002 09:24:43 -0500

NEVER, EVER send the same message to two lists.
Most of the people who would respond are on all the lists.
Choose one; if you choose the wrong one, someone will move it.

Brian

> -----Original Message-----
> From: Info Van [mailto:[email-masked]]
> Sent: Friday, January 18, 2002 10:10 AM
> To: SIP Implementors Group; SIP List; SIP; SIP-NG
> Subject: [Sipping] how do we handle 911 call originated by SIP user?
> 
> 
> hi,
> 
> for SIP->PSTN call, is there any ID or any other work-in-progress,
> any suggestion, as to how do we handle SIP->911 calls ?? the problem
> as i see it :-
> 1) SIP user can log on from any domain (and be a dial-up user 
> who get's a new IP everytime)
> 2) SIP UA currently doesn't seem to have any MANDATORY 
> "geographic-location" (not necessarily GPS based, but say 
> "postal address based") location information that can be 
> relayed onto the PSAP.
> 3) SIP user could be a mobile-IP user where finding out 
> location and IP bindings i believe is very costly!! (not sure 
> on that).
> 
> how do we plan to handle this ? i know this is a problem 
> we've lived with in 2-2.5G Mobile networks (and found some 
> solutions too), but i don't see any "triangulation" out 
> here... obviously implementors, network operators would be 
> mandated by FCC regs. to provide 911... so... how does the 
> SIP-ASP (service provider) make sure that the UA's like 
> Pingtel, HearMe or any other co. provide location info, 
> without standardizing it...??
> 
> i'm sure this has been discussed (but not sure if it's been 
> solved and taken care of) already... sorry for cross-posting, 
> but i thought it right because i wasn't sure if this is a 
> future-work, work-in-progress, or under-implementation (could 
> be all the 3).
> 
> thanks for any/all inputs,
> bdutta.
> 
> 
> 
> 

This e-mail and any attachments are confidential. If you are not the
intended recipient, please notify us immediately by reply e-mail and then
delete this message from your system. Do not copy this e-mail or any
attachment, use the contents for any purposes, or disclose the contents to
any other person: to do so could be a breach of confidence.