Subject: RE: [Sipping] RE: [Sip] calling number blocking at sip/isup gatew ay

From: "Mark Watson"<[email-masked]>
Date: Tue, 19 Feb 2002 14:20:02 -0000

Dean,

Sounds good to me.

I expect that whatever we go forward with now for the limited context
described below, can be extended later to meet the more general
requirements.

...Mark

> -----Original Message-----
> From: Dean Willis [mailto:[email-masked]]
> Sent: 18 February 2002 23:12
> To: Watson, Mark [MDN05:EP10:EXCH]; [email-masked];
> [email-masked]; [email-masked]
> Subject: Re: [Sipping] RE: [Sip] calling number blocking at sip/isup
> gateway
> 
> 
> Mark said:
> 
> > Your example below needs only a small extension to 
> illustrate Mike's point
> > and show why something like Remote-Party-ID as defined in 
> the privacy
> draft
> > is needed, and how it works despite the lack of a signature.
> 
> Yep. And what happens when my misconfigured proxy forwards 
> the call without
> paying attention to the Privacy header, because for some reason it's
> forwarding to the outside world instead of a PSTN gateway 
> under my control?
> We get a privacy leak.
> 
> But other than that, I'd say you've precisely described a 
> "sunny day" use
> case for RPID.
> 
> It still has a lot of security issues based on transitive 
> trust, which make
> it a lot more palatable in a two-party case than in three or 
> more party
> transitivity.
> 
> I believe we're approaching a general consensus that the Privacy draft
> provides a reasonable approach to solving a specific class of problem
> wherein interoperator-transitive trust is couple to 
> transport-layer message
> protection. That's not a general privacy mechanism, but it 
> does seem to have
> enough constituency to justify publication as long as it has a REALLY
> serious applicability statement explaining the particular 
> requirements and
> environments for which it is useful.
> 
> How does that sound?
> 
> --
> Dean
> 
>

---

From: Jean-Francois Mule <[email-masked]>
Date: Thu, 21 Feb 2002 14:21:41 -0700

I agree with the approach too.
Jean-Francois.

> environments for which it is useful.

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP