Subject: Re: [Sipping] Question regarding CANCEL

From: "Info Van" <[email-masked]>
Date: Tue, 05 Feb 2002 16:39:50 -0500

Yes. Since it is for a "pending" session establishment. Or am I missing something here !! Anyway you are also less than the 10 retries.

-iv.
---
---- Info Vaan is the way to go -------

On Tue, 5 Feb 2002 12:04:09   
 VIDHI RASTOGI wrote:
>Hi,
>
>Should the UAC send a CANCEL after INVITE request times out. (ie, the UAC
>has retransmitted INVITE 7 times and never received any response).
>
>Do we need to send CANCEL for any other SIP requests (say REGISTER, INFO)
>after the REQUEST TIMEOUT?
>
>regards
>Vidhi
>
>

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 08 Feb 2002 16:07:57 -0500

Info Van wrote:
> 
> Yes. Since it is for a "pending" session establishment. Or am I missing
> something here !! Anyway you are also less than the 10 retries.

Sorry, no. The spec is quite explicit. CANCEL only gets sent if a
provisional is received, period. If there is a timeout, its like you got
a 481, but you send no ACK, no CANCEL.

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.            72 Eagle Rock Avenue
Chief Scientist                         First Floor
dynamicsoft                             East Hanover, NJ 07936
[email-masked]                 FAX: (973) 952-5050
http://www.jdrosen.net                  PH:  (973) 952-5000
http://www.dynamicsoft.com