Subject: RE: AW: [Sipping] New draft about SIP conferencing avaiable

From: [email-masked]
Date: Tue, 12 Feb 2002 11:49:03 -0500

Hi Sean,

> On a different topic, it would be nice if there
> was some generic request that could be sent to 
> obtain information about an ongoing call. The 
> participants of that call is just one such piece
> of information. This kinda falls in line with the
> call events package that was proposed to be used
> with SUBSCRIBE/NOTIFY. By doing an immediate fetch
> with that event package, you could get the 
> participants without inventing a new method. And
> of course, the type of information you could retrieve
> could be expanded over time to include things like
> who is the moderator of this call, how long has this
> call been going on, etc.

This goes in the direction of course control of an ongoing
call or conference. I do agree that this might be
worthwhile to pursue. Looking into SIP events to realize
(some of) this functionality is worthwhile to pursue, too. 
However, as a first step it should be clear what functionality
is desired in this context.

Obtaining the (public) part of a call or conference information, 
e.g., containing the current participants and call information, 
is only one part of the story. Finding out who is the moderator
and being notified when he/she changed is another part. It might
also be desired to provide generic functionality to realize moderator
functionality, aka floor control.

Regards,

Dirk

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Sean Olson <[email-masked]>
Date: Tue, 12 Feb 2002 09:12:00 -0800 (PST)

Hi Dirk, 

Sure. I don't think we should tackle all these
problems at the start. But perhaps we can come
up with a more generic way of approaching the
conference participant problem that will lend itself
to solving these other problems in the future. 

/sean

> functionality, aka floor control.

=====
Sean Olson <[email-masked]>

__________________________________________________
Do You Yahoo!?
Send FREE Valentine eCards with Yahoo! Greetings!
http://greetings.yahoo.com

---

From: "Igor Miladinovic" <[email-masked]>
Date: Wed, 13 Feb 2002 18:07:27 +0100

Hi,

> to solving these other problems in the future.

I agree that we need a generic solution for the conference participant
problem. Additional information (conference moderator, conference type etc.)
could be placed in the body of the CONF request or as additional
headers/parameters (e.g. conference moderator can be specified in the status
parameter of the participant header). We tried to make the first step in the
direction of a generic solution for discovering of participant identities.
Of course, there are also some other conferencing problems, but we think
that most of them could be solved by extending/adopting our approach.

Regards,

Igor