Subject: [Sipping] Question regarding CANCEL

From: "VIDHI RASTOGI" <[email-masked]>
Date: Tue, 5 Feb 2002 12:04:09 +0530

Hi,

Should the UAC send a CANCEL after INVITE request times out. (ie, the UAC
has retransmitted INVITE 7 times and never received any response).

Do we need to send CANCEL for any other SIP requests (say REGISTER, INFO)
after the REQUEST TIMEOUT?

regards
Vidhi

---

From: [email-masked]
Date: Tue, 5 Feb 2002 15:35:54 +0530

Hi Vidhi,
please see my comments below :

Rgds,
Munish
Hughes Software Systems Limited
www.hssworld.com

"VIDHI RASTOGI" <[email-masked]> on 02/05/2002 12:04:09 PM

Please respond to [email-masked]

To:   [email-masked]
cc:    (bcc: Munish Chhabra/HSS)

Subject:  [Sipping] Question regarding CANCEL

Hi,

Munish : Refer to 14.4.1 Unreliable Transport Protocols in bis04 -
A SIP client using an unreliable transport protocol SHOULD retransmit a SIP
INVITE request with an interval
that starts at T1 seconds, and doubles after each packet transmission. The
client ceases retransmissions if
it receives a provisional or definitive response, or once it has sent a total of
 seven request packets. If no
response (final or provisional) is received after sending seven request packets,
 processing continues as if a
481 response was received for that request (no ACK is generated, however), and a
 CANCEL SHOULD NOT
be sent.

Munish : It doesn't really makes sense to send CANCEL for any of these request
timeouts
either.

regards
Vidhi