Subject: [Sipping] I-D ACTION:draft-ietf-sipping-service-examples-00.txt

From: [email-masked]
Date: Wed, 27 Feb 2002 07:27:18 -0500

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Session Initiation Proposal Investigation Working Group of the IETF.

	Title		: SIP Service Examples
	Author(s)	: A. Johnston et al.
	Filename	: draft-ietf-sipping-service-examples-00.txt
	Pages		: 113
	Date		: 26-Feb-02
	
This informational document gives examples of SIP (Session Initiation 
Protocol) services.  This covers most features offered in so-called 
Centrex offerings from local exchange carriers and PBX (Private 
Branch Exchange) features.  Most of the services shown in this 
document are implemented in the SIP User Agents, although some 
require the assistance of a SIP Proxy.  Some require some extensions 
to SIP including the REFER method and Replaces header. These features 
are not intended to be an exhaustive set, but rather show 
implementations of common features likely to be implemented on SIP IP 
telephones in a business environment.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-sipping-service-examples-00.txt

To remove yourself from the IETF Announcement list, send a message to 
ietf-announce-request with the word unsubscribe in the body of the message.

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-ietf-sipping-service-examples-00.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-ietf-sipping-service-examples-00.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: Alan Johnston <[email-masked]>
Date: Thu, 28 Feb 2002 08:40:14 -0600

All,

This document updates and replaces
draft-ietf-sip-service-examples-03.txt

The major changes are as follows:

   - Added Max-Forwards     
   - Added branch parm and received param to Vias     
   - Changed Record-Route and Route behavior to show loose routing.     
   - Added Record-Route and Contact to 18x responses     
   - Changed Call Pickup to show Replaces with an early dialog  
   - Changed description of Single Line Extension service  
   - Changed Call Park and Pickup flow to show a different user picking 
     up the call.  
   - Added Allow and Supported headers to REFER and replaces flows. 

These changes should bring the document in line with the latest bis
draft.

The biggest hole in the document is a method for a UA to discover dialog
information so that it can pickup a parked call, or pick a ringing
phone.  While this can be done outside of SIP, SUBSCRIBE/NOTIFY combined
with the Call Event Package (draft-rosenberg-sip-call-package-00.txt) is
a good method  that will be incorporated in future drafts.

As always, comments and corrections are greatly appreciated.

Thanks,
Alan Johnston
WorldCom
sip:[email-masked]

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of [email-masked]
> Sent: Wednesday, February 27, 2002 6:27 AM
> To: IETF-Announce:
> Cc: [email-masked]
> Subject: [Sipping] I-D 
> ACTION:draft-ietf-sipping-service-examples-00.txt
> 
> 
> A New Internet-Draft is available from the on-line 
> Internet-Drafts directories. This draft is a work item of the 
> Session Initiation Proposal Investigation Working Group of the IETF.
> 

http://www.ietf.org/internet-drafts/draft-ietf-sipping-service-examples-
00.txt

To remove yourself from the IETF Announcement list, send a message to 
ietf-announce-request with the word unsubscribe in the body of the
message.

Internet-Drafts are also available by anonymous FTP. Login with the
username "anonymous" and a password of your e-mail address. After
logging in, type "cd internet-drafts" and then
	"get draft-ietf-sipping-service-examples-00.txt".

Send a message to:
	[email-masked].
In the body type:
	"FILE
/internet-drafts/draft-ietf-sipping-service-examples-00.txt".
	
	a MIME-compliant mail reader.  Different MIME-compliant mail
readers

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP