Subject: [Sipping] SIP-PSTN Interconnection

From: "Jagannathan R" <[email-masked]>
Date: Wed, 27 Feb 2002 11:44:59 +0530

Hi all,

I have a some basic doubts regarding the SIP-PSTN Interworking, this is more on SIP-T. Can any one clarify these doubts please.

1. Proxy server is connected to MGC (point of SIP-PSTN Interconnection), 

1a. Is there a way proxy server registering itself with MGC?  
      This is required at MGC to know which are the SIP users this proxy  can service, 
      so that the PSTN originated call can be correctly terminated to that Proxy. 

1b. How the MGC knows the status of Proxy (In-Service or Out-of-Service) in order to terminate the call.

1c. How many Proxy servers with different/same set of SIP users can be linked to one MGC.

2. When SIP call arrives at MGC, MGC requires NOA (Nature of Address) in order to translate the called number and route the call to the correct PSTN Trunk Group. How the NOA address (like 0+IDDD, IDDD, DDD calls) can be represented in the SIP messages.

3. For SIP-PSTN call, how different digit sequences like ANI, Authorization code, Account code (these are required for billing at MGC and to have Dialing plan) can be sent to MGC in SIP Messages. 

Thanks in advance,
 
jagannathan

---

From: Gonzalo Camarillo <[email-masked]>
Date: Thu, 28 Feb 2002 23:10:19 +0200

Hi,

request routing in SIP works in a different way than in the PSTN. Your
proxy do not have to register towards your MGC. Your MGC will decide
where to send a particular request based on the host part of the
destination SIP URI (that has been obtained from the destination
telephone number in ISUP).

Regards,

Gonzalo

Jagannathan R wrote:
> 
> Hi all,
> 
> I have a some basic doubts regarding the SIP-PSTN Interworking, this
> is more on SIP-T. Can any one clarify these doubts please.
> 
> 1b. How the MGC knows the status of Proxy (In-Service or
> Out-of-Service) in order to terminate the call.
> 
> 2. When SIP call arrives at MGC, MGC requires NOA (Nature of Address)
> in order to translate the called number and route the call to the
> correct PSTN Trunk Group. How the NOA address (like 0+IDDD, IDDD, DDD
> calls) can be represented in the SIP messages.
> 
> 3. For SIP-PSTN call, how different digit sequences like ANI,
> Authorization code, Account code (these are required for billing at
> MGC and to have Dialing plan) can be sent to MGC in SIP Messages.
> 
> 
> Thanks in advance,
> 
> jagannathan
> 

-- 
Gonzalo Camarillo                    Phone :   +1 212 939 71 71
Columbia University                  Mobile:  +358 40 702 35 35
472 Computer Science Building        Fax   :  +358  9 299 30 52
1214 Amsterdam Ave., Mail Code 0401  http://www.hut.fi/~gonzalo
New York, NY 10027                   
USA                              [email-masked]

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP