Subject: Re: [Sipping] Comment on draft-schulzrinne-sipping-sos-01.txt

From: [email-masked]
Date: Tue, 19 Mar 2002 00:16:38 EST

In a message dated 3/18/2002 3:52:53 PM Eastern Standard Time, 
[email-masked] writes:

> - most of them are much longer than 'sos'. I can type out 'sos' on a
> 12-button keypad, but imagine trying to type out 'emergency'.
> 

In a message dated 3/18/2002 9:33:23 PM Eastern Standard Time, 
[email-masked] writes:

> No, it typically won't be typed, but I certainly would want to make it
> possible to do so, e.g., on PC-based software clients. Not all clients
> will have a "911" or "112" button.
> 

Sorry, if you think this whole thing is based on a user of a "SIP phone" 
typing "SOS" or anything else, then we're all barking up the wrong tree. In 
the US, the user dials "9-1-1" and SIP isn't going to change that 
requirement. I don't expect anyone to have a "911" button, but they all have 
a "9" and a "1" botton (or the equivalent on the screen to click) Yes, some 
terminal could also provide an emergency icon to click or a special emergency 
button, but just picking up a handset and dialing "911" must still work. I 
don't expect anyone to ever type in the SIP message string. At least, nothing 
in this service definition should be based on that possibility.

The "SOS" must be viewed as a protocol element that the user doesn't see, so 
it can be anything.

Mike Pierce

---

From: Henning Schulzrinne <[email-masked]>
Date: Tue, 19 Mar 2002 06:38:52 -0600

The draft discusses this. Yes, users should expect their SIP UA to allow
them to dial 911 or 112 or sos, either directly (typing '9-1-1') or via
some form of short-cut.

> Sorry, if you think this whole thing is based on a user of a "SIP phone" typing "SOS" or anything else, then we're all barking
> up the wrong tree. In the US, the user dials "9-1-1" and SIP isn't going to change that requirement. I don't expect anyone to
> have a "911" button, but they all have a "9" and a "1" botton (or the equivalent on the screen to click) Yes, some terminal
> could also provide an emergency icon to click or a special emergency button, but just picking up a handset and dialing
> "911" must still work. I don't expect anyone to ever type in the SIP message string. At least, nothing in this service
> definition should be based on that possibility. 
> 
> The "SOS" must be viewed as a protocol element that the user doesn't see, so it can be anything.

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP