Subject: RE: [Sipping] To-header is possible solution to 3GPP Requ for ori ginally dialle d user-ID?

From: "George Foti (LMC)" <[email-masked]>
Date: Wed, 6 Mar 2002 08:48:20 -0500

I know the 3GPP requirement you are refering to.
A  *PURE* proxy MUST not change the From & To fields.
Even if the proxy supports B2BUA behavior, there may be privacy reasons for
which the proxy may not be allowed to change the To field to point to the
subscriber IMPU.
So what you are proposing many not be possible at all times.

rgds/gf

> -----Original Message-----
> From: Mayer Georg [mailto:[email-masked]]
> Sent: Wednesday, March 06, 2002 8:25 AM
> To: SIPPING (E-Mail)
> Subject: [Sipping] To-header is possible solution to 3GPP Requ for
> originally dialle d user-ID?
> 
> 
> Hello,
> 
> as the dialog is now identified by Call-ID and only To- and 
> From-Tags, there might be a chance to solve a 3GPP 
> requirement very easily. Before dwelling in the 3G specific 
> details I want to ask the general question:
> 
> Is a proxy allowed to change to content (besides the tags) of 
> To and From headers?
> 
> Why would somebody (3GPP of course) need such an ill 
> mechanism in a SIP network? 
> In 3GPP IMS a (called) user may have several so-called 
> public-user-identities (IMPU) of which only one needs to be 
> registered explicitly with REGISTER and the others are 
> implicitly registered. IMPUs are either sip:- or tel:-URLs. 
> As user B may have more then one IMPU (one for work, one for 
> friends, one for family...), she wants to get informed about 
> the URL under which it was called. This is similar to the MSN 
> (Multiple Subscriber Number) concept in ISDN.
> 
> So A calls B:
> 	INVITE	sip:[email-masked]
> 	To: "You owe me 10 Euro" <sip:my-best-friend@speed-dial>
> 
> The registrar of user B now replaces the request URI with the 
> contact address of user B:
> 	INVITE	sip:a.b.c.d
> 	To: "You owe me 10 Euro" <sip:my-best-friend@speed-dial>
> 
> and after that, the originally dialled IMPU 
> (sip:[email-masked]) is lost. 
> 
> So is there a chance that the registrar of user B or the 
> outbound proxy of user A change the To-header in the INVITE 
> in the following way:
> 	To: "You owe me 10 Euro" <sip:[email-masked]>
> 
> I'd be happy to get some comments from your side.
> 
> Thanks a lot
> Georg
> 
> 
> _______________________________________________________
> Georg Mayer - Siemens AG
> Information and Communication Mobile
> ICM N PG SP ST N 1
> Hofmannstr. 51, 81359 Munich, Germany
> Fon: +49-89-722-33114
> Fax: +49-89-722-62250
> Mobile: +49-172-5371233
> Email: [email-masked]
> 
> 
> 
> 
> _______________________________________________
> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments of core SIP
> 

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Mayer Georg <[email-masked]>
Date: Wed, 6 Mar 2002 17:06:29 +0100

Hello George,

thanks for the answer. 

> A  *PURE* proxy MUST not change the From & To fields.

I understand that, but 3GPP defined their entities as transparent B2BUA as they already need to mess around with some of the messages. So this should not really be a blocking point.

> which the proxy may not be allowed to change the To field to 

I think you refer to the case wehere the user requests privacy and puts e.g. "anonymous" into the From-header. But what about the To-header field? The To-header is set by the caller. If user B (or any forwarded-to user) wants to hide her address it was not able to change the To header up till now. Why should it? The information has already traversed through the whole network. 

The only option I see here is that the calling user puts the To-header to "anonymous" from the very beginning. Nevertheless it propagates the B users URI in the Request URI. So I see no problem here (that does not mean that there is none, just says that I do not know enough to recognized the problem). 

> So what you are proposing many not be possible at all times.

So would it generally be possible that ... "some higher sophisticated entity in the network (transparent B2BUA)" ... "which is aware of privacy issues (if necessary)" ... changes the content of the To-field?

You say "may not be possible at all times" - does this mean it is forbidden?

Thanks for your help
Georg

> -----Ursprüngliche Nachricht-----
> Von: George Foti (LMC) [mailto:[email-masked]]
> Gesendet: Mittwoch, 6. März 2002 14:48
> An: 'Mayer Georg'; 'SIPPING (E-Mail)'
> Betreff: RE: [Sipping] To-header is possible solution to 3GPP Requ for
> ori ginally dialle d user-ID?
> 
>

---

From: "Mark Watson"<[email-masked]>
Date: Wed, 6 Mar 2002 17:29:07 -0000

As I understand it the To (and From) fields in 3GPP are currently obfuscated
by the UA due to potential privacy requirements not known to the UA which
originally sets them.

It would indeed make more sense if these fields could be used for their
intended purpose, but this requires the ability for the network entities to
modify them as you have discussed. This requires some thought, as I think I
saw someone mention that the values of these fields are used for some things
related to integrity/security, so changing them may have additional
implications.

You would also require the ability for the UA to signal any privacy
requirements in respect of these fields that it *did* know about and was
asking the network to provide.

So, worth discussion, but not a trivial problem.

Also, IMO, these privacy requirements are not specific to 3GPP, so a
solution which relies on the network entities being B2BUAs may not be
acceptable to all.

...Mark

> From: George Foti (LMC) [mailto:[email-masked]]
> Sent: 06 March 2002 16:46
> To: 'Mayer Georg'; 'SIPPING (E-Mail)'
> Subject: RE: [Sipping] To-header is possible solution to 3GPP Requ for
> >You say "may not be possible at all times" - does this mean it is
> forbidden,
> 
> The To field is not used by the SIP machinery any more (bis 
> 08 onwards)
> hence changing it should not cause problems.
> As far as privacy issues are concerned, I beleive this should 
> be discussed
> within the 3GPP forums to see if there are any concerns.
> 
> Rgds/gf
>

---

From: "George Foti (LMC)" <[email-masked]>
Date: Wed, 6 Mar 2002 13:38:13 -0500

True, thats why I said should not cause problems, and I would opt for not
changing them.
/gf

> From: Ben Campbell [mailto:[email-masked]]
> Sent: Wednesday, March 06, 2002 12:04 PM
> To: George Foti (LMC); 'Mayer Georg'; 'SIPPING (E-Mail)'
> As long as a pre-bis08 device might be in the dialog 
> somewhere, couldn't
> changing the To header cause problems?
> 
> > From: [email-masked] 
> [mailto:[email-masked]]On Behalf Of
> > George Foti (LMC)
> > Sent: Wednesday, March 06, 2002 10:46 AM
> > As far as privacy issues are concerned, I beleive this 
> should be discussed

---

From: "George Foti (LMC)" <[email-masked]>
Date: Wed, 6 Mar 2002 13:36:28 -0500

I personally would  opt not to touch them as they are really meant  for end
points, so even as a B2BUA, it is not a good idea to touch them. 
/gf

-----Original Message-----
From: Mark Watson [mailto:[email-masked]]
Sent: Wednesday, March 06, 2002 12:29 PM
To: George Foti (LMC); 'Mayer Georg'; 'SIPPING (E-Mail)'
Subject: RE: [Sipping] To-header is possible solution to 3GPP Requ for ori
ginally dialle d user-ID?

...Mark 

> From: George Foti (LMC) [ mailto:[email-masked]
<mailto:[email-masked]> ] 
> within the 3GPP forums to see if there are any concerns. 
<https://www1.ietf.org/mailman/listinfo/sipping>

---

From: "Mark Watson"<[email-masked]>
Date: Thu, 7 Mar 2002 11:17:39 -0000

So then you cannot put any useful information in them, because the UA does
not know whether this information may subsequently be subject to privacy
restrictions.
 
As far as I can see either (i) allow To/From to be modified or (ii) do not
put anything useful in them - those are the choices.
 
I don't like either of them but (i) seems a little more sensible, if you
accept those are the only choices. But then I have not analysed the
consequences of (i), and until we do I would agree they should not be
touched.
 
Regards...Mark

-----Original Message-----
From: Mark Watson [mailto:[email-masked]]
Sent: Wednesday, March 06, 2002 12:29 PM
To: George Foti (LMC); 'Mayer Georg'; 'SIPPING (E-Mail)'
Subject: RE: [Sipping] To-header is possible solution to 3GPP Requ for ori

...Mark