Subject: RE: [Sipping] comment on draft-rosenberg-sip-call-package-01.txt

From: "Roy, Radhika R, ALASO" <[email-masked]>
Date: Thu, 21 Mar 2002 12:34:50 -0500

Inline [RRR]

-----Original Message-----
From: David R. Oran [mailto:[email-masked]]
Sent: Thursday, March 21, 2002 11:59 AM
To: 'Even, Roni'; [email-masked]
Subject: RE: [Sipping] comment on
draft-rosenberg-sip-call-package-01.txt

I agree that it has privacy implications. Where I have a problem is
having a brittle classification scheme that categorizes people into
fixed classes like "participant" and "moderator". We need a general way
for participants to declare who is allowed to see and/or manipulate
their state in the conference, and who has rights to see and/or modify
other participants' state, including those whose streams they my no be
currently receiving. 

[RRR] It seems to be a good point. However, these two categories are appropriate when we see what roles that are being played by each entity in the conference. Now, we may further differentiate what preferences (e.g., policy) that each participant needs to have when they join in the conference.

In the classic controlled conference model, this
maps onto the two categories of "moderator" and "participant" but we
need not carry this forward or limit ourselves to this fixed
classification system.

[RRR] A centralized conferencing system seems to be a controlled one. We can add preferences (e.g., policy) of each participant when they join in the conference as stated above.

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Even, Roni" <[email-masked]>
Date: Thu, 21 Mar 2002 20:13:56 +0200

Hi,
The discussion is showing that the requirements for media mixing information
needs to be understood. the current information can supply information about
each stream in the call, I mentioned that for mixed video streams coming
from a video mixer (in non-overlapping or overlapping windows) the
information of which stream is in each window is required. The other
requirement I see is for a way to build the right information set for each
request.

Roni Even

> From: Roy, Radhika R, ALASO [mailto:[email-masked]]
> Sent: Thursday, March 21, 2002 7:35 PM
> To: David R. Oran
> Cc: [email-masked]
> [RRR] It seems to be a good point. However, these two 
> categories are appropriate when we see what roles that are 
> being played by each entity in the conference. Now, we may 
> further differentiate what preferences (e.g., policy) that 
> each participant needs to have when they join in the conference.
> 
> [RRR] A centralized conferencing system seems to be a 
> controlled one. We can add preferences (e.g., policy) of each 
> participant when they join in the conference as stated above.
> 
>

---

From: "Roy, Radhika R, ALASO" <[email-masked]>
Date: Thu, 21 Mar 2002 14:25:08 -0500

Inline [RRR]

-----Original Message-----
From: Even, Roni [mailto:[email-masked]]
Sent: Thursday, March 21, 2002 1:14 PM
To: Roy, Radhika R, ALASO; David R. Oran
Cc: [email-masked]
Subject: RE: [Sipping] comment on

Hi,

[RRR} Yes, I agree. We need to analyze a set of requirements for mixing of media for each participant. These requirements will set the stage what needs to be done in the context of multi-point, multi-media conferencing. For mixing of videos and their presentation to each participant, there can be a variety of ways - from a simple one to a very complex scenario. The present SDP spec or SIP signaling messages are yet to be there to meet those requirements.

[RRR] It appears that it would be better, as you have said, if we could generate a set of requirements first and proceed for development of specs accordingly.

Roni Even

---

From: "Roy, Radhika R, ALASO" <[email-masked]>
Date: Thu, 21 Mar 2002 15:32:14 -0500

Inline [RRR]

-----Original Message-----
From: Orit Levin [mailto:[email-masked]]
Sent: Thursday, March 21, 2002 2:58 PM
To: Jonathan Rosenberg (E-mail)
Cc: [email-masked]
Subject: RE: [Sipping] comment on

There will be many different requirements based on people's different
perception what a Conference is. Based on a specific Conference structure,
the meaning of (almost the same) content may turn out be different.
During our ad-hock "Conferencing BAR", we agreed to prepare a draft
identifying Conferencing structures of immediate interest and identifying
requirements for all of them (hopefuly) and for each one of them (if
required).
I think that this kind of work will help with sorting the requiremets for
the content of the Conferencing Package. The document will "give names" to
specific conferencing structures that could become a part of the
Conferencing Package content.

[RRR] Good point. I agree that this can be another higher level of refinement when we consider the type of multi-point, multi-media conferencing (e.g., Meet-Me, Ad Hoc, etc.). For each (centralized) conference type, we can then find a set of requirements that we have indicated in earlier emails.

Orit.