Subject: [Sipping] comment on draft-rosenberg-sip-call-package-01.txt

From: "Even, Roni" <[email-masked]>
Date: Thu, 21 Mar 2002 18:18:43 +0200

Hi, 
I have a comment about the media mixing information. The information that
interest the participants is if he is being heard or seen and who is he
getting in his incoming mixing stream. I do not think he wants to know the
information about all the streams in the conference. 
As for video mixing the information needs to specify the window in which the
stream is displayed.
Thanks
Roni Even

**********************************************
Roni Even

Polycom Network Systems
Tel: +972-3-9251200
Mobile: +972-55-481099
Fax: +972-3-9211571
Email: [email-masked]

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "David R. Oran" <[email-masked]>
Date: Thu, 21 Mar 2002 11:31:44 -0500

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of Even, Roni
> Sent: Thursday, March 21, 2002 11:19 AM
> To: [email-masked]
> Subject: [Sipping] comment on draft-rosenberg-sip-call-package-01.txt
> 
> 
> Hi, 
> I have a comment about the media mixing information. The 
> information that interest the participants is if he is being 
> heard or seen and who is he getting in his incoming mixing 
> stream. 
Well, that is certainly part of it. It's actually the hardest part in
the case of distribued rather than centralized mixing.

> I do not think he wants to know the information about 
> all the streams in the conference. 
I disagree here. While no one participant may be interested in ALL the
streams, a participant/moderator/administrator may in fact want a global
topology view of the current media streams. I also think one participant
may want to know why he is not hearing/seeing another participant (did
he mute himself, was he put on hold, did the mixer decide he wasn't
active, etc.)

> As for video mixing the information needs to specify the 
> window in which the stream is displayed. 
Unless I misunderstand, this is both un-necessary and violates privacy.
Why shold other partcipants learn the wndow topology of my private
display. Would you advocate repoting whether the earpiece is currently
in my left or right ear?

What I think you are asking for is in fact something different, which is
a mapping from the participant to the video region of the mixed video
stream which contains his camera input. Is that in fact what you meant?

Dave. 

Thanks Roni Even
> Use [email-masked] for questions on current 
> sip Use [email-masked] for new developments of core SIP
>