Subject: [Sipping] Key-Based User Indication Support

From: "Bert Culpepper" <[email-masked]>
Date: Thu, 7 Mar 2002 13:31:57 -0500

I apologize for this re-post, please pardon the Subject of the previous
posting...the current Subject line is hopefully more appropriate.

>
> Hello all/sipping chairs,
>
> I'd like find out if there is any interest moving forward
> with defining a mechanism to transport key presses (user
> indications) using SIP.  I believe there is significant
> interest in some standard mechanism for what's been typically
> referred to as "DTMF in INFO".  It is my belief that what's
> really desired is application access to user indications as
> the transport of DTMF in IP networks *is* handled nicely by
> RFC 2833.  I also believe that it is desirable to use SIP for
> the mechanism so as to reduce the number of protocols a
> device must support for access to the services that can be
> associated with media sessions.
>
> As far as I can tell, there are two current proposals that
> relate to the above.  The first is
> draft-mahy-sipping-signaled-digits-00 and the other (more
> general :-) is draft-culpepper-sip-key-events-01.
>
> Any feedback will be appreciated.
>
> BTW, the latest copy of the key events draft is available at
> http://www.ietf.org/internet-drafts/draft-culpepper-sip-key-ev
> ents-01.txt.
>
> Regards,
> Bert
>

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Rohan Mahy <[email-masked]>
Date: Thu, 7 Mar 2002 11:30:15 -0800 (Pacific Standard Time)

Bert, given sufficient list discussion, you could request an agenda slot
for SIPPING to discuss this issue.

thanks,
-rohan

---

From: "Dean Willis" <[email-masked]>
Date: Thu, 7 Mar 2002 14:45:08 -0600

Well, I think it's a worthwhile topic, but I liked DTMF-in-INFO, so what do
I know?

--
Dean

----- Original Message -----
From: "Bert Culpepper" <[email-masked]>
To: "'Rosen, Brian'" <[email-masked]>; "'Rohan Mahy'"
<[email-masked]>
Cc: <[email-masked]>
Sent: Thursday, March 07, 2002 12:31 PM
Subject: [Sipping] Key-Based User Indication Support

---

From: "Bert Culpepper" <[email-masked]>
Date: Thu, 7 Mar 2002 16:54:02 -0500

> Well, I think it's a worthwhile topic, but I liked

I've heard in conversation that the use of INFO for DTMF transport is a bad
idea contrary to what's in the INFO RFC.  However, at one time I too thought
is was a good idea :)

Anyway, one aspect about that mechanism I never liked was that an endpoint
had no indication that some other endpoint would send INFOs.  And to get
this indication, overloading the SIP request-response philosophy would be
required AFAIK.  Not an approach to be pursued.  SIP Events seems to me to
be the way to go.  It does have the notion of implied subscriptions so it's
conceivable that some scenarios might only use NOTIFYs.

I just want a standard mechanism and DTMF is not what I'm interested in.  I
want to fit in the distributed application framework of SIP and allow some
user interaction with my service during media sessions.

Regards,
Bert