Subject: RE: [Sipping] sip-911, Preventing dialog termination

From: Adam Roach <[email-masked]>
Date: Fri, 1 Mar 2002 14:48:24 -0500

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
>
> One challenge with the re-establishment technique is that it 
> requires that the
> incoming 911 call have the capacity to override any 
> subsequent connection that
> has been set up. This is of course not insoluble but appears 
> to be more
> difficult than just having the UA refuse to drop the call.

Even if the caller goes out of range?

The callback feature is going to be necessary. So, ask:
is it also sufficient? If the answer is yes, everything
else is wasted effort.

/a

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "David R. Oran" <[email-masked]>
Date: Fri, 1 Mar 2002 14:59:14 -0500

> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of Adam Roach
> Sent: Friday, March 01, 2002 2:48 PM
> To: [email-masked]'; Kozdon, Peter
> Cc: 'Henning Schulzrinne'; 'Farahmand, Fardad'; 'Dean 
> Willis'; [email-masked]'
> Subject: RE: [Sipping] sip-911, Preventing dialog termination
> 
> 
I agree that callback, as long as we have preemption capability in the
QoS domain, solves the network-related problems with 911 calls dropping.

However, it is far from clear the UA work is wasted effort. Consider the
case of a 911 call from a person who discovers a criminal in their
house. The criminal then grabs the phone from the person and hangs up.
Still good to have the connection up, no? (Ok, let's deal with the
obvious objections - (a)the criminal could yank the phone cord out of
the all too - answer is that the phone is 802.11 :-), (b) the criminal
could throw the phone on the floor and stomp on it - answer is the phone
is tempest certified :-) )

There is also quite a bit of utility for having the UA know intimately
about calls originated from a PSAP, so that such calls can be
prioritized and over-ride glare conditions like the phone being dropped
and sitting offhook.

None of this, other than identifying incoming calls from a PSAP and
using the resource-priority and manyfolks-resource mechanisms, affects
the protocol though.

Dave.

> Use [email-masked] for questions on current 
> sip Use [email-masked] for new developments of core SIP
>