Subject: RE: [Sipping] comment on draft-rosenberg-sip-call-package-01.txt

From: "Even, Roni" <[email-masked]>
Date: Thu, 21 Mar 2002 18:43:20 +0200

> -----Original Message-----
> From: David R. Oran [mailto:[email-masked]]
> Sent: Thursday, March 21, 2002 6:32 PM
> To: 'Even, Roni'; [email-masked]
> Subject: RE: [Sipping] comment on 
> draft-rosenberg-sip-call-package-01.txt
> 
> 
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]] 
> > On Behalf Of Even, Roni
> > Sent: Thursday, March 21, 2002 11:19 AM
> > To: [email-masked]
> > Subject: [Sipping] comment on 
> draft-rosenberg-sip-call-package-01.txt
> > 
> > 
> > Hi, 
> > I have a comment about the media mixing information. The 
> > information that interest the participants is if he is being 
> > heard or seen and who is he getting in his incoming mixing 
> > stream. 
> Well, that is certainly part of it. It's actually the hardest part in
> the case of distributed rather than centralized mixing.
> 
> > I do not think he wants to know the information about 
> > all the streams in the conference. 
> I disagree here. While no one participant may be interested in ALL the
> streams, a participant/moderator/administrator may in fact 
> want a global
> topology view of the current media streams.
This may have privacy implication. Typically the moderator want to know who
is in the conference and build the mixing that will be sent to all
participants. He will not allow a change by the participant if this is a
controlled conference.

 I also think one 
> participant
> may want to know why he is not hearing/seeing another participant (did
> he mute himself, was he put on hold, did the mixer decide he wasn't
> active, etc.)
This information should be for the streams he is receiving not for all of
them
> 
> > As for video mixing the information needs to specify the 
> > window in which the stream is displayed. 
> Unless I misunderstand, this is both un-necessary and 
> violates privacy.
> Why should other participants learn the window topology of my private
> display. Would you advocate reporting whether the earpiece is currently
> in my left or right ear?
This is not for the other participants. this is the information about what I
currently get from the video/audio mixer.
> 
> What I think you are asking for is in fact something 
> different, which is
> a mapping from the participant to the video region of the mixed video
> stream which contains his camera input. Is that in fact what 
> you meant?
Yes, what I meant is that when I receive a mixed video stream and I want to
know who is in my incoming stream I would like to associate each source with
his position on the screen.

> 
> Dave. 
> 
> Thanks Roni Even
> > 
> > **********************************************
> > Roni Even
> > 
> > Polycom Network Systems
> > Tel: +972-3-9251200
> > Mobile: +972-55-481099
> > Fax: +972-3-9211571
> > Email: [email-masked]
> > 
> > 
> > _______________________________________________
> > Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> > This list is for NEW development of the application of SIP
> > Use [email-masked] for questions on current 
> > sip Use [email-masked] for new developments of core SIP
> > 
> 

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "David R. Oran" <[email-masked]>
Date: Thu, 21 Mar 2002 11:59:14 -0500

> From: Even, Roni [mailto:[email-masked]] 
> Sent: Thursday, March 21, 2002 11:43 AM
> To: 'David R. Oran'; Even, Roni; [email-masked]
> > streams, a participant/moderator/administrator may in fact want a 
> > global topology view of the current media streams.
> This may have privacy implication. Typically the moderator 
> want to know who is in the conference and build the mixing 
> that will be sent to all participants. He will not allow a 
> change by the participant if this is a controlled conference.
>
I agree that it has privacy implications. Where I have a problem is
having a brittle classification scheme that categorizes people into
fixed classes like "participant" and "moderator". We need a general way
for participants to declare who is allowed to see and/or manipulate
their state in the conference, and who has rights to see and/or modify
other participants' state, including those whose streams they my no be
currently receiving. In the classic controlled conference model, this
maps onto the two categories of "moderator" and "participant" but we
need not carry this forward or limit ourselves to this fixed
classification system.

> This information should be for the streams he is receiving 
> not for all of them
See above. I believe the control/observation should be explicitly bound
via authorization and not implicitly bound based on what streams I am
sourcing/sinking.

> This is not for the other participants. this is the 
> information about what I currently get from the video/audio mixer.
OK.

> Yes, what I meant is that when I receive a mixed video stream 
> and I want to know who is in my incoming stream I would like 
> to associate each source with his position on the screen.
>
Agreed. However, we want to be careful to not exclude video processing
which produces avatars from the input video signals rather than the
current simple schemes of just tiling a larger window.

Thanks.

Dave.
 
> > > Sipping mailing list  
> https://www1.ietf.org/mailman/listinfo/sipping
> > > This list 
> is for NEW development of the application of SIP Use 
> > > [email-masked] for questions on current sip Use 
> > > [email-masked] for new developments of core SIP
> > > 
> > 
>