Subject: RE: [Sipping] ecan and silencesupp

From: Jean-Francois Mule <[email-masked]>
Date: Tue, 5 Mar 2002 14:18:56 -0700

Hi Joachim,

You wrote:
> in the fax pass-thru mode (re-INVITE after 606) new attributes
> 
> a=ecan: fb on
> a=silenceSupp: off
> 
> are used.
> 
> Are these attributes registered with IANA?
Yes.
Check http://www.iana.org/assignments/sdp-parameters

> a:silenceSupp: off is also needed when the V.25 ANS modem 
> tone (similar to CED) is detected. Therefore in my opinion 
> the gateway should switch to a Modem Transparency mode (this 
> is a new RTP payload with G.711, silence suppression=off, max 
> length for jitter buffer) when either CED or V.25 ANS modem 
> tone is detected.
If i understand you correctly, this would be for modem calls.  Are you suggesting that this real-time fax draft also addresses modem passthrough?

> Signalling of 'a=ecan: fb on' is not necessary since this is 
> controlled by CED w/ or w/o phase reversal.
yes, all ecan attributes will be removed from next version.

/Jean-Francois.

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Lueken Joachim <[email-masked]>
Date: Fri, 8 Mar 2002 15:57:30 +0100

Hi Jean-Francois,

Fax pass-thru and modem calls have similar requirements regarding VAD and jitter buffer size. Also the CED and V.25 ANS modem tones are similar. Therefore I propose to switch to Modem Transparency/Fax Pass-Thru mode after detection of CED or V.25 tones, respectively.

In case of fax we would then switch to T.38 on receipt of the V.21 preamble. If the re-INVITE fails, we can use the already installed fax pass-thru mode.

Joachim

-----Ursprüngliche Nachricht-----
Von: Jean-Francois Mule [mailto:[email-masked]]
Gesendet: Dienstag, 5. März 2002 22:19
An: 'Lueken Joachim'
Cc: [email-masked]; 'Bill Sulzen'
Betreff: RE: [Sipping] ecan and silencesupp

Hi Joachim,

Yes.

/Jean-Francois.