Subject: [Sipping] Re: draft-olson-sipping-content-indirection

From: Lawrence Conroy <[email-masked]>
Date: Mon, 8 Apr 2002 19:29:02 +0100

Hi Sean, Folks,
    IMHO, the content-indirection draft is is fine, but needs a little 
expansion.

I am unsure whether you're suggesting that it's required to provide a 
header (or
headers) holding URI/URLs WITHIN a SIP message, or that it's required 
to put URL
lists in MIME sub-parts associated with the SIP message, or to include such
references within an SDP part.

 From your covering note it SEEMs that you mean the first option. Perhaps it
would be useful to spell out why you need references in a SIP header rather
than elsewhere.

[The SDP approach was the one we took with PINT, where we needed 
external/static
data as part of the PINT session (for example, a file to be faxed), 
so I'm biased :].

Also, I'm not clear on REQ-10 - this reads as suggesting that a SIP message can
be fragmented, with some of the message being held indirectly (I guess with the
rump of the SIP message carrying a reference to the "rest" of the headers)?
That can't be right, so please explain.

all the best,
    Lawrence
-- 
[email-masked]: +44 1794 833666::<my opinions>:

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Sean Olson <[email-masked]>
Date: Mon, 8 Apr 2002 11:37:41 -0700 (PDT)

> references within an SDP part.

I am suggesting requirements. I am intentionally
avoiding defining implementation like whether
this should be done in a header or a MIME part, etc.
I realize this can be a source of confusion. To
clarify, I am leaning towards something that would
be a MIME part, but I will leave the protocol 
mechanics to the SIP working group.

> would be useful to spell out why you need references

Sorry for the confusion. As per a previous
suggestion, I will expand the section on the
intended uses of this mechanism in the hope that
the requirements will become clearer with more
context.

> data as part of the PINT session (for example, a

This is not something I had considered, but 
it is certainly one option. I will revisit the
requirements from this perspective to see if
any new requirements fall out.

> That can't be right, so please explain.

That is right. This requirement is a bit on the
fringe so I would welcome any feedback on whether
people think this is a good idea or not.

>     Lawrence

Thanks for the comments,
Sean

=====
Sean Olson <[email-masked]>

__________________________________________________
Do You Yahoo!?
Yahoo! Tax Center - online filing with TurboTax
http://taxes.yahoo.com/