Subject: RE: [Sipping] Screened From: and Privacy

From: [email-masked]
Date: Wed, 17 Apr 2002 12:01:26 +0300

> -----Original Message-----
> From: ext Dean Willis [mailto:[email-masked]]
> Sent: Tuesday, April 16, 2002 4:49 PM
> To: [email-masked]
> Cc: Sipping (E-mail)
> Subject: Re: [Sipping] Screened From: and Privacy
> 
> 
> 
> > in this case, the friend most likely would use your kid's "line"
> rather
> > than defining his/her own to the phone.  it is the same as using
> > someone's cell phone.  most likely the friend would not open it and
> > replace his/her own sim to the phone in order to make the call,
> because
> > that would be too complicated.
> 
> Exactly. But they're going to defin their own Subject field and other
> user (not SUBSCRIBER) data. I'm arguing that the display name field
> (From:) falls into this category.

Does that include Home Proxy? If you want to use my SIP phone and you don't have an account with my service provider, you have to reconfigure my phone with your service provider home proxy. I prefer for you to just use my phone and not change the configuration.

regards,
Hisham

> 
> > i again fail to see what this has to do with the privacy discussion.
> > when you use someone else's phone, you will also use his/her privacy
> > setup.
> 
> Because if the display name field (From:) is part of the SUBSCRIBER
> data, as you are arguing, then it falls into 
> network-controlled privacy
> management regulation and we end up with "MUST B2BUA 
> everything." If it
> is a USER field, then regulation affects it much more lightly.
> 
> What would be the implication if we added a "New" header for
> "UserDisplayName" intended for just what I've proposed above? Simple:
> The phone people would inist that that be rewritten by the network,
> because this MIGHT conflict with Subscriber privacy 
> requirements. Since
> the protocol allows extension with arbitrary new headers, the logical
> requirement is for "the network" to be required to block arbitrary new
> headers, thereby destroying service transparency.
> 
> Life is much better if we consider "From:", along with "Subject:" and
> other such fields, as  per-call user-provided data intended 
> for display
> to the other end of the dialog. Filtering the From, as you are doing,
> forces it into the regulatory realm in a way that you're not going to
> like.
> 
> --
> Dean
> 
> 
> --
> Dean
> 
> 
> _______________________________________________
> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments of core SIP
> 

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Dean Willis" <[email-masked]>
Date: Wed, 17 Apr 2002 10:54:44 -0500

Hisham said:
> Dean said:
> Does that include Home Proxy? If you want to use my SIP phone and you
don't have an account with my service provider, you have to reconfigure
my phone with your service provider home proxy. I prefer for you to just
use my phone and not change the configuration.

Think of this as like using a browser-based email client. Users key in
their subject and from fields, but they aren't likely to  (and generally
can't)  change the SMTP gateway used.

I wish people would top expecting phones to have a 10-key pad and a bad
user interface. This will change, and we should not cripple our designs
based on the assumption that it will never change.

--
Dean