Subject: Re: [Sipping] draft-yu-tel-url-04.txt comment

From: Christer Holmberg <[email-masked]>
Date: Fri, 12 Apr 2002 15:06:21 +0300

Hi,

What do you mean by "invalid url parameters" and "they don't mean anything"?
The spec allows one to specify any kind of uri parameter (other-param in the
ABNF syntax). Any implementation supporting the draft-yu-tel-url-04.txt will
treat them exactly the same way they would support them if they were in the
user-part, wouldn't it? They would only "mean nothing" to implementations
not supporting the draft...

Regards,

Christer Holmberg
Ericsson Finland

> Thanks.  I mean that they are "invalid url parameters."
>
> James
>
> > -----Original Message-----
> > From: Robert Sparks [mailto:[email-masked]]
> > Sent: Thursday, April 11, 2002 2:37 PM
> > To: Yu, James
> > Cc: 'Michael Hammer'; [email-masked]
> > Subject: RE: [Sipping] draft-yu-tel-url-04.txt comment
> >
> >
> > On Wed, 2002-04-10 at 12:39, Yu, James wrote:
> > > > I still feel that the use of parameters that are
> > > > intended to be
> > > > globally used, within the user part of a sip: URI (which I've
> > > > heard many
> > > > times can only be interpreted correctly by the domain after
> > > > the "@" sign)
> > > > may be an unintended contradiction.  I don't see a problem
> > > > with the tel:
> > > > URI as that does not have the domain construct.
> > >
> > > The routing is based on the host info. after "@" first.
> > The user part is
> > > then checked when that host receives the message.
> > >
> > > >
> > > > Would an address such as:
> > > > sip:[email-masked];user=phone;npdi=yes;rn=+1-202-
> > > > 544-000;cic=+1-6789
> > > > also be valid or is that prohibited by your draft?
> > > >
> > >
> > > No, it is not allowed because they are not valid url
> > parameters in sip url.
> >
> > That's not quite right. They are very much allowed. They just
> > don't mean
> > anything - everything will treat them as unknown SIP URI
> > parameters and
> > ignore them for anything but URI comparision.
> >
> > >
> > >
> > > _______________________________________________
> > > Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> > > This list is for NEW development of the application of SIP
> > > Use [email-masked] for questions on current sip
> > > Use [email-masked] for new developments of core SIP
> >
> >
>
> _______________________________________________
> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments of core SIP

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Yu, James" <[email-masked]>
Date: Thu, 11 Apr 2002 13:59:52 -0500

Robert,

James