Subject: RE: [Simple] Re: [Sipping] draft-olson-sipping-content-indirect-0 0.txt

From: "Sriram Parameswar"<[email-masked]>
Date: Mon, 8 Apr 2002 09:50:39 -0500

Sean:

Couple of additional comments/requirements:

** Access-Control - control over access to the content either by
authorization mechanisms or others. 
** Access-Control mechanism - this is probably extreme but we could probably
add an access-control mechanism. This should allow for a method of
access-control modification i.e. I gave you permission to see a particular
content - then want to revoke this privilege.

Thanks,

Sriram

__________________________________________
Sriram Parameswar              Phone: 972-685-8540
Interactive Multimedia Server (IMS) Fax: 972-684-3986
Nortel Networks, Richardson USA  Email: [email-masked]

-----Original Message-----
From: Paul Kyzivat [mailto:[email-masked]]
Sent: Monday, April 08, 2002 9:10 AM
To: Sean Olson
Cc: [email-masked]; [email-masked]
Subject: [Simple] Re: [Sipping]
draft-olson-sipping-content-indirect-00.txt

Sean - comment below.

	Paul

Sean Olson wrote:
> 
> FYI. I've put together a draft of requirements
> for a mechanism to allow content indirection
> (an indirect reference to content that would normally
> be carried directly in the SIP payload)
> 
>
http://www.ietf.org/internet-drafts/draft-olson-sipping-content-indirect-00.
txt

What is the purpose of REQ-2? 

Since this proposal is about content indirection, it seems like the purpose
of the content should be unchanged whether it is indirected or not. Whatever
mechanism there is
out to apply equally whether the content is direct or indirect. The
Content-Disposition header already serves this purpose.

Perhaps you are trying to say that it should be possible to use several URLs
as an alternative to several parts in a multipart-MIME body, and that you
want an ability
equivalent to specifying a separate Content-Disposition header for each.
That seems reasonable.

But if you are suggesting a need for more forms of disposition than are
currently covered by Content-Disposition, then I think that should be
handled in a way independent
of content indirection.

	Paul
_______________________________________________
simple mailing list
[email-masked]
http://mailman.dynamicsoft.com/mailman/listinfo/simple

---

From: Sean Olson <[email-masked]>
Date: Mon, 8 Apr 2002 10:04:47 -0700 (PDT)

This starts to spill over into the content vault
area. I'm preparing a separate draft for this.
There is obviously a lot of overlap here. I 
should be able to post the new draft in about a
week. Let me know if this doesn't cover your 
concerns.

Thanks,
Sean

--- Sriram Parameswar <[email-masked]>

=====
Sean Olson <[email-masked]>

__________________________________________________
Do You Yahoo!?
Yahoo! Tax Center - online filing with TurboTax
http://taxes.yahoo.com/

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP