Subject: AW: [Sipping] Screened From: and Privacy

From: "Jesske, R" <[email-masked]>
Date: Wed, 17 Apr 2002 15:04:33 +0200

> -----Ursprüngliche Nachricht-----
> Von: [email-masked] [mailto:[email-masked]]
> Gesendet am: Mittwoch, 17. April 2002 10:15
> An: Jesske, Roland
> Cc: [email-masked]; [email-masked]
> Betreff: AW: [Sipping] Screened From: and Privacy
> 
> Jesske, R writes:
> 
>  > That is the problem for the interworking with PSTN, that the phone
>  > include the From header. For the interworking case with 
> the PSTN the
>  > >From header is a not trusted information (because it is 
> direct from
>  > the user and not verified from the network). 
> 
> in my case it IS verified.

How should it be verified when I'm anonymous. Then I need some Information for the regulatory aspect!

> 
>  > But if there is a
>  > network provided indication (from a trusted network)that verifies
>  > that the From is the true user address (like the RPID do this with
>  > the screen = yes), than the Interworking entity can map the
>  > information in a proper way to the PSTN (including the regulatory
>  > aspects are fulfilled). 
> 
> i don't see how rpid would make things any more trusted than the from
> field. if two providers don't trust each other, they would not trust
> the rpid any more than the from field.
> 
>  > There will be no PSTN Operator that take an untrusted From 
> Header to
>  > a calling party number --> instead the PSTN operator will set up a
>  > new calling party number that is network provided and trusted!
> 
> to which number the network would set the calling party 
> number?  my sip
> users can have any number of calling party numbers belonging to any
> number of calling areas and soon even to any number of countries.  

Here I have two possibilities:
1. The user is only SIP user and insert some XYZ@user URL and want to reach the PSTN. The interworking function of the PSTN Gateway will set a network provided E.164 number (003333 for a special SIP Provider where the call come from) into the Calling Party Number. But if the PSTN Provider don't like calls without a E.164@user URL, the provider reject the call.

2. The SIP user has a E.164@user URL then the Gateway maps the URL direct to the Calling Party Number. (e.G. [email-masked] to CgPN=6151835940 with the indication national or international). 

> 
> thus the user thus MUST have some means to indicate to me 
> which of those
> numbers that i have allocated to the user, the user wants to 
> use as the
> calling party number in a particular call.  today this information is
> carried in the uri of the from field, which becomes a trusted entity
> after i have checked its validity.  
> 
> it is ok for me to add "screen=yes" parameter to the from 
> field although
> i don't need that information for anything. and if you want 
> to copy the
> from field to another rpid field and have "screen=yes" there, it is ok
> with me too as long as i'm not forced to do that myself.

I see, from the user aspect I don't want to add RPID within the user entity that have to do a trusted entity of the network provider.
If I'm anonymous I need the real identity within an other Header (RPID).The network will inset the real identity into the RPID with screen=yes. The RPID will be mapped to the PSTN as an restricted number, the restricted number is needed for some regulatory aspect (e.g. legal interception). But the normal user sees only the contend of the From header.
> -- juha

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: [email-masked]
Date: Wed, 17 Apr 2002 23:46:45 +0300

> How should it be verified when I'm anonymous. Then I need some Information for the regulatory aspect!

your display string is "Anonymous", but the uri contains the your from
address (see below).

 > 2. The SIP user has a E.164@user URL then the Gateway maps the URL direct to the Calling Party Number. (e.G. [email-masked] to CgPN=6151835940 with the indication national or international). 

this is what we are using and once it is used, the provider needs to
verify the number and after the verification is becomes trusted.

so i don't understand what additional value the rpid would bring.

 > If I'm anonymous I need the real identity within an other Header
 > (RPID).The network will inset the real identity into the RPID with
 > screen=yes. The RPID will be mapped to the PSTN as an restricted
 > number, the restricted number is needed for some regulatory aspect
 > (e.g. legal interception). But the normal user sees only the contend
 > of the From header.

you clearly didn't get my point.  the uri of the from field MUST contain
the calling number, whereas the display string controls the anonymity or
that number.

-- juha