Subject: RE: [Sipping] draft-olson-sipping-content-indirect-00.txt

From: "Sean Olson" <[email-masked]>
Date: Wed, 10 Apr 2002 06:57:16 -0700

I see where this is going. I will remove the "execute"
disposition. What the text below says, in different terms,
is that it is possible to verify that a CPL script does 
nothing "wrong" and you don't have to worry about a CPL
script taking an infinite amount of resources. There are
several types of executable sources that fit that description.
If you allow CPL, why not allow these? It is really academic
because what we are saying is that we are not going to 
allow a requirement that opens up the door for bad implementations.

/sean

-----Original Message-----
From: Beck01, Wolfgang [mailto:[email-masked]] 
Sent: Wednesday, April 10, 2002 1:06 AM
To: [email-masked]; [email-masked]
Subject: RE: [Sipping] draft-olson-sipping-content-indirect-00.txt

Sean,
> for now,
> what dangers do you perceive for handling an INVITE,
> or a SUBSCRIBE, or a REFER, or ... ? This is
> roughly equivalent to the problem of handling CPL
> upload. How do you trust the CPL you receive to
> know it is safe to execute? Assuming there is
> an answer to that question, can you apply that
> answer to an "execute" disposition?
Quoting from the CPL draft:
"The CPL is powerful enough to describe a large number of services and
features, but it is limited in power so that it can run safely in
Internet telephony servers. The intention is to make it impossible for
users to do anything more complex (and dangerous) than describing
Internet telephony services. The language is not Turing-complete, and
provides no way to write loops or recursion."

--
Wolfgang Beck
T-Systems Nova GmbH 

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Beck01, Wolfgang" <[email-masked]>
Date: Wed, 10 Apr 2002 10:06:04 +0200

Sean,
Quoting from the CPL draft:
"The CPL is powerful enough to describe a large number of services and
 features, but it is limited in power so that it can run safely in
Internet telephony servers. The intention is to make it impossible
for users to do anything more complex (and dangerous) than describing
Internet telephony services. The language is not Turing-complete, and
provides no way to write loops or recursion."

--
Wolfgang Beck
T-Systems Nova GmbH