Subject: RE: [Sipping] SIP/SIPT - ISUP/BICC Interworking

From: "Mark Watson"<[email-masked]>
Date: Mon, 29 Apr 2002 17:57:49 +0100

Hmm - I missed this draft. Not sure if it was sent to this list ?
 
We discussed this some 18 months ago on the SIP list.
 
BICC is basically ISUP plus extensions for controlling IP/ATM bearers in
place of TDM bearers. If you take the IP/ATM stuff out of BICC, then ISUP is
all that you are (should be) left with.
 
If you're interworking BICC with SIP, then you interwork all the bearer
stuff with SDP, so all you're left with is ISUP. So you never need to carry
BICC in SIP, you only need to carry ISUP.
 
Even if there was something which was in BICC and not ISUP, and which was
not related to Bearer Control, then we should discuss the correct way to
incorporate the function into SIP, not encapsulate BICC. What exactly are
the BICC capabilities that fall into this category that are applicable in a
SIP environment ?
 
Regards,
 
Mark

-----Original Message-----
From: Jagannathan R [mailto:[email-masked]]
Sent: 29 April 2002 10:47
To: [email-masked]
Subject: [Sipping] SIP/SIPT - ISUP/BICC Interworking

Hi,
 
   After having look at the I-D draft-chang-sipping-bicc-network-00.txt and
draft-ietf-sipping-sipt-01.txt, I am thoroughly confused about the
interworking of SIP-PSTN. Can some one help me to understand the difference
between or the different purposes of 
 
1. SIP-T which is primarily conceived for SIP-PSTN interworking (???)
2. SIP - BICC interworking.
 
I do know that BICC is basically for Inter MGC communication either within a
single network or across the networks. 
 
This bicc draft describes that extending SIP to support call control across
different networks. This extension encapsulates
BICC in the SIP message to provide the information needed across networks.
Integrating both SIP and BICC features,
this extension provides service providers a vehicle to deploy services
across different administration domains and different types of network.
 
My basic doubt is, by deploying SIP-T across the networks can't we achieve
this same purpose. If yes then, why one more framework on bicc?
 
Or am I missing some thing?
 
thanks,
jagannathan

---

From: Christian Groves <[email-masked]>
Date: Tue, 30 Apr 2002 11:58:43 +1000

G'Day Mark,

I surprised on your bought of amnesia :). There's a few other differences
between ISUP and BICC:
o the CIC size was increased in BICC
o BICC supports codec negotiation
o BICC supports in-call bearer modification
o BICC supports bearer redirection
o BICC supports a split MGC (CSF) & MG(BIWF) architecture

But I agree with you in that we shouldn't be looking at encapsulating BICC, I
wouldn't be encapsulating ISUP either though.

Cheers, Christian

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP