Subject: [Sipping] RE: [Sip] SIP support for IN services

From: "Peterson, Jon" <[email-masked]>
Date: Tue, 23 Apr 2002 02:15:50 -0500

Trimming the distribution back to the SIPPING list.

I have one comment off the bat - have you compared this work at all to the
following draft:

http://www.ietf.org/internet-drafts/draft-ietf-sipping-isup-01.txt

As you may know, this draft is a SIPPING WG last item, and it is currently
past WGLC. It contains, among other things, a SIP response code to Q.850
cause code mapping similar to the one in Appendix A of your document.
However, there are some discrepancies between the mappings suggested by the
two documents (it looks like yours may have been influenced by an earlier
version of sipping-isup?). The mappings in the SIPPING-ISUP draft have been
subjected to a reasonable amount of public scrutiny over the last two years
or so, and I feel they tell a reasonably good story at this point. Some of
the mappings in your draft look a little misplaced to me - to pick an
example at random, '403 Forbidden' mapping to '1 Unallocated number'.

I would actually suggest that your SIN draft should refer normatively to
SIPPING-ISUP for this mapping and any other SIP-to-ISUP needs.

Jon Peterson
NeuStar, Inc.

> -----Original Message-----
> From: Vijay K. Gurbani [mailto:[email-masked]]
> Sent: Friday, April 19, 2002 8:24 AM
> To: SIP LIST; SIPPING LIST; SPIRITS list; [email-masked]
> Subject: [Sip] SIP support for IN services
> 
> 
> Folks:
> 
> Enclosed is an I-D for review that describes SIP support for IN
> services.  The I-D represents agreement of the IETF SIN 
> (SIP/IN) design
> team and is intended for publication as an informational RFC.  It has
> been through Last Call in the IETF SIN DT and the comments of the WGs
> identified in the To list of this email are now being solicited.
> 
> http://search.ietf.org/internet-drafts/draft-gurbani-sin-00.txt
> 
> Thanks,
> 
> - vijay
> -- 
> Vijay K. Gurbani  vkg@{lucent.com,research.bell-labs.com,acm.org}
> Wireless Networks Group/Internet Software and eServices
> Lucent Technologies/Bell Labs Innovations, 2000 Lucent Lane, Rm 6G-440
> Naperville, Illinois 60566     Voice: +1 630 224 0216
> 
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> 

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Tue, 23 Apr 2002 16:37:45 -0500

Peterson, Jon wrote:

> two documents.

Jon:

There are 2 tables in Appendix A of my I-D; the second table which
attempts to map ISUP cause values to SIP responses is legacy, carried
over from older versions of the I-D.

You are right in your suggestion that,

> your SIN draft should refer normatively to SIPPING-ISUP for this 

> mapping and any other SIP-to-ISUP needs.

I will add a normative reference in lieu of the second table.

Thanks,

- vijay