Subject: Re: [Simple] RE: [Sipping] draft-olson-sipping-content-indirect-00.txt

From: Bobby Sardana <[email-masked]>
Date: Thu, 11 Apr 2002 00:37:07 -0700

"Beck01, Wolfgang" wrote:

> Bobby Sardana wrote:
> > I am sure that the appropriate UAC will implement a "security sandbox"
> > for both the "execute" and "render" feature set.
>
> Like MS Outlook and mIRC did? One global "I love you.vbs" desaster is enough in
> my opinion. Can you imagine what happens if administrators have to block
> all SIP traffic because of some broken, but widespread implementation?

Initial implementations require a period of time till they are stable and secure.
Primarily a UNIX user, I am aware of many robust functionalities being deployed, via
"execute" feature, to MS Explorer. The key here is deployment aka a mechanism to
deploy features. Provided the "security sandbox" is stable and the underlying
platform does not allow misuse, new services can be downloaded onto the UAC and
executed safely.  Is the underlying platform 100% secure to not allow misuse? This
requires time to mature.

>
> We can scan E-mails for worms and viruses as the receiver won't notice the delay.
> If we have to scan SIP messages, we are in trouble.

Almost all mobile manufacturers have published plans to support J2ME which will
follow similar constraints. Currently in infancy, but the promise still holds and
provides a framework to deploy executable services.

>
>
> > A properly designed UAC
> > will also allow such
> > features to be manually disabled.
>
> After the first major security incident many people will have to
> disable the feature by their organization's rules.
>
> > Personally, I like the "execute" feature as it allows new
> > services to be deployed on
> > the UAC.
>
> As long as a script can't access local data -- like address books --,
> can't access the net and can be limited in it's memory and CPU usage,
> it might be safe. But can such a script still be useful? (This is not a
> rhetorical question).

A simple script could be:

1. On render at UAC, present click to connect. On click, send an INVITE.

To conclude, yes there are constaints as what disposition types that can be
supported with regards to security. But restricting them, because of their past
misuse, should not be a limiting factor in their future adoption.

regards,

Bobby Sardana.
[email-masked]

>
>
> RfC 2046 spends no less than 2 pages on describing the dangers of PostScript
> files being sent as MIME attachment..
>
> --
> Wolfgang Beck
> T-Systems Nova GmbH

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Beck01, Wolfgang" <[email-masked]>
Date: Thu, 11 Apr 2002 08:34:51 +0200

--
Wolfgang Beck
T-Systems Nova GmbH