Subject: RE: [Sipping] draft-olson-sipping-content-indirect-00.txt

From: "Beck01, Wolfgang" <[email-masked]>
Date: Tue, 9 Apr 2002 15:20:29 +0200

Sean,

disposition "execute" in REQ-2 is very dangerous. A popular E-mail program
used to have a similar function enabled by default, which resulted
in a worldwide breakdown of many mail servers. Even "render" might be dangerous, if
the document uses some language like PostScript or Word macros.

--
Wolfgang Beck
T-Systems Nova GmbH 

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Sean Olson <[email-masked]>
Date: Tue, 9 Apr 2002 10:07:15 -0700 (PDT)

I absolutely appreciate your concern. Simply
put, any system must have an appropriately defined
security mechanism in place for any packets it
receives. Ignoring Content-Disposition: for now,
what dangers do you perceive for handling an INVITE,
or a SUBSCRIBE, or a REFER, or ... ? This is
roughly equivalent to the problem of handling CPL 
upload. How do you trust the CPL you receive to
know it is safe to execute? Assuming there is
an answer to that question, can you apply that
answer to an "execute" disposition?

I would like to solicit other people's comments
on this topic. If there is sufficient pushback,
I'll remove this item.

Thanks!
/sean

> the document uses some language like PostScript or

=====
Sean Olson <[email-masked]>

__________________________________________________
Do You Yahoo!?
Yahoo! Tax Center - online filing with TurboTax
http://taxes.yahoo.com/

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 10 Apr 2002 00:18:54 -0400

[trimmed SIMPLE]

Bobby Sardana wrote:
> 
> I am sure that the appropriate UAC will implement a "security sandbox"
> for both the
> "execute" and "render" feature set. A properly designed UAC will also
> allow such
> features to be manually disabled.
> 
> Personally, I like the "execute" feature as it allows new services to be
> deployed on
> the UAC.

I agree with those who think this is far too dangerous.

I think a lot more thinking needs to go into disposition types. In any
case, I think they are totally ortogonal to the problem at hand. Rather,
the appropriate requirement for this draft is to simply state that it
must be possible to associate a registered disposition with each URI.

If someone wants to write a separate draft on new disposition
requirements, they should feel free to do so...

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.            72 Eagle Rock Avenue
Chief Scientist                         First Floor
dynamicsoft                             East Hanover, NJ 07936
[email-masked]                 FAX: (973) 952-5050
http://www.jdrosen.net                  PH:  (973) 952-5000
http://www.dynamicsoft.com

---

From: "Sean Olson" <[email-masked]>
Date: Tue, 9 Apr 2002 22:21:52 -0700

Fair enough. This does spill over into implementation a bit.
I'll remove the specifics from the text. What I will add is
that these content dispositions should be extensible.

/sean

-----Original Message-----
From: Jonathan Rosenberg [mailto:[email-masked]] 
Sent: Tuesday, April 09, 2002 9:19 PM
To: Bobby Sardana
Cc: Beck01, Wolfgang; [email-masked]; [email-masked]
Subject: Re: [Simple] RE: [Sipping]
draft-olson-sipping-content-indirect-00.txt

[trimmed SIMPLE]

> for both the "execute" and "render" feature set. A properly designed 
> UAC will also allow such
> Personally, I like the "execute" feature as it allows new services to 
> be deployed on the UAC.

-Jonathan R.

---

From: Bobby Sardana <[email-masked]>
Date: Tue, 09 Apr 2002 18:57:04 -0700

I am sure that the appropriate UAC will implement a "security sandbox" for both the
"execute" and "render" feature set. A properly designed UAC will also allow such
features to be manually disabled.

Personally, I like the "execute" feature as it allows new services to be deployed on
the UAC.

regards,

Bobby Sardana.
[email-masked]

"Beck01, Wolfgang" wrote:

> simple mailing list
> [email-masked]
> http://mailman.dynamicsoft.com/mailman/listinfo/simple