Subject: RE: [Sipping] draft-yu-tel-url-04.txt comment

From: Michael Hammer <[email-masked]>
Date: Wed, 10 Apr 2002 13:53:49 -0400

James,

That begs the question on whether those parameters should be defined for 
sip URI as well?

Could I then infer that the answer to that question was NO?

Further, unless it knows the local policy on subsequent nodes, a gateway 
should use the tel: URI rather than the sip: URI to assure the least amount 
of opaqueness for those parameters.

Mike

At 12:39 PM 4/10/2002 -0500, Yu, James wrote:
> > I still feel that the use of parameters that are
> > intended to be
> > globally used, within the user part of a sip: URI (which I've
> > heard many
> > times can only be interpreted correctly by the domain after
> > the "@" sign)
> > may be an unintended contradiction.  I don't see a problem
> > with the tel:
> > URI as that does not have the domain construct.
>
>The routing is based on the host info. after "@" first.  The user part is
>then checked when that host receives the message.
>
> >
> > Would an address such as:
> > sip:[email-masked];user=phone;npdi=yes;rn=+1-202-
> > 544-000;cic=+1-6789
> > also be valid or is that prohibited by your draft?
> >
>
>No, it is not allowed because they are not valid url parameters in sip url.

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Yu, James" <[email-masked]>
Date: Wed, 10 Apr 2002 12:39:10 -0500

---

From: Robert Sparks <[email-masked]>
Date: 11 Apr 2002 13:36:51 -0500

> No, it is not allowed because they are not valid url parameters in sip url.

That's not quite right. They are very much allowed. They just don't mean
anything - everything will treat them as unknown SIP URI parameters and
ignore them for anything but URI comparision.

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 12 Apr 2002 10:45:40 +0300

Hi,

> >>I still feel that the use of parameters that are  intended to be
> >>heard many times can only be interpreted correctly by the domain after
> >>the "@" sign) may be an unintended contradiction.  I don't see a problem
> >>with the tel: URI as that does not have the domain construct.
> >
> >>544-000;cic=+1-6789 also be valid or is that prohibited by your draft?
> >

This issue has been discussed before, and the following is what I also said back
then.

Yes, the ABNF does allow the ";" character in the user-part. However, the SIP-URI
does not specify specific user-part  parameters, so if you send
"sip:+1-202-533-1234;npdi=[email-masked]" to a server which doesn't understand
the extension it's going to treat the whole "+1-202-533-1234;npdi=yes" eg as a
phone number, and in case of a PSTN GW try to route that "number" to the PSTN
network (which, of course, won't work, since the ";npdi=yes" part can't be routed
as a phone number).

So, I very much support to use the parameters in the host-part instead. Then, if
a server doesn't understand them it will simply ignore them, as specified in the
standard.

Regards,

Christer Holmberg
Ericsson Finland