Subject: RE: [Sipping] draft-yu-tel-url-04.txt comment

From: "Yu, James" <[email-masked]>
Date: Mon, 8 Apr 2002 22:28:11 -0500

Mike,
 
Yes, user=phone or branch=xxx is the url-parameter (after the hostport).
npdi, rn and cic are part of the tel URL and can appear in the user part of
the sip url when user=phone is present.
 
The user part of the sip url is usually treated as a string.  but when
user=phone is present, the user part will contain a telephone number and
with or without some tel URL parameters.  ";' in the user part does not
present any problem.
 
James

-----Original Message-----
From: Michael Hammer [mailto:[email-masked]]
Sent: Monday, April 08, 2002 2:23 PM
To: Yu, James
Cc: [email-masked]
Subject: RE: [Sipping] draft-yu-tel-url-04.txt comment

James,

I missed the intent of the first two lines of Section 6.  What you are
saying is that the npdi=, rn=, cic= are embedded in the URL, and not
appended to the end like the tag=xxx, user=phone, branch=xxx, received=xxx
and any other parameter I recall seeing in SIP.

Will the ";" in the middle of the URI present any problems?

Sorry for being obtuse and being perhaps the only one who didn't appreciate
this detail.

Mike

At 11:27 AM 4/8/2002 -0500, Yu, James wrote:

Mike,

Everything after "@" in a SIP URL belongs to the SIP host part.  tel URL
appears in the user part of the SIP URL.

James

> -----Original Message-----
> From: Michael Hammer [ mailto:[email-masked] <mailto:[email-masked]>
]
> Sent: Thursday, April 04, 2002 3:51 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [Sipping] draft-yu-tel-url-04.txt comment
> 
> 
> James,
> 
> Section 6: npdi-ident = "yes" | "no"
> Yet, section 7.3, example 1: "npdi=[email-masked],com"
> 
> Would that be rejected or truncated?
> 
> Also, cic-ident = *phonedigit
> Section 7.3, example 2: "cic=[email-masked]"
> 
> Does phonedigit include all alphanumeric?
> 
> Mike
>

---

From: Michael Hammer <[email-masked]>
Date: Tue, 09 Apr 2002 12:25:02 -0400

James,

Thanks.  I found that the ABNF on bis9 p.228 allowed the ";" in the user 
part.  I still feel that the use of parameters that are intended to be 
globally used, within the user part of a sip: URI (which I've heard many 
times can only be interpreted correctly by the domain after the "@" sign) 
may be an unintended contradiction.  I don't see a problem with the tel: 
URI as that does not have the domain construct.

Would an address such as:
sip:[email-masked];user=phone;npdi=yes;rn=+1-202-544-000;cic=+1-6789
also be valid or is that prohibited by your draft?

Thanks again.
Mike

At 10:28 PM 4/8/2002 -0500, Yu, James wrote:
>Mike,
>
>Yes, user=phone or branch=xxx is the url-parameter (after the 
>hostport).  npdi, rn and cic are part of the tel URL and can appear in the 
>user part of the sip url when user=phone is present.
>
>Sorry for being obtuse and being perhaps the only one who didn't 
>appreciate this detail.
>
>Mike
>
>
>
>
>

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP