Subject: RE: [Sipping] Thoughts on the conf-info package

From: "Eric Burger" <[email-masked]>
Date: Wed, 19 Jun 2002 03:11:55 -0400

Is this generally useful?  Because of resource allocation issues (why should
I let you use my mixer -- I wanted those extra MIPS for my game of Hack on
my phone display...) and billing issues (why should I pay for you to
conference in, unless I want to conference you in, at which point I would
conference you in on my mixer...), is there any reason to have third-party
intra-domain conference control?  Remember, you can always *ask* me to use
my mixer.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Paul Kyzivat
Sent: Thursday, May 23, 2002 12:04 PM
To: Orit Levin
Cc: 'Anders Kristensen'; Rohan Mahy; [email-masked]
Subject: Re: [Sipping] Thoughts on the conf-info package

[snip]

But if I knew there were one or more conference bridges already in the call
I would probably try them first, even if I have the capability to mix
locally. It may also be
useful to know about other parties in the call that have mixing capability.

This is a bit more information than is available with the conference
package, even with Rohan's proposed goodies.
[snip]

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 19 Jun 2002 13:51:08 -0400

It seems useful to me. Suppose I get a call and find I am talking to two other people. I don't know the topology by which they are connected to me. Now I want to bring you
into the same call, and eventually I may want to leave you talking to the other two people. How do I do that?

- I could call you and then mix you locally into my call
  with the others. Then when I want to leave I would
  have to do a shuffle to leave you in the call.
- I could my caller to you, letting it do the mixing.
  (This would be a good solution if the caller was a
  conference mixer, and might be ok if the caller is
  just a phone with mixing capability.) 
- I could allocate a conference mixer, move my end of the call to it,
  and then refer the mixer to you as well

What would really be silly would be for me to allocate a
new conference mixer when there is already one in the call.

Of course there are resource allocation issues. They can
be handled in at least a couple of ways. If you have mixing
capability but don't want to share it, then you can simply
fail to advertise that you have it. Or, you can tell me 
about it but fail my attempt to use it.

	Paul

---

From: "Eric Burger" <[email-masked]>
Date: Thu, 20 Jun 2002 00:42:25 -0400

We agree, just an error in terminology.

When I said "my mixer", I meant "the mixer to which I have an established
relationship".  That can be the mixer in my phone (e.g., PingTel), the mixer
in my gateway (e.g., Cisco), or the mixer in the network (e.g., SnowShore).
Each behaves differently when the user goes away.  HOWEVER, the user KNOWS
how "their" mixer works.  There are no surprises.

While it may be "silly" from an Engineering perspective for you to bring in
a mixer when I already have one, I do not see the Business case for my
letting you control "the mixer to which I have an established relationship".
In the case you outline below, you would ask the other people to mix me in
using that out-of-band channel, a.k.a. voice.  Remember, the protocol
requires the use of the PLEASE attribute :-)

-----Original Message-----
From: Paul Kyzivat [mailto:[email-masked]]
Sent: Wednesday, June 19, 2002 1:51 PM
To: [email-masked]
Cc: [email-masked]
Subject: Re: [Sipping] Thoughts on the conf-info package

It seems useful to me. Suppose I get a call and find I am talking to two
other people. I don't know the topology by which they are connected to me.
Now I want to bring you
into the same call, and eventually I may want to leave you talking to the
other two people. How do I do that?

	Paul

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 20 Jun 2002 17:03:12 -0400

Eric,

I have in mind actions that would would be carried out automatically, perhaps as a result of hitting the conference button on my phone, with the goal that it will just "do
the right thing". The voice-channel-PLEASE-protocol isn't a viable alternative in that case.

Surely there may be cases where you won't let me use your mixer, but I can think of lots of cases where you are either happy to have me do so, or else are unable to stop
me:

- your phone has free mixing capability. All I need to do is refer my extra party to join the existing call with you.

- I was called by a conference bridge in the first place. It was already set up to accept new callers. (But it isn't "my mixer".) I just need to realize that is the
situation.

	Paul

---

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 24 Jun 2002 16:30:42 -0400

I agree with Paul. If we have the ability to indicate that a particular 
user in a call has mixing capability that can be used in a conference, 
we can support all models. A user that would need to pay for such 
mixing, and therefore does not want to let others use it, would not 
advertise that capability. THose that don't have a billing issue, can 
advertise it.

-Jonathan R.

Paul Kyzivat wrote:
> Eric,
> 
> I have in mind actions that would would be carried out automatically,
> perhaps as a result of hitting the conference button on my phone, with
> the goal that it will just "do
> Surely there may be cases where you won't let me use your mixer, but I
> can think of lots of cases where you are either happy to have me do so,
> or else are unable to stop
> me:
> 
> - your phone has free mixing capability. All I need to do is refer my
> extra party to join the existing call with you.
> 
> - I was called by a conference bridge in the first place. It was already
> set up to accept new callers. (But it isn't "my mixer".) I just need to
> realize that is the
> situation.
> 
> 	Paul
> 
> Eric Burger wrote:
> 
>>When I said "my mixer", I meant "the mixer to which I have an
> 
> established
> 
>>relationship".  That can be the mixer in my phone (e.g., PingTel), the
> 
> mixer
> 
>>in my gateway (e.g., Cisco), or the mixer in the network (e.g.,
> 
> SnowShore).
> 
>>Each behaves differently when the user goes away.  HOWEVER, the user
> 
> KNOWS
> 
>>While it may be "silly" from an Engineering perspective for you to
> 
> bring in
> 
>>letting you control "the mixer to which I have an established
> 
> relationship".
> 
>>In the case you outline below, you would ask the other people to mix
> 
> me in
> 
>>It seems useful to me. Suppose I get a call and find I am talking to
> 
> two
> 
>>other people. I don't know the topology by which they are connected to
> 
> me.
> 
>>Now I want to bring you
>>into the same call, and eventually I may want to leave you talking to
> 
> the
> 
>>>Is this generally useful?  Because of resource allocation issues
>>
> (why
> 
>>should
>>
>>>I let you use my mixer -- I wanted those extra MIPS for my game of
>>
> Hack on
> 
>>>conference in, unless I want to conference you in, at which point I
>>
> would
> 
>>>conference you in on my mixer...), is there any reason to have
>>
> third-party
> 
>>>intra-domain conference control?  Remember, you can always *ask* me
>>
> to use
> 
>>>my mixer.
>>>
>>>From: [email-masked] [mailto:[email-masked]]On
>>
> Behalf Of
> 
>>>Paul Kyzivat
>>>But if I knew there were one or more conference bridges already in
>>
> the
> 
>>call
>>
>>>I would probably try them first, even if I have the capability to
>>
> mix
> 
>>>locally. It may also be
>>>useful to know about other parties in the call that have mixing
>>
>>capability.
>>

-- 
Jonathan D. Rosenberg, Ph.D.            72 Eagle Rock Avenue
Chief Scientist                         First Floor
dynamicsoft                             East Hanover, NJ 07936
[email-masked]                 FAX: (973) 952-5050
http://www.jdrosen.net                  PH:  (973) 952-5000
http://www.dynamicsoft.com