Subject: Re: [Sipping] update to 3pcc I-D

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 05 Jun 2002 00:36:06 -0400

realized I never responded to this:

Paul Kyzivat wrote:
> 
> Jonathan,
> 
> This sounds good.
> 
> There may be one more related issue. I don't know if it should be
> mentioned here or simply left to be dealt with elsewhere - it is a
> bigger issue that this. The issue is
> what the behavior should be for a SIP-PSTN gateway when it receives an
> invite with a media-less offer. I can think of three possibilities:
> 
> 1) send a 5xx error response to the invite
> 
> 2) forward the call out to the PSTN. If it succeeds,
>    return a 200 OK with no media. Effectively put
>    the media stream on hold. Wait for a reinvite
>    with media.
> 
> 3) Don't pass the call to the PSTN. Just respond with
>    200 OK. When you get a reinvite that wants to use
>    voice, then make the call to the PSTN. Of course,
>    it then may take a long time, and it may fail.
>    If a reinvite failed, then the call would revert
>    to no-media until somebody sends a BYE.
> 
> Of these, (1) is a bad choice. (2) may not give a very good experience
> to the called party - may initially hear silence, and some audio may be
> dropped even if the reinvite
> comes right away. (3) violates the assumptions of call flow IV.
> 
> (2) seems like the only choice that makes any sense for this call flow.
> But it results in added limitations.

It has to be (2). The behavior shouldn't be different for a PSTN gw than
for any other SIP UAS. Note that with the new preconditions related flow
in the spec, the INVITE with no media would not cause the gateway to
send the call to the PSTN yet (which would cause alerting, counter to
the preconditions). It would instead send a 183, and wait for the UPDATE
before sending the call to the PSTN. This is case 3b, I guess (since its
not a 200 OK that gets sent, but a 183).

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.            72 Eagle Rock Avenue
Chief Scientist                         First Floor
dynamicsoft                             East Hanover, NJ 07936
[email-masked]                 FAX: (973) 952-5050
http://www.jdrosen.net                  PH:  (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 05 Jun 2002 10:27:37 -0400

Alternative (2) isn't very appealing, though less bad than (1) and (3). This puts a premium on getting the preconditions flow together with (3b) established as the call
flow of choice for 3pcc when a gateway might be involved.

	Paul