Subject: RE: [Sipping] Discussion points for the hearing impairment meetin g 07-17-02 17: 30 (5.30 p.m.)

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Wed, 17 Jul 2002 07:24:49 +0100

Two comments from a 3GPP perspective. 

1)	GTT will be deployed, for two reasons, first that the specifications and the need to use it are available prior to release 5 deployment (there is an understanding that it can be implemented in earlier releases even though it is documented within release 5). SIP will not be deployed until the release 5 deployment. Additionally even when release 5 is generally deployed there is no requirement that all operators deploy the infrastructure necessary to support SIP.

Therefore we need to discuss how GTT will interoperate with any SIP deaf solution. I assume 3GPP would look at any SIP deaf solution for deployment to users that have SIP access.

2)	3GPP has a transcoding requirement as most IMS users will have AMR2 codecs only (required to use because of radio access bandwidth limitations), and many SIP users in non-3GPP implementations do not have AMR2 codecs. It would be desirable if any deaf solutions also solve the more general problem of incorporating a transcoder between two users.

Keith

> -----Original Message-----
> From: Arnoud van Wijk (ELN) [mailto:[email-masked]]
> Sent: 16 July 2002 14:34
> To: 'Sipping '
> Subject: [Sipping] Discussion points for the hearing 
> impairment meeting
> 07-17-02 17: 30 (5.30 p.m.)
> 
> 
> To all who are interested.
> I have here a few discussion points for the meeting.
> The goal of this meeting is in fact to have a starting point.
> And to know what the possible steps are/will be.
> 
> 1. Set up a strategy for the technical RFC.
>  - I will together with the RNID and others from the deaf 
> community start with describing the usecases. And write it up 
> in a starting document.
>  - You will receive this document and also be able to add 
> usecases that we may have forgotten.
>  - The technical SIP experts will then identify the current 
> SIP design and implementations (SIP, SIPPING and SIMPLE,3GPP?).
>  - IMPORTANT: Then identify what needs to be added to SIP to 
> make this all work. Headers that may be added, tags and 
> parameters. And even interworking with other protocols etc with SIP.
> That should become clearly a multi WG part and hopefully with 
> involvement from other standardization groups as well.(e.g. 3GPP).
> 
> 2. Awareness to other WGs and standardization groups 
> regarding this work. How should we do it? Perhaps a job for 
> the people who are also participating in others 
> standardization groups and WGs?
> And will SIPPING be the "controller" for the technical RFC/Draft?
> 
> 3. 3GPP, Global Text Telephony
>  - streaming text = DTMF /Boudot or other text telephone 
> generated tones over RTP. This is a copy of the legacy text 
> telephony. 
> The FCC forces the old text telephony into the IP telephony. :(
> We need to look at how to deal with this. Any suggestions? 
> The most desirable would be that 3GPP will join forces with 
> us for the best solutions and designs.
> 
> 
> 4. Design team communication.
> How will we communicate?
> Via Sipping mailinglist?
> Via Yhoo mailing list?
> Via a news server (preferred by the RNID)
> any suggestions?
> 
> People who are not able to attend that meeting are still 
> welcome to join this design team!
> Feedback is welcome and we will try to post the minutes of 
> that meeting on the list!
> 
> After all, the details and precise planning will be done on the list.
> 
> Thank you,
> 
> greetz
> 
> Arnoud van Wijk
> 
> _______________________________________________
> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments of core SIP
> 

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Mark Watson" <[email-masked]>
Date: Wed, 17 Jul 2002 13:17:25 +0100

Keith raises an interesting point (2) below.

There is an interesting 'generalised transcoder discovery' problem: (i) how
do two users determine, from their SDP and perhaps preferences information,
that a transcoder is needed for them to communicate, and (ii) how do they
find and introduce such a transcoder ?

Additionally, there is the possibility that a transcoder is needed for some
of the media streams but not for others, and further that there may be a
requirement for a user to receive both the original media stream and a
transcoded version.

Plus the fact that it's not symmetrical.

If by 'transcoder' we include anything which maps one collection of media
streams into another collection, the second collection containing a subset
of the information in the first, then we should cover most of the
requirements I can imagine. So, that's <audio codec A> -> <audio codec B>,
<video codec A> -> <video codec B>, <speech codec A> -> <text>, <video (sign
language)> -> <audio> + <text>, <audio speech (english)> -> <audio speech
(french)>, <speech phonyms> -> <sign language avatar instructions>, etc.

Some simple indications of the proposed usage of media streams (speech,
language) and some preference driven compatibility rules would allow a
simple end-to-end negotiation to determine the transcoding requirements, but
actually finding and introducing an appropriate transcoder might be a little
harder.

Regards,

Mark

> From: Drage, Keith (Keith) [mailto:[email-masked]]
> Sent: 17 July 2002 07:25
> To: Arnoud van Wijk (ELN); 'Sipping '
> Subject: RE: [Sipping] Discussion points for the hearing impairment
> meetin g 07-17-02 17: 30 (5.30 p.m.)
> 
> 
> 1)	GTT will be deployed, for two reasons, first that the 
> specifications and the need to use it are available prior to 
> release 5 deployment (there is an understanding that it can 
> be implemented in earlier releases even though it is 
> documented within release 5). SIP will not be deployed until 
> the release 5 deployment. Additionally even when release 5 is 
> generally deployed there is no requirement that all operators 
> deploy the infrastructure necessary to support SIP.
> 
> Therefore we need to discuss how GTT will interoperate with 
> any SIP deaf solution. I assume 3GPP would look at any SIP 
> deaf solution for deployment to users that have SIP access.
> 
> 2)	3GPP has a transcoding requirement as most IMS users 
> will have AMR2 codecs only (required to use because of radio 
> access bandwidth limitations), and many SIP users in non-3GPP 
> implementations do not have AMR2 codecs. It would be 
> desirable if any deaf solutions also solve the more general 
> problem of incorporating a transcoder between two users.
> 
> Keith
>