Subject: Re: [Sipping] draft-mahy-sipping-connect-reuse-reqs-00

From: Christer Holmberg <[email-masked]>
Date: Tue, 09 Jul 2002 19:32:33 +0300

Hi Sean,

> Is this really out of scope for this draft? Naturally
> the more re-use you make of the connection, the more
> benefit you get from re-use ;-)

Of course, but in that case it should be mentioned in the draft :)

The only thing the draft currently talks about the problem how to make sure
a single connection is used for both directions, per session - which is a
separate issue from reusing connections for multiple sessions.

And, since I don't think any draft currently talks about the reuse of
connections for multiple sessions (bis talks about keeping the connection
open to make sure the transaction uses the same transaction), maybe it
could be added to the connect-reuse draft?

Just some thoughts...

Regards,

Christer Holmberg
Ericsson Finland

>
>
> /sean
>
> -----Original Message-----
> From: Christer Holmberg [mailto:[email-masked]]
> Sent: Tuesday, July 09, 2002 6:30 AM
> To: Gonzalo Camarillo
> Cc: Sean Olson; [email-masked]; [email-masked]; [email-masked]
> Subject: Re: [Sipping] draft-mahy-sipping-connect-reuse-reqs-00
>
> Hi,
>
> RFC3261/bis-9 mainly talks about using a single connection (or, one in
> each
> direction) for a single transaction, and the connect-reuse draft talks
> about being able to use a single connection for messages in both
> direction, for a single session. Sometimes, however, when we talk about
> "reuse of connection" we mean when a single connection (or, one in each
> direction) is used for multiple sessions. I think it would be a good
> idea to mention that that kind of "reuse" is out of the scope of the
> draft. Otherwise the draft subject should more clear indicate what kind
> of reuse it refers to...
>
> Of course, once a single connection is established, according to the
> connect-reuse draft, it MAY be used for multiple sessions, but that's
> not the scope of the draft, so...
>
> Regards,
>
> Christer Holmberg
> Ericsson Finland

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 09 Jul 2002 19:40:35 +0300

Another comment,

I also think it is important to remember that there MAY be scenarios,
especially if a connection is used for multiple sessions, where one wants to
use separate connections per each direction - even if the client indicates he
wants to use the same connection for the response. Just to think of before the
MUSTs are added...

Regards,

Christer Holmberg
Ericsson Finland

---

From: "Sean Olson" <[email-masked]>
Date: Tue, 9 Jul 2002 09:23:55 -0700

/sean

-----Original Message-----
From: Christer Holmberg [mailto:[email-masked]] 
Sent: Tuesday, July 09, 2002 6:30 AM
To: Gonzalo Camarillo
Cc: Sean Olson; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [Sipping] draft-mahy-sipping-connect-reuse-reqs-00

Hi,

Regards,

Christer Holmberg
Ericsson Finland