Subject: [Sipping] Dialoge states / Interworking CCBS/CCNR

From: "Poetzl, Joachim" <[email-masked]>
Date: Wed, 31 Jul 2002 17:17:48 +0200

Hi all,

a question for clarification regarding usage of event notifcation package for CCBS/CCNR service interworking

> A UAC subscribes for statechange from subscribed to terminated (via filtering in the subscribe body, for further study)
> 
> after the state change occurs, the notifier notifies this to the subscriber 
> 
> Question: Is the subscription dialog automatically terminated after the notification of the event? Is the dialog still existend and further statechanges can be notified?
> Can the subscription state still be "active"?
> 
> Background:
> In CCBS (defined in Q.733.3) a message (ccbs suspended) is send  if a request cannot be served even if destination B is not busy, because user A is busy. After User A is free again a message (CCBS resume) is send. For this purpose an open Subscribe dialog could be helpful.
> 
> Regards
> 
> Joachim Pötzl
> 
........................................................................................
Deutsche Telekom AG
T-Com Zentrale T38-13
Signalling, Gateways and Switching Systems
64307 DARMSTADT, GERMANY 
Phone:  +49 6151 83-2134
Fax:      +49 6151 83-4577
email:	[email-masked]
........................................................................................

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Mark Watson" <[email-masked]>
Date: Wed, 31 Jul 2002 17:59:51 +0100

Joachim,

I am still confused about how dialog state can be used to implement
CCBS-like service when the called party is a normal SIP UA (rather than a
PSTN gateway).

If there are three dialogs in progress at the terminating UA, how do you
know which one is keeping the user 'busy'. Perhaps two of them are for IM
sessions, and the user is happy to take voice calls whilst the IM sessions
are ongoing.

Or is your intention only to implement an 'asymetric' service, where SIP
users can invoke CCBS against PSTN endpoints but not vice-versa ?

Regards,

Mark

> -----Original Message-----
> From: Poetzl, Joachim [mailto:[email-masked]]
> Sent: 31 July 2002 16:18
> To: [email-masked]
> Subject: [Sipping] Dialoge states / Interworking CCBS/CCNR
> 
> 
> Hi all,
> 
> a question for clarification regarding usage of event 
> notifcation package for CCBS/CCNR service interworking
> 
> > A UAC subscribes for statechange from subscribed to 
> terminated (via filtering in the subscribe body, for further study)
> > 
> > Question: Is the subscription dialog automatically 
> terminated after the notification of the event? Is the dialog 
> still existend and further statechanges can be notified?
> > In CCBS (defined in Q.733.3) a message (ccbs suspended) is 
> send  if a request cannot be served even if destination B is 
> not busy, because user A is busy. After User A is free again 
> a message (CCBS resume) is send. For this purpose an open 
> Subscribe dialog could be helpful.
> > 
> > Regards
> > 
> > Joachim Pötzl
> >

---

From: Adam Roach <[email-masked]>
Date: Wed, 31 Jul 2002 13:28:25 -0500

> terminated after the notification of the event? 

Please consult RFC 3265, which answers your question
unambiguously.

/a