Subject: RE: [Sipping] New Service Examples I-D

From: "Avella, Alejandro" <[email-masked]>
Date: Wed, 24 Jul 2002 18:51:29 -0600

Alan,

Here are some services that might be added to your draft...

Basic Calling	
Call Progress or Error
 Call Progress Tone - Busy	
 Call Progress Tone - Fast Busy	
 Call Progress Tone -- Offhook Warning	
Announcement on Error	
 Play SIT tone	
 Re-route call to announcement server	
Call Information (CLASS) Services	
 Caller ID - Onhook with Ringing	
 Caller ID - Off hook with Call Waiting	
 Block Caller ID	
Message Waiting Lamp (Visual Message Waiting Indication - VMWI)
Feature Invocation or Cancellation	
 From Onhook - Invocation/Cancellation with Dial-Code Only	
 From Onhook - Invocation with Dial-Code and Destination Address
 From Offhook - Invocation/Cancellation with Flash hook and Dial-Code Only
 From Offhook - Invocation with Flash hook, Dial-Code and Destination
Address
Single-Line Features	
 Facilitated Calling - Automatic Dialing (local)
 Facilitated Calling - Speed Dial
 Facilitated Calling - Redial	
 Facilitated Calling - Call Return	
 Facilitated Calling - Hot Line	
 Facilitated Calling - Automatic Callback	
 Distinctive ringing	
 Multiple DNs on Device	
Group Features
 Intercom Dialing  -- Abbreviated Dialing -- 4-digit dialing
 Coverage and Voice Mail (on busy and no Answer)
 Simultaneous Ring	
Handling Multiple Calls to/from Same Endpoint	
  Call Retrieve (Flash)	
  Disconnect after Hold
  Disconnect after Being Held	
  Call Waiting Indication	
  Call Waiting - Distinctive Tone(s)	
  Call Waiting - Hold and Answer	
  Call Waiting - Drop and Answer	
  Transfer - Blind	
  Transfer - Consultation Transfer	
  Conference - N-Way - to external bridge	
Modem 
FAX pass-trough  
FAX relay (T.38) 

Alejandro

-----Original Message-----
From: Alan Johnston [mailto:[email-masked]]
Sent: Wednesday, July 10, 2002 7:42 AM
To: [email-masked]
Subject: [Sipping] New Service Examples I-D

All,

There is a new version of the the Service Examples draft.  It has not yet 
appeared in the IETF archives.  Until it does, it is available at:

      http://ee.wustl.edu/~alan/draft-ietf-sipping-service-examples-02.txt

The main changes relate to two new call flows for transitioning a 2-party 
call to a 3-party call (2.9 3-way Conference - Third Party is Added and 
2.10 3-way Conference - Third Party Joins) which use a conference URI.

As always, comments and feedback are greatly appreciated.

Thanks,
Alan Johnston
sip:[email-masked]

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

*************************************************************************
This e-mail transmission, and any documents, files, or previous
e-mail messages attached to it may contain information that is 
confidential or legally privileged.  If you are not the intended 
recipient, or a person responsible for delivering it to the 
intended recipient, you are hereby notified that you must not 
read this transmission and that any disclosure, copying, printing,
distribution, or use of any of the information contained in or 
attached to this transmission is strictly prohibited.  If you have 
received this transmission in error, please immediately notify the 
sender by telephone or return e-mail and delete the original 
transmission and its attachments without reading or saving them 
in any manner.  Thank you.
*************************************************************************

---

From: Rohan Mahy <[email-masked]>
Date: Wed, 24 Jul 2002 18:21:10 -0700

Alejandro,

A great number of these items are already described either in 
draft-ietf-sipping-call-flows or draft-ietf-sipping-service-examples.  
In some cases one flow in the SIPPING drafts might correspond to several 
of the entries you copied here out of someone's legacy phone system 
feature list. For example, there is no difference to SIP between a 
4-digit basic call and a 10 digit basic call or an <n>-digit basic call.

Also please note that some of these "services" have no impact on SIP 
whatsoever.  For example, redial is purely a feature provided at a SIP 
user agent.  Even if the User Agent connects to a dumb analog phone 
which uses * codes or something, the User Agent should provide a redial 
feature if this is desired.

Please review your list against the material currently available, and if 
you feel that there is a feature which is missing which has an impact on 
the SIP protocol, please provide a description of the feature and why 
the feature can't be handled autonomously by the relevant user agent.  
After a very brief skim, I did not find any.

thanks,
-rohan