Subject: RE: [Sipping] call-flows remarks.

From: "Christian Jansson" <[email-masked]>
Date: Tue, 9 Jul 2002 10:43:45 +0200

> >Comment 4:
> >++++++++++    line 1385:
> >
> >Situation:
> >
> >The scenario is the following:
> >INVITE     CSeq=cseq1 Callid=callid1
> >407        CSeq=cseq1 Callid=callid1
> >ACK        CSeq=cseq1 Callid=callid1
> >
> >re-INVITE  CSeq=cseq1+1 Callid=callid1
> >
> >The spec recommends to use a CSeq+1 in the RE-INVITE.
> >I can't find a recommendation on using the same call-id?
> >is it mandatory?
> 
> It is not mandatory, but it is a very good idea as nonces can 
> be tied to 
> Call-IDs.

Do you mean that a re-INVITE could have a different CALL-ID
than the original INVITE? How would the receiver of such an
INVITE recognize it as an re-INVITE if the id has been changed?

---
Christian Jansson
Hotsip

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Alan Johnston <[email-masked]>
Date: Fri, 12 Jul 2002 11:22:02 -0500

Hi Christian,

See my answer below.

Thanks,
Alan.

>INVITE recognize it as an re-INVITE if the id has been changed?

This is not considered a re-INVITE as no dialog was established (a 407 was 
returned to the initial INVITE).

If a dialog was established (a 200 was returned to the initial INVITE) then 
of course the same Call-ID must be used.