Subject: RE: [Sipping] WGLC for ISUP overlap signaling

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Tue, 2 Jul 2002 12:07:35 +0100

As you seem to be substantially disagreeing on the word prefix, I would point out that according to E.164 none of the numbers given by Gonzalo is a prefix. E.164 definition of prefix is "A prefix is an indicator consisting of one or more digits, that allows the selection of different types of number formats, networks and/or service".

+358 9 299 3371 is the representation of 358 9 299 3371

00 placed in front of this to indicate an international number would be a prefix.

358 is a country code, not a prefix
9 is a national destination code, not a prefix
the remaining 7 digits are the subscriber number.
within the PBX the 299 could be considered as an escape code, but certainly not as a prefix.

Gonzalo appears to be describing the case where

+358 9 299 1 and
+358 9 299 1000 

are both valid numbers in the numbering plan.

I can find no specification in E.164 which specifies this as either allowed or precluded, and therefore no internationally recognised term to describe it. I believe in the US it used to be called critical dialling, but in this case it was used to reach attendants, and one of the numbers in that case was not an E.164 number, because it was a local service number.

I would stress that such numbering schemes are in very limited use throughout the world. I was not aware that any of the CEPT countries used them.

Keith

> -----Original Message-----
> From: Gonzalo Camarillo [mailto:[email-masked]]
> Sent: 02 July 2002 07:54
> To: [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: Re: [Sipping] WGLC for ISUP overlap signaling
> 
> 
> Hello,
> 
> I would appreaciate if you could use text format in your messages, as
> opposed to html. It is easier for me to answer.
> 
> You write:
> >This is one of the most significant disagreements I have with this 
> >entire discussion. I do not believe there is a single place in the
> >world's numbering plan where a number can be a "prefix" of another 
> >number. I'm speaking of the international, E.164 number, not
> >the local number that one might dial to reach operators, 
> local numbers, 
> >long-distance numbers, etc. Can you give me one example
> >of where one E.164 number is a "prefix" of another? 
> >
> >As for the above "example", I still don't believe there is a single 
> >valid case in which an INVITE with too many digits should result in
> >a response that says there isn't enough digits. 
> 
> 358 is the prefix for Finland.
> 9 is the prefix for Helsinki
> 299 is the prefix for the PBX of Ericsson.
> Within our PBX, we manage the last 4 digits of the number.
> 
> My phone number is: +358 9 299 3371
> My fax number is: +358 9 299 3052
> 
> If you want to call the reception, you should dial: +358 9 299 1
> 
> Now, if you want to dial any extension (the last four digits of the
> phone number) that begins with 1 (e.g., +358 9 299 1234), you have the
> problem I was describing.
> 
> Best regards,
> 
> Gonzalo
> -- 
> Gonzalo Camarillo         Phone :  +358  9 299 33 71
> Oy L M Ericsson Ab        Mobile:  +358 40 702 35 35
> Telecom R&D               Fax   :  +358  9 299 30 52
> FIN-02420 Jorvas          Email :  [email-masked]
> Finland                   http://www.hut.fi/~gonzalo
> 
> _______________________________________________
> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments of core SIP
> 

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Gonzalo Camarillo <[email-masked]>
Date: Tue, 02 Jul 2002 15:07:58 +0300

Keith,

As you point you, I was using the word "prefix" without giving any
formal definition... and it seems that people familiar with the ITU
definition got confused...

Could you suggest a clearer set of terms so that everybody understands
things in the same way? Let me know the paragraphs in the draft that are
not clear enough.

Thanks,

Gonzalo

---

From: Rohan Mahy <[email-masked]>
Date: Tue, 2 Jul 2002 08:19:27 -0700

On Tuesday, July 2, 2002, at 04:07 AM, Drage, Keith (Keith) wrote:

> As you seem to be substantially disagreeing on the word prefix, I would 
> point out that according to E.164 none of the numbers given by Gonzalo 
> is a prefix. E.164 definition of prefix is "A prefix is an indicator 
> consisting of one or more digits, that allows the selection of 
> different types of number formats, networks and/or service".
>
> I can find no specification in E.164 which specifies this as either 
> allowed or precluded, and therefore no internationally recognised term 
> to describe it. I believe in the US it used to be called critical 
> dialling, but in this case it was used to reach attendants, and one of 
> the numbers in that case was not an E.164 number, because it was a 
> local service number.
>
> I would stress that such numbering schemes are in very limited use 
> throughout the world. I was not aware that any of the CEPT countries 
> used them.

Hi Keith,

I believe the case Gonzalo wanted to describe is one where the same 
prefix in the TRIP sense is the same.  for example:
+49 40 3502

The following are both actual legal numbers in Germany:

+49 40 3502 0            (The SAS Radisson Hotel in Hamburg)
+49 40 3502 1226    (Room 1226 in that hotel)

You can dial both of these numbers direct from the PSTN (nationally and 
internationally).

hope this helps.
thanks,
-rohan