Subject: [Sipping] Usage SIP Event for automatic call back

From: "Poetzl, Joachim" <[email-masked]>
Date: Thu, 18 Jul 2002 15:28:02 +0200

Hi all,

some questions on SIP specific event notification (1) and event package for dialog state (2) for usage in automatic call back service (Call Completion to busy Subscriber, CCBS):

In (1) it is stated, that subscribed events will be identified by a token: 
The "Event" header will contain a token which indicates the type of state for which a subscription is being requested.

Has any token been defined and registered yet?
Could this token really be used to select the subscription of a specific event?

In (2) it is said that the subscribe body can be used as a filter for specific events. For the automatic call back service it is desireable to be notified only when the remote user terminates the call. 

Is it possible to subscribe only for the state change from state confirmed to state terminated? 
Can this event filtering be described in the subscribe body (XML)?
Is it still necessary to send an imediately notify with full state information as a response of a subscribe? This will cause unnecessary load and provides useless information.

> Greetings
> Joachim Pötzl
........................................................................................
Deutsche Telekom AG
T-Com Zentrale T38-13
Signalling, Gateways and Switching Systems
64307 DARMSTADT, GERMANY 
Phone:  +49 6151 83-2134
Fax:      +49 6151 83-4577
email:	[email-masked]
........................................................................................

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Adam Roach <[email-masked]>
Date: Mon, 22 Jul 2002 09:12:31 -0500

> -----Original Message-----
> From: Poetzl, Joachim [mailto:[email-masked]]
>
> Is it still necessary to send an imediately notify with full 
> state information as a response of a subscribe?

It is *always* necessary to send an immediate NOTIFY. Among
other things, it solves the Heterogeneous Error Response Forking
Problem (commonly known as HERFP).

/a