Subject: [Sipping] Dialog package

From: [email-masked]
Date: Tue, 23 Jul 2002 11:05:42 +0300

This was described earlier as a philosophical, but I think it applies here too.

Since Dialog package is only allowed for INVITES, why don't we call it session package? Then you don't need to explicitly mention that it is for INVITE only.

Will this package be extended in the future to include other methods like SUBSCRIBE?

Regards,
Hisham

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Robert Sparks <[email-masked]>
Date: 23 Jul 2002 13:44:31 -0500

Dialogs and sessions are not the same thing

We were very careful to refine the meanings of those terms while
building 3261. Sessions are what you describe with SDP.

So, if we want to rename it to be more obviously INVITE dialog specific,
we should go with something like idialog, not session.

RjS

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 23 Jul 2002 19:08:59 -0400

> we should go with something like idialog, not session.

I think it was my earlier posting that hisham refers to.

I agree that 3261 is very careful to define this. The "problem" (not sure that is the right word) is with using the name "dialog" as the name for the event package that
currently carries that name.

There are probably lots of names that would do. "idialog" would be better than "dialog", but it still has an improper connotation - you are not subscribing to information
about the dialog itself. Instead, you are subscribing to one of many possible pieces of state that are associated with a dialog. That piece of state used to be called a
call-leg. We did away with the term call-leg, but left ourselves with no name for that piece of state.

It is possible to reference that piece of state using just the dialogid and the name of that kind of state because there can be at most one instance of that kind of state
per dialog.

My two most preferred names for this would be "call" or any of the various possible punctuations of "call-leg".

Once it has been discussed, this is just a nit for the people who have been involved in the discussion. So personally I can tolerate using the name "dialog". But it will be
a source of unending confusion and questions if it remains.

	Paul

---

From: Sean Olson <[email-masked]>
Date: Tue, 23 Jul 2002 16:53:59 -0700 (PDT)

I vote for "invite-dialog".
/sean

__________________________________________________
Do You Yahoo!?
Yahoo! Health - Feel better, live better
http://health.yahoo.com