Subject: [Sipping] query on conference model

From: "Ranjit Avasarala" <[email-masked]>
Date: Tue, 16 Jul 2002 10:16:30 +0530

Hi
      according to draft draft-ietf-sipping-service-examples-02.txt , user B
sends INVITE to bridge to establish session. Now how do I differentiate this
INVITE from the normal INVITE?
I have this problem because my conference server is a combination of normal
UAS, Registrar and conference server.

Thanks In Advance

Ranjit

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Alan Johnston <[email-masked]>
Date: Tue, 16 Jul 2002 20:52:48 -0500

(trimmed to just the sipping list)

Hi Ranjit,

The answer is the Request-URI of the INVITE.  For example, if your server 
is a UAS, Registrar, and conference server, then perhaps the following 
example helps:

Request for UAS sent to sip:[email-masked]

Request for registrar sent to sip:registrar.there.com (these requests would 
also be a REGISTER not an INVITE)

Request for conference server sent to sip:[email-masked] (or even 
something using URI params such as    sip:[email-masked];feature=conf)

All three of these requests resolve to the same host.  Which app would 
receive it would depend on the  Request-URI.  Does this help?

Thanks,
Alan Johnston
sip:[email-masked]

---

From: Sanjay Kumar K <[email-masked]>
Date: Tue, 16 Jul 2002 19:48:24 -0700 (PDT)

Hi Ranjit,
 You can also receive INVITE conf=[email-masked],
where yyyyyyy is an uniquely generated identifier for
the conference and "conf" can be an provisionable
identifier representing the requested service to be an
conference service.

Kumar

--- Alan Johnston <[email-masked]> wrote:
> Request for registrar sent to
> sip:registrar.there.com (these requests would 
> >       according to draft
> draft-ietf-sipping-service-examples-02.txt , user B
> >Sipping mailing list 
> https://www1.ietf.org/mailman/listinfo/sipping
> Sipping mailing list 
> https://www1.ietf.org/mailman/listinfo/sipping

__________________________________________________
Do You Yahoo!?
Yahoo! Autos - Get free new car price quotes
http://autos.yahoo.com

---

From: "Ranjit Avasarala" <[email-masked]>
Date: Wed, 17 Jul 2002 10:30:37 +0530

Hi  Alan

   Thanks for the reply. is the parameter feature=conf user defined or is it
defined in any draft. if yes where can I get the list of parameters that a
request-uri can take

Thanks
Ranjit

---

From: "Ranjit Avasarala" <[email-masked]>
Date: Fri, 19 Jul 2002 14:58:56 +0530

is this a header in INVITE msg?
conf=
Ranjit
----- Original Message -----
From: Sanjay Kumar K <[email-masked]>
To: Alan Johnston <[email-masked]>; Ranjit Avasarala
<[email-masked]>; <[email-masked]>
Sent: Wednesday, July 17, 2002 8:18 AM
Subject: Re: [Sipping] query on conference model

---

From: Sanjay Kumar K <[email-masked]>
Date: Fri, 19 Jul 2002 11:00:02 -0700 (PDT)

Hi Ranjit,

   You can look at the the
draft-burger-sipping-msuri-01.txt for further
reference on this. This is not an header in INVITE but
an service indication in the Request-URI denoting
service is an conference service. 

Kumar

--- Ranjit Avasarala <[email-masked]>
wrote:
> > > The answer is the Request-URI of the INVITE. 
> For
> > > example, if your server
> > > receive it would depend on the  Request-URI. 
> Does
> > > this help?
> > >
> > > Thanks,
> > > Alan Johnston
> > > >sends INVITE to bridge to establish session.
> Now
> > > how do I differentiate this
> > > >I have this problem because my conference
> server is
> > > a combination of normal
> > > >This list is for NEW development of the
> application
> > > of SIP
> > > >Use [email-masked] for
> questions
> > > on current sip
> > > This list is for NEW development of the
> application
> > > of SIP
> > > Use [email-masked] for
> questions
> > > on current sip

---

From: "Ranjit Avasarala" <[email-masked]>
Date: Mon, 22 Jul 2002 10:24:02 +0530

Thanks Sanjay.
I wanted to know the status of the draft as it expires in May 2002

Ranjit
----- Original Message -----
From: Sanjay Kumar K <[email-masked]>
To: Ranjit Avasarala <[email-masked]>; Alan Johnston
<[email-masked]>; <[email-masked]>
Sent: Friday, July 19, 2002 11:30 PM
Subject: Re: [Sipping] query on conference model