Subject: RE: [Sipping] FW: Communication re: SIP - BICC/ISUP Interworking

From: "Mark Watson" <[email-masked]>
Date: Mon, 22 Jul 2002 10:27:21 +0100

The ability for the end-user to provide backwards tones/announcement before
answer is available in the ISDN in the form of the Q.931 Annex K procedures.

It is local policy matter to whom this capability is offered, but if it is
offered to a given user by a given terminating operator there is nothing
that originating/transit operators can do about it - indeed they would not
know.

I am confused about why there is an interworking issue here, though.

If the SIP UAC procedures at the gateway accept an offer of Early Media from
the UAS (which is presumably dependent on local policy), then the
interworking functions should obviously cut-through. The cut-through
behaviour is driven entirely by what is agreed in the offer/answer exchange
between Gateway UAC and UAS. I am not sure what the problem is.

Regards...Mark

> -----Original Message-----
> From: Taylor, Tom-PT [CAR:B602:EXCH] 
> Sent: 21 July 2002 11:10
> To: Rohan Mahy; Rosen, Brian
> Cc: [email-masked]'
> Subject: RE: [Sipping] FW: Communication re: SIP - BICC/ISUP
> Interworking
> 
> 
> 
> I agree that it is a policy decision at the gateway.  It 
> really depends on
> the service agreement between the gateway operator and the SIP network
> operator.  If the gateway operator knows that the SIP network 
> will withhold
> the actual media address until the 200 OK, the gateway can 
> cut through the
> connection before that point.  This makes an awful lot of 
> assumptions on the
> SIP network (e.g. B2BUA), so I think we are stuck with the SG 
> 11 assumption
> as a general rule.  What distresses me is that this precludes any
> announcements or other early media from the SIP network itself.
> 
> 
> -----Original Message-----
> From: Rohan Mahy [mailto:[email-masked]]
> Sent: Tuesday, July 16, 2002 10:40 AM
> ...
> Subject: Re: [Sipping] FW: Communication re: SIP - BICC/ISUP
> Interworking
> 
> [snip]
> 
> > 3.	Cut through in the backward direction for tones and 
> announcements
> > from the SIP network can be misused as there is a bearer path 
> > potentially
> > available from the user equipment without charging.  (The called UA 
> > could
> > send back a 180 Ringing, then send back its own media 
> without bothering 
> > to
> > send a 200 OK INVITE.)  We are currently taking a 
> conservative approach 
> > and
> > not cutting through until answer.  This is an issue of 
> whether the SIP
> > network can be trusted.
> The PSTN allows this functionality today.  Whether the PSTN GW allows 
> bidirectional early media, and how it records this request for 
> accounting purposes seem like a policy decision on the gateway.
> 
> thanks,
> -rohan
> 
> > [snip]
> > Due to the lack of the meeting time, ITU wasn't able to 
> make a complete
> > review of the IETF interworking document. It was agreed 
> that comments
> > regarding this interworking document would be made directly by the
> > individual experts and forward it to the IETF lists.
> >
> > The SG 11 BICC group looks forward to further 
> communications as this 
> > study
> > progresses.
> >
> >
> > Tom Taylor
> > [email-masked]
> > Ph. +1 613 736 0961 (ESN 396 1490)
> >
> >
> > _______________________________________________
> > Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> > This list is for NEW development of the application of SIP
> > Use [email-masked] for questions on current sip
> > Use [email-masked] for new developments of core SIP
> 
> 
> _______________________________________________
> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments of core SIP
> 
> _______________________________________________
> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments of core SIP
>

---

From: "Subhodeep Sarkar" <[email-masked]>
Date: Thu, 25 Jul 2002 09:46:51 +0530

We can define a interworking timer for the gateway, which will be
started when a early media
request comes in and upon expiring release the call. A similar sort of
procedure is used in the ISDN
network for backward tones/announcement.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Mark Watson
Sent: Monday, July 22, 2002 2:57 PM
To: Tom-PT Taylor; Rohan Mahy; Rosen, Brian
Cc: [email-masked]'
Subject: RE: [Sipping] FW: Communication re: SIP - BICC/ISUP
Interworking

The ability for the end-user to provide backwards tones/announcement
before answer is available in the ISDN in the form of the Q.931 Annex K
procedures.

It is local policy matter to whom this capability is offered, but if it
is offered to a given user by a given terminating operator there is
nothing that originating/transit operators can do about it - indeed they
would not know.

If the SIP UAC procedures at the gateway accept an offer of Early Media
from the UAS (which is presumably dependent on local policy), then the
interworking functions should obviously cut-through. The cut-through
behaviour is driven entirely by what is agreed in the offer/answer
exchange between Gateway UAC and UAS. I am not sure what the problem is.

Regards...Mark