Subject: Re: [Sipping] draft-ietf-sipping-isup

From: "Alexeitsev, D" <[email-masked]>
Date: Tue, 9 Jul 2002 13:22:05 +0200

Thanks for the reply

My point was about the use of PRACKs in the call flows. I'm agree, that its use is entirely the local SIP issue and they have no added value to the mapping itself, but I believe, that if they are deleted from the call flows there should be a statement, that highlights this issue a bit more.

As the paragraph 4.4 says:

"PSTN interworking should occur over a reliable transport layer end-to-end"

I had the discussion in the SIP list concerning the use of a reliable transport and it was pointed to me, that the SIP is independent from the transport layer, so even if you have reliable transport (TCP/SCTP) you still shall use the 100rel procedures.
 
So probably the last sentence in this paragraph should be changed:

"One application-layer provisional reliability mechanism is described in [16]."
"The application-layer provisional reliability mechanism as described in [16] should/shall be used."

Greetings,
Denis Alexeitsev

-----Ursprüngliche Nachricht-----
Von: Peterson, Jon [mailto:[email-masked]]
Gesendet am: Montag, 8. Juli 2002 20:54
An: 'Alexeitsev, D'; [email-masked]
Betreff: RE: [Sipping] draft-ietf-sipping-isup

To expand a bit on Adam's reply:

In a more literal sense, it was the elimination of the 100rel document. As
you may recall, for a time 100rel was wrapped (a little awkwardly, since it
was still cast as an extension) into the core SIP specification - this was
some time around rfc2543bis05, I believe. The reference to 100rel as a
separate document disappeared from sipping-isup then. When 100rel was pulled
back out of bis, there was still some confusion about its status, which
motivated the removal of PRACKs and so on from the SIP-ISUP draft. 

We reasoned at the time SIP-ISUP really had no dependency on any specific
means of making reply transmissions reliable, merely that they be so.
Omission of PRACKs made call flows somewhat smoother, and it didn't seem
that PRACKs had any mapping to ISUP or any especial bearing on the mapping
to ISUP (at least, no more bearing than reliable response delivery has for
any other SIP mechanism, not all of which provide PRACKful examples).

Do you feel differently? Is there some ambiguity in the mapping that arises
from the absence of the use of the 100rel mechanism? 

Jon Peterson
NeuStar, Inc.

> -----Original Message-----
> From: Alexeitsev, D [mailto:[email-masked]]
> Sent: Friday, July 05, 2002 1:09 AM
> To: [email-masked]
> Subject: [Sipping] draft-ietf-sipping-isup
> 
> 
> Hello All
> 
> Sorry if it was already discussed, but I couldn't fine the 
> SIPPING archives search page. 
> 
> What was the rationale to remove the 100rel from the 
> draft-ietf-sipping-isup?
> 
> Greeting,
> Denis Alexeitsev
> 
> _______________________________________________
> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments of core SIP
> 

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 09 Jul 2002 14:44:38 +0300

Hi,

I agree that PRACK isn't really needed in the ISUP/SIP draft.

The draft defines ISUP-to-SIP MAPPING, ie how we map SIP into ISUP (and the other way around). And, we do NOT map PRACK messages to ISUP messages, or the other way around (we MAY create ISUP messages from information we get in the PRACK message, but we don't map the PRACK itself into ISUP).

So, IF we want to require/recommend reliable transport for the provisional responses, wouldn't the SIP-T draft be a better place to do it?

Regards,

Christer Holmberg
Ericsson Finland