Subject: [Sipping] Regarding SIP messages

From: [email-masked]
Date: Tue, 8 Oct 2002 14:34:30 +0530

hello

              I am working in developing a P-CSCF server. I have some
doubts in SIP messages. Please help me out.

1)  How can I frame a SIP message?

2) Does a SIP message have traditional header and delimeters?

3) Is  SIP message, a plain text string?

4)  Can I just create a string called invite user name @sdfds.sdfds.sdf and
with some more paramters just as a string and send it to the server or I
need to convert everything to binary and send it?

I request you to clear the above queries with an example. (Please)

Thanking You

Ganesh Iyer. S

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Ranjit Kumar Avasarala" <[email-masked]>
Date: Fri, 18 Oct 2002 09:29:22 +0530

Hi
   Actually S-CSCF is the SIP Server and P-CSCF is the proxy while I-CSCF
acts like Location Server.
 So say your UE is a SIP entity , then it generates INVITE message just like
any SIP entity and sends it to SIP Server i.e S-CSCF.

so you frame the sip message just like it is framed in a typical SIP stack.

Ranjit

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
[email-masked]
Sent: Tuesday, October 08, 2002 2:35 PM
To: [email-masked]
Cc: [email-masked]
Subject: [Sipping] Regarding SIP messages

hello

Thanking You

Ganesh Iyer. S