Subject: RE: [Sipping] Mapping conferencing drafts to levin-sipping-confer encing-req..-01

From: Orit Levin <[email-masked]>
Date: Fri, 18 Oct 2002 18:12:43 -0400

Hi Arjun!
I am impressed with your thorough knowledge of the SIP conferencing
genealogy :-)

Instead of trying to address many of your issues, I would just say, please,
stay patient for another 2-3 weeks. We are working on a couple of new (sorry
about that) documents that intend to replace some of the old documents :-)
and map the requirements to a real thing.

Seriously, the first versions of a conferencing framework and a conferencing
call control document will be published for the upcoming IETF meeting. I
hope that, as a result, we will be able to have a more focused discussion
about how to do conferencing with SIP.

BR,
Orit Levin
Chief Architect
RADVISION
Tel: +1.201.6896330
The views or opinions presented herein are solely those of the author and do
not necessarily represent those of the company.

> -----Original Message-----
> From: Arjun Roychowdhury [mailto:[email-masked]]
> Sent: Friday, October 18, 2002 12:08 PM
> To: [email-masked]; [email-masked]
> Subject: [Sipping] Mapping conferencing drafts to levin-sipping-
> conferencing-req..-01
> 
> Hi all,
> In the past (and present) there has been quite a bit of confusion on what
> drafts to follow for sip conferences and the direction forward.
> Ofcourse, this all may be clear withing the SIP design group working on it
> ->so please humor others for trying to make sense of it all :-)
> 
> According to the minutes of SIP WG Interim meet in May 6 2002, there seems
> to be some sort of direction that cc-framework and
> conference-models drafts will be used as a base for defining further work.
> 
> To me the hierarchy as of now looks like:
> 
> a) cc-framework-01 and conferencing-models-01 defines high level concepts
> of various SIP conferencing models
>         a.1) Orit's sipping-conferencing-req..-01 focusses on a focussed
> star shaped conference (which is a subset of above)
>         and would form the base for requirements for a centralized
> conference server implementation .
> 
> Question: what is the priority of the design team to work on similar req.
> docs for other conferencing models ?
> [personal: my main interest is in this star shaped model, so the question
> is just curiosity, thats all :-) ]
> 
> Before I proceed, I have some general questions:
> 
> draft-wu-sipping-floor-control-01.txt: Is this an active draft that is
> being worked on (expires this Oct )
> draft-levin-sip-for-video-01.txt: Is this an active draft that is being
> worked on
> draft-koskelainen-sipping-conf-requirements-00.txt:  How does this fit in
> ?
> draft-even-sipping-conference-scenarios-00.txt:  How does this fit in ?
> Should this not be merged with cc-models ?
> 
> In addition, certain XML schemas for media control seem to be addressed in
> MMUSIC. Besides the XML schema
> for Media control draft posted in the SIP List yesterday, could someone
> let me know if there are other drafts
> that are being actively used by the design team ?
> 
> Now, with respect to Orit's reqts for the star conference, I am trying to
> understand various drafts that are being worked on
> that help addressing various requirement categories.
> 
> What I have done below is listed each category of reqt and the drafts I
> know of today that address some parts of it
> I would request that the knowledgeable please correct me on my
> understanding of the status/drafts:
> 
> General Conference Discovery:
> ===========================
>         a) It can be manually "discovered" (SRV,  provisioning,  etc) - no
> specific drafts needed
>         b)  RFC  3087 (Control of Service Context  using SIP R-URI)
> 
>         not yet addressed/ open :
>         ---------------------------------------
>         a) No specific drafts on specific conference discovery. 3087 may
> help in organizations "standardizing" conference server ids
>              within their domain,  hence helping in auto-discovery
>         b) No specific drafts on conference-capability-discovery
> .conference-package draft seems to provide packages for few or all user
>             status in a conference, not capabilities of a conference
> server in general (eg, type of models it can host, access restrictions,
> etc etc)
> 
> Particular Conference Location and Information Discovery:
> =================================================
> 
>         a) Again, RFC 3087 helps in part with this
>         b) So does SRV records for conference locators
>         c) draft-ietf-sipping-cc-framework-01.txt also discusses locating
> servers in it
> 
>         not yet addressed:
>         -----------------------------
>         a) No specific drafts on conference-capability-discovery
> (conference-package draft) seems to provide packages for user
>             status in a conference, not capabilities of a conference
> server in genera (eg, type of models it can host, access restrictions, etc
> etc)
>         b) Conference state - again, conference-package seems to define
> schemas where one user can discover conference state of another
>             user or all users in the conference. But does this address
> CFND-3 which talks about the state of the "conference" and not of specific
> user?
> 
>         [ Actually  CFND-2 and CAPD-3 seem similar requirements ]
> 
> Basic Conferencing Requirements
> =============================
>         a) I would think most of these would be met by call flow documents
> that base flows on how other requirements
>         in other sections of the draft are implememted.
> 
>         b) join-and-fork which addressed this space has been deleted - I
> assume the design team is soon going
>             to belt out new docs. (slurp ! slurp ! :-p )
> 
>         c) draft-ietf-sipping-cc-framework-01.txt   addresses call flows
> for some of these requirements
>         d) draft-...-conferencing-models-01 also lists various scenarios
> 
> 
>         However, certain procedures that need undertstanding are:
> 
>         a.1) DOUT-1: A means MUST be defined for a conference host to
> invite a User Agent to one of its active conferences
>                 Question: A wants focus to invite X in a call. focus will
> invite X only if it is an authenticated user. But focus needs
>                to send an INVITE (not the other way around). How does one
> address this ?
> 
> Conference Member Privacy
> =========================
>         a) Is this kind of privacy better covered in the XML schema of
> conference-state of user agents ? In which case
>              conference-package and optionally dialog-package can be
> extended ?
>         b) if not above, can this be handled in any way by "sip" privacy
> drafts ? [ havent thought abt this - its a wild shot ]
> 
> Conference State Dissemination
> ===========================
>         a) draft-conference-package
>         Open Issue:
>         a) I would assume the above draft would also cover schemas for
> notification of join/leave a conference ? [ does it already - i did
>         not find it in my first read ]
> 
> On-Demand  Dissemination
> ==========================
>         a) Again, conference-package seems to be the only draft in this
> space.  I would expect this draft be extended
>         or new derivates be written to cater to all the ODD requirements.
> Is this assumption correct ?
> 
> Miscellaneous Requirements
> ============================
> a) Some of these may well be implementation details (like failover on one
> server breaking down etc).
> b) Some others like transfer etc. may again happen by basic primitives
> explained in a call-flows draft.
> c) I am not sure if any specific drafts address this.
> 
> 
> Access Control List
> ==================
> a) Not aware of any existing drafts in this space yet
> 
> Floor Control
> ============
> 
> a) Only draft I know of in this space is wu-sipping-floor-control-01
> (which expires this month)
> Open Issue:
> a) What other work if any is ongoing for these reqts ?
> 
> Beyond Managing a single SIP Conference
> =====================================
> a) Again, only conferencing-models-01.txt touches on this briefly. No
> other drafts that I know of
> b) [personal: I dont care much abt this right now :-^ ]
> 
> 
> regds
> Arjun
> 
> --
> Arjun Roychowdhury @ Hughes Software Systems
> 11717 Exploration Lane, Germantown MD 20876
> (O): 301-212-7860        (M): 240-997-0066
> _______________________________________________
> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments of core SIP

---

From: Orit Levin <[email-masked]>
Date: Fri, 18 Oct 2002 18:12:43 -0400

Hi Arjun!

BR,
Orit Levin
Chief Architect
RADVISION
Tel: +1.201.6896330