Subject: Re: [Sipping] Q.931 and SIP-T

From: [email-masked]
Date: Tue, 29 Oct 2002 15:03:12 +0100

Hello Juan

ETSI SPAN 13 has started initial work on Interworking DSS1-SIP, where the
IW takes place in a
Softswitch (MGC); tunneling of DSS1 within SIP-T is currently not foreseen.

Regards

________________________________________________________________________
Peter Christos Kotar
Voice Networking Division, Dept. VS/EAC2
Alcatel SEL AG
Lorenzstrasse 10
70435 Stuttgart
Phone: (+49) 711 821 41170
Fax: (+49) 711 821 40211
Email: [email-masked]

Juan Luis Esteban <[email-masked]>@ietf.org on 10/29/2002 02:38:17 PM

Sent by:    [email-masked]

To:    "[email-masked]'" <[email-masked]>
cc:
Subject:    [Sipping] Q.931 and SIP-T

Is there any work in progress regarding Q.931-SIP Interworking ?.
Since ISUP-SIP interworking has been addressed, is there any reason for
which QSIG and DSS1 interworking has not been addressed ?.
I would think that since Q.931 is an asymmetrical protocol, its
interworking
with SIP is not as straightforward as ISUP. Nevertheless, mapping at the
message level is still possible. At a first glance, messages such as Call
proceeding and Connect Ack could be generated locally, it would be
unnecessary to encapsulate them in SIP. Different behaviours should be also
taken into account depending on whether the PRI Gateway is User or
Network...

In practice, Tier 2 and 3 service providers have been deploying low density
PRI gateways where possible due to lower costs than SS7 Gateways, even in
associated signalling scenarios.

Thanks,

Juan Luis Esteban
Capcom International

[email-masked]
Tel.: +34 91 217 00 04
Fax: +34 91 217 00 19

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Tue, 29 Oct 2002 10:42:19 -0500

I heard rumours there might be a proposal to work on this at ITU-T Study
Group 11.  I haven't had time yet to check the contributions to next month's
meeting to see if this is true.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> Sent: Tuesday, October 29, 2002 9:03 AM
> To: [email-masked]
> Subject: Re: [Sipping] Q.931 and SIP-T
> 
> 
> Hello Juan
> 
> ETSI SPAN 13 has started initial work on Interworking 
> DSS1-SIP, where the IW takes place in a Softswitch (MGC); 
> tunneling of DSS1 within SIP-T is currently not foreseen.
> 
> Regards
> 
> 
> Is there any work in progress regarding Q.931-SIP 
> Interworking ?. Since ISUP-SIP interworking has been 
> addressed, is there any reason for which QSIG and DSS1 
> interworking has not been addressed ?. I would think that 
> since Q.931 is an asymmetrical protocol, its interworking 
> with SIP is not as straightforward as ISUP. Nevertheless, 
> mapping at the message level is still possible. At a first 
> glance, messages such as Call proceeding and Connect Ack 
> could be generated locally, it would be unnecessary to 
> encapsulate them in SIP. Different behaviours should be also 
> taken into account depending on whether the PRI Gateway is 
> User or Network...
> 
> In practice, Tier 2 and 3 service providers have been 
> deploying low density PRI gateways where possible due to 
> lower costs than SS7 Gateways, even in associated signalling 
> scenarios.
> 
> Thanks,
> 
> 
> 
> 
> 
> 
> Juan Luis Esteban
> Capcom International
> 
> [email-masked]
> Tel.: +34 91 217 00 04
> Fax: +34 91 217 00 19
> 
> Use [email-masked] for questions on current 
> sip Use [email-masked] for new developments of core SIP
> 
> 
> 
> Use [email-masked] for questions on current 
> sip Use [email-masked] for new developments of core SIP
>

---

From: "Peterson, Jon" <[email-masked]>
Date: Tue, 29 Oct 2002 13:55:12 -0500

First of all, there is a QSIG-SIP mapping document currently circulating:

http://www.ietf.org/internet-drafts/draft-elwell-sipping-qsig2sip-03.txt

In Yokohama, I believe there was some consensus that this QSIG work should
continue.

Secondly, we have frequently discussed undertaking a Q.931-SIP mapping
document here in SIPPING. There hasn't been any real consensus that we need
such a document, but there is a fairly significant community of interest
(largely vendors of PRI gateways). I know I have an issues list related to
Q.931-SIP mapping, but to date I haven't had the cycles to work towards such
a draft personally.

Jon Peterson
NeuStar, Inc.

-----Original Message-----
From: Juan Luis Esteban [mailto:[email-masked]]
Sent: Tuesday, October 29, 2002 5:38 AM
To: [email-masked]'
Subject: [Sipping] Q.931 and SIP-T

I would think that since Q.931 is an asymmetrical protocol, its interworking

Thanks,

Juan Luis Esteban
Capcom International

[email-masked]
Tel.: +34 91 217 00 04
Fax: +34 91 217 00 19