Subject: [Sipping] Re: [Sip] Transport of conf control cmds using SIP msgs

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 17 Oct 2002 00:59:13 -0400

This is a sipping issue.

The conferencing design team is working on requirements and proposed 
protocols for conference policy. However, the general agreement is that 
sip is not suitable for this function. As specified in:
http://www.ietf.org/internet-drafts/draft-ietf-sip-guidelines-05.txt

using sip to do something just because you want to reduce a protocol 
count is not a valid reason to use sip.

-Jonathan R.

Kostas Katrinis wrote:
>     Hello to all,
> 
> actually I wanted to ask whether there is a specific guideline about 
> using a specific type of SIP message to carry conference control 
> commands (ex. SOAP payload), in case someone prefers to use an 
> "all-SIPP" solution instead of using HTTP requests for carrying the 
> mentioned commands.
> (In a similar manner is the use of SUBSCRIBE/NOTIFY msgs for conference 
> event propagation prescribed)
> 
> Thanks in advance,
> Kostas Katrinis
> ETH Zurich
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> 

-- 
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Kostas Katrinis <[email-masked]>
Date: Thu, 17 Oct 2002 09:23:48 +0200

I appreciate your answer.
However, according to draft-wu-sipping-floor-control-00.txt (floor 
control) commands may be transfered using SIP msgs (a simple call flow 
example is also given).
But somehow it is still not clear to me, why to use SIP to communicate 
just conference control events (according to the mentioned draft), but 
not commands.
Could you give me some clue, in what direction the conf. design team is 
working regarding this issue?

Kostas Katrinis

Jonathan Rosenberg wrote:
>> (In a similar manner is the use of SUBSCRIBE/NOTIFY msgs for 
>> conference event propagation prescribed)
>>
>> Thanks in advance,
>> Kostas Katrinis
>> ETH Zurich
>>