Subject: RE: [Sipping] Re: [Iptel] Re: [Sip] TEL-URL local numbers

From: "Rosen, Brian" <[email-masked]>
Date: Mon, 27 Jan 2003 14:12:44 -0500

This is actually an interesting problem.
In my environment, if I dial 304-3859, then I would
show my FROM as 300-7826, because if I'm calling within
my local network, then my network number is the best way
to call me back.  If I call the same fellow at
703-455-7826, then I might show my +17247426826 as
my From:

If I had the dialing plan in the UA, I could do this.
If the expansion is in a proxy, it can't modify From:.

I don't think we do anything about it.  It's more argument
why dial plan expansion in the UA is a better way to go.

Brian

> -----Original Message-----
> From: Paul Kyzivat [mailto:[email-masked]]
> Sent: Friday, January 24, 2003 6:42 PM
> To: Henning Schulzrinne
> Cc: Rosen, Brian; 'Christer Holmberg'; [email-masked]'; Conroy,
> Lawrence (SMTP); [email-masked]'
> Subject: Re: [Sipping] Re: [Iptel] Re: [Sip] TEL-URL local numbers
> 
> 
> Henning Schulzrinne wrote:
> > There seem to be at least three scenarios:
> > 
> > (1) The end system has a dialplan, learned automatically, 
> and can easily 
> > translate dialed digits into an E.164 number. ...  It also 
> allows inspection
> > - a device can easily display what will happen to a digit 
> string. If the 
> > proxy does translation, you only find out when what you 
> thought was a 
> > local extension gets translated to dial-a-prayer. (Or, 
> worse, doesn't 
> > get answered at all, in which case one may not suspect 
> anything amiss.)
> 
> There is a solution to this problem when using proxy expansion: The 
> proxy can do the expansion and then return the result as a redirect 
> (probably 301). The phone will then retry, but can display 
> the new number.
> 
> But this doesn't work for From. The calling phone had better know an 
> expanded form of its own address.
> 
> 	Paul
> 
_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: [email-masked]
Date: Mon, 27 Jan 2003 21:48:43 +0200

> 703-455-7826, then I might show my +17247426826 as

no matter how you call, it makes sense to always have a globally unique
uri in the from field.

-- juha

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 27 Jan 2003 14:49:29 -0500

Brian,

I think it is a *bad* idea for the UAC to be trying to figure out the 
best representation of the From address based on the To address. There 
are all sorts of cases where this does the wrong thing.

It makes way more sense for the UAC to represent the From address with 
maximal information, in the most universally understood form possible, 
and for each UAS to then transform the From into the form that is "best" 
for its user. (With the possibility of configuring the definition of 
"best".)

So I might dial a coworker using "1234", my From address is populated 
with my global address tel:+197855554321. My coworker's phone then might 
"reverse engineer" the dial plan to realize that number could be dialed 
as "4321", and so displays the number that way.

If my number wasn't globally reachable, my From address could be 
tel:4321;phone-context=lowell.cisco.com. Once again, the recipients 
phone could reverse engineer the dial plan and still show the number as 
just 4321.

If somebody called in from outside (From:tel:+12125554321), then the 
reverse engineering of the dial plan might result in it being displayed 
as: 9-1-212-555-4321.

Reverse engineering the dial plan imposes some new requirements. For 
one, it can't easily be done in the proxy, because there is no good way 
to convey it.

	Paul

>>From: Paul Kyzivat [mailto:[email-masked]]
[snip]