Subject: RE: [Sipping] URIs for Gateways

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Fri, 3 Jan 2003 16:20:26 -0000

Network asserted identity (RFC 3325) is the real network asserted identity. It is a P header not because it is preliminary, but because the whole idea of network assertion is not generally applicable to all SIP architectures. For RFC 3325 a trust domain needs to exist between proxies that use the P-Asserted-Identity in order to guarantee the privacy, this does not exist in all SIP networks. In does in 3GPP and therefore 3GPP are using RFC 3325.

If you want to let the 1et outbound proxy assert identity on your behalf then use RFC 3325. If you want to let application servers with whom you have a secure relationship assert your identity, then use Jon Petersons drafts, when they eventually become RFCs. 

One is not a short term solution for the other.

Keith

Keith Drage
Lucent Technologies
Tel: +44 1793 776249
Email: [email-masked] 

> -----Original Message-----
> From: Rosen, Brian [mailto:[email-masked]]
> Sent: 02 January 2003 20:49
> To: 'Henning Schulzrinne'
> Cc: [email-masked]'
> Subject: RE: [Sipping] URIs for Gateways
> 
> 
> Yeah, I actually thought of just allowing a display name in the
> Request URI and using that, but it seems so foolish to make a change,
> and have that change not be exactly what we needed.
> 
> We could use NAI.  I suppose we could use a P-Asserted-Identity
> with a tel URI:  
> P-Asserted-Identity tel:+17247426826
> 
> What do we do when the "real" NAI happens?
> 
> Brian
> 
> > -----Original Message-----
> > From: Henning Schulzrinne [mailto:[email-masked]]
> > Sent: Thursday, January 02, 2003 3:10 PM
> > To: Rosen, Brian
> > Cc: [email-masked]'
> > Subject: Re: [Sipping] URIs for Gateways
> > 
> > 
> > > I'd like to get a new header for the calling party number on
> > > an outbound call.  That way, the translator can be a proxy and
> > > add the header.  I'd recommend that gateways allow the number
> > > to be in the From.   
> > 
> > Generalized, you want something like the Request-URI that can be 
> > modified or inserted. How about the NAI stuff?
> > 
> _______________________________________________
> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments of core SIP
> 
_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Sunderajan Selvaraj <[email-masked]>
Date: Mon, 06 Jan 2003 10:50:31 +0530