Subject: RE: [Sipping] URIs for Gateways

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 7 Jan 2003 08:41:22 -0500

It may be that we want to use P-Asserted-Identity for this
purpose.  I currently think it's a pretty good idea, but:
	* It doesn't really meet the definition in RFC3325
	* The "P" bothers me if this is a permanent solution
Brian

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Tuesday, January 07, 2003 2:47 AM
> To: Rosen, Brian
> Cc: 'Peterson, Jon'; 'Drage, Keith (Keith)'; 'Henning Schulzrinne';
> [email-masked]'
> Subject: RE: [Sipping] URIs for Gateways
> 
> 
> Rosen, Brian writes:
> 
>  > I do think there is a problem which this whole thread talks about.
>  > The basic reality is that many users of SIP UAs will have two
>  > identities - a SIP URI and a telephone number.  It may be
>  > necessary to assert both identities in one call, because the
>  > originator of the call does not know which identity may be
>  > needed.  There is no current header to do this.  I think that 
>  > it is advantageous to have a proxy be able to assert the phone 
>  > number.  Otherwise EVERY UA will have to be able to understand 
>  > that two identities are possible, know them both by some 
>  > unspecified means, and assert them in every call on every UA.  
>  > This seems unreasonable.  I'm not sure that there is a reason
>  > to have both identities validated, but there could be.
> 
> if your proxy receives a call from sip:[email-masked] who has also been
> allocated a phone number +1234567890, why can't is add an asserted
> identity header containing sip:[email-masked] to the call in case
> the call is bound to pstn?  why would you need yet another header for
> that purpose?
> 
> -- juha
> 
_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: [email-masked]
Date: Tue, 7 Jan 2003 15:49:21 +0200

> 	* The "P" bothers me if this is a permanent solution

brian,

you can take a look at the archives and see that i was strongly against
in making asserted-identity a p header for the reason that as long as it
is a p header, sip/ss7 gw vendors are not likely to support in their
gateways as a means to obtain the asserted pstn number of the calling
party.  so in practice the header became a 3gpp only thing.

-- juha