Subject: RE: [Sipping] URIs for Gateways

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 9 Jan 2003 10:05:42 -0500

I don't think this works if I'm understanding you

I have a tel uri like tel:+14125551212.  I translate that
to sip:[email-masked]; user=phone
Where does the port number go?

Brian

> -----Original Message-----
> From: Cullen Jennings [mailto:[email-masked]]
> Sent: Thursday, January 09, 2003 12:30 AM
> To: 'Paul Kyzivat'; 'Rosen, Brian'
> Cc: [email-masked]
> Subject: RE: [Sipping] URIs for Gateways
> 
> 
> 
> The port names a specific resource on the GW (similar to a 
> trunk group)
> so if it is in a SIP URL, I think it should be in the user 
> portion. This
> matches up perfectly with just defining it in the tel URL then let the
> normal tel to sip translation rules apply to how looks in a SIP URL.
> 
> 
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]] 
> > On Behalf Of Paul Kyzivat
> > Sent: Wednesday, January 08, 2003 12:38 PM
> > To: Rosen, Brian
> > Cc: [email-masked]'
> > Subject: Re: [Sipping] URIs for Gateways
> > 
> > 
> > Brian,
> > 
> > A few initial comments. More later when I get time to think 
> about it.
> > 
> > - I'm not sure of the advisability of adding caller name to 
> > the tel uri. 
> > If  you do it, I don't like that way. Would prefer a tel: 
> > parameter, as in
> >       tel:+14125551212;caller-name="Alice Toklas"
> > 
> > - I don't think the port should be a sip uri parameter. It is very 
> > telephony oriented, so I think it is better as a tel: uri parameter.
> > 
> > 	Paul
> > 
> > Rosen, Brian wrote:
> > > After all of this, I propose the following:
> > > 
> > > 1. We add the possibility of a callerId string to a tel uri:
> > >    telephone-uri = "tel:" [callerIdName LWS] subscriber
> > >    callerIdName = quoted-string
> > > 
> > > 2. Gateways accept or send sip uris of the form:
> > >    sip:"Alice Toklas" [email-masked]; user=phone; 
> > > port=3 or tel uris of the form:
> > >    tel:"Alice Toklas" +14125551212; port=3
> > > or "ordinary" sip uri's with extra information in a 
> separate header
> > > of the form:
> > >    <header> +14125551212; port=3
> > > 
> > > where <header> could be "P-Asserted-Identity", or it 
> could be a new 
> > > header we define for the purpose.
> > > 
> > > Then, we have the following possibilities:
> > > 
> > > SIP device to gateway (outgoing) call
> > >    To a phone number
> > >         use the phone number in the Request-URI & To:, probably
> > >         in a tel URI, or maybe phonenumber@localdomain; user=phone
> > > 
> > >         use normal sip URI in From:
> > >      
> > >         If a translator is available, it may assert the 
> phone number
> > >         for the identity in the From: using <header>
> > > 
> > >         proxy may rewrite the Request-URI in the form of
> > >         sip: phone@gateway;user=phone;port=portnum
> > >    
> > >    To a sip URI
> > >         use the sip uri in the Request-URI and To:
> > >         use normal sip URI in From:
> > > 
> > >         proxy rewrites Request-URI, due to forwarding behavior,
> > >         ENUM lookup, etc, resulting in a tel URI or a 
> user=phone sip
> > >         uri.  If necessary, a local incoming proxy can 
> rewrite it to
> > >         add the port parameter to the Request-URI based 
> on the From:
> > >     
> > >         If a translator is available, it may assert the 
> phone number
> > >         for the identity in the From: using the <header>
> > > 
> > > Gateway to SIP device (incoming call)
> > >    With mapping
> > >         use the mapped uri in the Request-URI & To:
> > >           
> > >         (optionally) supply called number using <header>
> > >         This might be needed when multiple called numbers
> > >         map to the same uri.
> > >         
> > >         use sip:"callerId" phone@gateway; port=portnum or
> > >         a tel: uri in From:
> > > 
> > >    Without mapping
> > >         use a provisioned (per port) URI, a tel uri with 
> the called 
> > >         number, or a sip uri with calledNumber@localdomain; 
> > user=phone
> > >         in the Request-URI & To:.  Gateways should support all 3,
> > >         choice should be made by provisioning.
> > > 
> > >         use sip:"callerId" phone@gateway; port=portnum or tel
> > >         uri in From:
> > > 
> > >         proxy will rewrite the Request-URI with the 
> correct sip URI
> > >         associated with the called number
> > >   
> > > Brian
> > > _______________________________________________
> > > Sipping mailing list  
> https://www1.ietf.org/mailman/listinfo/sipping
> > > This list is for NEW development of the application of SIP Use 
> > > [email-masked] for questions on current sip Use 
> > > [email-masked] for new developments of core SIP
> > > 
> > 
> > _______________________________________________
> > Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> > This list is for NEW development of the application of SIP
> > Use [email-masked] for questions on current 
> > sip Use [email-masked] for new developments of core SIP
> > 
> 
_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 09 Jan 2003 17:10:37 +0200

Hi,

> Where does the port number go?

Into the user part. The URI would look like:

sip:14125551212;port=[email-masked];user=phone

Regards,

Christer Holmberg
Ericsson Finland