Subject: RE: [Sipping] URIs for Gateways

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Fri, 3 Jan 2003 16:20:28 -0000

See inline

Keith Drage
Lucent Technologies
Tel: +44 1793 776249
Email: [email-masked] 

> -----Original Message-----
> From: Paul Kyzivat [mailto:[email-masked]]
> Sent: 02 January 2003 21:34
> To: Rosen, Brian
> Cc: 'Jonathan Rosenberg'; [email-masked]'
> Subject: Re: [Sipping] URIs for Gateways
> 
> 
> Rosen, Brian wrote:
> > 
> > I'm not really happy with the display name trick, but there are
> > lots and lots of gateways that do this.  It works because, as we
> > know, To: and From: are never modified.  It's up to normal
> > SIP routing to get the INVITE to the right gateway.  When 
> it gets there,
> > the display name on the To: should be intact.  
> 
> You miss the point. You may have called sip:alice. That call is then 
> proxied to a pstn number "1234567890" sip:port@gateway. The 
> proxy can't 
> change the To address to put the phone number in. It can't even solve 
> the problem with a redirect, because your UAC will probably 
> just change 
> the request id and reissue the invite with the old To value.
> 
> > 
> > However, overloading the display name with the number to dial is
> > not a great idea, even if a lot of stuff in the field does it.
> > 
> > In a prior message, I did agree that P-Asserted-Identity with
> > a tel URI could be used for a proxy asserting the translation, 
> > but not the "real" NAI stuff (Jon's signed headers).  Do you
> > want a BCP to say that P-Asserted-Identity is what translators
> > use to get the phone number in the message? 
> 
> What you are suggesting seems backward. The 
> P-Asserted-Identity is only 
> useful for the calling number, not the called number. Assuming the 
> gateway can trust the callerid info it gets from the PSTN, it 
> should be 
> inserting a P-Asserted-Identity header with that value for inbound 
> calls. And it ought to be using it to generate callerid on outbound 
> calls. The kind of translator you describe seems useless for this.

Why is the P-Asserted-Identity only useful for calling number. It is perfectly valid in responses to INVITE. Obviously you still need to meet the requirements of having a first proxy to assert the identity, but that does exist in certain architectures, e.g. 3GPP, and the mechanisms to identify and include such a proxy are standards track items.

> 
> I think the best choice right now for outbound calls is a 
> tel: uri. You 
> can pack all sorts of info into it. This can also be represented as a 
> sip uri with user=phone. If you want to use a translator, start by 
> generating a tel: uri, then route it to the translator, which 
> can turn 
> it into a sip uri with user=phone, using the domain name to 
> select the 
> actual gateway. It can also fill in extra parameters (defined in the 
> tel: uri) in the user part of the sip uri to help the gateway do the 
> right thing.
> 
>  > The "P-" is a
> > problem.  P-Asserted-Identity should go away once the
> > signed header idea is fully baked, but this problem stays for
> > a very long time.
> 
> I don't think the signed header is a replacement for the 
> P-Asserted-Identity. Which to use depends on whether you have trusted 
> servers in the network that are responsible for some aspects of 
> identity. As long as you are interoperating with the PSTN this will 
> probably remain as a requirement.

I have commented on this in another mail. I support Paul on this. They are two different solutions and their usage depends on the network architecture that you are working with.

> 
> 	Paul
> 
> _______________________________________________
> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments of core SIP
> 
_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Paul Kyzivat <[email-masked]>
Date: Fri, 03 Jan 2003 13:51:37 -0500

Drage, Keith (Keith) wrote:
> Why is the P-Asserted-Identity only useful for calling number.
> It is perfectly valid in responses to INVITE.
> Obviously you still need to meet the requirements of having a
> first proxy to assert the identity, but that does exist in certain
> architectures, e.g. 3GPP, and the mechanisms to identify and
> include such a proxy are standards track items.

Sorry - I wasn't specific enough. It seemed that Brian was trying to use 
P-Asserted-Identity in a *request* to identify the *called* number. But 
NAI in the request can only identify who is calling. This is what seemed 
backward to me.

	Paul