Subject: RE: [Sipping] Re: Comments on revised 'sos' draft

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Mon, 6 Jan 2003 15:46:03 -0000

See below

Keith Drage
Lucent Technologies
Tel: +44 1793 776249
Email: [email-masked] 

> -----Original Message-----
> From: Henning Schulzrinne [mailto:[email-masked]]
> Sent: 04 January 2003 18:12
> To: Mills, Duncan, D, CND Tech Dev, VF UK
> Cc: Drage, Keith (Keith); [email-masked]
> Subject: Re: [Sipping] Re: Comments on revised 'sos' draft
> 
> 
> Mills, Duncan, D, CND Tech Dev, VF UK wrote:
> > In section 5 of the draft - 'Request Routing':
> > 
> > You talk about the need for a UA to be able to provide information
> > about its location.  You mention providing exact information such as
> > longitude, latitude and altitude.  You also mention possibilities of
> > providing 'Agent-Circuit-ID' and 'Remote-ID', as per RFC 3046.
> > 
> > Have you considered also mentioning the use of the
> > p-access-network-info header for this purpose?  (see
> > draft-garcia-sipping-3gpp-p-headers-02 which is in the RFC editors
> > queue).
> > 
> > The p-access-network-info header enables you to specify an
> > access-type and an access-info field in cases where the UA is aware
> > of the access network.
> 
> This seems potentially useful, but somewhat in the wrong 
> direction and 
> at the wrong layer. At least currently, the information 
> appears to be a 
> list of physical layers, as in
> 
> "IEEE-802.11a" / "IEEE-802.11b" /
> "3GPP-GERAN" / "3GPP-UTRAN-FDD" /
> "3GPP-UTRAN-TDD" /
> "3GPP-CDMA2000"
> 
> and is provided by the UA. This type of information doesn't 
> seem to help 
> much in determining the local emergency number, a local 
> suitable gateway 
> or other emergency information. How would you envision extending this 
> information and how would the UA find out this information?

The relevant parts of the information is (from the 3GPP P-headers i-d):

cgi-3gpp               = "cgi-3gpp" EQUAL
                               (token / quoted-string)
utran-cell-id-3gpp     = "utran-cell-id-3gpp" EQUAL
                               (token / quoted-string)

The values for "cgi-3gpp" and "utran-cell-id-3gpp"
   are defined in 3GPP TS 24.229 [15].

3GPP TS 24.229 then defines:

If the access type field is equal to "3GPP-UTRAN-FDD", "3GPP-UTRAN-TDD" or "3GPP-CDMA2000" the access info field shall contain a value for "utran-cell-id-3gpp" parameter. This value shall be made up of a concatenation of the MCC, MNC, LAC (as described in 3GPP TS 23.003) and the UMTS Cell Identity (as described in 3GPP TS 25.331), obtained from lower layers of the UE, and is coded as a text string as follows:
Starting with the most significant bit, MCC (3 digits), MNC (2 or 3 digits depending on MCC value), LAC (fixed length code of 16 bits using full hexadecimal representation) and UMTS Cell Identity (fixed length code of 28 bits).

A similar definition exists for the GERAN type of access.

Other access mechanisms would be expected to make their own definitions of location information, as the structure of the data in this header is specific to the access mechanism, i.e. it has not been converted into a standard geodetic specification.

> 
> > 
> > In 3GPP circles this helps (as Keith said) the outbound proxy to try
> > and figure out if the 'dialled digits' are that of a local emergency
> > centre or not...
> > 
> > Best Regards,
> > 
> > Duncan
> 
_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Henning Schulzrinne <[email-masked]>
Date: Mon, 06 Jan 2003 14:23:13 -0500

> Other access mechanisms would be expected to make their own definitions of location information, as the structure of the data in this header is specific to the access mechanism, i.e. it has not bee…

I've added a reference to this. I suppose for an 802.11 wireless base 
station, the basestation MAC address would be the equivalent. Any 
interest in defining this, given that the draft already lists 
IEEE-802.11a and IEEE-802.11b as access-types?