Subject: RE: [Sipping] Comments on sos draft -0

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Thu, 9 Jan 2003 16:43:04 -0000

Is the number 3333 on an internal network an emergency number in the terms of the sos draft?

The way I read the defined sos url is that it only reachs public emergency service centres. therefore the scope of the document with regard to tel urls is to define the format of tel urls to reach those same centres. Have I misunderstood the scope? We possible need to extend Hennings proposed scope to make this clear.

I do think we need to delve further into the subject of context, possible in association with additional clarifications in the rfc2806bis draft. I note that the text there has a special case dealing with 800 numbers, viz:
   "National freephone numbers do not need a context, even though they     |
   are not necessarily reachable from outside a particular country code   |
   or numbering plan. Recall that "tel" URIs are identifiers; it is       |
   sufficient that a global number is unique, but it is not required      |
   that it be reachable from everywhere." 

It therefore seems to me that we could say the same about emergency numbers that are globally unique. 

For those emergency numbers that are not globally unique (and we probably need to include 118 and 119 in this list), then looking at the existing RFC 2806 or at the bis, they probably do need a context. What worries me is that the user sticks in an inappropriate context, i.e. the one he uses for all his local calls, rather than one used for national calls. Such inappropriate usage would cause calls to fail. Would a special context used only for local service numbers be appropriate here? My thinking here is that if we give the user something real to code, then he will not be tempted to code something inappropriate.                                  

Keith Drage
Lucent Technologies
Tel: +44 1793 776249
Email: [email-masked] 

> -----Original Message-----
> From: Tom-PT Taylor [mailto:[email-masked]]
> Sent: 08 January 2003 14:54
> To: 'Drage, Keith (Keith)'; 'Henning Schulzrinne'; [email-masked]'
> Subject: RE: [Sipping] Comments on sos draft -0
> 
> 
> A comment on one point only.
> 
> > -----Original Message-----
> > From: Drage, Keith (Keith) [mailto:[email-masked]] 
> > Sent: Monday, January 06, 2003 10:56 AM
> > To: 'Henning Schulzrinne'; [email-masked]'
> > Subject: [Sipping] Comments on sos draft -0
> > 
> [snip]
> > 
> > 6)	section 3 (Emergency URI), 3rd paragraph: use of 
> > "phone-context". Is it appropriate to use phone context in 
> > any emergency call. In 3GPP, any use of one of the numbers 
> > from the list stored in the phone is an emergency call, no 
> > matter where it originates from. If my understanding of 
> > phone-context is correct, it SHOULD NOT be used, as it could 
> > result in failure to deliver an emergency call.
> > 
> [PTT] My company has a scheme where "3333" on the internal 
> network reaches
> an internal emergency response centre who then direct the 
> call externally if
> required.  This was introduced to ensure that emergency vehicles are
> directed to the right building and building entrance.  It might be
> conceivable under such an arrangement to have a phone-context in the
> original Request-URI.
> 
> [snip]
> > 
> 
_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Henning Schulzrinne <[email-masked]>
Date: Fri, 10 Jan 2003 15:30:46 -0500

Drage, Keith (Keith) wrote:
 > The way I read the defined sos url is that it only reachs public
 > emergency service centres. therefore the scope of the document with
 > regard to tel urls is to define the format of tel urls to reach those
 > same centres. Have I misunderstood the scope? We possible need to
 > extend Hennings proposed scope to make this clear.

Interesting question. I think the boundaries are kind of fuzzy. For 
example, most US universities have a campus police department; some even 
have a campus ambulance and fire department (UMass Amherst did, for 
example). If they are a state university, they are even public 
institutions. In some cases, they have separate identifiers from the 
public 911 system (99 on the Columbia campus), but they are otherwise 
indistinguishable from an ECC.

One solution might be to allow this as a qualification to 'sos', as in 
'sos.internal' or 'sos.private'.

 >
 > I do think we need to delve further into the subject of context,
 > possible in association with additional clarifications in the
 > rfc2806bis draft.

Agreed; in general, 'service numbers' are one of the major open issues 
for that draft.

 > numbers that are globally unique.

I assume, globally unique here means that they are not assigned for 
another purpose (extensions don't count). For 800#, we agreed after a 
long debate that the assignment system guarantees that the same number 
will not be assigned to two logically separate entities. It would be 
nice if we could get all national regulators to agree that assigning 911 
to directory services would be a really dumb idea. I suspect that with 
3GPP standardization, that this would be extremely unlikely. We know 
that none of the emergency numbers on the list could be assigned in the 
US since these are valid area codes, not N11 codes.

 >
 > For those emergency numbers that are not globally unique (and we
 > probably need to include 118 and 119 in this list), then looking at
 > the existing RFC 2806 or at the bis, they probably do need a context.
 > What worries me is that the user sticks in an inappropriate context,
 > i.e. the one he uses for all his local calls, rather than one used
 > for national calls. Such inappropriate usage would cause calls to
 > fail. Would a special context used only for local service numbers be
 > appropriate here? My thinking here is that if we give the user
 > something real to code, then he will not be tempted to code something
 > inappropriate.

The problem is that 118 can mean two different things. I don't see how a 
'use whatever local context applies here' would help with distinguishing

118 - I mean emergency service
and
118 - I mean (Finnish) directory services

If we effectively standardize dial strings, it seems unnecessary to have 
the UA propagate the original number as a tel URI.

One possible algorithm:

- If digits dialed = one of the emergency dial strings (preconfigured or 
locally learned) --> generate 'sos' request

- Otherwise, make local dial-string translation translate this into one of:

. tel:+something global string
. tel:digits;phone-context=local-context

where the translation would include something like
9### -> tel:number;phone-context=+1
for national service numbers.

This could all be expressed through the same set of regexps, as in
911 -> sip:[email-masked]
112 -> sip:[email-masked]
3333 -> sip:[email-masked]

(Being offline, I don't have my Megaco dial string reference handy.)

Thus, maybe we can unify the local advertisement of dial strings with 
the local advertisement of emergency numbers. By virtue of the 
translation to 'sos', the UA can readily recognize that this is an 
emergency number.

Henning