Subject: [Sipping] conf: comments on draft-wu-sipping-floor-control-04

From: "Eric Burger" <[email-masked]>
Date: Thu, 20 Mar 2003 14:43:52 -0500

In general, this draft has gotten really good.

I have a general comment about time.  There are a number of operations based on the client submitting a timestamp.  I would offer that client timestamps are irrelevant.  If I want to always jump the queue when I make a request, I will quickly learn to set my clock behind 10 minutes to make sure I'm always at the top of the queue.  My suggestion would be that all timestamps are generated by the server.  Yes, it means that if someone is on a slow link, their request might get pushed behind someone on a fast link.  I would simply state that and move on.

In the same vein, expirations should be delta times, not absolute stop times.

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Henning Schulzrinne <[email-masked]>
Date: Thu, 20 Mar 2003 16:01:00 -0500

Good suggestions; we'll incorporate those.

Eric Burger wrote:
> I have a general comment about time.  There are a number of
> operations based on the client submitting a timestamp.  I would offer
> that client timestamps are irrelevant.  If I want to always jump the
> queue when I make a request, I will quickly learn to set my clock
> behind 10 minutes to make sure I'm always at the top of the queue.
> My suggestion would be that all timestamps are generated by the
> server.  Yes, it means that if someone is on a slow link, their
> request might get pushed behind someone on a fast link.  I would
> simply state that and move on.
> 

These probably offer less of an incentive to "cheat", but might as well 
be consistent.

> 
> _______________________________________________ Sipping mailing list
> https://www1.ietf.org/mailman/listinfo/sipping This list is for NEW
> development of the application of SIP Use
> [email-masked] for questions on current sip Use
> [email-masked] for new developments of core SIP