Subject: RE: [Sipping] FW: I-D ACTION:draft-persson-sipping-sip-issues-dual-stack-00.txt

From: [email-masked]
Date: Wed, 19 Mar 2003 05:30:01 +0200

Hi,

A couple of comments to the draft.

First, it seems to omit record-routing. A dual-stack proxy really only provides for IPv6/IPv4 transition if it record-routes and thus assures that all requests after the initial INVITE also transition using the same dual-stack proxy. A dual-stack proxy that record-routes will make sure that the two endpoints never end up with contacts of different IP-versions and thus no way of communicating directly.

Secondly, none of this helps with transitioning of media. That's actually a lot bigger problem.

There are a couple of documents that discuss some transition scenarios for SIP in v6ops:
http://www.ietf.org/internet-drafts/draft-ietf-v6ops-3gpp-cases-02.txt
http://www.ietf.org/internet-drafts/draft-ietf-v6ops-3gpp-analysis-02.txt

Cheers,
Aki

 > -----Original Message-----
 > From: ext [email-masked] [mailto:[email-masked]]
 > Sent: 10 March, 2003 20:34
 > To: [email-masked]
 > Subject: [Sipping] FW: I-D
 > ACTION:draft-persson-sipping-sip-issues-dual-stack-00.txt
 > 
 > 
 > Hi all,
 > 
 > I forward this Internet-draft to the sipping list.
 > It discusses some issues regarding IPv4/IPv6 deployment and 
 > SIP interoperability.
 > Any comments?
 > 
 > Best regards,
 > Håkan Persson
 > 
 > -----Original Message-----
 > From: [email-masked] [mailto:[email-masked]]
 > Sent: den 28 februari 2003 13:26
 > Subject: I-D 
 > ACTION:draft-persson-sipping-sip-issues-dual-stack-00.txt
 > 
 > 
 > A New Internet-Draft is available from the on-line 
 > Internet-Drafts directories.
 > 
 > 
 > 	Title		: SIP Issues in Dual-stack Environments
 > 	Author(s)	: J. Mulahusic, H. Persson
 > 	Filename	: 
 > draft-persson-sipping-sip-issues-dual-stack-00.txt
 > 	Pages		: 9
 > 	Date		: 2003-2-27
 > 	
 > The advent of IPv6 in addition to IPv4 makes hosts and servers dual-
 > stack. SIP communications can be used in both environments but there 
 > is little understanding what will happen if some nodes are 
 > dual-stack 
 > while others, presently the majority, is IPv4 only enabled. This 
 > document describes some scenarios and associated issues when dual-
 > stack users and servers try to communicate with IPv4 only 
 > hosts using 
 > SIP. It is not evident that interoperability is achieved, 
 > and if that 
 > is not the case, this would severely limit the usability of both SIP 
 > and IPv6.
 > 
 > A URL for this Internet-Draft is:
 > http://www.ietf.org/internet-drafts/draft-persson-sipping-sip
-issues-dual-stack-00.txt

To remove yourself from the IETF Announcement list, send a message to 
ietf-announce-request with the word unsubscribe in the body of the message.

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-persson-sipping-sip-issues-dual-stack-00.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-persson-sipping-sip-issues-dual-stack-00.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.
_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 19 Mar 2003 16:41:47 -0500

I have the same comment as Aki.

In the sip space, this is the same problem as tcp/udp conversion, 
sip/sips and so on. In all cases, we are using record routing, with 
differeing URIs on each side, as a means to solve it. I believe that 
will work here.

Now, as Aki says, the harder problem is the media. Alas, I have a 
solution for that. It is ICE:

http://www.ietf.org/internet-drafts/draft-rosenberg-sipping-ice-00.txt

With ICE, a dual stack host would put both its IPv4 and IPv6 addresses 
in the SDP, using the ALT SDP mechanism:

http://www.ietf.org/internet-drafts/draft-camarillo-mmusic-alt-00.txt

Now, this reaches the UAS. According to the ICE draft, the UAS will use 
STUN to verify connectivity over those addresses it can reach. So, if 
its v4 only, it would verify connectivity to v4, and in its answer, list 
its v4 address only. The caller would verify its connectivity to that v4 
address, and then communications take place.

ICE, as written, explicitly prefers v6 addresses over v4. The result is 
that ICE will end up using v6 when both ends are dual stack and both are 
connected to a global v6 network. If, for some reason, both ends are v6 
but the v6 networks are not connected,  ICE will fall back to a global 
v4 address.

I believe ICE will also work with a 6to4 nat, although I have to work 
through the flows to be sure.

I mentioned ICE as being useful for v6 transition during sipping. I 
encourage folks who are interested in this problem to take a look at the 
draft.

Thanks,
Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com