Subject: RE: [Sipping] New version of the early media draft

From: "Mark Watson" <[email-masked]>
Date: Mon, 10 Mar 2003 09:21:41 -0000

And how do I know whether the RTP packets contain actual useful media, or
whether some PSTN gateway is blindly copying silence from the G.711 TDM
stream into RTP ? Is it specified somewhere that PSTN gateways SHALL NOT do
this ?

...Mark

> -----Original Message-----
> From: Gonzalo Camarillo [mailto:[email-masked]]
> Sent: 08 March 2003 09:04
> To: Audet, Francois [SC100:4K02:EXCH]
> Cc: Watson, Mark [MOP:EP10:EXCH]; 'Peterson, Jon'; 'Ejzak, Richard P
> (Richard)'; 'sipping'
> Subject: Re: [Sipping] New version of the early media draft
> 
> 
> Folks,
> 
> I was arguing that any MG will have to implement media 
> arrival detection
> anyway, because of the 200 OK-RTP race condition. Therefore, 
> you MG MUST
> implement media detection. What do you solve with a SIP provisional
> response that tells you that media will be coming? I do not see the
> value there. Could somebody explain the gains we get from 
> that approach?
> 
> And regarding Mark's comment about placing the functionaloty in the
> wrong place, a controller tells (using the media policies developed by
> the conferencing design team) the mixer of a conference which
> participant's voice should sound louder, which one should be 
> discarded,
> etc... you can see this as a media policy issue as well. The 
> MGC sends a
> media policy description to the MG:
> 
> 1) if media comes, play it.
> 
> 2) until media comes, play ringback tone. 
> 
> Gonzalo
>

---

From: Gonzalo Camarillo <[email-masked]>
Date: Mon, 10 Mar 2003 11:37:51 +0200

Mark,

what is the purpose of a gateway telling you to generate local ringback
and sending you silence at the same time?

Gonzalo

Mark Watson wrote:
> 
> And how do I know whether the RTP packets contain actual useful media,
> or whether some PSTN gateway is blindly copying silence from the G.711
> TDM stream into RTP ? Is it specified somewhere that PSTN gateways
> SHALL NOT do this ?
> 
> ...Mark
_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP