Subject: RE: [Sip] Re: [Sipping] New version of the SIP-AAA reqs draft

From: [email-masked]
Date: Mon, 3 Mar 2003 15:28:10 +0200

Can the proxy challenge with all its realms? I really don't believe you can trust the UA supplying the realm it belongs to.

Regards,
Hisham

> -----Original Message-----
> From: ext [email-masked] [mailto:[email-masked]]
> Sent: Monday, March 03, 2003 3:01 PM
> To: Khartabil Hisham (NMP/Helsinki)
> Cc: [email-masked]; [email-masked];
> [email-masked]; [email-masked]; [email-masked];
> [email-masked]
> Subject: RE: [Sip] Re: [Sipping] New version of the SIP-AAA reqs draft
> 
> 
> [email-masked] writes:
> 
>  > A server knows what realm to use for a certain interface (it can do
>  > its own mapping). It cannot rely of a UA telling it the realm.
> 
> what interface?  my sip proxy has a single ethernet ip interface and
> supports simultaneously any number of realms.  
> 
> 
_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Juha Heinanen <[email-masked]>
Date: Mon, 3 Mar 2003 18:56:41 +0200

[email-masked] writes:

 > Can the proxy challenge with all its realms? I really don't believe
 > you can trust the UA supplying the realm it belongs to.

of course it can, since in order for the authentication to succeed, the
user must have a user name and password that is valid in the realm the user
claims to belong to.  check the digest or eap/ttls specs.

-- juha