Subject: [Sipping] Change of IP mid session and Contact header question

From: "Valerie Kenneally" <[email-masked]>
Date: Wed, 5 Mar 2003 11:52:27 -0000

Hi All,

	I'm just trying to understand some SIP session scenarios and various
features.  My question is best explained by example

If a session is established using SIP between two endpoints (in a mobile
network) and during the session one of these endpoints moves such that it is
assigned a new ip, is it a MUST that this endpoint send a RE-INVITE with new
Contact information to the other communicating entity?

Thanks in advance,
Val Kenneally

-------------------Legal  Disclaimer---------------------------------------

The above electronic mail transmission is confidential and intended only for the person to whom it is addressed. Its contents may be protected by legal and/or professional privilege. Should it be received by you in error please contact the sender at the above quoted email address. Any unauthorised form of reproduction of this message is strictly prohibited. The Institute does not guarantee the security of any information electronically transmitted and is not liable if the information contained in this communication is not a proper and complete record of the message as transmitted by the sender nor for any delay in its receipt.

----------------------------------------------------------------------------------------

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Alan Johnston <[email-masked]>
Date: Thu, 06 Mar 2003 15:08:50 -0600

Hi Val,

What Keith describes is true for 3GPP, but not generally true for SIP.

For an RFC 3261 compliant user agent, if a user agent changes its IP 
address during a session for any reason (DHCP renewal failure, VPN failure 
and re-establishment, or due to mobility) and as a result the signaling or 
media packets need to be routed to a different IP address, then re-INVITE 
is the correct mechanism.  It does have the limitation that the routeset 
(set of proxies traversed) can not be changed with a re-INVITE, only the 
Contact URI.  So if a change of IP address requires a new proxy to be 
traversed, instead of a re-INVITE, the user agent should send a new INVITE 
(creating a new dialog with a new route set) with a Replaces header 
identifying the existing session.  A new REGISTER is required in order to 
receive new incoming calls, but has little to do with the current dialog.

This scenario is still likely when an endpoint wishes to switch a call 
between non-cooperating networks, such as a commercial wireless IP network 
and an enterprise or home 802.11 network.

Hope this helps.

Alan Johnston
WorldCom
sip:[email-masked]

At 02:23 PM 3/5/2003 +0000, Drage, Keith (Keith) wrote:
>Apart from some author drafts using SIP for mobility itself, which are not 
>being progressed by the working group, this question is outside IETF 
>itself. IETF has been working with 3GPP and 3GPP2 on how to put SIP into a 
>mobile environment.
>
>In 3GPP release 5, not only does a new IP address necessitate the use of a 
>new INVITE, it also necessitates the use of a new registration as well.
>
>Normally mobile users retain their PDP context to the GGSN when moving, 
>and therefore retain their IP address, and therefore the issue should not 
>arise. Mobility is handled below the SIP layer.
>
>3GPP2 are using mobile IP instead of GPRS, and therefore the same 
>considerations apply.
>
>Keith
>
>Keith Drage
>Lucent Technologies
>Tel: +44 1793 776249
>Email: [email-masked]
>
> > -----Original Message-----
> > From: Valerie Kenneally [mailto:[email-masked]]
> > Sent: 05 March 2003 11:52
> > To: [email-masked]
> > Subject: [Sipping] Change of IP mid session and Contact
> > header question
> >
> >
> > Hi All,
> >
> > -------------------Legal
> > Disclaimer---------------------------------------
> >
> > The above electronic mail transmission is confidential and
> > intended only for the person to whom it is addressed. Its
> > contents may be protected by legal and/or professional
> > privilege. Should it be received by you in error please
> > contact the sender at the above quoted email address. Any
> > unauthorised form of reproduction of this message is strictly
> > prohibited. The Institute does not guarantee the security of
> > any information electronically transmitted and is not liable
> > if the information contained in this communication is not a
> > proper and complete record of the message as transmitted by
> > the sender nor for any delay in its receipt.
> >