Subject: RE: [Sip] Re: [Sipping] New version of the SIP-AAA reqs draft

From: [email-masked]
Date: Mon, 3 Mar 2003 17:06:24 +0200

I was offering a solution to your problem in the form of a question. Here it is again in the form of a suggestion:

If your poxy supports multiple realms on the same interface, then it can challenge with all the realms and therefore the UA does not have to supply the realm to the proxy.

Regards,
Hisham

> -----Original Message-----
> From: ext Juha Heinanen [mailto:[email-masked]]
> Sent: Monday, March 03, 2003 6:57 PM
> To: Khartabil Hisham (NMP/Helsinki)
> Cc: [email-masked]; [email-masked];
> [email-masked]; [email-masked]; [email-masked];
> [email-masked]
> Subject: RE: [Sip] Re: [Sipping] New version of the SIP-AAA reqs draft
> 
> 
> [email-masked] writes:
> 
>  > Can the proxy challenge with all its realms? I really don't believe
>  > you can trust the UA supplying the realm it belongs to.
> 
> of course it can, since in order for the authentication to 
> succeed, the
> user must have a user name and password that is valid in the 
> realm the user
> claims to belong to.  check the digest or eap/ttls specs.
> 
> -- juha
> 
_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: [email-masked]
Date: Mon, 3 Mar 2003 17:16:22 +0200

[email-masked] writes:

 > I was offering a solution to your problem in the form of a
 > question. Here it is again in the form of a suggestion:
 > 
 > If your poxy supports multiple realms on the same interface, then it
 > can challenge with all the realms and therefore the UA does not have
 > to supply the realm to the proxy.

if i understod your suggestion correctly, it makes no sense. an 
operator proxy can easily have several hundred realms configured in it.
are you suggesting sending several hundred 407s for each bye?

-- juha