Subject: [Sipping] Proxy behavior with request URI parameters

From: [email-masked]
Date: Thu, 13 Mar 2003 18:18:52 +0100

Dear sipping members,

What must be a proxy behaviour when it receives a SIP request
with request-URI parameters that it doesn't undertstand.
In RFC 3261, It is said that "SIP elements MUST silently ignore
any uri-parameters that they do not understand".

Does it mean:
    that the proxy removes the uri-parameters when constructing the
   forwarded request.
    that  the proxy copies  transparently the unknown uri-parameters in the
   request-URI of the
forwarded request.

thanks for your help

Pascal

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Michael Hammer <[email-masked]>
Date: Fri, 14 Mar 2003 16:13:53 -0500

Pascal,

My understanding has always been that for forward compatibility reasons, 
the parameters get passed forward, else an older proxy would tend to break 
any new SIP parameters defined later.

Mike