Subject: [Sipping] netann Issue #3: Multiple Media Streams

From: "Eric Burger" <[email-masked]>
Date: Thu, 20 Mar 2003 14:43:50 -0500

Problem: The UAC is a multimedia terminal, and the request is to play multiple simultaneous streams.  How can we do that given that the netann draft only specifies a single play URI?

WHAT THIS PROBLEM IS NOT:
It is not "how do I send multiple streams to a device?"  Standard SDP deals with that.

It is not "how do I negotiate media capabilities of a device?" or "what if the UAC doesn't do video?"  Standard offer/answer deals with that.

Options:

1. Have multiple play= attributes, somehow correlated to m=lines in the SDP, pointing to the appropriate media source.

2. Add a=lines to the SDP associated with the appropriate m=lines, indicating the media to play, like the a:control lines of RTSP.

3. Only allow simplex or compound objects that are described by a single URI.

Discussion:
Option 1 assumes there is a mapping between SDP-layer information and SIP information.  This breaks down pretty quickly if the offer is offering multiple codecs for a given media type.  

Option 2 is asking the proxy to modify the SDP as it passes through the proxy.  This is a direct violation of the RFC3261 proxy rules.

Option 3 means that one could not play media from different sources in a single netann session.

Proposal:
Since a proper mapping of media types to source URI inherently creates multiple sessions (which, by the way, is exactly how RTSP operates), Option 2 is explicitly out of scope for netann.

Option 1 is a non-starter.  One may consider marking the media types with fid's or sid's.  However, the originating UAC is unaware that the request may terminate to a media server.  Thus the UAC has no reason to mark media types in the SDP.

Our proposal is to do Option 3.  If you can fetch a multimedia object from a single URI (as specified in the play= parameter), a multimedia media server will negotiate and map the appropriate media types using implementation dependent rules.  If one wants to play media from different sources, you are welcome to construct a B2BUA that establishes multiple netann (or other) sessions with the appropriate SDP.
_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Gonzalo Camarillo <[email-masked]>
Date: Mon, 31 Mar 2003 13:34:27 +0300

Eric,

> Option 3 means that one could not play media from different sources in a single netann session.

8< [snip] 8<

> Our proposal is to do Option 3.

Yes, applying the KISS rule here sounds sensible.

Gonzalo