Subject: RE: [Sipping] FW: I-D ACTION:draft-persson-sipping-sip-issues-dual-stack-00.txt

From: [email-masked]
Date: Thu, 20 Mar 2003 00:18:40 +0100

> -----Original Message-----
> From: Jonathan Rosenberg [mailto:[email-masked]] 
> Sent: den 19 mars 2003 22:42
> 
> I have the same comment as Aki.
> 
> In the sip space, this is the same problem as tcp/udp conversion, 
> sip/sips and so on. In all cases, we are using record routing, with 
> differeing URIs on each side, as a means to solve it. I believe that 
> will work here.
> 
> Now, as Aki says, the harder problem is the media. Alas, I have a 
> solution for that. It is ICE:
> 
> http://www.ietf.org/internet-drafts/draft-rosenberg-sipping-ice-00.txt
> 
> With ICE, a dual stack host would put both its IPv4 and IPv6 

ok. that seems to be solving problem with sdp.

but, who (which proxy) is going to rewrite/change the contact-header field in the initial INVITE?

thanx
jasminko
_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 19 Mar 2003 19:04:35 -0500

The UA sets its contact header. It needs to make sure it is set to use 
the same IP version as the proxy it is sending the request to. This may 
require the proxy to change the contact header after it does the DNS 
resolution, and finding, for example, that there are only AAAA records, 
and no A records.

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com