Subject: RE: [Sip] Re: [Sipping] New version of the SIP-AAA reqs draft

From: [email-masked]
Date: Mon, 3 Mar 2003 14:57:20 +0200

A server knows what realm to use for a certain interface (it can do its own mapping). It cannot rely of a UA telling it the realm.

There has to be some agreements and trust between networks in order for calls to complete. You cannot make a call from Sonera to Radiolinja (both Finnish operators) without both having trust relationships (or any relationship for that matter).

Regards,
Hisham

> -----Original Message-----
> From: ext [email-masked] [mailto:[email-masked]]
> Sent: Friday, February 28, 2003 3:45 PM
> To: Gonzalo Camarillo
> Cc: Beck01, Wolfgang; [email-masked]; [email-masked];
> [email-masked]; Jari Arkko
> Subject: Re: [Sip] Re: [Sipping] New version of the SIP-AAA reqs draft
> 
> 
> Gonzalo Camarillo writes:
> 
>  > You can change the contents of the From field. No problem. 
> In fact, one
>  > of the reasons we removed the To and From URIs from the dialog
>  > identifiers (only the tags remain) was to address this type of
>  > situation.
> 
> currently your text says:
> 
> The From URI of the request MUST be set to the local URI from 
> the dialog
> state.
> 
> ...
> 
> It is expected that mandatory reflection of the original To 
> and From URI
> in mid-dialog requests will be deprecated in a subsequent revision of
> this specification.
> 
> so before that is done and the text is changed so that the 
> from uri MUST
> be the from uri of the user sending the request, there can't be any
> challenging or accounting of requests within the dialog.
> 
> alternatively, we must add another header or field to the request that
> tells what realm the ua sending the request claims to belong to.
> 
> for example, take a look at eap/tls.  there the user has a 
> means to tell
> what realm he/she wants to authenticate with.  currently we 
> are lacking
> this possibility in sip, which is a major shortcoming.
> 
> -- juha
> 
> _______________________________________________
> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments of core SIP
> 
_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: [email-masked]
Date: Mon, 3 Mar 2003 15:01:00 +0200

[email-masked] writes:

 > A server knows what realm to use for a certain interface (it can do
 > its own mapping). It cannot rely of a UA telling it the realm.

what interface?  my sip proxy has a single ethernet ip interface and
supports simultaneously any number of realms.