Subject: RE: [Sipping] New version of the early media draft

From: "Mark Watson" <[email-masked]>
Date: Fri, 7 Mar 2003 09:21:15 -0000

Gonzalo,

Your text does not recognise the desire to avoid reading semantics in to the
arrival of RTP packets, to cope with the MGC/MG scenario.

I still think this problem remains unsolved.

...Mark

> -----Original Message-----
> From: Gonzalo Camarillo [mailto:[email-masked]]
> Sent: 07 March 2003 08:48
> To: Peterson, Jon
> Cc: 'Ejzak, Richard P (Richard)'; Watson, Mark 
> [MOP:EP10:EXCH]; sipping;
> Audet, Francois [SC100:4K02:EXCH]
> Subject: Re: [Sipping] New version of the early media draft
> 
> 
> Folks,
> 
> I agree with Jon that we should not encourage people to send in-band
> ringing tones, but I also agree with Mark that this issue has
> re-surfaced a number of times already. The message we want to get
> through is that adding a SIP flag for resolving that issue 
> offers little
> or no value.
> 
> I am willing, if people agree, to add some text saying why it is not a
> good idea to add a SIP-layer flag to 180 responses indicating 
> that media
> is coming.
> 
> What about a section along these lines:?
> 
> 2.2.1 Problems with SIP-layer Indications in 180 Responses
> 
> As stated above, it is not an easy task for a UAC that receives a 180
> (Ringing) response to decide whether it should generate local ringback
> or it will be receiving early media. At first sight, it may seem that
> adding a "there is media coming" indication to 180 (Ringing) responses
> would facilitate the task of UACs. Upon reception of a 180 (Ringing)
> response with such an indication, the UAC would not generate local
> ringback. However, such an indication would offer little or no gain.
> 
> The only scenario where such an indication would be applicable is when
> the UAS sends a 180 (Ringing) response and starts sending early media
> right away. If the UAS intended to send early media at a later time,
> instead of right away, a sensible local policy for the UAC could be to
> generate local ringback in the meantime. Therefore, the 
> "there is media
> coming" indication would be useless.
> 
> Assuming, then, that the UAS sends the 180 (Ringing) response and the
> first media packets in parallel towards the UAC, we have a race
> condition. If the media packets arrive at the UAC before the 180
> (Ringing) response, the "there is media coming" indication will not
> provide any further information to the UAC.
> 
> The only situation where the UAC could benefit from that indication is
> when the 180 (Ringing) response arrives before the first 
> media packets.
> The UAC could avoid generating local ringback for an instant 
> before the
> first media packets arrive. However, the same result can be 
> achieved in
> a much simpler way (without protocol extensions) by just having UACs
> always delay the generation of local ringback for a short period of
> time. The UAC can, for instance, generate a short beep upon 
> reception of
> the 180 (Ringing) response (this is already done by some
> circuit-switched mobile terminals) and one second later start 
> generating
> local ringback if no media have been received during that period.
> 
> \motivation{Note that adding such an indication does not keep 
> UACs from
> implementing media arrival detection either, since they have to
> implement it anyway to cover other scenarios, like the race condition
> between the 200 OK for the INVITE and the first regular media 
> packets).}
> 
> 
> Opinions?
> 
> Gonzalo
>

---

From: Gonzalo Camarillo <[email-masked]>
Date: Fri, 07 Mar 2003 11:27:05 +0200

Mark,

the text says that such a flag would not solve that issue, because you
have to implement media detection *anyway* for covering other scenarios
(motivational paragraph at the bottom).

> I still think this problem remains unsolved.

The point is that such a flag would not solve it either.

Gonzalo

Mark Watson wrote:
> 
> Gonzalo,
> 
> Your text does not recognise the desire to avoid reading semantics in
> to the arrival of RTP packets, to cope with the MGC/MG scenario.
> 

-- 
Gonzalo Camarillo         Phone :  +358  9 299 33 71
Oy L M Ericsson Ab        Mobile:  +358 40 702 35 35
Telecom R&D               Fax   :  +358  9 299 30 52
FIN-02420 Jorvas          Email :  [email-masked]
Finland                   http://www.hut.fi/~gonzalo
_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP