Subject: RE: [Sipping] [Sipping]Questions on draft-ietf-sipping-connect-re use-reqs-00

From: Nicole Johnson <[email-masked]>
Date: Thu, 22 May 2003 13:12:48 +0100

Thanks for the clarification.

I have two comments about the second security mechanism discussed in section
4.1 of this draft.

1. The draft states that, for a server to accept an alias, the target
address of that alias must previously have been registered with the server.
However, this mechanism is only as secure as the REGISTER itself.  For
example, if the REGISTER is not integrity-checked, a man-in-the-middle could
alter the contact address in the REGISTER.

I think the draft should recommend that the REGISTER also be
integrity-checked using S/MIME and a sipfrag bodypart containing the
Contact.  I would be happy to propose some text.  Alternatively, if I have
misunderstood the proposed mechanism, please let me know where I have gone
wrong.

2.  It is not clear how this mechanism could be used to reuse connections
between two proxies in a secure manner.  Would each proxy have to REGISTER
its address with the other?

Thanks,
Nicole

-----Original Message-----
From: Rohan Mahy [mailto:[email-masked]]
Sent: Tuesday, May 20, 2003 9:09 PM
To: Nicole Johnson
Cc: [email-masked]'
Subject: Re: [Sipping] [Sipping]Questions on
draft-ietf-sipping-connect-reuse-reqs-00

Hi,

On Thursday, May 15, 2003, at 07:23 AM, Nicole Johnson wrote:

> I have a couple of questions about 
> draft-ietf-sipping-connect-reuse-reqs-00.

> 1.  Intended scope of alias parameter.
>
> Is the aim of this draft to enable connections to be reused within a 
> single
> dialog, or across multiple dialogs, i.e. can an alias learned within 
> the
> scope of one dialog be used in another?  Is the alias parameter valid 
> on
> out-of-dialog requests?

across multiple dialogs.  it would work on out-of-dialog requests (ex: 
OPTIONS).
perhaps these should be explicit requirements?

> 2.  Target address fails to authenticate.
>
> If a server receives a request containing the alias parameter and the 
> target
> address of the request fails authentication, how should the server 
> react?

it should not create the alias.

> It could drop the message, respond to the target address with a "not
> authorized" response, or continue processing the request as if the 
> "alias"
> parameter was not present.  Is there a recommended behaviour?

the behavior for handling the request should then do whatever normally 
happens when a request without an alias parameter arrives with failed 
or missing authentication.  frequently this is fine and will result in 
a digest authentication challenge (401 or 407).

hope this makes sense.

thanks,
-rohan

> Thanks,
> Nicole
>
>
> _______________________________________________
> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments of core SIP
_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Nicole Johnson <[email-masked]>
Date: Thu, 22 May 2003 17:43:46 +0100

Rohan,

I think that the requirements should be modified to clarify the scope of the
alias parameter.  I suggest we could add "The mechanism SHOULD allow the
reuse of an existing connection for requests and responses sent both outside
a dialog and within one or more dialogs" to the end of requirement 1 in
section 3.

I also have a question about the lifetime of the alias.  Should the alias be
destroyed as soon as the connection is lost, or is there a reason why you
might want to maintain the alias for any time after?  Is it worth clarifying
this in the draft, perhaps at the beginning of section 4 in the overview of
the mechanism?

Thanks,
Nicole  

-----Original Message-----
From: Rohan Mahy [mailto:[email-masked]]
Sent: Tuesday, May 20, 2003 9:09 PM
To: Nicole Johnson
Cc: [email-masked]'
Subject: Re: [Sipping] [Sipping]Questions on

Hi,

hope this makes sense.

thanks,
-rohan