Subject: [Sipping] SIP and TCP transport....

From: "Sarkar, Uttam" <[email-masked]>
Date: Thu, 29 May 2003 15:23:55 -0400

Hi All,
I have posted this messgage to the sip-implementors list. There might have
been a discussion already regarding this.
When transport is TCP, do you keep the socket connection open till the call
is active or you close the socket once party A and party B are connected.
When you get BYE or other sip Message from either end, then you open new
socket connection to the other side to send that request. I would appreciate
your inputs.
Thanks,
Uttam Sarkar

             B2BUA
A<----------->|
              |
              |<-------------->B
              |
              |
_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Jonathan Rosenberg <[email-masked]>
Date: Sat, 31 May 2003 01:55:48 -0400

> is active or you close the socket once party A and party B are connected.

The specification only requires that you keep a connection open until 
there have been 64*T1 seconds of inactivity. However, genreally 
speaking it is good to keep the connections open for as long as you 
have resources, since they could potentially be reused down the road.

> socket connection to the other side to send that request. I would appreciate

Genreally there is a separate connection used for requests in each 
direction.

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
Chief Scientist                             Parsippany, NJ 07054-2711
dynamicsoft
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com