Subject: Re: [Sipping] FWD:I-D ACTION:draft-johnston-sipping-rtcp-summary-00.txt

From: Cullen Jennings <[email-masked]>
Date: Sat, 09 Aug 2003 11:03:16 -0700

One of the problems with end of call reporting is that it needs to have
enough time based granularity information to be useful. For example ....
Consider two calls.

Call A. This is a 100 minute call with 1% packet loss distributed evenly.

Call B. This had 0% packet loss for first 99 minutes then 100% packet loss
for 1 minute then user hung up.

Call A was a good call and the service provider is probably happy. Call B is
a bad call and needs attention. The reporting needs to differentiate between
these two cases. 

Cullen

On 7/14/03 8:09, "Eric Burger" <[email-masked]> wrote:

> Would any reporting system ever be interested in RTCP messages?  I would
> expect network operators (who I presume would be the interested third-parties)
> to be interested in end-of-call summaries only.  Otherwise, a service provider
> of any significant size is signing up for a significant amount of RTCP
> reporting (flooding?).
> 
> Being NOTIFIED of end-of-call statistics is a sensible option.  That way you
> can use the existing SIP security, subscription, and message routing
> infrastructure.  
> 
>> -----Original Message-----
>> From: Alan Johnston [mailto:[email-masked]]
>> Sent: Fri, June 27, 2003 2:38 PM
>> To: [email-masked]
>> Subject: [Sipping] FWD:I-D
>> ACTION:draft-johnston-sipping-rtcp-summary-00.txt
>> 
>> 
>> FYI - a new draft on the delivery of RTCP summary reports to
>> third parties.
>> 
>> Comments most welcome.
>> 
>> Thanks,
>> Alan Johnston
>> MCI
>> 
>> 
>> ----------
>> To: IETF-Announce: ;
>> Subject: I-D ACTION:draft-johnston-sipping-rtcp-summary-00.txt
>> From: [email-masked]
>> Date: Tue, 24 Jun 2003 06:56:20 -0400
>> Reply-to: [email-masked]
>> Sender: [email-masked]
>> 
>> A New Internet-Draft is available from the on-line
>> Internet-Drafts directories.
>> 
>> 
>>          Title           : RTCP Summary Report Delivery to
>> SIP Third Parties
>>          Author(s)       : A. Johnston, H. Sinnreich, A. Clark
>>          Filename        : draft-johnston-sipping-rtcp-summary-00.txt
>>          Pages           : 9
>>          Date            : 2003-6-23
>> 
> 
> 
> _______________________________________________
> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments of core SIP
> 

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Henry Sinnreich <[email-masked]>
Date: Sun, 10 Aug 2003 18:43:04 -0500

Cullen, I agree that 

>The reporting needs to differentiate between
> these two cases.

Burst errors are treated very well I believe in 

http://www.ietf.org/internet-drafts/draft-ietf-avt-rtcp-report-extns-06.txt 

and this benefit extends to

http://www.ietf.org/internet-drafts/draft-johnston-sipping-rtcp-summary-00.t
xt 

Henry

> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Cullen Jennings
> Sent: Saturday, August 09, 2003 1:03 PM
> To: Eric Burger; Alan Johnston
> Cc: [email-masked]
> Subject: Re: [Sipping] FWD:I-D ACTION:draft-johnston-sipping-rtcp-summary-
> 00.txt
> 
>