Subject: RE: [Sipping] App-Interaction: Considering models

From: Adam Roach <[email-masked]>
Date: Thu, 14 Aug 2003 12:26:46 -0500

Cullen Jennings [mailto:[email-masked]] writes:

> I seem to recall someone asking about the expire time on the 
> subscription

You appear to have misinterpreted what I said in the same
way as Jonathan did.

The issue I was attempting to raise is that subscriptions,
as defined in 3265, always have a well-defined number of
seconds before they expire. This amount of time can be
expressed using an integer. If you start defining this
period of time to be "until some other event happens,
and we don't know when that will occur", you have to
significantly modify RFC 3265 behavior.

So, for the two SUBSCRIBE solutions I describe, the
subscription would initially be for some arbitrary period
of time (say, two hours). If the need for interaction
lasts longer than that, you refresh. If the interaction
is shorter, you unsubscribe.

/a

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Cullen Jennings <[email-masked]>
Date: Thu, 14 Aug 2003 12:28:53 -0700

> is shorter, you unsubscribe.

I had wondered about how to solve this - I think putting in a really large
number is more or less what people had imagined. If you were running a
session timer on the original dialog that time might be usable. If you sent
a notify with 100 minutes, then 20 minutes later sent a new notify with 100
minutes (and there had been no subscribe in the meantime) would that violate
3265? What does the implicit subscribe in refer do? Anyways, I'm not really
arguing for NOTIFY but this is one of the issues we need to figure out to
use it.