Subject: RE: [Sipping] App-Interaction: Considering models

From: Adam Roach <[email-masked]>
Date: Thu, 14 Aug 2003 18:11:33 -0500

Cullen Jennings [mailto:[email-masked]] writes:

> Proposal 3) Use NOTIFY. Semantics are, here is some 
> information about some event that you requested to
> be informed about. The usual complaint on this one
> is that there was no Subscribe, or it was implicit,
> or it was explicit, or it violated some law of the
> SIP world. I think there was a subscribe, it was in
> the message that initiated the script. There is also
> a clear time it will end - when the script is terminated
> or when the dialog of the message that initiated the
> script ends. We all remember that implicit subscribes
> where bad (whatever an implicit subscribe is) but people
> seem to have a hard time remembering why this will be
> bad here.

It's not simple dogma; there are real problems here. I've
cited a few of them (and, as I point out in another message,
Jonathan's rebuttal is somewhat lacking in the area of
duration; also, I still plan to respond on the correlation
issue, because I think his rebuttal glosses over the
details).

Can these problems be fixed? Probably. REFER provides an
existence proof that implicit subscriptions[1] can be made
to work with enough crafting. After it's said and done,
do we regret choosing that path? I do. Robert does. Do we
want to learn from our mistakes?

Your phrasing above knocked loose in my mind another reason
that implicit subscriptions[1] are ill-advised: you are using
a single transaction to perform two operations. Conveying
partial success (e.g. the call completed, but the subscription
failed) is problematic. We have made efforts to avoid this
type of situation in the past.

/a

[1] To be clear, I mean "subscriptions put in place via some
    other mechanism than that described in RFC 3265."

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Cullen Jennings <[email-masked]>
Date: Fri, 15 Aug 2003 14:27:34 -0700

Fair enough, I am not really arguing for NOTIFY, I sort of like the
NEW_METHOD approach because it lets us get past all the semantics arguments
by defining the semantics to be exactly what we want.

I forgot on my list, PUBLISH may be an option to use to depending on what
people believe the semantics of it are.

On the topic of reporting that there was some error in dealing with the
script referenced in the App-Info header, we use the (cough) web model of
error reporting, which is to say we don't do it at all. Thought this seems
lame at first glance, after much discussion, we came to the conclusion that
any useful application you wanted to build with this needed to deal with
never receiving any stimulus from the script and that web model was quite
reasonable and the right thing for this. I think this decision makes the
problem of multiple error report on implicit subscribes a non issue here.

Cullen