Subject: RE: [Sipping] Kill Overlap Dialling

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Thu, 28 Aug 2003 08:59:46 +0100

The conclusion everyone has always reached on this issue in the past is that you can only eliminate overlap dialling when you have control over whether the terminal can overlap dial or not.

Therefore the GSM people eliminated overlap dialling from the handset, and therefore in the network, by insisting that all GSM phones had the user entering the number and then hitting a SEND key. They have not eliminated overlap dialling in the core network, in so far as incomplete numbers can still be received from other networks, which have to be resolved into terminal identifiers before they can be declared to be complete.

Likewise, you can insist on the SIP phone dialling complete, but if you want to interwork with the PSTN, then the problem will be there.

regards

Keith

> -----Original Message-----
> From: Christian Stredicke [mailto:[email-masked]]
> Sent: 26 August 2003 06:37
> To: 'sipping'
> Subject: [Sipping] Kill Overlap Dialling
> 
> 
> Hi All,
> 
> the feedback which I received so far on overlap dialling was pretty
> clear: There will be no overlap dialling support for SIP.
> 
> Arguments:
> 
> A. ENUM does not support overlap dialling. There are security concerns
> on who will own the nodes of incomplete numbers and it was 
> also reported
> that the overhead for the node lookup is too much.
> 
> B. Countries with fixed-length numbers (like USA) can have a dial plan
> on the phone. Other countries always need to press the dial button
> except for cases where extension numbers are dialled. People calling
> from the US have to press a dial key (or #) after dialling a non-US
> number. That is accepted by the customers.
> 
> C. The lack of support of 484 responses on PSTN gateways makes overlap
> dialling unusable anyway. A SIP extension would be necessary, but does
> not exist at this time and the probability that we reach consensus on
> such an extension in time is minimal. 
> 
> D. "Grandma" is not in the customer focus any more. 
> "Grandchildren" are
> used to cell phones and press the dial button after making up their
> minds on which person to call.
> 
> E. Phones without display will not be sold in large numbers 
> any more. If
> vendors should decide to make SIP phones without display, they must
> include a dial button (timeout of 5 seconds to start dialling is not
> feasible as this makes printed telephone book lookup impossible).
> 
> 
> Am I right? I this is so, we would like to stop efforts on 
> implementing
> this in out endpoints.
> 
> Best,
> 
> 
> Christian
> 
> 
> _______________________________________________
> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments of core SIP
> 

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Dean Willis <[email-masked]>
Date: Thu, 28 Aug 2003 13:07:53 -0500

> Likewise, you can insist on the SIP phone dialling complete, but if you want to interwork with the PSTN, then the problem will be there.

yes, but like GSM, only as an INBOUND problem. I would expect calls
ORIGINATING from SIP nodes to always be en-bloc.

--
Dean