Subject: Re: [Sipping] Question on pick-up in service-examples-04

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 13 Aug 2003 14:26:26 -0400

Old email, and a sort-of-related point.

It seems to me that the INVITE/Replaces really needs to be targeted at 
the GRUU for Alice's phone, no? Otherwise this service won't work in 
places where Carol is located in a different network. For example, if 
Carol takes here SIP phone to a hotel, she won't be able to directly 
reach the contact, and so the pickup will fail. I think we want pickup 
services to work independent of the physical locations of the two devices.

In that case what is more useful in the dialog event package is the 
gruu, not just the contact.

-Jonathan R.

Alan Johnston wrote:

> John,
> 
> You are correct - the NOTIFY F5 does not show the Contact URI.  It 
> should have been shown in a Remote Target tag.  However, this tag is 
> listed as optional in the dialog package - I'm not sure why as it is 
> useful in a number of situations.
> 
> I agree that it is important to use the Contact URI in this flow.
> 
> Thanks,
> Alan Johnston
> MCI
> 
> At 09:41 AM 7/10/2003 +0100, Elwell, John wrote:
> 
>> Can anyone explain something to me in section 2.16 (call pick-up)?
>>
>> In F7, the Request-URI is the contact URI for Alice: 
>> [email-masked]
>>
>> It is not clear how Carol's UA receives this contact address. F5 from 
>> Bob to Carol provides only the AoR: [email-masked].
>>
>> I believe it is important to use the contact URI in F7 to avoid the 
>> case where the INVITE request reaches the wrong UA at Alice. This is 
>> particularly true when Alice is in a legacy network - the contact 
>> address might help selection of the correct gateway.
>>
>> John ([email-masked])
> 
> 
> 
> _______________________________________________
> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments of core SIP
> 

-- 
Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
Chief Technology Officer                    Parsippany, NJ 07054-2711
dynamicsoft
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Rohan Mahy <[email-masked]>
Date: Tue, 19 Aug 2003 23:09:50 -0700

> gruu, not just the contact.

Or this can be seen as yet another motivation to always put a GRUU in 
the Contact header....

thx,
-r

>>> It is not clear how Carol's UA receives this contact address. F5 
>>> from Bob to Carol provides only the AoR: [email-masked].
>>>