Subject: RE: [Sipping] FYI: RADIUS & SIP

From: Bernard Aboba <[email-masked]>
Date: Tue, 5 Aug 2003 09:42:07 -0700 (PDT)

> I remember a different decision back in San Francisco IETF. That was
> RADIUS for SIP Authentication. There were concerns (unresolved, if
> I remember right) about what to do with accounting due to lack of
> reliability in RADIUS.
>
> Also, my testimony -- quite some iptel.org users (mostly from ISP crowd)
> have been asking us for RADIUS. There was no way around it: they
> are much more uncomfortable with changing largely deployed base than
> with claimed RADIUS shortcomings. None has ever asked for Diameter.
>
> -jiri

There is now an I-D discussing RADIUS transport behavior:

http://www.ietf.org/internet-drafts/draft-lior-radius-reliable-accounting-00.txt

The suggestion is that a specification of this nature could address some
of the concerns about RADIUS accounting reliability.  The debate is how
far such a specification could go -- since RADIUS has no "heartbeat"
functionality, it isn't clear that failover functionality equivalent to
RFC 3539 can be added to it:

http://www.ietf.org/rfc/rfc3539.txt

Obviously, RADIUS clients and servers would need to change to be
compatible with any such specification, if it were to be created.  The
question is whether the issues of "changing largely deployed base" would
represent an obstacle to such an effort.

Any opinions?

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Jiri Kuthan <[email-masked]>
Date: Tue, 05 Aug 2003 17:58:14 +0200

-jiri

At 04:39 PM 7/29/2003, McCandless, Kevin wrote:
>This thread seems to rehash an old issue and that was DIAMETER or RADIUS for SIP authentication.  As I remember the discussion and tentative recommendation is that SIP would adopt DIAMETER as the  standard for AAA functionality and that DIAMETER servers would interoperate with RADIUS servers.  As I understood it, the companies that have the embedded base of RADIUS servers could continue to use them for SIP and the entities deploying new DIAMETER based servers must be able to interoperate with the RADIUS servers.  
>
>Kevin....
> 
>
>> -----Original Message-----
>> From: Liess, Laura [mailto:[email-masked]]
>> Sent: Friday, July 18, 2003 4:44 AM
>> To: [email-masked]; [email-masked]; [email-masked]
> Cc: Dumler, Alexander; Wolff, Christian
>> Subject: AW: [Sipping] FYI: RADIUS & SIP
>> 
>> 
>> I think most carriers currently use some kind of RADIUS 
>> platform to do user authentication and they would like to 
>> reuse it in the future to authenticate their SIP customers. 
>> My colleagues who are responsible for the RADIUS Platform of 
>> the Deutsche Telekom (CC)are currently on vacation so I could 
>> not check with them now about how to answer this mail, but we 
>> already talked about this issue a number of times and my 
>> strong opinion is that "yes, Deutsche Telekom cares a lot 
>> about SIP and RADIUS". Reusing the existing RADIUS platform 
>> for SIP authentication is a strong requirement for the 
>> development of SIP services within the Deutsche Telekom.  
>> 
>> Laura (T-Systems/Deutsche Telekom Group)  
>> 
>> 
>> >-----Ursprungliche Nachricht-----
>> >Von: Henning Schulzrinne [mailto:[email-masked]]
>> >Gesendet: Freitag, 18. Juli 2003 09:45
>> >An: [email-masked]
>> >Betreff: [Sipping] FYI: RADIUS & SIP
>> >
>> >
>> >Bernard Aboba <[email-masked]> would like to know about 
>> >people and 
>> >companies that care about SIP and RADIUS (for authentication). 
>> >There is 
>> >an attempt afoot to rationalize RADIUS-related efforts within 
>> >the IETF, 
>> >but there seems to be a lack of representation from SIP 
>> folks, as per 
>> >the note to the radius-authors mailing list:
>> >
>> >"I was not clear about the need for SIP/RADIUS work. 
>> >Apparently there is
>> >ongoing deployment of I-Ds (e.g. the Sterman draft on RADIUS 
>> attributes
>> >for HTTP Digest Authentication), so perhaps standardization would be
>> >valuable in documenting what is in use. On the other hand, I 
>> >also heard 
>> >that "there
>> >isn't much commercial interest." Note sure what to make of 
>> >this, perhaps
>> >someone can clarify."
>> >
>> >Henning
>> >
>> >