Subject: RE: [Sipping] Re: Comment on GRUU requirements

From: Adam Roach <[email-masked]>
Date: Mon, 18 Aug 2003 12:22:27 -0500

Rohan Mahy [mailto:[email-masked]] writes:

> In fact we already have a precedent (in the REGISTER method) 
> that a Contact should be valid for more than one dialog.

This is one of those perfect-hindsight problems, but
the issue here is that "Contact" in REGISTER is wildly
different in meaning than "Contact" in any other context
(except, arguably, 300-class responses).

These uses really should have employed a different header
than "Contact". Citing them as precedent is shaky
at best.

/a

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Rohan Mahy <[email-masked]>
Date: Tue, 19 Aug 2003 12:58:15 -0700

> (except, arguably, 300-class responses).

I completely disagree; and I believe that this is the core of the 
semantic problem we are having.  I take "Contact" to mean a URI where a 
particular user or service can be reached.  This makes a Contact in a 
REGISTER no different from a Contact in an INVITE or a <contact> in the 
dialog package.  I believe that any other definition of Contact is 
completely contrived.

thanks,
-rohan