Subject: RE: [Sipping] KPML Digit Maps

From: "Jean-Francois Mule" <[email-masked]>
Date: Wed, 12 Nov 2003 10:16:55 -0700

Hi Eric,
Comments inline.
Jean-François 

Eric Burger [mailto:[email-masked]] wrote
> Right now, KPML specifies 3 mandatory digit map styles:
>  - Regular Expressions
>  - H.248.1 digitmap
>  - J.162   digitmap
J.162 may appear an obscur ITU-T spec... it is the ITU-T recommendation for NCS, the Network Control Signaling protocol defined by PacketCable and it is based on the IETF MGCP RFC 2705. On digitmaps, NCS (j.162) digit maps follow the mgcp digit maps (Flemming or Bill can correct me - there are some variances between the digitmap bnf j.162-ncs, rfc2705 and rfc3534 but the latter could be considered as refinements). 
This digitmap format is used by many PacketCable MTA CPE vendors and CMS call agents today.
BTW - MGCP digit map a la RFC 3435 which defines some additional ExtensionDigitMapLetters could be added above.

> Choices are:
>  1. We can pick one, and only one digit map style.
>  2. We can negotiate the style, with a mandatory
>     to implement for guaranteed baseline
>     interoperability.
> 
> There was a leaning in Minneapolis towards option #2.
One can implement an mgcp digit map using a regexp. You eliminate the negotiation complexity for this and the management or registration of the styles. Why couldn't a regexp be the only option: option #1?

> The 
> mechanism roughly would be to put a parameter on the event: 
> kpml header in the SUBSCRIBE, with a suitable failure if the 
> style is not supported by the KPML server.  Given that there 
> are already three (or four, see below) different digit map 
> styles, this probably would become an IANA-registered tag.

> 
> For the people that think expression evaluation is 
> computationally complex, one of the styles can be a hardcode 
> of "match digit."  [Ed. Note: this mode is not really useful 
> for the reasons given, in that expression evaluation is not 
> computationally complex, especially when compared to the 
> computational complexity of running a SIP stack or (if on a 
> single processor) the complexity of detecting DTMF).]
> 
> Comments?

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Tom Taylor <[email-masked]>
Date: Wed, 12 Nov 2003 13:38:19 -0600

H.248 actually has two digit map procedures now: H.248.1 and H.248.16.

Regarding Jean-François's comment: what about digit timing?  That goes 
beyond regexp.