Subject: [Sipping] Comments on dialog-package-03

From: "Eric Burger" <[email-masked]>
Date: Thu, 6 Nov 2003 04:44:11 -0500

Section 3.3, last bullet:
I don't like the "or" in the explicitly requested and / or explicitly authorized.  Even if I am authorized, I don't want the information unless I explicitly request it (making it an "and" only).

How about, "The notifier MUST NOT include additional information unless explicitly requested.  The notifier SHOULD authorize the request before honoring the request."

Section 3.10 on notification rate:
I think the granularity is too small.  I would expect a flurry of interesting activity during call state change, and then relative quiet during conversations.  Given a conversation of 1 minute (efficient call center), how about having a suggested limit of 10 messages (or some other appropriate number) in one minute?  That way, you can have a message per second (as people answer calls, etc.), without flooding the network (as the dialog will be relatively quiet after the flurry).

Section 4.1.1 open issue (escaped quotes):
Don't forget, you get to chose between ' and ".  We could suggest using single tics.

Example in 4.1.1 is not consistent with the draft.  The version indicates which message number this is.  In the example, version=0, which implies this is the first message.  However, state="partial", which is wrong: the first message always conveys state="full".

Open issue 4.1.6 (reporting route set): Is there a use case for this?

Open issue 4.1.6.1.4 (reporting CSeq): What could anyone possibly do with this information?

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Rohan Mahy <[email-masked]>
Date: Mon, 10 Nov 2003 08:51:10 -0800

Thanks for your comments Eric.

inline...

On Thursday, November 6, 2003, at 01:44 AM, Eric Burger wrote:
> I don't like the "or" in the explicitly requested and / or explicitly 
> authorized.  Even if I am authorized, I don't want the information 
> unless I explicitly request it (making it an "and" only).
>
> How about, "The notifier MUST NOT include additional information 
> unless explicitly requested.  The notifier SHOULD authorize the 
> request before honoring the request."

sounds good.

> I think the granularity is too small.  I would expect a flurry of 
> interesting activity during call state change, and then relative quiet 
> during conversations.  Given a conversation of 1 minute (efficient 
> call center), how about having a suggested limit of 10 messages (or 
> some other appropriate number) in one minute?  That way, you can have 
> a message per second (as people answer calls, etc.), without flooding 
> the network (as the dialog will be relatively quiet after the flurry).

good idea

> Don't forget, you get to chose between ' and ".  We could suggest 

i don't think this is so easy.  a baroque call-id can contain both 
single and double quotes.  the question is if you can escape them with 
&quot; and &apos; .

> Example in 4.1.1 is not consistent with the draft.  The version 
> indicates which message number this is.  In the example, version=0, 
> which implies this is the first message.  However, state="partial", 
> which is wrong: the first message always conveys state="full".

sorry, I meant to update the version number on this one.  will fix.

> Open issue 4.1.6 (reporting route set): Is there a use case for this?

that's why I asked.

> Open issue 4.1.6.1.4 (reporting CSeq): What could anyone possibly do 

you mean other than be an evil B2BUA that wants to insert messages into 
the middle of your session?  I can't think of anything either.  ;-)

thanks,
-rohan

---

From: "Christian Stredicke" <[email-masked]>
Date: Mon, 10 Nov 2003 11:05:47 -0600

> > Open issue 4.1.6 (reporting route set): Is there a use case for
this?

This is helpful for call pick up. You might want to know how to reach
the one who is calling (with a Replaces header).

Christian

---

From: Rohan Mahy <[email-masked]>
Date: Mon, 10 Nov 2003 11:46:27 -0800

I'm assuming you wouldn't need this if the remote target provided a 
Contact with GRUU properties.

thanks,
-rohan