Subject: [Sipping] Comment on the applicability of draft-ietf-sipping-config-framework

From: [email-masked]
Date: Wed, 12 Nov 2003 05:21:52 +0200

Hi,

I want to elaborate on the comment I made about draft-ietf-sipping-config-framework and wireless devices in today's SIPPING session:

In general I think the framework presented in the draft is very good. However, it is not clear how usable it will be in its current form for wireless devices (more specifically wireless devices used mainly in cellular networks) having a SIP UA. For those kind of devices it is anyway essential to be able to configure a number of parameters related to various applications, e.g. MMS or e-mail. I believe there is nothing special about SIP-related parameters in this respect. So, rather than using a mechanism targeted specifically for SIP, it makes more sense to use a generic "device management" technology to take care of all applications. 

The prevailing technology for this, at least in GSM/GPRS/WCDMA space is - SMS - which is obviously very limited. This is currently being superseded by SyncML-based device management technology standardized by the Open Mobile Alliance, OMA. This clearly diminishes the need for a separate SIP mechanism. (Note that so far e.g. 3GPP has not made any decision whether to follow sipping-config-framework or SyncML when configuring service parameters for IMS SIP UAs. It is as well possible that they will not specify anything on this for Release 6, which comes out next year.)

There may be, however, some synergies between sipping-config-framework and how SyncML device menagement needs to evolve. SyncML DM currently relies on WAP push technology to deliver notifications to devices, and uses MSISDN numbers to address them (this may sound bad, but the advantage is that it works even when the device is not connected to IP network). In the future when a large number of cellular devices have SIP and constant IP connectivity, it may actually make sense to replace the _notification part_ with SIP. This would conceptually fit in the sipping-config-framework, only it is not clear whether SUBSCRIBE-NOTIFY is actually the best (or at leat the only) solution. 

We are going to take a look on the requirements from SyncML point of view, and after that comment if SIP has any role at all there, and whether a potential solution would have commonalities with the sipping-config-framework work done in the IETF. The optimal solution would be that there would be at least some commonalities how the device gets its configuration in cellular network and when it is used e.g. in an enterprise VoIP system with WLAN access.

Regards,
	Markus    

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Cullen Jennings <[email-masked]>
Date: Tue, 18 Nov 2003 13:52:53 -0800

Are there are any patents or other IPR issues with SyncML?

On 11/11/03 7:21 PM, "[email-masked]" <[email-masked]>
wrote:

> Hi,
> 
> I want to elaborate on the comment I made about
> draft-ietf-sipping-config-framework and wireless devices in today's SIPPING
> session:
> 
> In general I think the framework presented in the draft is very good. However,
> it is not clear how usable it will be in its current form for wireless devices
> (more specifically wireless devices used mainly in cellular networks) having a
> SIP UA. For those kind of devices it is anyway essential to be able to
> configure a number of parameters related to various applications, e.g. MMS or
> e-mail. I believe there is nothing special about SIP-related parameters in
> this respect. So, rather than using a mechanism targeted specifically for SIP,
> it makes more sense to use a generic "device management" technology to take
> care of all applications.
> 
> The prevailing technology for this, at least in GSM/GPRS/WCDMA space is - SMS
> - which is obviously very limited. This is currently being superseded by
> SyncML-based device management technology standardized by the Open Mobile
> Alliance, OMA. This clearly diminishes the need for a separate SIP mechanism.
> (Note that so far e.g. 3GPP has not made any decision whether to follow
> sipping-config-framework or SyncML when configuring service parameters for IMS
> SIP UAs. It is as well possible that they will not specify anything on this
> for Release 6, which comes out next year.)
> 
> There may be, however, some synergies between sipping-config-framework and how
> SyncML device menagement needs to evolve. SyncML DM currently relies on WAP
> push technology to deliver notifications to devices, and uses MSISDN numbers
> to address them (this may sound bad, but the advantage is that it works even
> when the device is not connected to IP network). In the future when a large
> number of cellular devices have SIP and constant IP connectivity, it may
> actually make sense to replace the _notification part_ with SIP. This would
> conceptually fit in the sipping-config-framework, only it is not clear whether
> SUBSCRIBE-NOTIFY is actually the best (or at leat the only) solution.
> 
> We are going to take a look on the requirements from SyncML point of view, and
> after that comment if SIP has any role at all there, and whether a potential
> solution would have commonalities with the sipping-config-framework work done
> in the IETF. The optimal solution would be that there would be at least some
> commonalities how the device gets its configuration in cellular network and
> when it is used e.g. in an enterprise VoIP system with WLAN access.
> 
> Regards,
> Markus    
>