Subject: RE: RE : RE : [sipping] comment on draft-polk-sipping-location-re quirements-01.txt

From: "Rosen, Brian" <[email-masked]>
Date: Mon, 15 Dec 2003 09:39:06 -0500

Sébastien

Presently, there are no phones with any support at all for emergency
calls, nor any but a very few proxy servers.  We are now defining 
how they should work.  This will require changes in UAs and servers 
eventually.  There will need to be a transition plan, which would 
allow older system components to work.  Such a transition plan would 
have to start with the existing emergency calling system, and work 
forward to what we eventually want.

I think having the phone know its location is not difficult, even 
for very inexpensive phones, and is very useful.  It is also best,
where emergency services is concerned, to have simple rules, without
a lot of options.  Having some phones know where they are, with
others reliant on some kind of proxy action creates the kind of
incompatibilities that could cause serious harm.  I would prefer to
have ONE way, even if this makes one more piece of work in the
transition plan.

Brian

> -----Original Message-----
> From: PROUVOST Sébastien FTRD/DAC/ISS
> [mailto:[email-masked]]
> Sent: Monday, December 15, 2003 8:54 AM
> To: Rosen, Brian
> Cc: [email-masked]; [email-masked]
> Subject: RE : RE : [sipping] comment on
> draft-polk-sipping-location-requirements-01.txt
> 
> 
> Brian,
> 
> In a context as sensible as emergency services, we cannot 
> rely only on terminal capabilities. We shall be able to 
> rescue a person making an emergency call even if its terminal 
> does not support such and such options.
> 
> Sébastien Prouvost
> France Télécom R&D/DAC/CAR
> http://www.francetelecom.com/rd
> 
> -----Message d'origine-----
> De : Rosen, Brian [mailto:[email-masked]] 
> Envoyé : vendredi 12 décembre 2003 19:39
> À : PROUVOST Sébastien FTRD/DAC/ISS
> Cc : [email-masked]; [email-masked]
> Objet : RE: RE : [sipping] comment on 
> draft-polk-sipping-location-requirements-01.txt
> 
> 
> Sébastien
> 
> When would there be a situation where the terminal is not
> able to obtain its own location?  Are you arguing on 
> technical grounds or business reasons?  
> 
> If the international standards for VoIP emergency calls 
> were structured so that UAs were informed of their location, 
> and included that information on an emergency call, would you 
> still worry that some country would impose regulations 
> requiring a carrier to insert location?  If that happened, 
> would you expect the IETF to change the specifications?
> 
> Don't you see that the mechanism for having proxy insertion 
> PLUS mechanisms for UAs to request that proxies not insert is 
> more complicated, without having a compelling technical advantage?
> 
> Brian
> 
> > -----Original Message-----
> > From: PROUVOST Sébastien FTRD/DAC/ISS
> > [mailto:[email-masked]]
> > Sent: Friday, December 12, 2003 1:30 PM
> > To: Rosen, Brian
> > Cc: [email-masked]; [email-masked]
> > Subject: RE : [sipping] comment on 
> > draft-polk-sipping-location-requirements-01.txt
> > 
> > 
> > Well, I still believe that the cases where the terminal will not be 
> > able to get information shall be covered and that a proxy should be 
> > allowed to insert this information in such a case (if it is able to 
> > obtain it).
> >  
> > If not, there is a significant issue with emergency calls : 
> it may be 
> > a regulatory obligation for an operator to make this location 
> > information available.
> > 
> > I also agree that privacy considerations regarding the 
> divulgation of 
> > location information is important and that except for 
> emergency calls 
> > this information shall not be delivered to any entity without the 
> > agreement of the UA. If a proxy in the path is allowed to 
> insert the 
> > info, this shall lead to the additionnal requirement that a 
> UA shall 
> > be able to inform proxies in the path whether of not they are
> > allowed to insert this information.
> >  
> >  
> > Regards,
> > 
> > Sébastien Prouvost
> > France Télécom R&D/DAC/CAR
> > http://www.francetelecom.com/rd
> > 
> > -----Message d'origine-----
> > De : Rosen, Brian [mailto:[email-masked]]
> > Envoyé : vendredi 12 décembre 2003 14:03
> > À : PROUVOST Sébastien FTRD/DAC/ISS
> > Cc : [email-masked]; [email-masked]
> > Objet : RE: [sipping] comment on
> > draft-polk-sipping-location-requirements-01.txt
> > 
> > 
> > I think that the issue is one of privacy control.  If some 
> > intermediary puts your location on the message without your 
> consent, 
> > there is a significant breach of privacy.
> > 
> > The emergency case is somewhat different, and we are 
> looking into how 
> > best to accommodate it.  In general, our approach is to get 
> the UA to 
> > know its location and report it with the call.  We understand the 
> > issue of authentication of location, and will need to 
> assure that the 
> > location is accurate
> > when a carrier knows what it is.   If the location is
> > provided to the UA, and it chooses to NOT send it, I 
> believe he should 
> > be allowed to do so.  There are several ways the UA could learn its 
> > location from some other entity.  One of them is DHCP (for a 
> > non-mobile UA).
> > 
> > Do you see any problem with that approach?
> > 
> > Brian
> > 
> > > -----Original Message-----
> > > From: PROUVOST Sébastien FTRD/DAC/ISS
> > > [mailto:[email-masked]]
> > > Sent: Monday, December 08, 2003 10:10 AM
> > > To: [email-masked]; [email-masked]
> > > Cc: [email-masked]
> > > Subject: [sipping] comment on
> > > draft-polk-sipping-location-requirements-01.txt
> > > 
> > > 
> > > Hi,
> > > 
> > > I fully support the idea of having location information 
> conveyed in 
> > > SIP.
> > > 
> > > However, I fail to see in the draft a requirement for a 
> proxy to be 
> > > able to insert the location object on behalf of the UA. It
> > is likely
> > > that in some cases terminals may not have this 
> information. In some 
> > > architectures, an outbound proxy may be able to retrieve this 
> > > information (eg. Through a MIDCOM or COPS interface with an
> > entity in
> > > the transport plane) and it is useful to allow such an
> > outbound proxy
> > > to insert this location object.
> > > 
> > > As stated in requirement E-3 regarding emergency calls, 
> it may be a 
> > > regulatory obligation for an operator to make this location 
> > > information available to certain users. Operators may 
> therefore be 
> > > mandated to have this information inserted by proxies if
> > the terminal
> > > does not insert it.
> > > 
> > > Regards,
> > > 
> > > Sébastien Prouvost
> > > France Télécom R&D/DAC/CAR
> > > http://www.francetelecom.com/rd
> > > 
> > > 
> > > _______________________________________________
> > > Sipping mailing list  
> https://www1.ietf.org/mailman/listinfo/sipping
> > > This list is for NEW development of the application of SIP Use
> > > [email-masked] for questions on current sip Use 
> > > [email-masked] for new developments of core SIP
> > > 
> > 
> 

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Tue, 16 Dec 2003 10:15:36 -0000

I would suggest that even if the terminal information is not necessarily reliable, the emergency call centres will still require it if it is available.

It is then up to the emergency centre (and its staff) to make a judgement call as to its reliability, in the context of other information provided by outbound proxies and other SIP servers.

regards

Keith

> From: Rosen, Brian [mailto:[email-masked]]
> Sent: 15 December 2003 14:39
> To: 'PROUVOST Sébastien FTRD/DAC/ISS'
> Subject: RE: RE : RE : [sipping] comment on
> draft-polk-sipping-location-re quirements-01.txt
> 
> 
> Sébastien
>

---

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 16 Dec 2003 10:18:40 -0500

I agree.

Most emergency centers still ask you where you are, even if they have
location.  Some centers do follow up investigations if location was
not provided, or the location differed from that reported by the caller
to see what failed.

Brian

> From: Drage, Keith (Keith) [mailto:[email-masked]]
> Sent: Tuesday, December 16, 2003 5:16 AM
> To: 'Rosen, Brian'; 'PROUVOST Sébastien FTRD/DAC/ISS'
> I would suggest that even if the terminal information is not 
> necessarily reliable, the emergency call centres will still 
> require it if it is available.
> 
> It is then up to the emergency centre (and its staff) to make 
> a judgement call as to its reliability, in the context of 
> other information provided by outbound proxies and other SIP servers.
> 
> regards
> 
> Keith
>