Subject: RE: [Sipping] WGLC on Early Media Drafts

From: "Francois Audet" <[email-masked]>
Date: Thu, 18 Dec 2003 11:28:29 -0800

Gonzallo, Dean,

I'm not sure if I like Dean's recommendation, as many terminals may not
be able or may have no need to distinguish between early and regular media.
I would agree however that if you DO want to distinguish between early
and regular media, Dean's recommendation is good.

In my opinion, the use of different ports is recommended only if you
want to distinguish between the early and the regular media.

I would thus reword the sentence like this:

***
If distinguishing between early and regular media is required,
different transport addresses (IP address plus port) MUST 
be used in a session body and in an early-session body. Using 
different transport addresses (e.g., different ports) to 
receive early and regular media makes it easy to detect the 
start of the regular media.
****

Comments?

> -----Original Message-----
> From: Gonzalo Camarillo [mailto:[email-masked]] 
> Sent: Tuesday, December 16, 2003 23:11
> To: Dean Willis
> Cc: [email-masked]; [email-masked]
> Subject: Re: [Sipping] WGLC on Early Media Drafts
> 
> 
> Folks,
> 
> I have received one comment on the early media disposition type draft 
> that will be addressed adding the following text at the end 
> of the first 
> paragraph of Section 4:
> 
> ***
> It is also NOT RECOMMENDED to use the same transport address 
> (IP address 
> plus port) in a session body and in an early-session body. Using 
> different transport addresses (e.g., different ports) to 
> receive early 
> and regular media makes it easy to detect the start of the 
> regular media.
> ***
> 
> Gonzalo
> 
> Dean Willis wrote:
> 
> > Based on feedback from the Minneapolis meeting, it seems that the 
> > Early Media work is believed ready to proceed.
> > 
> > Please review:
> > 
> > 
> http://www.ietf.org/internet-drafts/draft-> ietf-sipping-early-media-01.
> > txt
> > 
> > 
> http://www.ietf.org/internet-drafts/draft-> ietf-sipping-early-dispositi
> > on-00.
> > txt
> > 
> > 
> > Please send any comments back to the authors, and copy the list if 
> > your comments are appropriate for public reading (and they SHOULD 
> > be!).
> > 
> > The working group last call for these documents will close 
> January 7, 
> > 2004.
> > 
> > Thanks,
> > 
> > --
> > Dean
> > 
> 
> 
> _______________________________________________
> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP
> Use [email-masked] for questions on current 
> sip Use [email-masked] for new developments of core SIP
>

---

From: Gonzalo Camarillo <[email-masked]>
Date: Fri, 19 Dec 2003 01:18:25 +0200

Francois,

> Gonzallo, Dean,

By the way, Gonzalo only has one "l" ;o)... I know that folks have 
problems spelling your name as well ;o)

> I'm not sure if I like Dean's recommendation

To be clear. I came up with that recommendation when I received a 
comment from Christer.

>, as many terminals may not

I am aware that some implementors, in particular gateway vendors, will 
use the same port anyway. That's why it is a NOT RECOMMENDED, instead of 
a MUST NOT. Nevertheless, from the standard point of view, you really 
need to distinguish between early and regular media every time, because 
if you do not do it, and the INVITE forks, you may get media clipping or 
mixing of media (early and regular) from different sources.

I believe that the NOT RECOMMENDED is a good compromise between what the 
standard should say about a general situation and what the implementors 
will do in controlled environments.

Thanks,

Gonzalo

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP