Subject: RE: [Sipping] User=Phone/DialString and Pause and Wait

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 2 Dec 2003 14:45:48 -0500

> Well, the configuration you don't do for the phone is 
> configuration you 
> have to do for the proxy instead. It doesn't substantially change the 
> problem.
Our experience is that it's quite a lot different.
You configure DHCP or the proxy once, and it's done.
Phones, you keep having to fiddle with
	Because every brand is just a little different
	Because users want to change things
	Because they come and go
> 
> If I have to manually enter the configuration into the phone 
> I agree it 
> is pretty evil in general. But if the configuration data for 
> the phone 
> lives somewhere in the network and is "discovered" when the 
> phone boots, 
> then it is much less evil. Then it doesn't matter much whether that 
> config data is consumed  by the phone or by a proxy.
If it's really discovered and really standardized I agree.
I think we have quite a long way to go before we get there.

> 
> Sip is postulated on smart endpoints. But smart endpoints need 
> information before they can act smart. It is still going to 
> take a bit 
> of work before phones can act smart and yet be used mix and match in 
> heterogeneous sip systems.
I'm actually surprised at how untrue this is.
If you know your outgoing proxy server, and the details of authentication,
you can get A LONG way towards zero touch.

It's when you do get into things like digitmaps that things get weird.
I think some phones try to be too configurable.

Our present systems, which to be sure usually work homogeneously
with our proxy, is zero touch.  Out of the box, plug in, and
logon (with a PC username and password).  Everything is discovered.
We do in fact use a discoverable configuration mechanism, which
is currently proprietary, to deal with terminal specific configuration.
Most of the personalization that we see in many other brands of phones
we think is misplaced from the user to the phone.  Things like
speed dials, UI choices, etc belong to a user, and not a phone,
and should be downloaded when you authenticate, and not when you boot 
the phone.  If you authenticate as the same user to a different 
phone, your personality should follow you.   But I digress.
> 
> I think there ought to be standards for configuring dial 
> plans that will 
> be executed by phones.
I agree

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 04 Dec 2003 15:59:38 -0500

> I think we have quite a long way to go before we get there.

Sure. But that is something we ought to be working on, because it is 
essential to interop. There is already some work in progress (though 
still at a very early stage):

- draft-ietf-sipping-ua-prof-framewk-reqs-00
- draft-stredicke-sipping-ep-config-00
   (now expired)

> It's when you do get into things like digitmaps that things get weird.

Sure. But that is the subject isn't it?

> logon (with a PC username and password). 

This is to register a PC softphone? Or to register a real sip phone?

How do you enter a PC username and password into a phone with just a 
number pad? Do you expect grandma to be able to do so?

 > Everything is discovered.

Yeah. And it will of course continue to be proprietary until there is a 
standard. But if you have this, proprietary or standard, then it can be 
used to load dialplans into a phone. Then the issue of sending 
dialstrings to the proxy becomes moot.

> phone, your personality should follow you.   But I digress.

No disagreement here. But this provides considerable latitude in where 
things are done. As long as the personalization info for the user/phone 
is managed centrally, it doesn't matter whether it is consumed by the 
phone or a proxy.

>>I think there ought to be standards for configuring dial 

Great!

	Paul