Subject: RE: [Sipping] WGLC on Early Media Drafts

From: "Francois Audet" <[email-masked]>
Date: Thu, 18 Dec 2003 15:35:13 -0800

> I am aware that some implementors, in particular gateway 
> vendors, will 
> use the same port anyway. That's why it is a NOT RECOMMENDED, 
> instead of 
> a MUST NOT. Nevertheless, from the standard point of view, you really 
> need to distinguish between early and regular media every 
> time, because 
> if you do not do it, and the INVITE forks, you may get media 
> clipping or 
> mixing of media (early and regular) from different sources.
> 
> I believe that the NOT RECOMMENDED is a good compromise 
> between what the 
> standard should say about a general situation and what the 
> implementors 
> will do in controlled environments.

I hadn't tought about gateways, but you are right that it would double
the number of required ports.

There are other issues as well, even for IP phones.

Using 2 different ports will mean that if you are using STUN, you will need
one more STUN query for the early media port. Same thing for ICE.

Then if you are using RSVP or NSIS, it will mean that you have to double the
procedures.

It just makes the process heavier in those cases.

Anyways, this is not a big issue to me, so I am OK with it.

---

From: "Christer Holmberg (JO/LMF)" <[email-masked]>
Date: Mon, 22 Dec 2003 15:26:56 +0100

Hi,
 
NOT RECOMMENDED is fine with me too, as long as it's not forbidden :) My issue, which I have been talking with Gonzalo about, has been related with the gateway issue, where one probably doesn't want to reserve two ports for every session setup.
 
Regards,
 
Christer Holmberg
Ericsson Finland

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Francois Audet
Sent: 19. joulukuuta 2003 1:35
To: Gonzalo Camarillo (JO/LMF)
Cc: 'Dean Willis'; [email-masked]'; [email-masked]'
Subject: RE: [Sipping] WGLC on Early Media Drafts

Then if you are using RSVP or NSIS, it will mean that you have to double the procedures.