Subject: RE: [Sipping] Concern within sos ID - user addresses reserved

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Thu, 12 Feb 2004 13:54:56 -0000

With a view of trying to borrow decisions from elsewhere.

In 3GPP when the phone recognises that it is an emergency call, and needs to identify the type of emergency call, then it has access to signal categories with the following names (ref 3GPP TS 22.101):

------------------------------
-	Police
-	Ambulance
-	Fire Brigade
-	Marine Guard
-	Mountain Rescue
-	Spare, at least [three] different types
-----------------------------

which results in a coding accompanying the call establishment of (ref 3GPP TS 24.008 table 10.5.135d)

--------------------------
Emergency Service Category Value (octet 3)
The meaning of the Emergency Category Value is derived from the following settings (Please see 3GPP TS 22.101 clause 8):
Bit 1	Police
Bit 2	Ambulance
Bit 3	Fire Brigade
Bit 4	Marine Guard
Bit 5	Mountain Rescue
Bits 6,7,8 are spare and set to "0"

Mobile station may set one or more bits to "1"
If more than one bit is set to "1", routing to a combined Emergency centre (e.g. ambulance and fire brigade in Japan) is required. If the MSC can not match the received service category to any of the emergency centres, it shall route the call to an operator defined default emergency centre.

If no bit is set to "1", the MSC shall route the Emergency call to an operator defined default emergency centre
-------------------------

These terms are at least accepted by multiple SDOs in the international community for transposition into their national standards.

I also note that 3GPP does have the capability of signalling multiple preferences - this left me wondering whether we would be better off trying to follow that, possibly with a single emergency uri, but with the possibility of signalling category as a URI parameter with a list of values. Any thoughts on this?

regards

Keith

> -----Original Message-----
> From: Andrew Allen [mailto:[email-masked]]
> Sent: 11 February 2004 16:57
> To: [email-masked]; [email-masked]
> Subject: Re: [Sipping] Concern within sos ID - user addresses reserved
> 
> 
> 
> 
> How about sos.medical then since that outlines the type of 
> emergency. I agree that rescue may be confused with the others.
> 
> Andrew
> --------------------------
> Andrew Allen
> Manager Standards
> Research In Motion Ltd
> BlackBerry Mobile  +1 847 809 8636
> European Mobile    +358 50 467 5870
> http://www.rim.com/
> 
> Sent from my BlackBerry Wireless Handheld
> 
> 
> -----Original Message-----
> From: Michael Hammer <[email-masked]>
> To: [email-masked] <[email-masked]>
> Sent: Wed Feb 11 10:45:29 2004
> Subject: Re: [Sipping] Concern within sos ID - user addresses reserved
> 
> At 03:55 PM 2/10/2004 -0600, James M. Polk wrote:
> >         sos.fire                fire brigade
> >         sos.rescue      ambulance (rescue)
> >         sos.marine      marine guard
> >         sos.police      police (law enforcement)
> >         sos.mountain    mountain rescue
> 
> The second sub-address seems vague to me.  Rescue could mean many 
> things.  Perhaps, I need to be rescued from a fashion 
> emergency. :)  Would 
> something like:
> 
>          sos.medic        medical (doctor, nurse, paramedic team)
> 
> be more descriptive?
> 
> Also, with respect to registrations, I could see commercial interests 
> wanting to get into the act, such as an sos.fashion that I hinted at 
> above.  Is there some guidance necessary to IANA?  Do we 
> expect that the 
> IETF WGs will act as arbiters for this?
> 
> Second, wrt location information reporting, is there any need for a 
> convention for providing a URL to which a receiving ECC can 
> SUBSCRIBE to 
> get location updates from either the UA or a network element 
> that is doing 
> triangulation.  I am wondering if something like the following can be 
> inserted into the emergency INVITE:
> 
> Call-Info: <sips:[email-masked]> 
> ;purpose=location
> 
> Mike
> 
> 
> _______________________________________________
> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments of core SIP
> 
> 
> _______________________________________________
> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments of core SIP
> 

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Henning Schulzrinne <[email-masked]>
Date: Thu, 12 Feb 2004 09:15:47 -0500

Interesting. The selection sounds like caller preferences to me. The 
nice thing about that is that you might be able to use existing 
techniques to match up services and destinations.

For example, this could be considered a sip.class value, extending 
'home' and 'business', or a new media feature tag, either specific to 
emergency services or a more generic service identifier. (The latter 
does invite the fashion emergency and roadside repair services into the 
same namespace.)

---

From: David Oran <[email-masked]>
Date: Thu, 12 Feb 2004 12:07:54 -0500

--On Thursday, February 12, 2004 1:54 PM +0000 "Drage, Keith (Keith)" 
<[email-masked]> wrote:

> In 3GPP when the phone recognises that it is an emergency call, and needs
> to identify the type of emergency call, then it has access to signal
> categories with the following names (ref 3GPP TS 22.101):
>
> The meaning of the Emergency Category Value is derived from the following
> settings (Please see 3GPP TS 22.101 clause 8): Bit 1	Police
> Bit 2	Ambulance
> Bit 3	Fire Brigade
> Bit 4	Marine Guard
> Bit 5	Mountain Rescue
> If more than one bit is set to "1", routing to a combined Emergency
> centre (e.g. ambulance and fire brigade in Japan) is required. If the MSC
> can not match the received service category to any of the emergency
> centres, it shall route the call to an operator defined default emergency
> centre.
>
> If no bit is set to "1", the MSC shall route the Emergency call to an
> operator defined default emergency centre -------------------------
>
> These terms are at least accepted by multiple SDOs in the international
> community for transposition into their national standards.
>
> I also note that 3GPP does have the capability of signalling multiple
> preferences - this left me wondering whether we would be better off
> trying to follow that, possibly with a single emergency uri, but with the
> possibility of signalling category as a URI parameter with a list of
> values. Any thoughts on this?
>
Actually, this seems like ideal fodder for caller prefs, no?