Subject: RE: [Sipping] sos - dead or alive

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 17 Feb 2004 15:37:35 -0500

If the SIP URI for a PSAP was sip:[email-masked], and the
test
URI was sip:[email-masked], I don't think we have any routing
problems.  The router for chicago.il.us would get exercised for test code,
but not the proxy.

I like the scaling idea.

RTCP has never been tested with a billion phones randomly trying anything.
I think we need to be careful. Very careful.

Brian

> -----Original Message-----
> From: Henning Schulzrinne [mailto:[email-masked]]
> Sent: Tuesday, February 17, 2004 3:28 PM
> To: Rosen, Brian
> Cc: 'Cullen Jennings'; [email-masked]
> Subject: Re: [Sipping] sos - dead or alive
> 
> 
> 
> 
> Rosen, Brian wrote:
> 
> > Probably need a separate URI for this; don't want to have even a 
> > possibility for overwhelming the real proxy server.  It 
> would be easy
> > for the test one to heartbeat the real one to keep them in sync.
> 
> While you can obviously do method-based routing, I would worry about 
> building any such knowledge into the UA. After all, you want 
> to test as 
> much of the whole chain as you can.
> 
> To improve scaling, an outbound proxy could answer all such OPTIONS 
> requests to keep testing load local, depending on our perception of 
> where the likely failures are. (The emergency-call-aware 
> outbound proxy 
> could then in turn exercise the path from itself to the ECCs of 
> interest, but you'd then have one per company or provider, instead of 
> 10,000 tests per campus.)
> 
> > 
> > We could define a more precise algorithm based on lsbs of 
> IP address to
> > randomize test times.
> 
> I don't think that helps much beyond simple randomization. We have 
> reasonably good experience with randomization in RTCP after all.
> 

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Henning Schulzrinne <[email-masked]>
Date: Tue, 17 Feb 2004 15:45:26 -0500

Unless this is identified in the mapping algorithm (location -> ECC), I 
don't see how a device can find the test destination.