Subject: RE: [Sipping] Concern within sos ID - user addresses reserved

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Fri, 13 Feb 2004 11:52:28 -0000

Depending on which 3GPP release you get there are a number of mechanisms.
 
1)    Certain numbers are built into the phone and recognised there.
 
2)    Certain numbers are preloaded onto the SIM/UICC card by the operator at subscription time.
 
3)    Numbers can be downloaded to the phone at registration time from the local providing access network.
 
These are identified in the various versions of 22.101 (see http://www.3gpp.org/ftp/Specs/html-info/22101.htm <http://www.3gpp.org/ftp/Specs/html-info/22101.htm> ) clause 10.
 
I am not sure what terminal manufacturers do in the case of setting the bits for phones supplied for use in the US, however inspection of the 3GPP TS 24.008 text says that in the US, whatever the bits are set to, or not set at all, the call will be routed to an emergency centre. Note that this category element does not determine an emegency call, only the category of an emergency call. A call identified by the terminal as an emergency call will be sent with an EMERGENCY SETUP message rather than a SETUP message. Special characteristics of the EMERGENCY SETUP message include ignoring any called party number sent in that message.
 
Note that none of the above mechanisms can guarantee that an emergency call is always identified as such at the phone, and therefore there is also a responsibility on the local serving network to do its own analysis as well. In the 3GPP SIP environment, that responsibility may well extend to other proxies, with the need to reroute back to the country of origin (all calls carry the mobile country code and mobile network code as well as potentially geographic information).
 
regards
 
Keith

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: 12 February 2004 20:52
To: [email-masked]; [email-masked]
Subject: Re: [Sipping] Concern within sos ID - user addresses reserved

In a message dated 2/12/2004 8:58:35 AM Eastern Standard Time, [email-masked] writes: 

...

I also note that 3GPP does have the capability of signalling multiple preferences - this left me wondering whether we would be better off trying to follow that, 

possibly with a single emergency uri, but with the possibility of signalling category as a URI parameter with a list of values. Any thoughts on this? 

It's always good to use other standards as the base. This list of "subadresses" is good. But I still don't see how a 3GPP phone can translate number dialed into one of these, unless it knows the local dial plan, or knows all dial plans and knows its location. 

Does the 3GPP spec mean that, if someone dials 911 in the US, that all bits must be set? 

Mike Pierce

---

From: Henning Schulzrinne <[email-masked]>
Date: Fri, 13 Feb 2004 08:51:41 -0500

Thanks for the pointer. From the description, Mike should talk to 3GPP 
about his concerns :-)

http://www.3gpp.org/ftp/Specs/archive/22_series/22.101/22101-660.zip 
(SP-22) has pretty much the mechanisms described in the SOS draft.

Note, in particular, in Section 10.1:

"The user friendly MMI that specifies the type of emergency directly 
(e.g. menu) should be supported for use in any (i.e. home or visited) 
PLMN to avoid the mis-connection in roaming case.  This shall be allowed 
both with and without SIM/USIM being present."

and 10.1.1

"a)	112 and 911 shall always be available. These numbers shall be stored 
on the ME.
b)	Any emergency number stored on a SIM/USIM when the SIM/USIM is present.
c)	000, 08, 110, 999, 118 and 119 when a SIM/USIM is not present. These 
numbers shall be stored on the ME.
d)	Additional emergency numbers that may have been downloaded by the 
serving network when the SIM/USIM is present."

Note that bullet (b) specifically means that a traveling user will have 
his or her home emergency numbers available even when roaming.

Unless we identify an equivalent set of personalization mechanisms for 
item (c), these would always have to be recognized, given that most 
non-3G SIP phones don't seem to carry SIMs or equivalent devices. 
Suggestions are most welcome here.

My general inclination is to follow the spirit of this document, as it 
seems strange that if a user is used to be able to dial 112 on a 
SIM-less 3GPP SIP device that this wouldn't work on a non-3GPP SIP phone.

Henning

Drage, Keith (Keith) wrote:

> These are identified in the various versions of 22.101 (see 
> http://www.3gpp.org/ftp/Specs/html-info/22101.htm) clause 10.
>  
> I am not sure what terminal manufacturers do in the case of setting the 
> bits for phones supplied for use in the US, however inspection of the 
> 3GPP TS 24.008 text says that in the US, whatever the bits are set to, 
> or not set at all, the call will be routed to an emergency centre. Note 
> that this category element does not determine an emegency call, only the 
> category of an emergency call. A call identified by the terminal as an 
> emergency call will be sent with an EMERGENCY SETUP message rather than 
> a SETUP message. Special characteristics of the EMERGENCY SETUP message 
> include ignoring any called party number sent in that message.
>  
> Note that none of the above mechanisms can guarantee that an emergency 
> call is always identified as such at the phone, and therefore there is 
> also a responsibility on the local serving network to do its own 
> analysis as well. In the 3GPP SIP environment, that responsibility may 
> well extend to other proxies, with the need to reroute back to the 
> country of origin (all calls carry the mobile country code and mobile 
> network code as well as potentially geographic information).
>  
> regards
>  
> Keith
> 
>     *From:* [email-masked] [mailto:[email-masked]]
>     *Sent:* 12 February 2004 20:52
>     *To:* [email-masked]; [email-masked]
>     *Subject:* Re: [Sipping] Concern within sos ID - user addresses reserved
> 
>     I also note that 3GPP does have the capability of signalling
>     multiple preferences - this left me wondering whether we would be
>     better off trying to follow that,
> 
>>     possibly with a single emergency uri, but with the possibility of
>>     signalling category as a URI parameter with a list of values. Any
>>     thoughts on this?
> 
> 
>     It's always good to use other standards as the base. This list of
>     "subadresses" is good. But I still don't see how a 3GPP phone can
>     translate number dialed into one of these, unless it knows the local
>     dial plan, or knows all dial plans and knows its location.
> 

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP