Subject: [Fwd: RE: [Sipping] I-D ACTION:draft-ietf-sipping-kpml-02.txt]

From: "Christer Holmberg (JO/LMF)" <[email-masked]>
Date: Tue, 24 Feb 2004 16:25:57 +0100

Hi,

I guess this is a clarification question on kpml, as well as on gruu (and functions where gruu is used) in general.

If you have a node that doesn't register, but eg wants to use kpml (a gateway, for example), could it generate the gruu on its own, or is it "mandated" to use the register mechanism? If the register mechanism is not used, are there any issues which could come up?

Regards,

Christer Holmberg
Ericsson Finland

> -------- Original Message --------
> Subject: RE: [Sipping] I-D ACTION:draft-ietf-sipping-kpml-02.txt
> Date: Mon, 23 Feb 2004 17:34:22 -0500
> From: Eric Burger <[email-masked]>
> To: Jonathan Rosenberg <[email-masked]>, <[email-masked]>
> 
> Yep, yep, yep, we can (and will) use GRUU.
> 
> > -----Original Message-----
> > From: Jonathan Rosenberg [mailto:[email-masked]]
> > Sent: Thursday, February 05, 2004 2:46 AM
> > To: [email-masked]
> > Subject: Re: [Sipping] I-D ACTION:draft-ietf-sipping-kpml-02.txt
> > 
> > 
> > Eric,
> > 
> > The draft talks about sending the subscribe requests on the 
> > same dialog 
> > as the INVITE. For many reasons that have been discussed ad 
> > nauseam on 
> > the list, dialog sharing is a bad idea. GRUU provides a 
> solution that 
> > does not require dialog sharing. As I recall, there was 
> discussion on 
> > this point in the last ietf, and this seemed to be the 
> > preferred direction.
> > 
> > Is there any reason we cant change this to use gruu's rather 
> > than dialog 
> > sharing?
> > 
> > Also, you are missing the IANA registration for the kpml 
> > event package.
> > 
> > Thanks,
> > Jonathan R.
> > 
> > [email-masked] wrote:
> > 
> > > A New Internet-Draft is available from the on-line 
> > Internet-Drafts directories.
> > > This draft is a work item of the Session Initiation 
> > Proposal Investigation Working Group of the IETF.
> > > 
> > > 	Title		: Keypad Stimulus Protocol (KPML)
> > > 	Author(s)	: E. Burger
> > > 	Filename	: draft-ietf-sipping-kpml-02.txt
> > > 	Pages		: 42
> > > 	Date		: 2004-2-4
> > > 	
> > > The Key Press Stimulus Protocol uses the SIP SUBSCRIBE/NOTIFY
> > >    mechanism and Keypad Markup Language (KPML) to provide 
> > instructions
> > >    to SIP User Agents for the reporting of user key presses.
> > > 
> > > A URL for this Internet-Draft is:
> > > http://www.ietf.org/internet-drafts/draft-ietf-sipping-kpml-02.txt
> > > 
> > > To remove yourself from the IETF Announcement list, send a 
> > message to 
> > > ietf-announce-request with the word unsubscribe in the body 
> > of the message.
> > > 
> > > Internet-Drafts are also available by anonymous FTP. Login 
> > with the username
> > > "anonymous" and a password of your e-mail address. After 
> logging in,
> > > type "cd internet-drafts" and then
> > > 	"get draft-ietf-sipping-kpml-02.txt".
> > > 
> > > A list of Internet-Drafts directories can be found in
> > > http://www.ietf.org/shadow.html 
> > > or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> > > 
> > > 
> > > Internet-Drafts can also be obtained by e-mail.
> > > 
> > > Send a message to:
> > > 	[email-masked].
> > > In the body type:
> > > 	"FILE /internet-drafts/draft-ietf-sipping-kpml-02.txt".
> > > 	
> > > NOTE:	The mail server at ietf.org can return the document in
> > > 	MIME-encoded form by using the "mpack" utility.  To use this
> > > 	feature, insert the command "ENCODING mime" before the "FILE"
> > > 	command.  To decode the response(s), you will need "munpack" or
> > > 	a MIME-compliant mail reader.  Different MIME-compliant 
> > mail readers
> > > 	exhibit different behavior, especially when dealing with
> > > 	"multipart" MIME messages (i.e. documents which have been split
> > > 	up into multiple messages), so check your local documentation on
> > > 	how to manipulate these messages.
> > > 		
> > > 		
> > > Below is the data which will enable a MIME compliant mail reader
> > > implementation to automatically retrieve the ASCII version of the
> > > Internet-Draft.
> > > 
> > 
> > -- 
> > Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
> > Chief Technology Officer                    Parsippany, NJ 
> 07054-2711
> > dynamicsoft
> > [email-masked]                     FAX:   (973) 952-5050
> > http://www.jdrosen.net                      PHONE: (973) 952-5000
> > http://www.dynamicsoft.com
> > 
> > _______________________________________________
> > Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> > This list is for NEW development of the application of SIP
> > Use [email-masked] for questions on current sip
> > Use [email-masked] for new developments of core SIP
> > 
> > 
> 
> 
> _______________________________________________
> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments of core SIP
> 
> 
> 
> -- 
> Gonzalo Camarillo         Phone :  +358  9 299 33 71
> Oy L M Ericsson Ab        Mobile:  +358 40 702 35 35
> Telecom R&D               Fax   :  +358  9 299 30 52
> FIN-02420 Jorvas          Email :  [email-masked]
> Finland                   http://www.hut.fi/~gonzalo
> 

This communication is confidential and intended solely for the addressee(s). Any unauthorized review, use, disclosure or distribution is prohibited. If you believe this message has been sent to you in error, please notify the sender by replying to this transmission and delete the message without disclosing it. Thank you.

E-mail including attachments is susceptible to data corruption, interruption, unauthorized amendment, tampering and viruses, and we only send and receive e-mails on the basis that we are not liable for any such corruption, interception, amendment, tampering or viruses or any consequences thereof.

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 25 Feb 2004 14:45:32 -0500

Christer Holmberg (JO/LMF) wrote:

> Hi,
> 
> I guess this is a clarification question on kpml, as well as on gruu
> (and functions where gruu is used) in general.
> 
> If you have a node that doesn't register, but eg wants to use kpml (a
> gateway, for example), could it generate the gruu on its own, or is
> it "mandated" to use the register mechanism? If the register
> mechanism is not used, are there any issues which could come up?

Use of the registration mechanism is not mandated; the spec says that 
this is one way, but not the only possible way, to get a gruu. However, 
no other mechanisms are standardized at this time.

Generating your own gruu is probably a bad idea, since it is extremely 
hard to guarantee that it is indeed globally routable.

-Jonathan R.

Chief Technology Officer                    Parsippany, NJ 07054-2711