Subject: Betr.: [Sipping] ToIP Requirements

From: "A vWijk" <[email-masked]>
Date: Tue, 24 Feb 2004 13:21:52 +0100

Hello Gonzalo,
While there are device requirements in the text. Those requirements and the explanation on the different analogue text telephone systems is included to give the reader an understanding what kind of devices will connect with ToIP. And the need for the text gateways. And what the different behaviour can/may be compared to end to end IP devices.
The most important part will be the ToIP framwork and the text gateways and how such gateways will be used and work with the ToIP framework.

There is a ToIP framework where a terminal uses streaming text as defined in RFC2793 to connect with any other Interactive texting/real-time streaming text device.
This can be end-to-end IP, and a direct T140/RTP stream is established with SIP. But in other cases, a text gateway must be used to allow T.140/RTP to connect with a non IP text telephony device.
It can be an analogue text telephone (TDD/TTY) that uses a text gateway to be able to understand RFC2793 text. (PSTN-IP)
It can be a mobile phone running GPRS that uses the text gateway to understand RFC2793 text. (this exist right NOW using SIP! And those gateways will be used in mobile networks this year!)
Or a mobile text telephone using CTM via the text gateway to communicate with RFC2793 text.
Or even one analogue text telephone connecting to another analogue text telephone in a different country, and the PSTN's use IP to connect the call.

The question is for example, how do we use that gateway from the IP side? Is it invisible for the IP side? Or do we need special extensions in SIP to that the IP terminal knows it is communicating with the end-device through the text gateway?
There may be a slightly different call setup flow when a text gateway is included.
Or additional SIP messages indicating gateway activity. When you connect for example to an analogue text telephone with an RFC2793 capable IP terminal the capabilities will be less then IP to IP terminal directly (different transmission speeds, half/full duplex etc).
Or what to do with emergency calls that are in RFC 2793 text only? 

That are requirements that will be defined and worked out in this draft.
Also, we want to make everybody in SIP and SIPPING aware about those text gateways. So that complicated matters like how to send analogue text telephone text through a PSTN and connect with a SIP telephone using RFC2793 interactive texting. When using the text gateway, there is then no need for RFC 2833 events at the PSTN for text telephones. 

So, yes. I believe that this should be in the SIPPING WG. And it will fit in the charter - support for hearing-/speech-impaired calling.

greetz

Arnoud

Drs. Arnoud A. T. van Wijk
Viataal
Research & Development
Afdeling RDS
Theerestraat 42
5271 GD Sint-Michielsgestel
The Netherlands.
Mobile: +31651921948
International text telephone: +31735588408

>>> Gonzalo Camarillo <[email-masked]> 24-02-04 10:21 >>>
Hello,

the draft below provides a set of requirements for real-time 
conversations using SIP.
http://www.ietf.org/internet-drafts/draft-manyfolks-sipping-toip-01.txt 

Nevertheless, I have found a lot of device requirements in the text, but 
I fail to understand which particular protocol requirements we need to 
fulfill with new protocol extensions.

While SIPPING is the right place to handle requirements that will lead 
to new SIP protocol extensions, SIPPING may not be the right place to 
deal with device requirements (e.g., text phones MUST have a display of 
at least 100 characters).

Thanks,

Gonzalo

This communication is confidential and intended solely for the addressee(s). Any unauthorized review, use, disclosure or distribution is prohibited. If you believe this message has been sent to you in error, please notify the sender by replying to this transmission and delete the message without disclosing it. Thank you.

E-mail including attachments is susceptible to data corruption, interruption, unauthorized amendment, tampering and viruses, and we only send and receive e-mails on the basis that we are not liable for any such corruption, interception, amendment, tampering or viruses or any consequences thereof.

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping 
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Gunnar Hellstrom" <[email-masked]>
Date: Wed, 25 Feb 2004 22:54:12 +0100

I think PSTN textphone gateway invocation is one area where we either need
protocol extensions, or need agreements on what current mechanisms to use.

Another is invocation of various kinds of relay services or translation
services.

A third is calling emergency services and reach positions capable of
handling the type of communication that the user prefers.

Gunnar
-------------------------------------------
Gunnar Hellstrom
Omnitor AB
Renathvagen 2
SE 121 37 Johanneshov
SWEDEN
+46 8 556 002 03
Mob: +46 708 204 288
www.omnitor.se
[email-masked]
--------------------------------------------

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
A vWijk
Sent: Tuesday, February 24, 2004 1:22 PM
To: [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked];
[email-masked]; [email-masked]; [email-masked]
Subject: Betr.: [Sipping] ToIP Requirements

Hello Gonzalo,
While there are device requirements in the text. Those requirements and the
explanation on the different analogue text telephone systems is included to
give the reader an understanding what kind of devices will connect with
ToIP. And the need for the text gateways. And what the different behaviour
can/may be compared to end to end IP devices.
The most important part will be the ToIP framwork and the text gateways and
how such gateways will be used and work with the ToIP framework.

There is a ToIP framework where a terminal uses streaming text as defined in
RFC2793 to connect with any other Interactive texting/real-time streaming
text device.
This can be end-to-end IP, and a direct T140/RTP stream is established with
SIP. But in other cases, a text gateway must be used to allow T.140/RTP to
connect with a non IP text telephony device.
It can be an analogue text telephone (TDD/TTY) that uses a text gateway to
be able to understand RFC2793 text. (PSTN-IP)
It can be a mobile phone running GPRS that uses the text gateway to
understand RFC2793 text. (this exist right NOW using SIP! And those gateways
will be used in mobile networks this year!)
Or a mobile text telephone using CTM via the text gateway to communicate
with RFC2793 text.
Or even one analogue text telephone connecting to another analogue text
telephone in a different country, and the PSTN's use IP to connect the call.

The question is for example, how do we use that gateway from the IP side? Is
it invisible for the IP side? Or do we need special extensions in SIP to
that the IP terminal knows it is communicating with the end-device through
the text gateway?
There may be a slightly different call setup flow when a text gateway is
included.
Or additional SIP messages indicating gateway activity. When you connect for
example to an analogue text telephone with an RFC2793 capable IP terminal
the capabilities will be less then IP to IP terminal directly (different
transmission speeds, half/full duplex etc).
Or what to do with emergency calls that are in RFC 2793 text only?

That are requirements that will be defined and worked out in this draft.
Also, we want to make everybody in SIP and SIPPING aware about those text
gateways. So that complicated matters like how to send analogue text
telephone text through a PSTN and connect with a SIP telephone using RFC2793
interactive texting. When using the text gateway, there is then no need for
RFC 2833 events at the PSTN for text telephones.

So, yes. I believe that this should be in the SIPPING WG. And it will fit in
the charter - support for hearing-/speech-impaired calling.

greetz

Arnoud

Hello,

Thanks,

Gonzalo

This communication is confidential and intended solely for the addressee(s).
Any unauthorized review, use, disclosure or distribution is prohibited. If
you believe this message has been sent to you in error, please notify the
sender by replying to this transmission and delete the message without
disclosing it. Thank you.

E-mail including attachments is susceptible to data corruption,
interruption, unauthorized amendment, tampering and viruses, and we only
send and receive e-mails on the basis that we are not liable for any such
corruption, interception, amendment, tampering or viruses or any
consequences thereof.