Subject: RE: [Sipping] TCAP tunneling

From: [email-masked]
Date: Mon, 2 Feb 2004 10:20:01 +0530

Hi
   TCAP is used for Transaction Capabilities i.e database related while
SIP with ISUP tunneling is used between MGCs. So I don't think TCAP can
be tunneled in SIP.

Ranjit
Ph: 8520408/16 extn: 2173

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Kaitki Agarwal
Sent: Monday, February 02, 2004 8:28 AM
To: [email-masked]
Subject: [Sipping] TCAP tunneling

Hi
 Can we tunnel tcap message in SIP as we do  ISUP. If not why. 
 
Thanks
Kaitki
Jj~Yzy=i~Rz}y

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Banibrata Dutta" <[email-masked]>
Date: Mon, 2 Feb 2004 10:55:31 +0530

hi,

franly, i'd say that, it depends on your motivation/reason to use SIP
for 
tunneling TCAP. of course you can tunnel TCAP, but why you'd want to, is
a justification you'd have to work out. AFAIK, there's not ietf-draft
that
says, how.

you can obviously tunnel TCAP query in an INVITE or INFO for that matter

(ideally in INVITE s.t. a SIP-dialog is also created which may be used
to
model the TCAP dialog as well, perhaps!). the ASN.1 BER encoded TCAP
messages may then reside within the body of a multi-part (MIME) enc,
INVITE.

infact 1 reason i see where this may make sense is that you would rather
not have two stacks s.a. SIGTRAN and SIP for signalling transport, and
use
SIP as the *only* signalling solution, i.e. for the signalling
application
as well as for signalling transport, and support legacy/TCAP apps by
tunneling
them within SIP. but then, you generally have the constraints of
not-enough-
space, (for 2 stacks) only on resource-limited devices, s.a. hand-sets,
embedded devices etc., but i am unable see (yet), how TCAP can be
related to
such devices.

my 2 cents,
Banibrata Dutta,
  Hewlett-Packard ISO (P) Ltd,
  29, Cunningham Road,
  Bangalore - 560052
  Ph: +91-80-22051796

> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of [email-masked]
> Sent: Monday, February 02, 2004 10:20 AM
> To: [email-masked]; [email-masked]
> Subject: RE: [Sipping] TCAP tunneling
> 
> 
> Hi
>    TCAP is used for Transaction Capabilities i.e database 
> related while SIP with ISUP tunneling is used between MGCs. 
> So I don't think TCAP can be tunneled in SIP.
> 
> Ranjit
> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of Kaitki Agarwal
> Use [email-masked] for questions on current 
> sip Use [email-masked] for new developments of core SIP
>