Subject: [Sipping] Translating ISDN IE or SS7 optional fields to SIP

From: Joseph Herman <[email-masked]>
Date: Thu, 12 Feb 2004 18:01:19 -0500

Is there a document that defines (or proposes) a standard way to map 
protocol specific information into SIP to be consumed by a UA?   SIP-T 
provides  the entire SS7 packet embedded in the SIP message rather than a 
translation of the fields.   I am hoping for a mapping like

redirection-number <==> redir-num: SIP header field

Is there such a document?

                                        Thanks for any info,
                                        Joe H.

--
Joe Herman
IBM Annapolis RM Telephony Solutions
410-571-7117
[email-masked]

Everything is wonderful until you know something about it.

---

From: "Banibrata Dutta" <[email-masked]>
Date: Fri, 13 Feb 2004 10:06:04 +0530

One quick way would be to check that out by searching the ID-list hosted
at the
very useful http://softarmor.com/sipping/ site.
AFAIK, such a draft doesn't exist. SIP-T is what comes closest (i
think).
 
-BDutta.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Joseph Herman
Sent: Friday, February 13, 2004 4:31 AM
To: [email-masked]
Subject: [Sipping] Translating ISDN IE or SS7 optional fields to SIP

Is there a document that defines (or proposes) a standard way to map
protocol specific information into SIP to be consumed by a UA?   SIP-T
provides  the entire SS7 packet embedded in the SIP message rather than
a translation of the fields.   I am hoping for a mapping like 

                                        Thanks for any info, 
                                        Joe H.

---

From: [email-masked]
Date: Fri, 13 Feb 2004 10:41:01 +0530

RFC 3398 - Integrated Services Digital Network (ISDN) User Part (ISUP) to
Session Initiation Protocol (SIP) Mapping.
This RFC describes a way to perform the mapping between SIP and ISUP
(message and parameter level).

-
Elias
Hughes Software Systems
http://www.hssworld.com
-

             Joseph Herman                                                 
             <[email-masked].                                             
             com>                                                       To 
             Sent by:                  [email-masked]                    
             sipping-admin@iet                                          cc 
             f.org                                                         
                                                                   Subject 
                                       [Sipping] Translating  ISDN IE or   
             02/13/04 04:31 AM         SS7 optional fields to SIP          

                                                                           

                                        Thanks for any info,
                                        Joe H.

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Tom Taylor <[email-masked]>
Date: Fri, 13 Feb 2004 11:24:09 -0500

Also, the ITU-T and regional bodies (ANSI T1S1 for sure) are defining their own 
rules.  The ITU-T reference is Q.1912.5.

---

From: Alex Audu <[email-masked]>
Date: Fri, 13 Feb 2004 13:49:42 -0600

And for ISUP Overlap Signaling to SIP mapping, see rfc3578

Alex.