Subject: [Sipping] RE: Conferencing for UAs

From: [email-masked]
Date: Tue, 24 Feb 2004 14:15:30 +0200

Gonzalo:

The idea is fine, but I am afraid we may end up defining Associated-Transaction-State, Associated-Conference-State, Associated-XXX-State.

Aren't we heading to defining a generic Associated-State header with a "role" parameter that contains a value "transaction", "conference", "xxx", etc...

/Miguel

> -----Original Message-----
> From: ext Gonzalo Camarillo [mailto:[email-masked]]
> Sent: 24 February, 2004 14:06
> To: sipping
> Cc: Alan Johnston; Orit Levin; Garcia Miguel.An (Nokia-NRC/Helsinki)
> Subject: Conferencing for UAs
> 
> 
> Hello,
> 
> some comments on the following draft:
> http://www.ietf.org/internet-drafts/draft-ietf-sipping-cc-conf
> erencing-03.txt
> 
> The focus of a conference returns the conference URI in the contact 
> header field of the 200 OK for the INVITE. The UAC uses this URI to 
> SUBSCRIBE to the conf package (using a new dialog)...
> 
> Why are we forcing the focus to use the same URI for receiving the 
> INVITEs from all the users and for receiving the SUBSCRIBEs? 
> I believe 
> the solution would be cleaner if we defined a new header field (e.g., 
> Associated-Conf-State) that carried a globally routable URI. 
> The 200 OK 
> for the initial INVITE (or the INVITE in a dial-out case) would carry 
> this header field. This would keep separate the URI used for 
> joining the 
> conference and the URI used for subscribing to the state of 
> the conference.
> 
> This is actually the approach that the draft below follows:
> http://www.ietf.org/internet-drafts/draft-camarillo-sipping-tr
ansac-package-00.txt

We define the Associated-Transactions-State to be returned, for example, 
in the 200 OK of a MESSAGE sent to an exploder. Note that we had to 
create this new header because MESSAGE does not carry a Contact 
header... following the same approach in both, the conferencing work and 
the exploders work would be good, in my opinion.

Comments?

Thanks,

Gonzalo

This communication is confidential and intended solely for the addressee(s). Any unauthorized review, use, disclosure or distribution is prohibited. If you believe this message has been sent to you in error, please notify the sender by replying to this transmission and delete the message without disclosing it. Thank you.

E-mail including attachments is susceptible to data corruption, interruption, unauthorized amendment, tampering and viruses, and we only send and receive e-mails on the basis that we are not liable for any such corruption, interception, amendment, tampering or viruses or any consequences thereof.

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Gonzalo Camarillo <[email-masked]>
Date: Tue, 24 Feb 2004 14:20:26 +0200

Hi,

> Aren't we heading to defining a generic Associated-State header with
> a "role" parameter that contains a value "transaction", "conference",
> "xxx", etc...

I actually do not care how we encode this information; in a header with 
several parameters or in multiple headers (in any case, you may be right 
that using a single header could be cleaner).

What I want to know is whether or not people think that it is worthwhile 
keeping separate the URI used for the INVITE dialog and the one (or 
ones) used for subscriptions to some piece of state that is associated 
somehow with that dialog. My personal opinion is that we should keep 
them separate.

Gonzalo

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 25 Feb 2004 14:48:19 -0500

I think the same URI makes sense. At the core, there really is one 
resource here - the conference. All that differs is the methods that are 
invoked on it and how that resource behaves when users contact it. 
Subscribing to it and initiating a session to it are two different 
methods, but both against fundamentally the same resource.

-Jonathan R.

Gonzalo Camarillo wrote:

> This communication is confidential and intended solely for the 
> addressee(s). Any unauthorized review, use, disclosure or distribution 
> is prohibited. If you believe this message has been sent to you in 
> error, please notify the sender by replying to this transmission and 
> delete the message without disclosing it. Thank you.
> 
> E-mail including attachments is susceptible to data corruption, 
> interruption, unauthorized amendment, tampering and viruses, and we only 
> send and receive e-mails on the basis that we are not liable for any 
> such corruption, interception, amendment, tampering or viruses or any 
> consequences thereof.
> 
> 

-- 
Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
Chief Technology Officer                    Parsippany, NJ 07054-2711
dynamicsoft
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com