Subject: RE: Betr.: [Sipping] ToIP Requirements

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 26 Feb 2004 09:36:23 -0500

Arnoud

I do not believe this can work.  A TDD user dials 112 or 911.  Today, this
will be routed directly to a "selective router" (a TDM switch) which sends
the
call to the correct Emergency Response Center.  You can't insert a gateway,
because you don't know that it's a TDD call until it is answered.  To make
it work, you would have to establish a special PSTN number for emergency
TDD,
which would route to the gateway, which would then call the ERC.  I don't
believe that is practical.

Brian

> -----Original Message-----
> From: Arnoud van Wijk [mailto:[email-masked]]
> Sent: Thursday, February 26, 2004 9:17 AM
> To: 'Rosen, Brian'; 'Gunnar Hellstrom'; 
> [email-masked];
> [email-masked]
> Cc: [email-masked]; [email-masked]; 
> [email-masked];
> [email-masked]; [email-masked]
> Subject: RE: Betr.: [Sipping] ToIP Requirements
> 
> 
> Hello Brian,
> That is also why we need to look at the emergency call system.
> This text gateway is only at the PSTN side, thus another 
> requirement for a
> T140/RTP gateway for the PSTN is that when a local emergency number is
> dialled (112, or 911 etc). That the gateway must be able to 
> receive that
> call (even dropping existing calls if necessary). Such a call 
> is easy to
> recognize as an emergency call. (PSTN side).
> From that gateway on, it is all IP with RFC2793 interactive 
> text. And then
> it is just all existing SIP as if it was from an IP end-point.
> 
> This gives emergency centers an advantage, all calls will be 
> T.140/RTP, so
> integration in their computer systems will be easy instead 
> being forced to
> have analog textphones available for a textphone call. (or a 
> separate text
> telephone emergency center).
> 
> /Arnoud
> 
> Drs. Arnoud A. T. van Wijk
> Viataal
> Research & Development
> Afdeling RDS
> Theerestraat 42
> 5271 GD Sint-Michielsgestel
> The Netherlands. 
> Mobile: +31651921948
> International text telephone: +31735588408
> 
> 
> -----Original Message-----
> From: Rosen, Brian [mailto:[email-masked]] 
> Sent: donderdag 26 februari 2004 15:04
> To: 'Arnoud van Wijk'; 'Gunnar Hellstrom'; 
> [email-masked];
> [email-masked]
> Cc: [email-masked]; [email-masked]; 
> [email-masked];
> [email-masked]; [email-masked]
> Subject: RE: Betr.: [Sipping] ToIP Requirements
> 
> Arnoud
> 
> Generally, you don't want to rely on very many SIP elements 
> to complete
> an emergency call.  Present systems accept TDD at all answering
> points because they don't know before the calls is answered that it
> is a TDD call.  I certainly don't want the user to have to do anything
> other than dial his local emergency number, or complete a device
> specific key sequence to complete an emergency call, and I don't
> want a gateway busy to prevent an emergency call.
> 
> Brian
> 
> > -----Original Message-----
> > From: Arnoud van Wijk [mailto:[email-masked]]
> > Sent: Thursday, February 26, 2004 6:07 AM
> > To: 'Rosen, Brian'; 'Gunnar Hellstrom'; 
> > [email-masked];
> > [email-masked]
> > Cc: [email-masked]; [email-masked]; 
> > [email-masked];
> > [email-masked]; [email-masked]
> > Subject: RE: Betr.: [Sipping] ToIP Requirements
> > 
> > 
> > Actually,
> > When using the text gateway, there is no need to detect the 
> > TDD/Analogue
> > text telephone tones/signals. That is the job of the text gateway. 
> > 
> > And for the emergency calling. We have to look closely at this in
> > combination with a text gateway. Possible behaviour/action. 
> > And possible
> > action in SIP.
> > 
> > Right now I cannot say what has to happen, I must study the 
> > emergency calls
> > in depth. But as I see it, using the text gateway, all SIP 
> > originating and
> > receiving emergency calls will be possible for any textphone user.
> > 
> > Cheers
> > 
> > Arnoud
> > 
> > 
> > Drs. Arnoud A. T. van Wijk
> > Viataal
> > Research & Development
> > Afdeling RDS
> > Theerestraat 42
> > 5271 GD Sint-Michielsgestel
> > The Netherlands. 
> > Mobile: +31651921948
> > International text telephone: +31735588408
> > 
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]] 
> > On Behalf Of
> > Rosen, Brian
> > Sent: woensdag 25 februari 2004 23:08
> > To: 'Gunnar Hellstrom'; A vWijk; [email-masked];
> > [email-masked]
> > Cc: [email-masked]; [email-masked]; 
> > [email-masked];
> > [email-masked]; [email-masked]
> > Subject: RE: Betr.: [Sipping] ToIP Requirements
> > 
> > I'm particularly interested in the last one, emergency calling.
> > 
> > Given that you propose an appropriate SDP indicating 
> support for text,
> > do you think there is anything else we need to do to in SIP 
> > to make this
> > happen?  I don't see anything.
> > 
> > I know that the problem of using a legacy TDD device on any kind of
> > adapter is as problematic as current TDD; the call will answered
> > as if it was a voice call, the baudot/whatever tones will be 
> > detected, 
> > and the operator will look for text.  
> > Can't think of any way to make that better.
> > 
> > Do note that language preference headers should be set!!!
> > 
> > Brian
> > 
> > > -----Original Message-----
> > > From: Gunnar Hellstrom [mailto:[email-masked]]
> > > Sent: Wednesday, February 25, 2004 4:54 PM
> > > To: A vWijk; [email-masked]; [email-masked]
> > > Cc: [email-masked]; [email-masked]; 
> > > [email-masked];
> > > [email-masked]; [email-masked]
> > > Subject: RE: Betr.: [Sipping] ToIP Requirements
> > > 
> > > 
> > > I think PSTN textphone gateway invocation is one area where 
> > > we either need
> > > protocol extensions, or need agreements on what current 
> > > mechanisms to use.
> > > 
> > > Another is invocation of various kinds of relay services or 
> > > translation
> > > services.
> > > 
> > > A third is calling emergency services and reach positions 
> capable of
> > > handling the type of communication that the user prefers.
> > > 
> > > 
> > > 
> > > Gunnar
> > > -------------------------------------------
> > > Gunnar Hellstrom
> > > Omnitor AB
> > > Renathvagen 2
> > > SE 121 37 Johanneshov
> > > SWEDEN
> > > +46 8 556 002 03
> > > Mob: +46 708 204 288
> > > www.omnitor.se
> > > [email-masked]
> > > --------------------------------------------
> > > 
> > > 
> > > -----Original Message-----
> > > From: [email-masked] 
> > > [mailto:[email-masked]]On Behalf Of
> > > A vWijk
> > > Sent: Tuesday, February 24, 2004 1:22 PM
> > > To: [email-masked]; [email-masked]
> > > Cc: [email-masked]; [email-masked]; 
> > > [email-masked];
> > > [email-masked]; [email-masked]; 
> > [email-masked]
> > > Subject: Betr.: [Sipping] ToIP Requirements
> > > 
> > > 
> > > Hello Gonzalo,
> > > While there are device requirements in the text. Those 
> > > requirements and the
> > > explanation on the different analogue text telephone systems 
> > > is included to
> > > give the reader an understanding what kind of devices will 
> > > connect with
> > > ToIP. And the need for the text gateways. And what the 
> > > different behaviour
> > > can/may be compared to end to end IP devices.
> > > The most important part will be the ToIP framwork and the 
> > > text gateways and
> > > how such gateways will be used and work with the ToIP framework.
> > > 
> > > There is a ToIP framework where a terminal uses streaming 
> > > text as defined in
> > > RFC2793 to connect with any other Interactive 
> > > texting/real-time streaming
> > > text device.
> > > This can be end-to-end IP, and a direct T140/RTP stream is 
> > > established with
> > > SIP. But in other cases, a text gateway must be used to allow 
> > > T.140/RTP to
> > > connect with a non IP text telephony device.
> > > It can be an analogue text telephone (TDD/TTY) that uses a 
> > > text gateway to
> > > be able to understand RFC2793 text. (PSTN-IP)
> > > It can be a mobile phone running GPRS that uses the text 
> gateway to
> > > understand RFC2793 text. (this exist right NOW using SIP! And 
> > > those gateways
> > > will be used in mobile networks this year!)
> > > Or a mobile text telephone using CTM via the text gateway to 
> > > communicate
> > > with RFC2793 text.
> > > Or even one analogue text telephone connecting to another 
> > > analogue text
> > > telephone in a different country, and the PSTN's use IP to 
> > > connect the call.
> > > 
> > > The question is for example, how do we use that gateway from 
> > > the IP side? Is
> > > it invisible for the IP side? Or do we need special 
> > > extensions in SIP to
> > > that the IP terminal knows it is communicating with the 
> > > end-device through
> > > the text gateway?
> > > There may be a slightly different call setup flow when a text 
> > > gateway is
> > > included.
> > > Or additional SIP messages indicating gateway activity. When 
> > > you connect for
> > > example to an analogue text telephone with an RFC2793 capable 
> > > IP terminal
> > > the capabilities will be less then IP to IP terminal directly 
> > > (different
> > > transmission speeds, half/full duplex etc).
> > > Or what to do with emergency calls that are in RFC 2793 text only?
> > > 
> > > That are requirements that will be defined and worked out in 
> > > this draft.
> > > Also, we want to make everybody in SIP and SIPPING aware 
> > > about those text
> > > gateways. So that complicated matters like how to send 
> analogue text
> > > telephone text through a PSTN and connect with a SIP 
> > > telephone using RFC2793
> > > interactive texting. When using the text gateway, there is 
> > > then no need for
> > > RFC 2833 events at the PSTN for text telephones.
> > > 
> > > So, yes. I believe that this should be in the SIPPING WG. And 
> > > it will fit in
> > > the charter - support for hearing-/speech-impaired calling.
> > > 
> > > greetz
> > > 
> > > Arnoud
> > > 
> > > 
> > > 
> > > Drs. Arnoud A. T. van Wijk
> > > Viataal
> > > Research & Development
> > > Afdeling RDS
> > > Theerestraat 42
> > > 5271 GD Sint-Michielsgestel
> > > The Netherlands.
> > > Mobile: +31651921948
> > > International text telephone: +31735588408
> > > 
> > > >>> Gonzalo Camarillo <[email-masked]> 
> > > 24-02-04 10:21 >>>
> > > Hello,
> > > 
> > > the draft below provides a set of requirements for real-time
> > > conversations using SIP.
> > > http://www.ietf.org/internet-drafts/draft-manyfolks-sipping-to
> > ip-01.txt
> > 
> > Nevertheless, I have found a lot of device requirements in 
> > the text, but
> > I fail to understand which particular protocol requirements 
> we need to
> > fulfill with new protocol extensions.
> > 
> > While SIPPING is the right place to handle requirements 
> that will lead
> > to new SIP protocol extensions, SIPPING may not be the 
> right place to
> > deal with device requirements (e.g., text phones MUST have a 
> > display of
> > at least 100 characters).
> > 
> > Thanks,
> > 
> > Gonzalo
> > 
> > 
> > This communication is confidential and intended solely for 
> > the addressee(s).
> > Any unauthorized review, use, disclosure or distribution is 
> > prohibited. If
> > you believe this message has been sent to you in error, 
> > please notify the
> > sender by replying to this transmission and delete the 
> message without
> > disclosing it. Thank you.
> > 
> > E-mail including attachments is susceptible to data corruption,
> > interruption, unauthorized amendment, tampering and viruses, 
> > and we only
> > send and receive e-mails on the basis that we are not liable 
> > for any such
> > corruption, interception, amendment, tampering or viruses or any
> > consequences thereof.
> > 
> > 
> > _______________________________________________
> > Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> > This list is for NEW development of the application of SIP
> > Use [email-masked] for questions on current sip
> > Use [email-masked] for new developments of core SIP
> > 
> > _______________________________________________
> > Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> > This list is for NEW development of the application of SIP
> > Use [email-masked] for questions on current sip
> > Use [email-masked] for new developments of core SIP
> > 
> > 
> > 
> > 
> > _______________________________________________
> > Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> > This list is for NEW development of the application of SIP
> > Use [email-masked] for questions on current sip
> > Use [email-masked] for new developments of core SIP
> > 
> > _______________________________________________
> > Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> > This list is for NEW development of the application of SIP
> > Use [email-masked] for questions on current sip
> > Use [email-masked] for new developments of core SIP
> > 
> > 
> 
> 

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Arnoud van Wijk" <[email-masked]>
Date: Thu, 26 Feb 2004 16:56:48 +0100

Hello Brian,

Yes you are right about that the PSTN cannot detect if it is a voice call or
TDD/Textphone call. They are both audio.
The PSTN would if it can detect it is a textphone call, route it to the text
gateway. And transcode the call into T.140 over RTP as decribed in RFC 2793.
This is for PSTNs which use IP to interconnect with other PSTNs or with any
SIP telephones. So it is for analoge telephony into SIP telephony here.

In the ToIP draft:
http://www.ietf.org/internet-drafts/draft-manyfolks-sipping-toip-01.txt
A possible solution is a prefix for textphone users before dialling the
selected number.
It indeed would mean that you dial e.g. 600-112 instead 112 directly.
Is that bad?
I believe it is not.

Most textphones have the emergency number pre programmed. And when textphone
users have to use a pre-fix for any textphone call, then the same prefix
before 112 or 911 will be fine.
In the Netherlands, we have for emergency calls 800-112 instead of 112. It
works fine, only almost no deaf users call 112, since they are then mostly
in a situation where they do not have a textphone nearby!

Maybe there are other solutions that allow the PSTN to detect that the
incoming call is a textphone user and acts on it.

For example it is possible to create a database where the PSTN can check if
the incoming number is registered as a textphone.

But using a text gateway to connect PSTN textphones/TDDs to ToIP is still
the best solution, even the only solution in my opinion.
There should be no attempts to transport the text telephone tones (e.g.
Baudot) over the IP voice channel! I believe that will open Pandora's box.

I am not a PSTN expert, and we can surely look into this matter to find a
solution. Let it be prefix or any other solution that lets the PSTN
immediately route the call to the text gateway.

What do you PSTN people think? How would you tackle this problem? Your input
will be very welcome.

Greetz

Arnoud

-----Original Message-----
From: Rosen, Brian [mailto:[email-masked]] 
Sent: donderdag 26 februari 2004 15:36
To: 'Arnoud van Wijk'; 'Gunnar Hellstrom'; [email-masked];
[email-masked]
Cc: [email-masked]; [email-masked]; [email-masked];
[email-masked]; [email-masked]
Subject: RE: Betr.: [Sipping] ToIP Requirements

Arnoud

Brian

---

From: "Gunnar Hellstrom" <[email-masked]>
Date: Fri, 27 Feb 2004 07:45:27 +0100

The INCOM group of the European commission made recommendations that the
same emergency number shall be used for all kinds of terminals.
It is dangerous to have different prefixes or other tricks in different
countries. How shall you keep track of that if you are a visitor?

From PSTN, it is only the old textphones that cause problems. A calling V.18
sends a very distinct calling identifier that can be catched by a gateway or
an emergency centre and be properly handled. On the SIP side, the options
are even better.

I do not mean that all problems are solved by this statement, but I do not
think that the prefix is the only solution, and I do not think we shall
recommend it in connection to emergency.

Gunnar

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Arnoud van Wijk
Sent: Thursday, February 26, 2004 4:57 PM
To: 'Rosen, Brian'; 'Gunnar Hellstrom'; [email-masked];
[email-masked]
Cc: [email-masked]; [email-masked]; [email-masked];
[email-masked]; [email-masked]
Subject: RE: Betr.: [Sipping] ToIP Requirements

Hello Brian,

In the ToIP draft:

Greetz

Arnoud

-----Original Message-----
From: Rosen, Brian [mailto:[email-masked]]
Sent: donderdag 26 februari 2004 15:36
To: 'Arnoud van Wijk'; 'Gunnar Hellstrom'; [email-masked];
[email-masked]

Arnoud

Brian

---

From: Henning Schulzrinne <[email-masked]>
Date: Fri, 27 Feb 2004 09:15:42 -0500

> countries. How shall you keep track of that if you are a visitor?

There are no different 'tricks'. Please read the 'sos' and 
emergency-arch drafts; we would appreciate comments, but general worry 
not grounded on actual proposals is somewhat less helpful.

Indeed, the proposals improve on the current system in that

- all countries will use the same identifier, sos@
- visitors can use their home and visited country identifiers
- discovery of these identifiers is automated
- callers MAY, but do not have to, indicate preferences for the kind of 
emergency service and the kind of media desired; the latter is most 
likely automatic, not something a user would type in (indeed, they can't)

> recommend it in connection to emergency.

As far as I can tell, nobody is recommending a 'prefix'.

---

From: "Barry Dingle" <[email-masked]>
Date: Fri, 27 Feb 2004 10:48:41 +1100

Brian,

In Australia, we have a separate emergency number for Textphone users. It is
'106' and is regulated by legislation.

We have a separate '106' emergency call centre. This makes special support
for a range of text services much easier. (See
http://www.aceinfo.net.au/Services/NRS/Services/ers.html).  I understand
that this may be difficult to implement for historical reasons in some
countries - but it is possible and works well.

As an aside, we are seriously investigating a 'Text Server' to support a
whole range of text interworking scenarios - and ToIP is planned to be
supported in Stage 2. I believe that we will eventually move to a single
emergency number - but not until we can easily and reliably identify text
emergency calls.

Cheers,

Barry DINGLE
Telecommunications Consultant
Project Manager - ACIF Any-to-Any Text Connectivity Options WG
Fellow of the University of Melbourne
   [email-masked]
Mob:   +61 (0)41 911 7578
Fixed: +61 (0)3 9725 3937
----- Original Message ----- 
From: "Rosen, Brian" <[email-masked]>
To: "'Arnoud van Wijk'" <[email-masked]>; "'Gunnar Hellstrom'"
<[email-masked]>; <[email-masked]>;
<[email-masked]>
Cc: <[email-masked]>; <[email-masked]>;
<[email-masked]>; <[email-masked]>; <[email-masked]>
Sent: Friday, February 27, 2004 1:36 AM
Subject: RE: Betr.: [Sipping] ToIP Requirements