Subject: RE: [Sipping] automatic answer

From: "Thomas Gal" <[email-masked]>
Date: Mon, 11 Oct 2004 11:54:47 -0700

Have you read the spec? You will probably get slammed with some
responses as there's several ways to do this.
    If you support presence, then it should be automatic. The SIP Proxy
would route the request to vmail and it would be automatic. Or:
 
21.4.24 486 Busy Here

   The callee's end system was contacted successfully, but the callee is
   currently not willing or able to take additional calls at this end
   system.  The response MAY indicate a better time to call in the
   Retry-After header field.  The user could also be available
   elsewhere, such as through a voice mail service.  Status 600 (Busy
   Everywhere) SHOULD be used if the client knows that no other end
   system will be able to accept this call.
 
Would be indicative of the need to contact another location, probably to
leave a voicemail. Typically this could be done with a redirection server.
If it was stateful it would know to try another location (ie voicemail). 
 
    Plus your question is kinda ambiguous, so I hope this helps. Really this
is a system implementation question it seems, and up to the implementor.
 
Tom

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf
Of ???
Sent: Friday, October 08, 2004 8:02 PM
To: [email-masked]
Subject: [Sipping] automatic answer

Hi, 
 
Is there any I-D regarding params for SIP phone to answer automatically ?
(for answering machine functionality)
 
I would like to know when the call arrives a phone, by which param/header
value the phone answers without ringing.

Any reponse would be appreciated.

Jinkyung Hwang
KT

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: 황진경 <[email-masked]>
Date: Tue, 19 Oct 2004 14:17:23 +0900

Dear Folks,

I have not found out the related I-D or RFC regarding "automatic answer feature" for SIP phone.

To implement in the SIP phone, is it reasonable to use Call-Info field ?

Jinkyung Hwang
KT

  ----- Original Message ----- 
  From: 황진경 
  To: [email-masked] 
  Sent: Saturday, October 09, 2004 12:01 PM
  Subject: automatic answer

  Hi, 

  Is there any I-D regarding params for SIP phone to answer automatically ? (for answering machine functionality)

  I would like to know when the call arrives a phone, by which param/header value the phone answers without ringing.

  Jinkyung Hwang
  KT

---

From: "Christian Stredicke" <[email-masked]>
Date: Tue, 19 Oct 2004 11:18:38 +0200

As far as I know there is a vendors that sends such headers:
INVITE sip:abc SIP/2.0
From: <sip:a@domain>
To: <sip:b@domain>
Call-Info: <sip:b@domain>;answer-after=0

We challenge that request because of the security implications.

CS

________________________________

	From: [email-masked] [mailto:[email-masked]] On Behalf Of ???
	Sent: Tuesday, October 19, 2004 2:16 PM
	To: [email-masked]
	Subject: Re: [SIPPING] automatic answer

	Dear Folks,

	Jinkyung Hwang
	KT

		----- Original Message ----- 
		From: 황진경 <mailto:[email-masked]>  
		To: [email-masked] 
		Sent: Saturday, October 09, 2004 12:01 PM
		Subject: automatic answer

		Hi, 

		 

		Jinkyung Hwang
		KT