Subject: RE: [Sipping] Continuation of discussion on draft-elwell-sipping- redirection-re ason

From: "Mary Barnes" <[email-masked]>
Date: Tue, 5 Oct 2004 11:21:24 -0400

Hi all,
 
It's been awhile and there's been no further discussion on this thread, so
it appears that there is general consensus for the approach to define a new
"protocol" in the Reason Header with a new set of codes for redirection
scenarios.   This would require the Reason header in responses to be
captured in the History-Info.  
 
This does impact the current version of the History-Info draft as it
currently does not look at the Reason header when adding the Reason to its
entry, but rather uses only the SIP response codes to create a new reason
header.  I'll follow-up on the SIP list with the impact on the draft to
support the general concept of using the Reason header.
 
Regards,
Mary 

-----Original Message-----
From: Audet, Francois [SC100:9T51:EXCH] 
Sent: Friday, August 20, 2004 1:55 PM
To: 'Elwell, John'; [email-masked]'
Subject: RE: [Sipping] Continuation of discussion on draft-elwell-sipping-
redirection-re ason

That's fine with me. Makes sense from a backward compatibility perspective 
too. 

> -----Original Message----- 
> From: Elwell, John [mailto:[email-masked]
<mailto:[email-masked]> ] 
> Sent: Friday, August 20, 2004 03:10 
> To: Audet, Francois [SC100:9T51:EXCH]; [email-masked]' 
> Subject: RE: [Sipping] Continuation of discussion on 
> draft-elwell-sipping- redirection-re ason 
> 
> 
> Francois, 
> 
> I agree that is a problem that needs to be solved. The 
> relationship to my redirection-reason proposal is that a 
> redirection reason could be inserted somehow into the 3xx 
> response to indicate that it is a redirection in support of a 
> retarget (according the usage of this term in History-Info) 
> and therefore should result in the addition of a History-Info 
> entry (subject to other considerations such as privacy) in 
> the redirected INVITE request. Absence of this indication in 
> the 3xx response (or an explicit value) would imply normal 
> routing (case 2 in your example). 
> 
> Regards, 
> 
> John 
> 
> ________________________________ 
> 
> From: Francois Audet [mailto:[email-masked]
<mailto:[email-masked]> ] 
> Sent: 19 August 2004 02:38 
> To: [email-masked]' 
> Cc: 'Elwell, John' 
> Subject: RE: [Sipping] Continuation of discussion on 
> draft-elwell-sipping- redirection-re ason 
> 
> 
> 
> At the San Diego meeting, I promised to described on the list the 
> 302 ambiguity issue. 
> 
> 1st scenario: 
> 
> In this scenario, Alice calls Victor Mann who is absent, and 
> his phones 
> forwards the call to his voicemail system at +1-408-555-1212. 
> 
> A Proxy server is used for routing. Call is routed to 
> sip:[email-masked]. 
> Victor has programmed Call forwarding on his phone 
> to forward it to his voicemail at sip:[email-masked]. 
> Victor's phone responds to the INVITE with a 302 Moved temporarily, 
> with Contact: <sip:[email-masked]>. I.e., Victor's phone 
> retargets the call to sip:[email-masked]. Alice's 
> phone then 
> sends an INVITE to Victor's voicemail which will be received 
> interpreted by 
> the voicemail system. The INVITE will look like this: 
> 
> INVITE sip:[email-masked] 
> From: Alice <sip:[email-masked]> 
> To: <sip:[email-masked]> 
> History-Info: <sip:[email-masked]?Reason=SIP;cause=302>;index=1, 
>               <sip:[email-masked]>;index=2 
> ... 
> 
> 
> 2nd scenario: 
> 
> In this scenario, Alice calls directly her voicemail system. 
> 
> A Redirect server is used for routing. In this case, the voicemail 
> system's address of record is sip:[email-masked]. This address is 
> currently routed to a PSTN address +1-408-555-1212 where the 
> legacy voicemail system resides. 
> 
> The redirect server responds with a 302 Moved temporarily, 
> with Contact: 
> <sip:[email-masked]>. This is NOT a retarget in a 
> call forwarding 
> sense, but simple routing with a redirect server. Alice's 
> phone then sends 
> an INVITE to the voicemail system. The INVITE will look like this: 
> 
> INVITE sip:[email-masked] 
> From: Alice <sip:[email-masked]> 
> To: <sip:[email-masked]> 
> History-Info: <sip:[email-masked]?Reason=SIP;cause=302>;index=1, 
>               <sip:[email-masked]>;index=2 
>                    
>            
> In the two cases, the INVITEs are exaclty the same (including 
> History-Info). 
> 
> 
> However, in the first example, the voicemail system is supposed to 
> let Alice LEAVE a message in Victor Mann's mailbox and in the 
> second case, 
> it is supposed to let Alice RETRIEVE her messages. 
> 
> The 302 Reason is ambiguous in this case because it doesn't 
> distinguish 
> between routing (with a redirect server) and retargeting. 
> 
> Note that the problem does NOT occur with a proxy server: 
> only with a redirect 
> server. It will result in inconsistent behavior between 
> networks where a proxy is 
> used and networks where a redirect server is used for call routing. 
> 
> Of course, this is just an example. Similar issues will occur if one 
> is trying to carryover retargetting/redirection information 
> into the PSTN. 
> Similar issues will also occur for any type of service which 
> have different 
> behaviors depending if the call was retargeted or not (e.g., 
> IVR systems). 
> 
> 
> > -----Original Message----- 
> > From: Elwell, John [mailto:[email-masked]
<mailto:[email-masked]> ] 
> > Sent: Tuesday, August 17, 2004 09:51 
> > To: [email-masked]' 
> > Subject: [Sipping] Continuation of discussion on 
> > draft-elwell-sipping-redirection-re ason 
> > 
> > 
> > At the IETF60 SIPPING meeting different opinions were 
> > expressed about the value of enhancing the repertoire of 
> > reasons for retargeting/redirection, as proposed in the 
> > draft. I would like to solicit more opinions on the following 
> > questions: 
> 
> 
> _______________________________________________ 
> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
<https://www1.ietf.org/mailman/listinfo/sipping>  
> This list is for NEW development of the application of SIP 
> Use [email-masked] for questions on current sip 
> Use [email-masked] for new developments of core SIP 
> 

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Elwell, John" <[email-masked]>
Date: Mon, 11 Oct 2004 07:52:38 +0100

Mary,
 
Sorry for the delay in replying. I am in the final stages of producing a
revised I-D to define a new "protocol" in the Reason header.
 
John

  _____  

From: Mary Barnes [mailto:[email-masked]] 
Sent: 05 October 2004 16:21
To: [email-masked]'
Cc: Francois Audet; 'Elwell, John'
Subject: RE: [Sipping] Continuation of discussion on draft-elwell-sipping-
redirection-re ason

Hi all,

 
Regards,
Mary 

-----Original Message-----
From: Audet, Francois [SC100:9T51:EXCH] 
Sent: Friday, August 20, 2004 1:55 PM
To: 'Elwell, John'; [email-masked]'
Subject: RE: [Sipping] Continuation of discussion on draft-elwell-sipping-
redirection-re ason