Subject: RE: [Sipping] Doubt in ANBF defined indraft-ietf-sip-history-info -02.txt draft

From: "Mary Barnes" <[email-masked]>
Date: Fri, 15 Oct 2004 15:37:47 -0400

Brett,

Thanks for your response. Yes, I do need to correct that example in terms of
accurately reflecting the escaping across the SIP-URI, although, the text
prior to the example in section 4.2 of  the -03 version (current WG version,
submitted in July) of the draft does suggest that the current format is for
readability purposes, this point has been brought up before.  But, from a
specification perspective, it should be accurate.  I'll fix that in the -04
which I will be submitting soon. 

Mary

-----Original Message-----
From: Brett Tate [mailto:[email-masked]] 
Sent: Friday, October 15, 2004 11:48 AM
To: [email-masked]
Cc: Barnes, Mary [NGC:B601:EXCH]; [email-masked]
Subject: RE: [Sipping] Doubt in ANBF defined
indraft-ietf-sip-history-info-02.txt draft

> However in an example of History-Info 
> header defined in the draft (in section 4.2) :- 
> History-Info:<sip:[email-masked]
>  ?Reason=SIP;cause=302;text=
>  "Moved Temporarily">; index=1; foo=bar
> 
> note that quoted string occurs in uri-parameters 
> of SIP URI
> 
> But as per the SIP-URI grammar defined in 
> Rfc3261, quoted string cannot occur .
> 
> Please confirm on this..

A quoted string can occur; however the 
example does not reflect the escaping 
across the sip-uri which must occur.

However I continue to have doubts with the
escaping/unescaping process concerning 
quoted strings containing UTF8-NONASCII 
characters.  This can occur in a sip-uri
when embedding a header containing a 
name-addr with a UTF8-NONASCII display-name.

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Prasanna <[email-masked]>
Date: Sat, 16 Oct 2004 09:57:06 +0530

I guess the WSP in the URI also has to be escaped, as that is also not
allowed.
-Prasanna

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Mary Barnes
Sent: Saturday, October 16, 2004 1:08 AM
To: 'Brett Tate'; [email-masked]
Cc: [email-masked]
Subject: RE: [Sipping] Doubt in ANBF
definedindraft-ietf-sip-history-info-02.txt draft

Brett, 

Mary