Subject: [Sipping] I-D ACTION:draft-ietf-sipping-callerprefs-usecases-03.txt

From: [email-masked]
Date: Mon, 25 Oct 2004 16:07:09 -0400

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Session Initiation Proposal Investigation Working Group of the IETF.

	Title		: Guidelines for Usage of the Session Initiation 
			  Protocol (SIP) Caller Preferences Extension
	Author(s)	: J. Rosenberg, P. Kyzivat
	Filename	: draft-ietf-sipping-callerprefs-usecases-03.txt
	Pages		: 43
	Date		: 2004-10-25
	
This document contains guidelines for usage of the Caller Preferences
Extension to the Session Initiation Protocol (SIP). It motivates the
benefits of caller preferences with specific example applications,
provides use cases to show proper operation, provides guidance on the
applicability of the registered feature tags, and describes a
straightforward implementation of the matching algorithm.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-sipping-callerprefs-usecases-03.txt

To remove yourself from the I-D Announcement list, send a message to 
[email-masked] with the word unsubscribe in the body of the message.  
You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce 
to change your subscription settings.

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-ietf-sipping-callerprefs-usecases-03.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-ietf-sipping-callerprefs-usecases-03.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.
_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 27 Oct 2004 10:55:26 -0400

A new version of draft-ietf-sipping-callerprefs-usecases is now 
available on the server. There are no dramatic changes here - just 
cleaning it up for completion. The following changes have been made in 
this version:

- changes made to how the "message" feature param is referenced.
   (To "+sip.message) This is due to an oversight discovered in
   RFC 3840.

- use of "sip.extensions" was corrected (to "+sip.extensions")

- The "UA Routing" case has been removed. It was never a great
   example, and now GRUU provides a much better alternative.

- references updated

- a new section has been added, providing some implementation guidance
   on how the matching algorithm could be implemented.

- extra explanation provided about use of require and explicit tags.

- an alternative solution provided for the "Prefer Voicemail" case.

- q-value changed in "Mobile Phone Only" case to make the cae
   more sensible.

- Some text has ben added to the "Usage of the Feature Tags"
   section, replacing an OPEN ISSUE.

- some editorial notes removed.

- The TODO section has been removed. (I believe everything in
   it has been done.)

I think this is about ready for WGLC.

	Paul

[email-masked] wrote:
> -------------------------------------------------------------------------
> In order to maintain computing infrastructure integrity, Cisco Systems
> Enterprise Messaging Services and InfoSec teams have set a mail policy
> disallowing executable attachments in email.
> 
> This message contained an executable attachment type that is prohibited 
> by this policy. The attachment has been removed from this message and 
> copied to quarantine by our systems. It will be held in quarantine for
> seven days in the event that the content needs to be retrieved.
> 
> 
> -------------------------------------------------------------------------
> For further reference information about viruses and email antivirus 
> efforts within Cisco, please visit:
> 
> http://wwwin.cisco.com/it/ems/services/antiviral
> 
> 
> If your concern isn't addressed by the information in this notification 
> or the above web page, you may open a support request:
> 
> http://wwwin.cisco.com/support/
> 
> Select "Messaging", "Email-Related", "Mail Routing"
> 
> Please include in the text of your case the following information:
> 
> * Full headers of the message. Documentation on displaying the full 
> headers is available at this URL:
> 
> http://wwwin.cisco.com/support/library/faqs/solution002471.html 
> 
> * This unique quarantine identifier: i9PNCZTM024964
> 
> If the matter is urgent, you may follow up by calling one of the below 
> referenced numbers. Please make every effort to provide the above 
> requested information via the support web tool prior to calling as it 
> will greatly aid the resolution of your issue.
> 
> Americas:
> 1 408 526 8888
> 
> Asiapac
> +61 2 8446 8888
> 
> EMEA
> +31 20 485 4888
> 
> Japan
> +81 3 5549 6888
> 
> US (Toll Free)
> 1| 800| 888| 8187| (ext.68888)
> 
> Thank you for your cooperation,
> 
> Enterprise Messaging Services
> Cisco Systems, Inc
> 
> 
> ------------------------------------------------------------------------
> 
> I-D-Announce mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/i-d-announce
>