Subject: [Sipping] draft-ietf-sipping-ToIP-00 - Section 8.4

From: "Peter Ridler" <[email-masked]>
Date: Tue, 28 Dec 2004 12:07:46 -0500

Hi,

In section 8.4 of this draft states::

--.--.--.--.--.--.--.--.--.--.--.--.--.--.--.--.--.--.--.--.--

Text capability SHOULD be announced in SDP by a declaration in 
line with this example: 
          
      m=text 11000 RTP/AVP 98 100 
      a=rtpmap:98 t140/1000 
      a=rtpmap:100 red/1000 
      a=fmtp:100 98/98/98 
          
Characters SHOULD BE buffered for transmission and transmitted 
every 300 ms. 

--.--.--.--.--.--.--.--.--.--.--.--.--.--.--.--.--.--.--.--.--

On SDP line 2 (a=rtpmap:98 t140/1000) what does the 1000 stand for?

Nominally it is the clock rate.  If just a filler, could it be the
Timeout value i.e. 1000 = 1000ms or better yet (a=rtpmap:98 t140/300)
300 = 300ms timeout value?

Thanks
Peter

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Gunnar Hellstrom" <[email-masked]>
Date: Wed, 29 Dec 2004 09:48:20 +0100

Peter,
I am glad you are looking at details of sipping-toip.

The figure 1000 in the sdp line
>      a=rtpmap:98 t140/1000
is indeed a clock rate.

You can read more about it in:
http://www.ietf.org/internet-drafts/draft-ietf-avt-rfc2793bis-09.txt
Where some requirements are stated for handling the timestamps.

Even if it has little meaning for a text packet where text characters are stored at the
moment they are created rather than by being sampled, we did not want to deviate from
normal RTP usage of that parameter.

The clock is used for setting the timestamp of the text packets, and for calculation of
time offset for redundant text, and can thus be used if there is a desire to time the
display of characters.

------

Do you see a need for negotiation of the transmission interval?

Regards

Gunnar

-------------------------------------------
Gunnar Hellstrom
Omnitor AB
Renathvagen 2
SE 121 37 Johanneshov
SWEDEN
+46 8 556 002 03
Mob: +46 708 204 288
www.omnitor.se
[email-masked]
--------------------------------------------

>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]]On
>Behalf Of Peter Ridler
>Sent: Tuesday, December 28, 2004 6:08 PM
>To: IETF Sipping
>Subject: [Sipping] draft-ietf-sipping-ToIP-00 - Section 8.4
>
>
>Hi,
>

---

From: "Peter Ridler" <[email-masked]>
Date: Wed, 29 Dec 2004 14:35:31 -0500

Gunnar,

Thanks for the reply.

If indeed the 1000 is the clock rate, how is this value derived at?

The negotiation of the transmission interval is where I was thinking that
each end MAY suggest a timeout value that it is willing to accept (default
would be the 300ms).  The application I have in mind is the case a TDD
device is communicating via a PSTN gateway to a SIP IVR/ITR where it can
handle a longer delay of text packets (say 500 - 1000ms range).  This would
reduce the number of RTP packets going across the network.  BUT, I am quite
happy with the fixed 300ms interval.

Regards

Peter

> From: Gunnar Hellstrom [mailto:[email-masked]] 
> Sent: Wednesday, December 29, 2004 3:48 AM
> To: IETF Sipping; Peter Ridler
> Cc: Toip list
> Subject: RE: [Sipping] draft-ietf-sipping-ToIP-00 - Section 8.4
> 
> Peter,
> Even if it has little meaning for a text packet where text 
> characters are stored at the moment they are created rather 
> than by being sampled, we did not want to deviate from normal 
> RTP usage of that parameter.
> 
> The clock is used for setting the timestamp of the text 
> packets, and for calculation of time offset for redundant 
> text, and can thus be used if there is a desire to time the 
> display of characters.
> 
> ------
> 
> >Text capability SHOULD be announced in SDP by a declaration in line 
> >with this example:
> >
> >Characters SHOULD BE buffered for transmission and transmitted every 
> >300 ms.
> >
> >This list is for NEW development of the application of SIP Use 
> >[email-masked] for questions on current sip Use 
> >[email-masked] for new developments of core SIP
> >
> 
>

---

From: "Gunnar Hellstrom" <[email-masked]>
Date: Thu, 30 Dec 2004 20:57:56 +0100

The time synchronization requirements on text is low.
I suggest that you read a clock every time you copmpose a packet for transmission, and
convert it to a 1 ms base.

If you have a need to synch it to the audio channel, you can follow the general habits for
timing source synchronization of RTP streams.

For your IVR/ITR application, I realize that you could survive with longer transmission
intervals while collecting input from the user, but when the user is ready, she wants a
rapid response. If you really feel a need for increasing the transmission interval during
data collection, it needs to be combined with special action on the character marking the
end of the transaction. That starts to carry too far with application intelligence on the
transport level in my view, so I hope you are happy with the 300 ms default, and knowing
that during input pauses, nothing is transmitted. (except feeding out the redundancy ).

In rfc2793bis there is a section on expected bandwidth loads that you can read to get a
feeling of if the load is acceptable.

Gunnar

>From: Peter Ridler [mailto:[email-masked]]
>Sent: Wednesday, December 29, 2004 8:36 PM
>To: 'Gunnar Hellstrom'; 'IETF Sipping'
>Cc: 'Toip list'