Subject: [Sipping] Re: [Sip-implementors] Re: Doubt indraft-ietf-simple-message-sessions-08 [bcc][faked-from]

From: Cullen Jennings <[email-masked]>
Date: Sun, 23 Jan 2005 18:29:21 -0800

Uh, I see what you mean...I'll leave this to Ben but I would have thought

msrp://[email-masked]   is legal but not when used in SDP
msrp://[email-masked]:1234 is legal everywhere

msrp://[email-masked]: seems pretty weird as a legal thing to me - I guess
we would follow what other URLs have done

On 1/21/05 5:27 AM, "Christian Jansson" <[email-masked]>
wrote:

> 
>> The syntax allows port to be null.
>> 
>> That being said, the MSRP spec requires an explicit value for port
>> whenever the MSRP URL is exchanged in the SDP. But the MSRP relay spec
>> allows for a null port in certain narrow circumstances.
> 
> Just checking, msrp://[email-masked]: would be valid? (notice the ":"
> on the end). If not, the idea proposed to have port = 1*digit seems
> good.
> 
> 
> / Christian
> 
>> 
>> Hope this helps!
>> 
>> Ben.
>> 
>> 
>> On Jan 19, 2005, at 3:30 AM, [email-masked] wrote:
>> 
>>> 
>>> 
>>> 
>>> 
>>> Hi All,
>>>       As per the grammar of Msrp-Url,
>>> MSRP_urls = msrp-scheme "://" [userinfo "@"] hostport ["/"
>>>       resource] ";" transport
>>> 
>>> and hostport as per RFC2396 is:
>>> hostport      = host [ ":" port ]
>>> port          = *digit
>>> 
>>> The doubt is that ,can the port be NULL or it should have been
>>> port  =1 *digit
>>> 
>>> Please clarify the doubt.
>>> 

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Ben Campbell <[email-masked]>
Date: Mon, 24 Jan 2005 00:01:43 -0600

That sounds like a bug to me. I don't see any reason to allow the colon 
when the port value is null.