Subject: [Sipping] Re: Doubt in draft-niemi-sipping-event-throttle-01

From: Aki Niemi <[email-masked]>
Date: Mon, 10 Jan 2005 23:23:04 +0200

Hi Anil,

I'm not sure I understand the concern. The draft isn't changing the 
grammar for generic-param. Instead, it is adding a new construct that 
*should* conform to the generic-param syntax. AFAIK, delta-seconds is 
conformant with gen-value.

Cheers,
Aki

ext [email-masked] wrote:
> 
> 
> 
> Hi All,
>       This draft defines the grammar for generic param as:-
> 
>       generic-param  =  throttle-param / token [ EQUAL gen-value ]
>       throttle-param =  "throttle" EQUAL delta-seconds
>       option-tag     =  throttle-tag / token
>       throttle-tag   =  "event-throttle"
> 
> as per Rfc 3261:-
> generic-param  =  token [ EQUAL gen-value ]
> 
> The introduction of throttle-param in generic param results in backward
> compatibility issues if
> event-throttle=IPV4/IPV6/Token occurs ,which is incorrect as per the
> definition of generic-param in
> draft-niemi-sipping-event-throttle-01.
> Can you please clarify the reason for making this change.
> 
> Regds
> Anil N
> Hughes Software Systems (HSS)-  B'lore India
> Office Number: +91-80-51067074
> 
> ***********************  HSS-Unclassified   ***********************
> "DISCLAIMER: This message is proprietary to Hughes Software Systems Limited
> (HSS) and is intended solely for the use of the individual to whom it is
> addressed. It may contain  privileged or confidential information and
> should not be circulated or used for any purpose other than for what it is
> intended. If you have received this message in error, please notify the
> originator immediately. If you are not the intended recipient, you are
> notified that you are strictly prohibited from using, copying, altering, or
> disclosing the contents of this message. HSS accepts no responsibility for
> loss or damage arising from the use of the information transmitted by this
> email including damage from virus."
> 
> 

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 10 Jan 2005 17:45:18 -0500

> conformant with gen-value.

Well, maybe that was your intent, but it really does redefine 
generic-param. I believe it should instead have redefined event-param 
(from 3265) as:

- old:

    event-param       =  generic-param / ( "id" EQUAL token )

- new:

    event-param       =  ( "id" EQUAL token )
                      /  ("throttle" EQUAL delta-seconds)
                      /  generic-param

Both this and yours are backward compatible. The difference is that done 
this way, when the extension is known, it has meaning specifically in 
the context of the Event header. Done as you did it, it might be thought 
to have significance anywhere that generic-param is valid.

	Paul

> Sip-implementors mailing list
> [email-masked]
> http://lists.cs.columbia.edu/mailman/listinfo/sip-implementors
>

---

From: Aki Niemi <[email-masked]>
Date: Tue, 11 Jan 2005 11:27:10 +0200

Hi Paul,

I agree that the draft should redefine event-param instead of 
generic-param, simply because it is cleaner done that way. However, as 
you also said both approaches present no backwards compatibility issues. 
   Any parser will be able to handle the param, even though the 
application might not understand it and thus ignore it.

Cheers,
Aki