Subject: [Sipping] Clarification regarding draft-ietf-sipping-cc-transfer-03.txt

From: "Venkatesh Venkataramanan" <[email-masked]>
Date: Fri, 7 Jan 2005 12:18:47 -0800

The sipping-cc-transfer draft proposes the use sending REFER requests on a different dialog and uses the GRUU/GRID information in the REFER to match the dialog on which the transfer is being requested to avoid the problems referred in http://www.ietf.org/internet-drafts/draft-sparks-sipping-dialogusage-00.txt. How would this approach work when the network entity involved in the transfer doesn't REGISTER. For examples, entities like SIP gateways, SIP UM systems dont necessarily need to REGISTER with a REGISTRAR but would want to participate in transfers.

Venkatesh

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Paul Kyzivat <[email-masked]>
Date: Fri, 07 Jan 2005 15:46:00 -0500

> The sipping-cc-transfer draft proposes the use sending REFER requests on a different dialog and uses the GRUU/GRID information in the REFER to match the dialog on which the transfer is being reques…

GRUUs don't have to be obtained as a result of registration.
Any node that is in a position to *know* that it has a globally routable 
address is free to just use it, and declare that it is a gruu.

This would be a non-unreasonable requirement to impose on devices like 
gateways.

	Paul

---

From: "Daniel G. Petrie" <[email-masked]>
Date: Fri, 7 Jan 2005 13:39:45 -0800 (PST)

--- Venkatesh Venkataramanan
<[email-masked]> wrote:

> The sipping-cc-transfer draft proposes the use
> sending REFER requests on a different dialog and
> uses the GRUU/GRID information in the REFER to match
> the dialog on which the transfer is being requested
> to avoid the problems referred in
> 

The separate dialogs associated by GRUUs is being
backed out of the transfer-cc draft.  It was 
discovered that using a GRUU to relate the dialogs
does not work.

http://www.ietf.org/internet-drafts/draft-sparks-sipping-dialogusage-00.txt.
> How would this approach work when the network entity
> involved in the transfer doesn't REGISTER. For
> examples, entities like SIP gateways, SIP UM systems
> dont necessarily need to REGISTER with a REGISTRAR
> but would want to participate in transfers.
> 
> Venkatesh
> 
> 
> Sipping mailing list 
> https://www1.ietf.org/mailman/listinfo/sipping