Subject: RE: [Sipping] Draft: Functions of Current SBCs

From: "Bharrat, Shaun" <[email-masked]>
Date: Fri, 18 Feb 2005 08:42:09 -0500

Arjun:

Not agreeing or disagreeing about what this draft should be; just
have a question on the following statement...

> As an example, a thread above stated that the primary objective of an
> SBC is NAT traversal. If that were true, then the work is already done
> :-) - we have ICE, STUN and the rest of the group.
> 

SBC implementations out there currently "solve" the NAT problem without
requiring any special support from the IAD (there are some IAD requirements
such as symmetric signaling and RTP but leaving those out). How does ICE, 
STUN, etc solve the NAT traversal problem in this manner -- don't they all
require active participation on the part of the IAD?

Thanks and cheers,
Shaun

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On
> Behalf Of Arjun Roychowdhury
> Sent: Friday, February 18, 2005 8:14 AM
> To: Jani Hautakorpi
> Cc: sipping
> Subject: Re: [Sipping] Draft: Functions of Current SBCs
> 
> 
> On Fri, 18 Feb 2005 10:39:13 +0200, Jani Hautakorpi 
> > However, I also thing that we shouldn't list all the imaginable
> > functions as an SBC function, but we should instead use 
> common sense on
> > which function is really relevant.
> > 
> 
> The way I see it, unless we really get to see everything that an SBC
> does, it would be impossible to understand what breaks SIP guidelines
> and what does not. Once we do have a list of all the sins of the SBC,
> one can work into what needs to be architecturally seperated.
> 
> As an example, a thread above stated that the primary objective of an
> SBC is NAT traversal. If that were true, then the work is already done
> :-) - we have ICE, STUN and the rest of the group.
> 
> So my preference would be to support this draft, and get all the
> features that are  bundled today. Lets not argue on what really should
> be done right now, but rather what is being done in the industry for
> the scope of this draft.
> 
> regds
> arjun
> 
> 
> -- 
> Arjun Roychowdhury
> 
> _______________________________________________
> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments of core SIP
> 

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Fri, 18 Feb 2005 07:31:13 -0800

> require active participation on the part of the IAD?

This is supposed to be a good thing. We need better endpoints, not 
crutches for broken endpoints.

-- 
Marc Petit-Huguenin
Home: [email-masked]
Professional: [email-masked]
Work: [email-masked]