Subject: RE: [Sipping] label in Conference package

From: [email-masked]
Date: Wed, 02 Feb 2005 19:20:20 +0000

Bryan,

I'm sorry - if you want to learn what SIP conferencing is all about, please read the SIP conferencing requirements.

SIP Conferencing is normatively defined in cc-conferencing, and that document normatively references the conference package.

The conference package has already completed WGLC.

XCON is only ONE user of the conference package.  

XCON is going to extend the conference package to add in or fix any XCON-specific requirements.

Ergo, the conference package does not have to wait for XCON.

Thanks,
Alan Johnston
sip:[email-masked]

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Brian Rosen
> Sent: Wednesday, February 02, 2005 10:21 AM
> To: Johnston, Alan; [email-masked]
> Subject: RE: [Sipping] label in Conference package
> 
> 
> Alan
> 
> I'm sorry, but there are a ton of dependencies between xcon 
> and the SIP conference package, and we're discovering that we 
> can't do the SIP stuff first and then try to deal with 
> inconsistencies later.  We have to do the XCON, the SDP work 
> and the SIP work TOGETHER, because they are dealing with 
> EXACTLY the same thing.  
> 
> The ONLY thing you need to conference in SIP is a simple UA 
> that calls a conference server.  We do that now, and there is 
> no problem.  There is no pressing need for anything else 
> except maybe a roster.  What we actually need is a complete 
> mechanism to make a conference service, including the SIP and 
> SDP mappings to that service.  
> 
> The conference package defines what a conference aware SIP UA 
> means, and it has to work in conjunction with the XCON 
> defined conference service.  Doing one end without the other 
> never makes any sense, and it doesn't make any sense here.  
> You can't define the mapping to something before you define 
> what you are mapping to. 
> 
> The specifics we are talking about in this thread: how to 
> refer to one stream of many streams in a conference, is 
> exactly the discussion in the SDP label, and is exactly the 
> discussion in the definition of streams in the template, all 
> of which should be summarized in the framework.  
> 
> Precisely, conference-package-08 defines label as:
> 5.7.4  label of string type
> 
>    The element <label> carries a unique identifier for this 
> stream among
>    all streams in the conference and is assigned by the focus.  The
>    value of this element corresponds to the SDP "label" media 
> attribute
>    defined in [21].
> 
> Which relates label in conference package to label in SDP.  
> The label document SPECIFICALLY links SDP labels and XCON:
>    Additionally, XCON identifies the need to uniquely
>    identify a media stream in terms of its role in a conference
>    regardless of its media type, transport protocol, and media format.
>    This can be acomplished by using an external document that 
> points to
>    the appropriate media stream and provides information (e.g., the
>    media stream's role in the conference) about it.
> 
> So conference-package-08 links label in media-type to label 
> in SDP, and mmusic-sdp-media-label links the label to XCON.  
> This is a proper linkage, and nothing is going to work 
> without that linkage.  We're designing this elephant by 
> committee, and we have more than a few members of this committee.
> 
> Many conference efforts in the IETF have failed.  I don't 
> want this one to, and pushing sip mapping to conference state 
> before defining conference state is wrong.  This is but one 
> example of many similar problems.
> 
> Brian
> 
> 
> ________________________________________
> From: Johnston, Alan [mailto:[email-masked]] 
> Sent: Wednesday, February 02, 2005 9:56 AM
> To: [email-masked]; [email-masked]
> Subject: Re: [Sipping] label in Conference package
> 
> Brian,
> 
> I am only going to address your first paragraph.  The rest of 
> your comments should be redirected to the XCON list where it 
> is in scope.
> 
> There is no dependencies between the SIP Conference Package 
> and XCON.  There are many users of this spec that will never 
> incorporate any XCON spec. 
> There is running code and actual products based on this spec.
> 
> As you know XCON does not even have a framework document.  
> Consensus on details like those you mention are likely a year 
> off.  We can not wait for XCON to publish SIP conferencing specs.
> 
> Right now there are exactly 0 RFCs that say how to do SIP 
> conferencing. 
> Delaying this work any further is not an option.
> 
> Thanks,
> Alan Johnston
> Sip:[email-masked]
> 
> 
> 
> 
> _______________________________________________
> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP
> Use [email-masked] for questions on current 
> sip Use [email-masked] for new developments of core SIP
> 

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Brian Rosen" <[email-masked]>
Date: Wed, 2 Feb 2005 20:53:58 -0500

Clearly cc-conferencing references conference package, but it does not
discuss media issues.  Conference package references SDP labels,
and SDP labels references XCON albeit not normatively.

Conference Requirements has almost nothing in it related to the issue at
hand.

XCON Framework and Templates are very concerned with these issues, and I for
one don't see how to separate them.

Brian

> From: [email-masked] [mailto:[email-masked]]
> Sent: Wednesday, February 02, 2005 2:20 PM
> I'm sorry - if you want to learn what SIP conferencing is all about,
> please read the SIP conferencing requirements.
> 
> SIP Conferencing is normatively defined in cc-conferencing, and that
> document normatively references the conference package.
>

---

From: Cullen Jennings <[email-masked]>
Date: Sun, 06 Feb 2005 17:19:56 -0800

> The conference package has already completed WGLC.

This keeps getting said and I'm not sure what it means, so let me ask a very
specific question, Alan do you think the 08 version is ready to go to IESG?