Subject: RE: [Sipping] Re: Refer-To context parameter

From: "Johnston, Alan" <[email-masked]>
Date: Sun, 20 Feb 2005 02:44:07 +0000

If the intention is for the Target-Dialog header to be generally useful
(and I think this is an excellent idea), it should be documented in a
separate (short) SIP working group document which can reference the
SIPPING dialog usage draft for requirements.

Thanks,
Alan Johnston
sip:[email-masked]

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Jonathan Rosenberg
> Sent: Thursday, February 17, 2005 9:35 PM
> To: Rohan Mahy
> Cc: SIPPING WG
> Subject: [Sipping] Re: Refer-To context parameter
> 
> 
> Rohan,
> 
> In the interests of moving forward I don't really have a problem with 
> your alternative. Its really just a syntactic transformation 
> of whats in 
> app interaction today; same information, just in a header 
> instead of a 
> Refer-To parameter. I suppose thats a little more general in that it 
> might be reusable outside of REFER.
> 
> What is not clera is the proposed plan for moving forward. Is it to:
> 
> 1. update app-interaction to define the header field 
> currently described 
> in the dialog-usage draft?
> 
> 2. reference dialog-usage from app-interaction, move dialpog-usage to 
> the standards track?
> 
> I think that (1) makes more sense given that (2) would add a new 
> dependency and seriously delay things, needlessly I think.
> 
> If the folks involved in this discussion can respond (in a 
> more timely 
> fashion, AHEM), and agree to this, I will attempt to rev app 
> interaction 
> again before Monday AM. Whats one more I-D to do by Monday when I've 
> already get 13 to go....
> 
> -Jonathan R.
> 
> Rohan Mahy wrote:
> > Hi Jonathan,
> > 
> > Judging from how quiet the list has been on this topic, I can
> > understand your decision.  Unfortunately, Alan Johnston, 
> Dan Petrie,  
> > Robert Sparks, and I (the folks who posted with opinions on 
> this topic  
> > back in November) came to consensus on a different approach 
> which is  
> > already documented in Robert's dialog usage draft.
> > 
> > The technique is described in 
> draft-sparks-sipping-dialogusage-01.txt
> > 
> > Unless you or anyone else has strong objections, I suggest we go
> > forward with the technique described in dialog-usage.
> > 
> > thanks,
> > -rohan
> > 
> > 
> >> It seems like there is general consensus for this 
> approach. As such,
> >> I  have gone ahead and submitted an update to the 
> framework. Until it  
> >> appears in the archives, you can pick up a copy at:
> >>
> >> http://www.jdrosen.net/papers/draft-ietf-sipping-app-interaction-
> >> framework-04.txt
> >>
> >> This includes comments made during WGLC.
> >>
> >> This document is now ready to go to IESG.
> >>
> >> Thanks,
> >> Jonathan R.
> > 
> > 
> 
> -- 
> Jonathan D. Rosenberg, Ph.D.                   600 Lanidex Plaza
> Director, Service Provider VoIP Architecture   Parsippany, NJ 
> 07054-2711
> Cisco Systems
> [email-masked]                              FAX:   (973) 952-5050
> http://www.jdrosen.net                         PHONE: (973) 952-5000
> http://www.cisco.com
> 
> _______________________________________________
> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP
> Use [email-masked] for questions on current 
> sip Use [email-masked] for new developments of core SIP
> 

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Jonathan Rosenberg <[email-masked]>
Date: Sun, 20 Feb 2005 12:35:21 -0500

> SIPPING dialog usage draft for requirements.

The dialog usage draft isn't really a requirements document per se. If 
this was done as a standalone draft, I would embed a section on 
requirements in the document itself, as we have done in other places. 
The document can have an informational reference to dialog usage too, 
but the extracted requirements would be embedded.

Here is a first stab at such a doc:
http://www.jdrosen.net/papers/draft-rosenberg-sip-target-dialog-00.txt

if this seems about right, I can polish it, add requirements, and we can 
move forward with this.

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.                   600 Lanidex Plaza
Director, Service Provider VoIP Architecture   Parsippany, NJ 07054-2711
Cisco Systems
[email-masked]                              FAX:   (973) 952-5050
http://www.jdrosen.net                         PHONE: (973) 952-5000
http://www.cisco.com