Subject: RE: [Sipping] Draft: Functions of Current SBCs

From: "Roy, Radhika" <[email-masked]>
Date: Mon, 28 Feb 2005 13:30:21 -0500

Hi,
 
I agree that we may not be able to provide names for devices other than some functionalities. Hope that we would have one in a more generic way like Middle box, etc.
 
The question is this: Will we ever be able to "generalize" the behavior with one "shot" just what you have indicated?
 
If we could, we it would be the best. I wish you "Good Luck!" You have my full support.
 
I would also request to see why are we defining (or have defined) the services like 3rd party call controller, transcoder, exploder, centralized SIP-based conferencing (XCON), etc where all of them are acting as a kind of "Middle Box" in the network for providing services to the endpoints (presumably SIP UAs)?
 
Does it not point out that we better take another approach, for example, service-specific solutions?
 
Best regards,
Radhika

________________________________

From: Gonzalo Camarillo [mailto:[email-masked]]
Sent: Mon 2/28/2005 1:04 PM
To: Roy, Radhika
Cc: Paul Kyzivat; Bob Penfield; Alan Hawrylyshen; Christer Holmberg (JO/LMF); sipping; Shai Mohaban; David R Oran
Subject: Re: [Sipping] Draft: Functions of Current SBCs

Hi,

I actually do not think that having a definition of a device that is
called SBC would help. Having different definitions for different types
of SBCs would not help either, IMO.

I would rather say: "if you perform this function in this way, you are
not a SIP compliant device. But you can perform the same function in
this other way, and you will be compliant".

Of course, we need to explain the advantages of being compliant (e.g.,
faster service deployment and more innovations)

Gonzalo

Roy, Radhika wrote:
> Agreed.
> 
> It is a fact that a "device" can do many things (as stated below by
> Paul).
> 
> A "device" can be built to act the UA, Proxy, B2BUA, RTP-aware/dealing
> with media, location server, and/or many other things.
> 
> Based on some pre-define service logic, we can define a "device," for
> example, as follows:
> 
> 1. 3rd Party Call Controller
> 2. Transcoder
> 3. Exploder
> 4. Media Bridge
> 4. Anonymizer (SIP Proxy with B2BUA to provide a lot of services
> transparent to users)
> 5. Others
> 
> Radhika
>

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Medhavi Bhatia" <[email-masked]>
Date: Mon, 28 Feb 2005 13:38:32 -0500

I guess the difference may be, as a user agent, I routed my call to the
service. With the SBC, it is like an intermediary, maybe accepting calls
from other intermediaries (like proxies) and routing calls to them. 

Medhavi.

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf
Of Roy, Radhika
Sent: Monday, February 28, 2005 1:30 PM
To: Gonzalo Camarillo
Cc: Bob Penfield; Alan Hawrylyshen; Christer Holmberg (JO/LMF); David R
Oran; Paul Kyzivat; sipping; Shai Mohaban
Subject: RE: [Sipping] Draft: Functions of Current SBCs

Hi,

I agree that we may not be able to provide names for devices other than some
functionalities. Hope that we would have one in a more generic way like
Middle box, etc.

The question is this: Will we ever be able to "generalize" the behavior with
one "shot" just what you have indicated?

If we could, we it would be the best. I wish you "Good Luck!" You have my
full support.

I would also request to see why are we defining (or have defined) the
services like 3rd party call controller, transcoder, exploder, centralized
SIP-based conferencing (XCON), etc where all of them are acting as a kind of
"Middle Box" in the network for providing services to the endpoints
(presumably SIP UAs)?

Does it not point out that we better take another approach, for example,
service-specific solutions?

Best regards,

Radhika

  _____  

From: Gonzalo Camarillo [mailto:[email-masked]]
Sent: Mon 2/28/2005 1:04 PM
To: Roy, Radhika
Cc: Paul Kyzivat; Bob Penfield; Alan Hawrylyshen; Christer Holmberg
(JO/LMF); sipping; Shai Mohaban; David R Oran
Subject: Re: [Sipping] Draft: Functions of Current SBCs

Hi,

Gonzalo