Subject: RE: [Sipping] draft-elwell-sipping-redirection-reason-01

From: "Elwell, John" <[email-masked]>
Date: Wed, 09 Feb 2005 10:17:36 +0000

Mike,

The device doing the retargeting (or sending a 3xx to cause recursion) must
be a device responsible for the domain in the received Request-URI, so I
don't understand what situation you have in mind.

John

> -----Original Message-----
> From: Mike Hammer [mailto:[email-masked]] 
> Sent: 08 February 2005 19:29
> To: 'Paul Kyzivat'; 'Francois Audet'
> Cc: 'Jesske, R'; [email-masked]; 'Joanne McMillen'; 'Elwell,John'
> Subject: RE: [Sipping] draft-elwell-sipping-redirection-reason-01
> 
> Paul,
> 
> To confuse things further...
> 
> Does it make a difference whether the device doing the
> redirection/retargeting is in the service of the calling party, an
> intermediate, or on behalf of the called party?
> 
> Mike 

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: David R Oran <[email-masked]>
Date: Wed, 9 Feb 2005 08:29:59 -0500

> don't understand what situation you have in mind.
I'm not so sure about what I'm about to say, so take it with copious 
crystals of sodium chloride.

I know that a domain other than the domain responsible for a URI is not 
allowed to *interpret* that URI, but what prevents an outgoing proxy 
for domain nannysrus.com from simply replacing any URI of the form
"sip:[email-masked]" with 
"sip:[email-masked]".

>> intermediate, or on behalf of the called party?
David R. Oran
Cisco Fellow
Cisco Systems
7 Ladyslipper Lane
Acton, MA 01720 USA
Tel: +1 978 264 2048
Email: [email-masked]

---

From: "Mike Hammer" <[email-masked]>
Date: Wed, 9 Feb 2005 16:55:08 -0500

How about this case:

Caller A targets caller B.
Caller B service has some type of service mobility feature.

Let's say caller B has a camp-on service that allows him to pick up a random
phone (C) and register that phone as his own so that any call to B gets
forwarded to phone C.

Now, caller C picks up and calls D, but also has a call forward busy
feature.  Note that there is a feature interaction problem here.  So, a call
from A to B gets redirected to C which might get redirected to D.  But,
caller A doesn't want to get sent to caller C's voicemail for example.

On the other hand, a call from A to B redirected to C could be answered by
B, who then manually transfers the call.  In this case it is user B not user
C doing the transfer, so here it is desirable for A to get retargeted to D.

I suppose that as long as manual versus automatic means are indicated party
A can decide whether to honor the retarget from C or whether to choose
another target provided back from B earlier.

Or perhaps there is a better way to instantiate a service for a use on a
visited device.

Mike

   >From: Elwell, John [mailto:[email-masked]] 
   >Sent: Wednesday, February 09, 2005 5:18 AM
   >To: Mike Hammer; 'Paul Kyzivat'; 'Francois Audet'
   >Cc: 'Jesske, R'; [email-masked]; 'Joanne McMillen'; Elwell, John
   >The device doing the retargeting (or sending a 3xx to cause 
   >recursion) must be a device responsible for the domain in 
   >the received Request-URI, so I don't understand what 
   >situation you have in mind.
   >
   >John
   >

---

From: "Mike Hammer" <[email-masked]>
Date: Wed, 9 Feb 2005 17:10:18 -0500

After sending my last response, I think I got my mind wrapped around an
axle.
That or taking crystals of something other than NaCl.
Or maybe time to find that happy hour.
Disregard.

Mike 

   >From: David R Oran [mailto:[email-masked]] 
   >Sent: Wednesday, February 09, 2005 8:30 AM
   >To: Elwell, John
   >Cc: 'Paul Kyzivat'; 'Joanne McMillen'; 'Jesske, R'; 
   >[email-masked]; Mike Hammer; 'Francois Audet'
   >Subject: Re: [Sipping] draft-elwell-sipping-redirection-reason-01
   >
   >
   >> The device doing the retargeting (or sending a 3xx to 
   >cause recursion) 
   >> must be a device responsible for the domain in the received 
   >> Request-URI, so I don't understand what situation you 
   >have in mind.
   >>
   >I'm not so sure about what I'm about to say, so take it 
   >with copious crystals of sodium chloride.
   >
   >I know that a domain other than the domain responsible for 
   >a URI is not allowed to *interpret* that URI, but what 
   >prevents an outgoing proxy for domain nannysrus.com from 
   >simply replacing any URI of the form 
   >> Sipping mailing list  
   >https://www1.ietf.org/mailman/listinfo/sipping
   >> This list is for NEW development of the application of SIP Use 
   >> [email-masked] for questions on current sip Use 
   >> [email-masked] for new developments of core SIP
   >>
   >David R. Oran
   >Cisco Fellow
   >Cisco Systems
   >7 Ladyslipper Lane
   >Acton, MA 01720 USA
   >Tel: +1 978 264 2048
   >Email: [email-masked]
   >