Subject: Re: [Sipping] P2P why not DNS for discovery?

From: Brijesh Kumar <[email-masked]>
Date: Thu, 03 Feb 2005 09:09:43 -0500

Juha:

----- Original Message -----
From: Juha Heinanen <[email-masked]>
Date: Wednesday, February 2, 2005 9:21 pm
Subject: [Sipping] P2P why not DNS for discovery?

> there must be some ery good reasons for inventing all those new p2p
> protocols we have read on this mailing list, but i would still 
> like to
> hear why an existing protocol, namely DNS, is not good for discovery?

DNS is good for discovery, but is it P2P?

P2P applications need to  run without relying on centralized servers in networking 
infrastructure. So, clearly the use of centralized DNS to resolve does't fullfill 
that requirement. Actually, there is a project called Distributed DNS which is 
a P2P version of DNS based on DHT. While P2P based DNS is useful idea, it is
is n't designed or meant to replace sip registrar function. The efficiency of
DHT based search, makes P2P sip a good proposition to explore.

> my sip uri is sip:[email-masked].  if someone wants to get my contact
> information, they could simply make a sip srv query on jh.tutpro.com,
> which my sip ua is keeping up to date via dynamic dns updates either
> directly or indirectly using xmlrpc, for example.
> 
> what is wrong with this kind of DNS approach?

Nothing wrong. But, this clearly is not P2P approach being
pursued in P2P SIP. 

cheers,

--bk

> 
> -- juha
> 
> _______________________________________________
> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments of core SIP
> 

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Brian Rosen" <[email-masked]>
Date: Thu, 3 Feb 2005 09:35:15 -0500

I'm not sure I buy this argument.
DNS is sufficiently distributed that I wouldn't consider it centralized, and
its real life situation is that it is highly reliable and highly available,
and of course, essentially free (you're paying for DNS service somewhere,
but it's usually built into your access bill). 

If the solution relied in dynamic DNS, then we have a little less of the
"highly reliable" and "highly available" and "free".  You can get one of
those for sure, and two out of three often, but usually not all three.
Nevertheless I suspect even dynamic DNS is good enough.

I'm not much of a purist.  I think Juha's ideas might work and merit more
thought.

Brian

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Brijesh Kumar
> Sent: Thursday, February 03, 2005 9:10 AM
> To: Juha Heinanen
> Cc: [email-masked]
> Subject: Re: [Sipping] P2P why not DNS for discovery?
> 
> Juha:
>

---

From: Cliff McCollum <[email-masked]>
Date: Thu, 03 Feb 2005 09:48:17 -0800

My concern with using DNS is pretty simple: it doesn't always have the 
entries I'm looking for. Two simple examples:

1) I have a small office with a half-dozen machines. We don't run our 
own DNS, because we have no need for it, and the individual machines 
aren't in the upstream DNS because we're behind a NAT firewall. However, 
I want to use P2P SIP in order to communicate from office to office. If 
I am dependent upon DNS to house my URI's, I'm out of luck.

2) I'm running a bunch of gizmos all connected via BlueTooth or WiFi (my 
cell phone, my PDA, my Gameboy :-) These gizmos won't end up the DNS 
anytime soon (maybe in the world of IPV6?), but they should still be 
able to find each other using P2P SIP.

Cliff

-- 
Cliff McCollum, M.Sc.
Vice-President Technology and Development, Voice Mobility Inc.

[email-masked]
www.voicemobility.com
Voice, Mobile, Fax: (250) 978 4255

---

From: David R Oran <[email-masked]>
Date: Thu, 3 Feb 2005 13:26:59 -0500

On Feb 3, 2005, at 12:48 PM, Cliff McCollum wrote:

> aren't in the upstream DNS because we're behind a NAT firewall. 
> However, I want to use P2P SIP in order to communicate from office to 
> office. If I am dependent upon DNS to house my URI's, I'm out of luck.
>
Zeroconf?

>  2) I'm running a bunch of gizmos all connected via BlueTooth or WiFi 
> (my cell phone, my PDA, my Gameboy :-) These gizmos won't end up the 
> DNS anytime soon (maybe in the world of IPV6?), but they should still 
> be able to find each other using P2P SIP.
>
Ditto?

> From: [email-masked]  [ mailto:[email-masked] ] On 
> Behalf
> Of Brijesh Kumar
> infrastructure. So, clearly the use of centralized DNS to resolve 
> does't
> fullfill
> a P2P version of DNS based on DHT. While P2P based DNS is useful idea, 
> it
> is
> is n't designed or meant to replace sip registrar function. The 
> efficiency
> of
> my sip uri is sip:[email-masked] .  if someone wants to get my contact
David R. Oran
Cisco Fellow
Cisco Systems
7 Ladyslipper Lane
Acton, MA 01720 USA
Tel: +1 978 264 2048
Email: [email-masked]

---

From: Brian Rosen <[email-masked]>
Date: Thu, 3 Feb 2005 14:39:48 -0500

Have a look at dynamic DNS

---

From: Juha Heinanen <[email-masked]>
Date: Fri, 4 Feb 2005 03:12:13 +0200

> able to find each other using P2P SIP.

none of the "machines" need to be in dns.  what needs to be there is
user.host SRV entries of user's sip uris.  if your DNS provider doesn't
support dynamic update of DNS entries of your domain, you can always
choose another DNS provider.

-- juha