Subject: [Sipping] Comment on RE: WGLC draft-ietf-sipping-callerprefs-usecases-03.txt

From: "Dolly, Martin C, ALABS" <[email-masked]>
Date: Thu, 7 Apr 2005 07:54:26 -0500

Hello,

The use cases are well written and very clear.

It would be useful to identify dependencies in the introduction or a background section, particularly to: 
(1) RFC 3840, Indicating User Agent Capabilities in SIP, for the new media tags, expressing capabilities in a Registration, usage of the content negotiation framework, etc..
(2) RFC 3841, Caller Presences for the SIP, for preference and capability matching, new header definitions, etc...

Lastly, the draft, along with RFC 3840/3841, describe the behavior starting at the SIP UA. And though this may be out of scope, I feel there should be something on how the user (a person) conveys their preference(s) to the SIP UA via ???. The answer maybe that this is an implementation issue.

Sorry for the delay,

Cheers,

Martin

-----Original Message-----
From: Gonzalo Camarillo [mailto:[email-masked]]
Sent: Tuesday, March 01, 2005 3:03 PM
To: sipping; Dean Willis; Rohan Mahy; Paul Kyzivat; Jonathan Rosemberg
Cc: Cliff McCollum; Dolly, Martin C, ALABS; Chris Wang; [email-masked]
Subject: WGLC draft-ietf-sipping-callerprefs-usecases-03.txt

Folks,

we would like to WGLC the following draft:
http://www.ietf.org/internet-drafts/draft-ietf-sipping-callerprefs-usecases-03.txt

This WGLC will end on March 31st.

The persons in the cc: of this email committed to perform a detailed 
review of the draft. Once you have your review, please send it to the 
authors and to the mailing list. Thanks a lot for volunteering.

Gonzalo
SIPPING co-chair

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 07 Apr 2005 10:02:29 -0400

Martin,

Thanks for the feedback. A couple of questions/comments inline.

	Paul

> (1) RFC 3840, Indicating User Agent Capabilities in SIP, for the new media tags, expressing capabilities in a Registration, usage of the content negotiation framework, etc..

The reference is already there in the Introduction. What more are you 
asking for?

> (2) RFC 3841, Caller Presences for the SIP, for preference and capability matching, new header definitions, etc...

I see there is screwup right now in intro. referenceing 3840 twice when 
the 2nd reference should be to 3841. Will fix that. Otherwise, what are 
you looking for?

> Lastly, the draft, along with RFC 3840/3841, describe the behavior starting at the SIP UA. And though this may be out of scope, I feel there should be something on how the user (a person) conveys t…

This is a hard one. My personal opinion is that I don't expect a UA to 
provide a *general* mechanism for a user to express callerprefs for a 
call. Instead, I expect that the use of callerprefs will be implicit in 
the implementation of more coarse grained features. Exactly how that 
happens is TBD. (Example 3.19 does provide one example.)

I look on this as an introduction *to developers* of a mechanism that is 
powerful but obscure. It shows the kinds of things that are (and are 
not) possible with this mechanism. I expect actual applications to come 
later. I guess a few words can be added explaining that.