Subject: RE: [Sipping] RE: Comments on draft-johnston-sipping-p2p-ipcom-01.txt

From: "Michael Hammer \(mhammer\)" <[email-masked]>
Date: Wed, 6 Apr 2005 17:12:58 -0400

Better to have an explicit email contact provided than play guessing
games.
 
Mike

________________________________

	From: [email-masked] [mailto:[email-masked]]
On Behalf Of Eunsoo Shim
	Sent: Wednesday, April 06, 2005 5:05 PM
	To: Arjun Roychowdhury
	Cc: sipping; Henning Schulzrinne
	Subject: Re: [Sipping] RE: Comments on
draft-johnston-sipping-p2p-ipcom-01.txt

	With a SIP proxy serving the target UA, certainly the response
message can be used to deliver the email address as you said below.
	My guess is that the recommendations to associate SIP URI, email
addresses, and telephone numbers for the same person (owner) may make
many things simpler.
	But back to the initial motivation of this discussion, the
starting point was how to leave a voicemail in P2P SIP where no one will
send any response message when the target UA is simply offline.
	
	Regards,
	
	Eunsoo

		Instead of (or in addition to) all of this, why not just
specify a
		reccomendation that if a SIP call fails to  connect you
to a user,
		then in the 3xx or 4xx response, there is a well defined
mechanism
		that allows you to specify a contact email address which
the sender
		then can use if needed ? The advantage then is that
domain similarity
		requirements and such go away, and I can still use my
compuserv email,
		which may well be  [email-masked] for my SIP
id, which is
		a refined [email-masked]
		
		This will also avoid mail bounces to a great degree for
systems that
		do not support such a direct translation.
		
		regds
		arjun

		On Apr 6, 2005 3:05 PM, Eunsoo Shim
<[email-masked]> <mailto:[email-masked]>  wrote:

			Henning,
			
			I'd be happy to do that. Your contributions will
be greatly helpful and
			appreciated.
			You and other people already provided many good
points in the list.
			
			I have a quick question below.

				Maybe you can start writing a draft
describing the relationships of
				the various identifiers (tel, sip,
email) and recommended practices.
				I'd be happy to contribute.
				
				Basically, I think the rules are
roughly:
				
				- A SIP address MUST only have the same
user and domain part of an
				email address for the same person or
service, not some other
				individual or service.
				
				- All SIP addresses SHOULD have a
working email-equivalent, possibly
				restricted to non-telephone-URIs (i.e.,
those not starting with a digit).

			Do you mean equivalent email addresses within
the same domain as the SIP
			addresses?
			Below are examples for clarification.
			
			<SIP URI> ---- <equivalent email address>
			[email-masked] ---- [email-masked] (OK)
			[email-masked] ---- [email-masked] (OK)
			[email-masked] ---- [email-masked] (OK)
			
			In these three cases, the SIP URIs can be
registered as aliases of the
			equivalent email addresses easily.
			
			[email-masked] ---- [email-masked] (OK ?)
			[email-masked] ---- [email-masked] (OK
?)
			
			The SIP URI and the email address have different
domains in the last two
			cases.
			If myisp just provides VoIP but not the email
service or Alice prefers
			to use her job email address for all voice
mails, the last two relations
			should be allowed if a working email-equivalent
is required for, let
			say, the voice mail purpose.
			What do you think?

				- Some email addresses may not have SIP
equivalents, e.g., because
				they don't support SIP services.
				
				- Telephone numbers are mapped to SIP
URIs without visual separators
				(hyphen, etc.), as partially described
in the tel URI RFC and the SIP
				RFC.

			Regards,
			
			Eunsoo

		

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Juha Heinanen <[email-masked]>
Date: Thu, 7 Apr 2005 06:50:36 +0300

> Better to have an explicit email contact provided than play guessing

i don't like any guessing games either.  here is my requirement:

- IF i have an email address mailto:user@domain, i MUST be able to be
  reached (if i so wish and want to set it up) also using uri
  sip:user@domain no matter if domain provides sip service or not.

-- juha