Subject: RE: [Sipping] Expires header in INVITE

From: "Nayak, Subhash" <[email-masked]>
Date: Thu, 9 Jun 2005 17:28:04 +0530

Session Timer is the mechanism you're looking for. It's now RFC 4028.

Subhash Nayak
Sonus Networks Inc.
http://www.sonusnet.com

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of DarshanBildikar 70559
Sent: Thursday, June 09, 2005 5:01 PM
To: [email-masked]
Subject: [Sipping] Expires header in INVITE

Is there any way for a stateful proxy (e.g. a soft switch) to determine
the end of a session. This could be useful in certain prepaid
applications wherein a call can go on for only a specified amount of
time or in the case of error scenarios where the connection between the
B2BUA and switch is broken.

Could the Expires Header be applied to an INVITE dialog as it is to
REGISTER and SUBSCRIBE? 

Header field          where   proxy ACK BYE CAN INV OPT REG
Expires                              -   -   -   o   -   o

According to the RFC the Expires header can be used with the INVITE and
200 OK messages. Is there a problem with this? 

Darshan

There was a draft draft-ietf-sip-session-timer-00.txt (Oct 99) that
addressed the above problem. 

************************************************************************
******************
 This email and its attachments contain confidential information from
HUAWEI, which is intended only for the person or entity whose address is
listed above. Any use of the information contained herein in any way
(including, but not limited to, total or partial disclosure,
reproduction, or dissemination) by persons other than the intended
recipient(s) is prohibited. If you receive this e-mail in error, please
notify the sender by phone or email immediately and delete it!
 
************************************************************************
*****************

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Samuel Osorio Calvo" <[email-masked]>
Date: Thu, 09 Jun 2005 14:15:15 +0200

>From what I understand, there are two scenarios you want to cover:
a) pre-paid
b)connection error

The first scenario requires the presence of a B2BUA which will set up an internal timer and close the connection if no extra credit is provided. Since B2BUA implementation is left up to the programmer, the way you set up the timer is up to you. 

For the second scenario, might be better to use session timers instead of Expires header. There's a recent RFC called "Session Timers in the Session Initiation Protocol (SIP)"(I'm sorry but I don't have the number right here) which covers the error scenario for proxies.

Hope it helps,

Samuel.

Unclassified.
>>> DarshanBildikar 70559 <[email-masked]> 06/09/05 01:30PM >>>
Is there any way for a stateful proxy (e.g. a soft switch) to determine the end of a session. This could be useful in certain prepaid applications wherein a call can go on for only a specified amount of time or in the case of error scenarios where the connection between the B2BUA and switch is broken.

Could the Expires Header be applied to an INVITE dialog as it is to REGISTER and SUBSCRIBE? 

According to the RFC the Expires header can be used with the INVITE and 200 OK messages. Is there a problem with this? 

Darshan

There was a draft draft-ietf-sip-session-timer-00.txt (Oct 99) that addressed the above problem. 

******************************************************************************************
 This email and its attachments contain confidential information from HUAWEI, which is intended only for the person or entity whose address is listed above. Any use of the information contained herein in any way (including, but not limited to, total or partial disclosure, reproduction, or dissemination) by persons other than the intended recipient(s) is prohibited. If you receive this e-mail in error, please notify the sender by phone or email immediately and delete it!
 *****************************************************************************************