Subject: [Sipping] sipping session mobility

From: Salvatore Loreto <[email-masked]>
Date: Sat, 18 Jun 2005 09:00:02 +0200 (CEST)

Hi all,
 
I've a question about the simultaneous mobility, of course it is a special case of a singol host mobility:
 
when a SIP UA changes his subnetwork and it obtains a new IP address,
it send a re-INVITE message, but my question is:
 
the REGISTER message (inorder to uptodate it location information) must be sent before or after the re-INVITE.
In the case of simultaneous mobility it should be sent before.
 
what do you think about?
 
best regards
/sal

---------------------------------
Yahoo! Mail: gratis 1GB per i messaggi, antispam, antivirus, POP3

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Diego B <[email-masked]>
Date: Sat, 18 Jun 2005 18:53:13 +0200

Hi;
If the REGISTER response change anything in the UA route information ( 
like Service-Route ) it may be sent before the re-INVITE.

If the REGISTRAR does not change anything in the current dialog, I think 
the two ( REGISTRAR and re-INVITE ) may be sent in parallel.

My question is now, if the REGISTER brings a new changed Service-Route, 
the UA may use the new route to send
the re-invite ( changing in dialog routing ) or keep using the route it 
initially use when the dialog was created.

Regards
Diego B

Salvatore Loreto wrote:

> the REGISTER message (inorder to uptodate it location information) 
> must be sent before or after the re-INVITE.
> ------------------------------------------------------------------------
> *Yahoo! Mail* 
> <http://us.rd.yahoo.com/mail_it/taglines/*http://it.mail.yahoo.com>: 
> gratis 1GB per i messaggi, antispam, antivirus, POP3
>
>------------------------------------------------------------------------
>

---

From: "Jeroen van Bemmel" <[email-masked]>
Date: Sat, 18 Jun 2005 23:05:09 +0200

Hi,

Suppose one would make a useragent that uses SIP for presence and XCAP for 
manipulation of buddy lists etc. , what would be the best way to provision 
the client with the URL of its XCAP server?

Regards,

Jeroen

---

From: Arjun Roychowdhury <[email-masked]>
Date: Sun, 19 Jun 2005 09:36:16 -0400

Hi,
most implementations I know of today provision the UA with the XCAP
services root URI. Once the root URI is known, since XCAP mandates
that documents are organized according to a defined hierarchy, the UA
can then navigate to the exact service that is required.

I am personally not aware of any best practices to dynamically
identify the XCAP URI but I guess something like ${domain}/services
may not be a bad idea where ${domain} is the domain that is servicing
the User Agent.

regds
arjun

-- 
Arjun Roychowdhury

---

From: Salvatore Loreto <[email-masked]>
Date: Sun, 19 Jun 2005 18:40:13 +0200 (CEST)

Hi Diego,
 
your underline a problem I didn't think about.
My scenario is both the UA involved in the session move in the same time in two different network and both bring a new IP address.
 
In this scenario if each UA try to send a re-Invite before a new Register message with the new location information the new re-Invite fails.
So maybe in this situation a new Register must be sent before an new re-INVITE... and I think send both messages in parallel is not a good idea.
 
Anyway, about the case the new IP address involve a new Service Route , maybe you think the case a new Sip Server is added to the signaling Route,
i think a possibile solution could be the new Sip Server forward the signaling the old one.
What do you think about?
 
regards
/Sal

Diego B <[email-masked]> ha scritto: 
Hi;
If the REGISTER response change anything in the UA route information ( 
like Service-Route ) it may be sent before the re-INVITE.

Regards
Diego B

Salvatore Loreto wrote:

> :

---

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 20 Jun 2005 06:31:25 -0400

The xcap root services URI should be one of many parameters passed to 
the client through the configuration framework:

http://www.ietf.org/internet-drafts/draft-ietf-sipping-config-framework-06.txt

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.                   600 Lanidex Plaza
Director, Service Provider VoIP Architecture   Parsippany, NJ 07054-2711
Cisco Systems
[email-masked]                              FAX:   (973) 952-5050
http://www.jdrosen.net                         PHONE: (973) 952-5000
http://www.cisco.com

---

From: "Dale Worley" <[email-masked]>
Date: Mon, 20 Jun 2005 10:56:36 -0400

The updated registration has nothing to do with revising the routing for an
existing dialog, so both operations can be done in parallel.

The biggest problem with mobility is that a re-INVITE is only allowed to
change the contact addresses at each end of the dialog, not any of the
components of the "route set", that is, the Record-Route'ed addresses.  This
may limit the changes in network attachment that can be accomodated.

It may be possible to do more complex re-routing by using an INVITE with
Replaces header to establish a new dialog with new route set that
functionally continues the original dialog.

Dale
  -----Original Message-----
  From: [email-masked] [mailto:[email-masked]]On Behalf
Of Salvatore Loreto
  Sent: Saturday, June 18, 2005 3:00 AM
  To: [email-masked]
  Subject: [Sipping] sipping session mobility

  Hi all,

  I've a question about the simultaneous mobility, of course it is a special
case of a singol host mobility:

  the REGISTER message (inorder to uptodate it location information) must be
sent before or after the re-INVITE.
  In the case of simultaneous mobility it should be sent before.

  what do you think about?

  best regards
  /sal

----------------------------------------------------------------------------

---

From: Diego B <[email-masked]>
Date: Mon, 20 Jun 2005 18:35:52 +0200

Hi;

Service-Route is added in responce to REGISTER.
My question was if the Service-Route change, what is the effect in 
current dialogs.

And I also think both actions can be done in parallel.

Best Regards
Diego B

Dale Worley wrote:

> The updated registration has nothing to do with revising the routing 
> for an existing dialog, so both operations can be done in parallel.
>

> The biggest problem with mobility is that a re-INVITE is only allowed 
> to change the contact addresses at each end of the dialog, not any of 
> the components of the "route set", that is, the Record-Route'ed 
> addresses.  This may limit the changes in network attachment that can 
> be accomodated.
>  
> It may be possible to do more complex re-routing by using an INVITE 
> with Replaces header to establish a new dialog with new route set that 
>     *From:* [email-masked]
>     [mailto:[email-masked]]*On Behalf Of *Salvatore Loreto
>     *Sent:* Saturday, June 18, 2005 3:00 AM
>     *To:* [email-masked]
>     *Subject:* [Sipping] sipping session mobility
>
>     Hi all,
>

---

From: "Jeroen van Bemmel" <[email-masked]>
Date: Mon, 20 Jun 2005 20:06:19 +0200

Hi Jonathan,

OK, thanks for the update. Perhaps this could be mentioned in the XCAP 
draft?

Regards,

Jeroen

----- Original Message ----- 
From: "Jonathan Rosenberg" <[email-masked]>
To: "Arjun Roychowdhury" <[email-masked]>
Cc: "Jeroen van Bemmel" <[email-masked]>; <[email-masked]>
Sent: Monday, June 20, 2005 12:31 PM
Subject: Re: [Sipping] XCAP server discovery

> The xcap root services URI should be one of many parameters passed to the 
> client through the configuration framework:
>

---

From: Dean Willis <[email-masked]>
Date: Tue, 21 Jun 2005 20:06:06 -0500

> My question was if the Service-Route change, what is the effect in 

No effect on existing dialogs. The Service-Route is only used in 
requests sent outside of a dialog. Consequently, an existing dialog 
would continue to observe the Record-Route and Via chains associated 
with that dialog.

--
Dean Willis
editor, Service-Route draft

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 22 Jun 2005 02:32:17 -0400

This is out of scope for XCAP itself. Something like this belongs in the 
data profile document that goes with the sipping configuration framework.

-Jonathan R.

Jeroen van Bemmel wrote:

> ----- Original Message ----- From: "Jonathan Rosenberg" <[email-masked]>