Subject: [Sipping] Expires header in INVITE

From: DarshanBildikar 70559 <[email-masked]>
Date: Thu, 09 Jun 2005 16:30:55 +0500

Is there any way for a stateful proxy (e.g. a soft switch) to determine the end of a session. This could be useful in certain prepaid applications wherein a call can go on for only a specified amount of time or in the case of error scenarios where the connection between the B2BUA and switch is broken.

Could the Expires Header be applied to an INVITE dialog as it is to REGISTER and SUBSCRIBE? 

Header field          where   proxy ACK BYE CAN INV OPT REG
Expires                              -   -   -   o   -   o

According to the RFC the Expires header can be used with the INVITE and 200 OK messages. Is there a problem with this? 

Darshan

There was a draft draft-ietf-sip-session-timer-00.txt (Oct 99) that addressed the above problem. 

******************************************************************************************
 This email and its attachments contain confidential information from HUAWEI, which is intended only for the person or entity whose address is listed above. Any use of the information contained herein in any way (including, but not limited to, total or partial disclosure, reproduction, or dissemination) by persons other than the intended recipient(s) is prohibited. If you receive this e-mail in error, please notify the sender by phone or email immediately and delete it!
 *****************************************************************************************

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 09 Jun 2005 08:58:53 -0400

The Expires header in an INVITE refers to how long the *invitation* is 
good for, not how long the *session* is good for.

-Jonathan R.

DarshanBildikar 70559 wrote:

> Is there any way for a stateful proxy (e.g. a soft switch) to
> determine the end of a session. This could be useful in certain
> prepaid applications wherein a call can go on for only a specified
> amount of time or in the case of error scenarios where the connection
> between the B2BUA and switch is broken.
> 
> Header field          where   proxy ACK BYE CAN INV OPT REG Expires
> -   -   -   o   -   o
> 
> According to the RFC the Expires header can be used with the INVITE
> and 200 OK messages. Is there a problem with this?
> 
> Darshan
> 
>  This email and its attachments contain confidential information from
> HUAWEI, which is intended only for the person or entity whose address
> is listed above. Any use of the information contained herein in any
> way (including, but not limited to, total or partial disclosure,
> reproduction, or dissemination) by persons other than the intended
> recipient(s) is prohibited. If you receive this e-mail in error,
> please notify the sender by phone or email immediately and delete it!
>  
> _______________________________________________ Sipping mailing list
> https://www1.ietf.org/mailman/listinfo/sipping This list is for NEW
> development of the application of SIP Use
> [email-masked] for questions on current sip Use
> [email-masked] for new developments of core SIP
> 

-- 
Jonathan D. Rosenberg, Ph.D.                   600 Lanidex Plaza
Director, Service Provider VoIP Architecture   Parsippany, NJ 07054-2711
Cisco Systems
[email-masked]                              FAX:   (973) 952-5050
http://www.jdrosen.net                         PHONE: (973) 952-5000
http://www.cisco.com