Subject: [Sipping] Modifying subscribed URI list

From: Avshalom Houri <[email-masked]>
Date: Mon, 6 Jun 2005 15:55:14 +0300

Draft draft-ietf-sipping-uri-list-subscribe-03.txt
enables subscribing to a list of users.

In many cases the list of users changes
quite fast and sending the whole modified list again may be quite heavy.

I think that it will be quite helpful
to add very simple add/remove operators to the URI list of subscribe in
order to

enable fast change of the URI list.

For example if the initial body of the
subscribe was:

<?xml version="1.0"
encoding="UTF-8"?>

<resource-lists xmlns="urn:ietf:params:xml:ns:resource-lists"

xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

<list>

<entry uri="sip:[email-masked]"
/>

<entry uri="sip:[email-masked]"
/>

<entry uri="sip:[email-masked]"
/>

</list>

</resource-lists>

If we want to add Alice and remove Bill
the resubscribe will look like (more or less):

<?xml version="1.0"
encoding="UTF-8"?>

<resource-lists xmlns="urn:ietf:params:xml:ns:resource-lists"

xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

<list>

<<REM>
entry uri="sip:[email-masked]" />

<<ADD>
entry uri="sip:[email-masked]" />

</list>

</resource-lists>

Avshalom

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Dean Willis <[email-masked]>
Date: Mon, 6 Jun 2005 17:12:06 -0500

On Jun 6, 2005, at 7:55 AM, Avshalom Houri wrote:

> I think that it will be quite helpful to add very simple add/remove 
> operators to the URI list of subscribe in order to

Sounds like valid requirements.

We should see if there's a reasonable way to unify this with the other 
partial-notification work.

--
Dean