Subject: RE: [Sipping] Telling a proxy which service to execute

From: "Francois Audet" <[email-masked]>
Date: Wed, 2 Nov 2005 14:28:19 -0600

> -----Original Message-----
> From: Elwell, John [mailto:[email-masked]] 
> Sent: Wednesday, November 02, 2005 12:18
> To: Audet, Francois [SC100:9T51:EXCH]; Gonzalo Camarillo; sipping
> Subject: RE: [Sipping] Telling a proxy which service to execute
> > However, if the proxy retargets for whatever reason, I 
> agree with you 
> > that the expectation would be for the parameters to be lost.
> >
> [JRE] But that is where history-info comes in, because if the 
> URI is recorded in history-info then it is not completely lost. 
> 
> John

Agreed.

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Jeroen van Bemmel" <[email-masked]>
Date: Wed, 2 Nov 2005 22:07:49 +0100

http://www.ietf.org/internet-drafts/draft-ietf-sip-history-info-06.txt 
section 3.3: "[...]  local policy MAY also be used to determine whether to 
include the History-Info header at all"

Header field    where   proxy
------------    -----   -----
History-Info            amdrSo in other words: any proxy can decide to 
remove the History-Info header from the request based on local policy, and 
it would even be (draft) standards compliant

IMO basic requirement for "Telling a proxy which service to execute" is that 
intermediate proxies do not remove this information from the request

Regards,

Jeroen

----- Original Message ----- 
From: "Francois Audet" <[email-masked]>
To: "Elwell, John" <[email-masked]>; "Gonzalo Camarillo" 
<[email-masked]>; "sipping" <[email-masked]>
Sent: Wednesday, November 02, 2005 9:28 PM
Subject: RE: [Sipping] Telling a proxy which service to execute

Agreed.

---

From: Dean Willis <[email-masked]>
Date: Wed, 2 Nov 2005 15:34:20 -0600

On Nov 2, 2005, at 3:07 PM, Jeroen van Bemmel wrote:

> http://www.ietf.org/internet-drafts/draft-ietf-sip-history- 
> info-06.txt section 3.3: "[...]  local policy MAY also be used to  
> determine whether to include the History-Info header at all"
>
> Header field    where   proxy
> ------------    -----   -----
> History-Info            amdrSo in other words: any proxy can decide  
> to remove the History-Info header from the request based on local  
> policy, and it would even be (draft) standards compliant
>
> IMO basic requirement for "Telling a proxy which service to  
> execute" is that intermediate proxies do not remove this  
> information from the request
>
> Regards,
>

But there's still a big difference between telling 1) a proxy which  
service to execute, and 2) telling a proxy which services have  
already been executed and hoping it can guess which one is needed next.

History-info, as is, is a solution for #2.

--
Dean