Subject: RE: [Sipping] Making SBCs more transparent for NAT traversal

From: [email-masked]
Date: Wed, 2 Nov 2005 22:59:27 +0200

Juha,

> 
> i still haven't got any answer why something would need to be
> standardized for this kind of stupid UA/stupid NAT scenario, 
> intelligent
> sip proxy/media proxy, since it seems to work fine within the 
> limits of
> already existing standards.
>

I think you are right, but in that case you will run into issues discussed in http://www.ietf.org/internet-drafts/draft-camarillo-sipping-sbc-funcs-02.txt and also to scaling issues if all media needs to traverse the media proxies.

ICE, STUN and TURN provide another set of tools, and the question is whether they are good enough in the cases constrained by power consumption and session setup latency. If yes, there is no new standardization needed. If not, we may need to reconsider.
 
> -- juha

Markus

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Juha Heinanen <[email-masked]>
Date: Thu, 3 Nov 2005 13:27:50 +0200

[email-masked] writes:

 > ICE, STUN and TURN provide another set of tools, and the question is
 > whether they are good enough in the cases constrained by power
 > consumption and session setup latency. 

regarding STUN, we have given up on it, because most of the NATs that
our users have, are symmetric, which means that even if some SIP UAs are
STUN capable, they still need to use media proxy.

-- juha