Subject: [Sipping] RE: Telling a proxy which service to execute

From: "Elwell, John" <[email-masked]>
Date: Thu, 03 Nov 2005 08:52:24 +0000

Gonzalo,

> -----Original Message-----
> From: Gonzalo Camarillo [mailto:[email-masked]] 
> Sent: 02 November 2005 17:42
> To: sipping
> Cc: Elwell, John
> Subject: Telling a proxy which service to execute
> 
> Folks,
> 
> it seems to me that the History-Info approach can meet the 
> requirements 
> coming from services that need to know what has happened to 
> this request 
> so far.
[JRE] With the significant disadvantage that the UAC has to support the
generation of History-Info for this to work. It is my opinion that proxies
and B2BUAs will support the addition of History-Info entries, but support by
UAs might be limited to reading what is received rather than adding entries.
The service-retargeting solution is the only solution proposed that does not
require special UAC support.

John

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Gonzalo Camarillo <[email-masked]>
Date: Thu, 03 Nov 2005 11:01:03 +0200

John,

in a previous email you are saying that service retargetting needs H-I 
in order to work (in case a proxy in the middle changes the 
Request-URI), and now you are saying that you do not want to use H-I at 
all and only use service retargetting... I am confused.

Thanks,

Gonzalo