Subject: RE: [Sipping] Making SBCs more transparent for NAT traversal

From: "Christer Holmberg (JO/LMF)" <[email-masked]>
Date: Fri, 4 Nov 2005 10:31:53 +0100

Hi,

How does the NAT know which packages are "keepalive" ones?

Regards,

Christer 

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Juha Heinanen
> Sent: 3. marraskuuta 2005 13:43
> To: [email-masked]
> Subject: RE: [Sipping] Making SBCs more transparent for NAT traversal
> 
> [email-masked] writes:
> 
>  > If we assume that the wireless access provider indeed uses 
> NAT, and  > is not able/willing to do any specific 
> configurations for them, ...
> 
> markus,
> 
> since in mobile networks, NAT is most likely implemented in 
> GGSN or somewhere close to it, that NAT (since it is service 
> provide controlled) should be mobile network friendly by 
> default and keep NAT bindings open when receiving keepalives 
> from the proxy.  
> 
> it could also be clever and not pass these keepalives to the 
> mobile terminal, thus saving battery power.  this works ok if 
> there is no other nat behind a mobile terminal, for example, 
> when SIP application sits in the mobile terminal itself.
> 
> so mobile operators, if they ever want to be SIP friendly 
> (which may not be the case) could have a separate access 
> point name for mobile terminals that actually terminate the 
> traffic (as in the example above) and a separate access point 
> name for cases where there is a network behind the mobile terminal.
> 
> in the latter case, keepalives would not be absorbed by the 
> mobile operator NAT, but that would be ok, because the mobile 
> terminal that has a network behind it most likely will have 
> constant power available and thus the power problem doesn't exist.
> 
> markus, you are free to pass this on to your product 
> development department :-).
> 
> -- juha
> 
> _______________________________________________
> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP 
> Use [email-masked] for questions on current 
> sip Use [email-masked] for new developments of core SIP
> 

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Juha Heinanen <[email-masked]>
Date: Fri, 4 Nov 2005 15:10:47 +0200

> How does the NAT know which packages are "keepalive" ones?

you could standardize it if it is not obvious otherwise.  but perhaps
you prefer much more complex solutions for nat traversal.

-- juha