Subject: RE: [Sipping] Making SBCs more transparent for NAT traversal

From: "Michael Hammer \(mhammer\)" <[email-masked]>
Date: Tue, 1 Nov 2005 12:55:20 -0500

Is there a dependency here on the type of NAT and which side is inside
v. outside?
Are all NATs in question under SP control?

Mike

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Juha Heinanen
> Sent: Tuesday, November 01, 2005 8:12 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: RE: [Sipping] Making SBCs more transparent for NAT traversal
> 
> [email-masked] writes:
> 
>  > I've tested this in a lab, and found that if you need to 
> send keep  > alives  > every 30 seconds or so, you'll have 
> about one-quarter of the battery  > life,  > as if you didn't 
> send them.  Note that I just took a number of different  > 
> phones (from different manufacturers) and that's the rough measure.
> 
> and i tried to say that in the setup that i described, the 
> terminal only needs to RECEIVE, not send keepalives.  thus 
> there should be no power issue involved and thus no need to 
> have something special for mobile sip UAs.
> 
> -- juha
> 
> _______________________________________________
> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP 
> Use [email-masked] for questions on current 
> sip Use [email-masked] for new developments of core SIP
> 

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Juha Heinanen <[email-masked]>
Date: Wed, 2 Nov 2005 07:43:07 +0200

Michael Hammer \(mhammer\) writes:

 > v. outside? Are all NATs in question under SP control?

the NATs are what user buy, so service provide has little control on
them.  of course, if service provider knows that certain NATs are
broken, it may warn about them.  most of the NATs that my user buy seem
to be symmetric, so we gave up on STUN about a year ago.

i don't know what you mean by inside and outside.  in our case, sip and
media proxies have global addresses.

i still haven't got any answer why something would need to be
standardized for this kind of stupid UA/stupid NAT scenario, intelligent
sip proxy/media proxy, since it seems to work fine within the limits of
already existing standards.

-- juha