Subject: RE: [Sipping] Redirection on busy and History Info

From: "Francois Audet" <[email-masked]>
Date: Tue, 1 Nov 2005 12:09:37 -0600

I think it is a slippery slope.

A typical "IP PBX" (i.e., a big blob controling IP Phones and TDM
phones) or a Gateway can
often redirect "internally".

In this model, it would then generate "fake" History-Info with 486 and
other codes. 

If I am the only one uncomfortable with this, then we *could* just write
guidelines on rules
for mapping History-Info to PSTN.

But again, this seems very bizarre to me...

I'd like to hear other opinions on this.

> -----Original Message-----
> From: Gonzalo Camarillo [mailto:[email-masked]] 
> Sent: Monday, October 31, 2005 23:52
> To: Audet, Francois [SC100:9T51:EXCH]
> Cc: Barnes, Mary [RICH2:B601:EXCH]; sipping; Elwell, John
> Subject: Re: [Sipping] Redirection on busy and History Info
> 
> 
> Hi Francois,
> 
> a UAS stating that there was a 486 response and then a 302, 
> when all it 
> did was redirecting because the user was busy (i.e., there was no 486 
> response in the network) is not actually cheating, IMO. It is just 
> modeling itself as two SIP entities (a virtual proxy and a 
> UAS) with a 
> SIP interface between them.
> 
> We have a similar case with the double routing mechanism described in 
> RFC 3486 used with Sigcomp, where a proxy record-routes 
> twice. It is not 
> cheating; it is just modeling itself as two proxies linked by a SIP 
> interface.
> 
> Cheers,
> 
> Gonzalo
> 
> 
> Francois Audet wrote:
> > Also, on the "what has happened so far" model, one issue is PSTN 
> > interop.
> > 
> > I always held the view that SIP UAC or proxies should not
> > generate "fake" History-Info to account for redirection that
> > occured outside of SIP (e.g., the PSTN). I.e.., it shouldn't
> > lie that that there was a 486 or 302 received when there 
> > were no such thing.
> > 
> > This is one of the main reason for the 3087 model.
> > 
> > 
> >>-----Original Message-----
> >>From: [email-masked]
> >>[mailto:[email-masked]] On Behalf Of Gonzalo Camarillo
> >>Sent: Monday, October 31, 2005 10:58
> >>To: Barnes, Mary [NGC:B601:EXCH]
> >>Cc: sipping; Elwell, John
> >>Subject: Re: [Sipping] Redirection on busy and History Info
> >>
> >>
> >>Hi,
> >>
> >> > Of course,  I think the primary debate isn't necessarily over
> >>
> >>>whether one could or could not use History-Info for this type of
> >>>service, but rather there is a preference to provide even more 
> >>>explicit service information, per the RFC 3087 model.
> >>
> >>as Dave pointed out a few messages ago in a related thread, 
> there are
> >>two models: one where the entity explains what has happened 
> >>so far, and 
> >>the other where the entity tells what should happen in the 
> >>future. The 
> >>solution we are discussing here would cover the former model. 
> >>As long as 
> >>there are folks interested in that model, I guess it is worthwhile 
> >>pursuing that solution (or something equivalent).
> >>
> >>Then, as a separate discussion, we can analyze how to support
> >>the latter 
> >>model as well.
> >>
> >>Cheers,
> >>
> >>Gonzalo
> >>
> >>_______________________________________________
> >>Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> >>This list is for NEW development of the application of SIP Use 
> >>[email-masked] for questions on current sip Use 
> >>[email-masked] for new developments of core SIP
> >>
> >>
> 
> -- 
> Gonzalo Camarillo         Phone :  +358  9 299 33 71
> Oy L M Ericsson Ab        Mobile:  +358 40 702 35 35
> Telecom R&D               Fax   :  +358  9 299 30 52
> FIN-02420 Jorvas          Email :  [email-masked]
> Finland                   http://www.hut.fi/~gonzalo
> 
> 

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Gonzalo Camarillo <[email-masked]>
Date: Tue, 01 Nov 2005 21:42:12 +0200

Hi Francois,

I agree it would be great to hear opinions from more people on this. In 
any event, the fact that a piece of information containing the status o 
a resource is sent over an internal bus instead of over an ethernet 
cable does not seem enough reason to call that piece of information "a 
fake".

Cheers,

Gonzalo

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 01 Nov 2005 14:54:45 -0500

IMO "fake" reason codes are quite acceptable as long as they convey the 
proper semantics. Busy is busy, whether it came from a UA, proxy, or 
gateway.

If "fake" reason codes are not acceptable, then gateways should always 
be returning pstn codes rather than sip codes.

	Paul

---

From: Dean Willis <[email-masked]>
Date: Tue, 1 Nov 2005 17:26:02 -0600

> I'd like to hear other opinions on this.

Hey, I've been faking technical expertise for years, and it usually  
works OK.

Why not fake some history-infos, as long as the result is a valid  
model of the internal process?

--
Dean