Subject: [Sipping] Re: Telling a proxy which service to execute

From: Gonzalo Camarillo <[email-masked]>
Date: Thu, 03 Nov 2005 11:13:52 +0200

Hi John,

the proxy recursing on the 302 will be the one adding that information. 
The 302 does not need to go all the way to the UAC.

Gonzalo

Elwell, John wrote:
> Gonzalo,
> 
> No I'm not saying I don't want H-I at all. I was trying to avoid needing
> special support at a UAC. With your proposal it requires the UAC to take
> special action to copy H-I from the 3xx to the retargeted Request-URI -
> otherwise the information is lost.
> 
> John
>  
> 
> 
>>-----Original Message-----
>>From: Gonzalo Camarillo [mailto:[email-masked]] 
>>Sent: 03 November 2005 09:01
>>To: Elwell, John
>>Cc: sipping
>>Subject: Re: Telling a proxy which service to execute
>>
>>John,
>>
>>in a previous email you are saying that service retargetting 
>>needs H-I 
>>in order to work (in case a proxy in the middle changes the 
>>Request-URI), and now you are saying that you do not want to 
>>use H-I at 
>>all and only use service retargetting... I am confused.
>>
>>Thanks,
>>
>>Gonzalo
>>
>>
>>Elwell, John wrote:
>>
>>>Gonzalo,
>>>
>>>
>>>
>>>
>>>>-----Original Message-----
>>>>From: Gonzalo Camarillo [mailto:[email-masked]] 
>>>>Sent: 02 November 2005 17:42
>>>>To: sipping
>>>>Cc: Elwell, John
>>>>Subject: Telling a proxy which service to execute
>>>>
>>>>Folks,
>>>>
>>>>it seems to me that the History-Info approach can meet the 
>>>>requirements 
>>>>coming from services that need to know what has happened to 
>>>>this request 
>>>>so far.
>>>
>>>[JRE] With the significant disadvantage that the UAC has to 
>>
>>support the
>>
>>>generation of History-Info for this to work. It is my 
>>
>>opinion that proxies
>>
>>>and B2BUAs will support the addition of History-Info 
>>
>>entries, but support by
>>
>>>UAs might be limited to reading what is received rather 
>>
>>than adding entries.
>>
>>>The service-retargeting solution is the only solution 
>>
>>proposed that does not
>>
>>>require special UAC support.
>>>
>>>John
>>

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Elwell, John" <[email-masked]>
Date: Thu, 03 Nov 2005 09:09:41 +0000

Gonzalo,

John

---

From: Dean Willis <[email-masked]>
Date: Thu, 3 Nov 2005 11:00:04 -0600

On Nov 3, 2005, at 3:13 AM, Gonzalo Camarillo wrote:

> Hi John,
>
> the proxy recursing on the 302 will be the one adding that  
> information. The 302 does not need to go all the way to the UAC.
>

But if the UAS is generating a 302 because the UAS is busy, and we  
use H-I to convey this "business" to the proxy-that-recurses, then  
the UAS would indeed be required to support H-I.

OTOH, if the UAS never returns 302, but instead returns 486, the the  
proxy has all the information. Of course, this requires that the  
proxy have even MORE information, including the new target. This  
precludes some use cases, such as "the called user decides where to  
redirect the caller based on caller identity".

--
Dean