Subject: [Sipping] DialogUsage: new draft

From: Robert Sparks <[email-masked]>
Date: Tue, 22 Nov 2005 16:31:31 -0600

I've just submitted http://www.nostrum.com/~rjsparks/draft-ietf- 
sipping-dialogusage-00.txt
to the repository.

There are two discussions to close on quickly, each of which I'll  
start threads on with
separate messages:
   - Do we have clarity around how 481 affects dialogs/usages/ 
transactions
   - Should this draft so strongly state that multiple usages should  
be avoided?

RjS

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Jeroen van Bemmel" <[email-masked]>
Date: Tue, 22 Nov 2005 23:48:53 +0100

Robert,

Here's a third question to add to your list:

On sip-implementors Paul just stated that SUBSCRIBE and NOTIFY are both 
target-refresh requests. A thread from some time ago 
(http://lists.cs.columbia.edu/pipermail/sip-implementors/2002-November/004066.html) 
states that they are not, quoting "complications" with multiple dialog 
usages.

Q: What are these complications, and how should they be dealt with?

I suppose that often the assumption is that if a SUBSCRIBE arrives on the 
same dialog as a previous INVITE, the sending entity is the same in both 
cases (the odds that another entity would use the same call-id, from-tag and 
to-tag at random are negligible). Is there a reason for an entity to 
advertise different contact addresses for NOTIFYs versus other in-dialog 
requests?

If yes, then perhaps the Contact should be maintained per dialog usage, 
instead of per dialog?

Regards,
Jeroen

----- Original Message ----- 
From: "Robert Sparks" <[email-masked]>
To: "Sipping WG" <[email-masked]>
Sent: Tuesday, November 22, 2005 11:31 PM
Subject: [Sipping] DialogUsage: new draft

> There are two discussions to close on quickly, each of which I'll  start 
> threads on with
> separate messages:
>   - Do we have clarity around how 481 affects dialogs/usages/ transactions
>   - Should this draft so strongly state that multiple usages should  be 
> avoided?
>
> RjS
>
>

---

From: Robert Sparks <[email-masked]>
Date: Wed, 23 Nov 2005 09:18:04 -0600

On Nov 22, 2005, at 4:48 PM, Jeroen van Bemmel wrote:

> On sip-implementors Paul just stated that SUBSCRIBE and NOTIFY are  
> both target-refresh requests. A thread from some time ago (http:// 
> lists.cs.columbia.edu/pipermail/sip-implementors/2002-November/ 
> 004066.html) states that they are not, quoting "complications" with  
> multiple dialog usages.
>
I'll dig back for that thread, but the its conclusion as you  
summarize it is incorrect.

SUBSCRIBE and NOTIFY are very much dialog refresh requests.

The draft already talks about the complications of shared dialog  
state between usages (see section 3.4).

>
> I suppose that often the assumption is that if a SUBSCRIBE arrives  
> on the same dialog as a previous INVITE, the sending entity is the  
> same in both cases (the odds that another entity would use the same  
> call-id, from-tag and to-tag at random are negligible). Is there a  
> reason for an entity to advertise different contact addresses for  
> NOTIFYs versus other in-dialog requests?
You can't.
>
> If yes, then perhaps the Contact should be maintained per dialog  
> usage, instead of per dialog?
No. If you have this kind of requirement, you _definitely_ need to be  
using different dialogs.

>
> Regards,
> Jeroen
>
> ----- Original Message ----- From: "Robert Sparks"  
> <[email-masked]>
>>   - Should this draft so strongly state that multiple usages  
>> should  be avoided?
>>
>> RjS
>>
>>