Subject: RE: [Sipping] RE: Warning codes discussion

From: "Jean-Francois Mule" <[email-masked]>
Date: Thu, 10 Nov 2005 00:20:45 -0700

Gonzalo and all,

Having other examples for how other organizations or applications are thinking about using warning codes would help.

The piece that I don't like about the ID and the new warning code proposal is specifically the free form text parameter and the new notion of namespace being introduced beyond the current "protocol" reasons.

--- On the text parameter
What is the intended usage of this human readable string? 
If the intent is to display it to some end-user GUI, then it should be used in conjunction with the Accept-Language header (and the internationalization issues arise in implementations of warning codes making this human output usage somewhat difficult without new status codes). Reading the ID, examples like "text=low battery" provide good reason for not using "SIP-warning" code imo.
If the intent is to just allow a bigger range as Sean points to for richer parsing, then defining new status codes is the way to go.

--- namespace explosion
The other question is about the can of worms you open with the SIP-warning namespace. In 3326, the name space is limited to protocol error codes. How do you avoid anyone from adding its own vendor-specific warnings in there?

For those reasons, I personally prefer new status codes.

Jean-François

> -----Original Message-----
> From: Sean Olson [mailto:[email-masked]]
> Sent: Wednesday, November 09, 2005 3:30 PM
> To: Gonzalo Camarillo; sipping
> Subject: [Sipping] RE: Warning codes discussion
> 
> Simply adding new status codes does not solve all the problems.
> Sometimes what you want is a hierarchical status. E.g. you want
> distinct
> sub-codes for various types of "Busy". (486.1, 486.2, etc.)
> 
> A problem with the current Warning codes is that many of the things
> you
> may want to do have to fall in the 390-399 range reserved for
> "miscellaneous warnings". We need a bigger range and that's assuming
> we
> can cheat and use Warning codes to apply to problems other than the
> SDP
> itself. The type of problems I want to solve can't depend on the
> warning
> text or reason phrase; I need a static value that automata can handle.
> 
> I'd like to see some clarification on how best to solve these type of
> problems, in particular if Warning should NOT be used.
> 
> Cheers,
> sean
> 
> -----Original Message-----
> From: Gonzalo Camarillo [mailto:[email-masked]]
> Sent: Wednesday, November 09, 2005 1:45 PM
> To: sipping
> Cc: Sean Olson; Jonathan Rosenberg
> Subject: Warning codes discussion
> 
> Folks,
> 
> following up on the face-to-face discussion on Warning codes we just
> had
> during the SIPPING session, I would like the WG to agree on how we use
> Reason codes and Warning codes.
> 
> Would everybody agree that the WG should recommend defining new status
> codes as opposed to defining new Warning codes?
> 
> The fact that the WG agreed on this would be useful for external
> organizations that intend (or are in the process of) defining new
> Warning codes for things that could be better resolved with new status
> codes.
> 
> Thanks,
> 
> Gonzalo
> 
> 
> _______________________________________________
> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments of core SIP

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Gonzalo Camarillo <[email-masked]>
Date: Thu, 10 Nov 2005 16:57:27 +0200

Hi,

to be absolutely clear: forget about the draft. The draft is only a 
strawman to trigger discussions about the use of status codes vs. 
Warning codes. That is the discussion I wanted to have.

Thanks,

Gonzalo

-- 
Gonzalo Camarillo         Phone :  +358  9 299 33 71
Oy L M Ericsson Ab        Mobile:  +358 40 702 35 35
Telecom R&D               Fax   :  +358  9 299 30 52
FIN-02420 Jorvas          Email :  [email-masked]
Finland                   http://www.hut.fi/~gonzalo