Subject: RE: [Sipping] Redirection on busy and History Info

From: "Dolly, Martin C, ALABS" <[email-masked]>
Date: Tue, 1 Nov 2005 08:42:28 -0600

Hello,

I see the need for History-Info and service-retargetting.

Though I believe that Gonzalo's approach might work, there are too may
"if's" in the proposal.

Cheers,

Martin

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On
> Behalf Of Elwell, John
> Sent: Tuesday, November 01, 2005 2:45 AM
> To: Francois Audet; Gonzalo Camarillo; Mary Barnes
> Cc: sipping
> Subject: RE: [Sipping] Redirection on busy and History Info
> 
> 
> As co-author of both the redirection-reason draft and the
> service-retargeting draft, my motivation was essentially 
> providing a model
> that described what has happened so far, rather than a model 
> that prescribes
> what should happen next. The redirection-reason draft clearly 
> follows the
> first model. The service-retargeting draft could support 
> either model, which
> is one of its advantages. So I guess the question is whether 
> we need support
> for both models and whether it is appropriate to have a 
> single solution to
> satisfy both models or more appropriate to have two separate 
> solutions.
> 
> Concerning the "what has happened so far" model, this should 
> extend to being
> interoperable with PSTN. Given that History-Info is a basis 
> for both/all the
> solutions proposed so far (even service-retargeting relies on 
> History-Info
> to capture what happened prior to the last retarget), then 
> History-Info will
> play some part in this PSTN interoperability.
> 
> John
>  
> 
> > -----Original Message-----
> > From: Francois Audet [mailto:[email-masked]] 
> > Sent: 01 November 2005 00:51
> > To: Gonzalo Camarillo; Mary Barnes
> > Cc: sipping; Elwell, John
> > Subject: RE: [Sipping] Redirection on busy and History Info
> > 
> > Also, on the "what has happened so far" model, one issue is PSTN
> > interop.
> > 
> > I always held the view that SIP UAC or proxies should not 
> > generate "fake" History-Info to account for redirection that
> > occured outside of SIP (e.g., the PSTN). I.e.., it shouldn't
> > lie that that there was a 486 or 302 received when there 
> > were no such thing.
> > 
> > This is one of the main reason for the 3087 model.
> > 
> > > -----Original Message-----
> > > From: [email-masked] 
> > > [mailto:[email-masked]] On Behalf Of Gonzalo Camarillo
> > > Sent: Monday, October 31, 2005 10:58
> > > To: Barnes, Mary [NGC:B601:EXCH]
> > > Cc: sipping; Elwell, John
> > > Subject: Re: [Sipping] Redirection on busy and History Info
> > > 
> > > 
> > > Hi,
> > > 
> > >  > Of course,  I think the primary debate isn't necessarily over
> > > > whether one could or could not use History-Info for 
> this type of 
> > > > service, but rather there is a preference to provide even more 
> > > > explicit service information, per the RFC 3087 model.
> > > 
> > > as Dave pointed out a few messages ago in a related thread, 
> > there are 
> > > two models: one where the entity explains what has happened 
> > > so far, and 
> > > the other where the entity tells what should happen in the 
> > > future. The 
> > > solution we are discussing here would cover the former model. 
> > > As long as 
> > > there are folks interested in that model, I guess it is 
> worthwhile 
> > > pursuing that solution (or something equivalent).
> > > 
> > > Then, as a separate discussion, we can analyze how to support 
> > > the latter 
> > > model as well.
> > > 
> > > Cheers,
> > > 
> > > Gonzalo
> > > 
> > > _______________________________________________
> > > Sipping mailing list  
> https://www1.ietf.org/mailman/listinfo/sipping
> > > This list is for NEW development of the application of SIP
> > > Use [email-masked] for questions on current 
> > > sip Use [email-masked] for new developments of core SIP
> > > 
> > > 
> > 
> 
> _______________________________________________
> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments of core SIP
> 

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Gonzalo Camarillo <[email-masked]>
Date: Tue, 01 Nov 2005 18:53:19 +0200

Hi Martin,

> Though I believe that Gonzalo's approach might work, there are too may

My view is that if people want to support the "what happened so far" 
model, this is a workable solution that requires minimum specification 
work (which is a good thing).

Of course, we will have to look into the other model as well, which is 
not covered by this solution.

Thanks,

Gonzalo