Subject: Re: [Sipping] Handling UPDATE

From: Retesh Chadha <[email-masked]>
Date: Tue, 29 Nov 2005 17:08:06 +0530

Hi Rajpal

I think incoming UPDATE should be processed as a new offer, and should be responded normally with an answer. Now when the timer for UPDATE fires, a new offer should be sent if the state of the UA allows it to.

This is what the RFC says,

"When the timer fires, the UAC SHOULD attempt the UPDATE once more, if
it still desires for that session modification to take place."

Rgds

Retesh

[email-masked] wrote: -----

To: <[email-masked]>
From: [email-masked]
Sent by: [email-masked]
Date: 11/29/2005 03:14PM
Subject: [Sipping] Handling UPDATE

Hi All,

In scenario like:

UAC sends UPDATE with offer to UAS.
UAC receives 491 response for UPDATE
UAC starts a timer. When this timer will fire, UAC again attempt to send UPDATE.
When timer is running, UAC receives UPDATE with offer from UAS.

What  treatment should be given to UPDATE received from UAS while timer is running at UAC ?

Thanks,

Rajpal

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

*****FSS-Unclassified *****" DISCLAIMER: This message is proprietary to Flextronics Software Systems Limited (FSS) and is intended solely for the use of the individual to whom it is addressed. It may contain privileged or confidential information and should not be circulated or used for any purpose other than for what it is intended. If you have received this message in error, please notify the originator immediately. If you are not the intended recipient, you are notified that you are strictly prohibited from using, copying, altering, or disclosing the contents of this message. FSS accepts no responsibility for loss or damage arising from the use of the information transmitted by this email including damage from virus."

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 29 Nov 2005 13:22:45 -0500

The incoming update should be processed as a new offer, yes. Furthmore, 
whatever session updates were desired can be passed in the answer. Thus, 
when the timer fires, there would be no need to generate an updated offer.

-Jonathan R.

Retesh Chadha wrote:

> Hi Rajpal
> I think incoming UPDATE should be processed as a new offer, and should 
> be responded normally with an answer. Now when the timer for UPDATE 
> fires, a new offer should be sent if the state of the UA allows it to.
>  
>         * UAC sends UPDATE with offer to UAS.
>         * UAC receives 491 response for UPDATE
>         * UAC starts a timer. When this timer will fire, UAC again
>           attempt to send UPDATE.
>         * When timer is running, UAC receives UPDATE with offer from UAS. 
> 
> *****FSS-Unclassified *****" DISCLAIMER: This message is proprietary to 
> Flextronics Software Systems Limited (FSS) and is intended solely for 
> the use of the individual to whom it is addressed. It may contain 
> privileged or confidential information and should not be circulated or 
> used for any purpose other than for what it is intended. If you have 
> received this message in error, please notify the originator 
> immediately. If you are not the intended recipient, you are notified 
> that you are strictly prohibited from using, copying, altering, or 
> disclosing the contents of this message. FSS accepts no responsibility 
> for loss or damage arising from the use of the information transmitted 
> by this email including damage from virus."
> 
> 
> ------------------------------------------------------------------------
> 

-- 
Jonathan D. Rosenberg, Ph.D.                   600 Lanidex Plaza
Cisco Fellow                                   Parsippany, NJ 07054-2711
Cisco Systems
[email-masked]                              FAX:   (973) 952-5050
http://www.jdrosen.net                         PHONE: (973) 952-5000
http://www.cisco.com