Subject: Re: [Sipping] DialogUsage: How strong should the admonition against multiple usages be

From: Paul Kyzivat <[email-masked]>
Date: Fri, 02 Dec 2005 14:03:43 -0500

If there is a plan to eliminate use of shared dialogs for *all* 
purposes, and it is just a matter of migrating from here to there, then 
I am fine to declare the mechanism deprecated and banned for all new uses.

But if the plan is allow it in perpetuity for existing uses, then I 
consider deprecating it *all* new uses somewhat silly. That just becomes 
one more excuse for people not to implement support at all. If it is 
good enough for existing uses, then it should be good enough for similar 
uses that find the pro/con tradeoff favorable. And it encourages 
implementors to ensure that the required support is there.

Its not clear to me what the plan is.

	Paul

Vijay K. Gurbani wrote:
> Paul Kyzivat wrote:
> 
>> Its a matter of degree. Having the alternative mechanisms is good. But 
>> I don't think it is inconsistent to acknowledge the other mechanism is 
>> still useful in certain cases.
> 
> 
> I am looking at this from an implementation point of view: having
> alternative mechanisms for doing the same thing lead to all
> sorts of interoperability problems.
> 
> We are dealing with one right now in the double R-R vs. response
> re-writing.  Admittedly, that one is not as severe as multiple
> dialog usage one, but it is ambiguity all the same.
> 
> It'll be good if we pick *one way* and stick with it.  For the record,
> I thought that we had agreed that dialog sharing was bad and
> we were going to deprecate it.
> 
> Thanks,
> 
> - vijay

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Mon, 05 Dec 2005 13:47:21 -0600

> Its not clear to me what the plan is.

I don't know what the plan is either.

However, I think that grandfather-ing existing uses and banning new
ones is not all that silly.  As is the case with complex ecosystems,
our understanding of multiple dialog usage has evolved over time.
What once looked like a nice property may not be so once we have
built, interoperated, and better understood the feature.  Change
process is built into IETF protocols, and I see obsolecense of a
particular feature -- if it has proved too complex to understand
and implement uniformly -- a part of this change.

FWIW, dialogusage-00 devotes a fair amount of verbiage on
alternatives for existing multiple usages.  Presumably, new
implementations can avail themselves of these instead of
sharing dialogs.

Thanks.

- vijay
-- 
Vijay K. Gurbani, Ph.D.  vkg@{lucent.com,research.bell-labs.com,acm.org}
Lucent Technologies/Bell Laboratories, 2000 Lucent Lane, Rm 6G-440
Naperville, Illinois 60566     Voice: +1 630 224 0216
_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP