Subject: RE: [Sipping] Call Forwarding Queries

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Thu, 1 Dec 2005 12:43:26 -0000

At the mement the intent appaears to be to solve the issues addressed in relation to forwarding reason using provision of 
 
 <http://www.ietf.org/internet-drafts/draft-jennings-sip-voicemail-uri-05.txt> http://www.ietf.org/internet-drafts/draft-jennings-sip-voicemail-uri-05.txt
 
This document is currently an AD sponsored author draft undergoing IESG review.
 
Therefore I beieve the author currently does not intend to progress 
 
 <http://www.ietf.org/internet-drafts/draft-elwell-sipping-redirection-reason-02.txt> http://www.ietf.org/internet-drafts/draft-elwell-sipping-redirection-reason-02.txt 
 
regards
 
Keith

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Gaurav Kheterpal
Sent: 01 December 2005 06:01
To: [email-masked]; [email-masked]
Subject: [Sipping] Call Forwarding Queries

Hi,

I had some queries regarding the implementation of Call Forwarding in SIP. I would like to implement the conventional CF modes - CFU (Always), CFB (Busy), CFN (No Answer) and CFC (Calendar) on a SIP phone as on a normal PSTN phone/ PBX.

1. For CFU: Is it better to use

a) The Forwarding URI as a CONTACT header in the REGISTER request itself, so that no INVITES are received on the original URI. This would make forwarding to be dependent on registration expiry so is it a good idea?

b) OR respond to every INVITE request with a 302/ 301 (which one of these) with the Forwarding URI as the CONTACT header? (And with reason header as 'Forward Immediate')

2. For CFN:

a) In this case, should the callee ring for duration of timer B (default = 64*500 ms = 32 sec) before we send out a response (typically a 302 again with reason as 'Forward no reply'). But in this case, most proxies will themselves generate a 408 Request Timeout on expiration of timer B? How to handle this?

3. For CF based on Calendar (particular date/ time settings), which value of reason header should be used?

4. For DND (Do Not Disturb), some implementations return a 480 while others return a 486 in response to an INVITE. Though I feel it's better to use a 480 as compared to 486 for the same, I would like a second opinion on this.

I'm referring to the draft-elwell-sipping-redirection-reason-01.txt draft for REASON header.

Thanks for your guidance in advance.

Regards,

Gaurav

********************** Legal Disclaimer **************************** 

"This email may contain confidential and privileged material for the sole use of the intended recipient. Any unauthorized review, use or distribution by others is strictly prohibited. If you have received the message in error, please advise the sender by reply email and delete the message. Thank you." 

********************************************************************** 

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Dean Willis <[email-masked]>
Date: Thu, 1 Dec 2005 15:52:30 -0600

On Dec 1, 2005, at 6:43 AM, Drage, Keith (Keith) wrote:

> At the mement the intent appaears to be to solve the issues  
> addressed in relation to forwarding reason using provision of
>
> http://www.ietf.org/internet-drafts/draft-jennings-sip-voicemail- 
> uri-05.txt
>
> http://www.ietf.org/internet-drafts/draft-elwell-sipping- 
> redirection-reason-02.txt
>

Keith's assertion is consistent with this chair's understanding.

--
Dean