Subject: RE: [Sipping] Call Forwarding Queries

From: "Gordon Ledgard" <[email-masked]>
Date: Thu, 1 Dec 2005 17:06:27 -0500

Just out of curiosity, I noticed that Cullen's draft uses a technique of
inserting a diversion reason into a parameter in the URI of the call.

What is the primary advantage of this method over the insertion of the 
reason into a separate header (like - oh - say - Diversion)?

I thought the primary reason for abandoning Diversion was its inability
to
deal with various forking issues, and accurately reflect the nuances of
call redirection history, or am I wrong? And that these reasons were
thus the big push to try to capture this information in History headers.

I'm not advocating anything, BTW. Just wondering.

Thanks,
Gordon Ledgard
IPeria, Inc.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
Behalf
> Of Dean Willis
> Sent: Thursday, December 01, 2005 4:53 PM
> To: Drage, Keith (Keith)
> Cc: [email-masked]
> Subject: Re: [Sipping] Call Forwarding Queries
> 
> 
> On Dec 1, 2005, at 6:43 AM, Drage, Keith (Keith) wrote:
> 
> > At the mement the intent appaears to be to solve the issues
> > addressed in relation to forwarding reason using provision of
> >
> > http://www.ietf.org/internet-drafts/draft-jennings-sip-voicemail-
> > uri-05.txt
> >
> > This document is currently an AD sponsored author draft undergoing
> > IESG review.
> >
> > Therefore I beieve the author currently does not intend to progress
> >
> > http://www.ietf.org/internet-drafts/draft-elwell-sipping-
> > redirection-reason-02.txt
> >
> 
> Keith's assertion is consistent with this chair's understanding.
> 
> --
> Dean
> 
> _______________________________________________
> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments of core SIP

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Jeroen van Bemmel" <[email-masked]>
Date: Fri, 2 Dec 2005 08:05:41 +0100

Gordon,

One reason - which could be mentioned in the draft - could be that the 
request URI is covered by the loop detection digest, and a Digest header 
would not be. Modifying the request URI avoids that another proxy would 
signal it as looping

Regards,

Jeroen

----- Original Message ----- 
From: "Gordon Ledgard" <[email-masked]>
To: "Dean Willis" <[email-masked]>; "Drage, Keith (Keith)" 
<[email-masked]>
Cc: <[email-masked]>
Sent: Thursday, December 01, 2005 11:06 PM
Subject: RE: [Sipping] Call Forwarding Queries

Thanks,
Gordon Ledgard
IPeria, Inc.

Behalf