Subject: RE: [Sipping] how to change of SSRC in the media stream?

From: "Elwell, John" <[email-masked]>
Date: Fri, 16 Dec 2005 08:52:33 +0000

Colin,

But beware that MIKEY (if used) effectively locks down the SSRC.

John

> -----Original Message-----
> From: Colin Perkins [mailto:[email-masked]] 
> Sent: 16 December 2005 00:32
> To: Sreedhar Pampati
> Cc: [email-masked]
> Subject: Re: [Sipping] how to change of SSRC in the media stream?
> 
> On 15 Dec 2005, at 01:19, Sreedhar Pampati wrote:
> > I have the following scenario:
> >
> > 1. SIP Phone1 calls an App Server (AS) and the AS connects 
> the call to
> > play prompts. This sets up the stream from the AS to the phone with
> > SSRC=1000 in the RTP header.
> >
> > 2. After collecting the digits (and the destination number) the AS
> > (which is acting in B2BUA mode) places an outgoing call to SIP  
> > Phone 2.
> > This sets up the stream from the Phone 2 to the AS with SSRC=9999.
> >
> > 3. The AS is in the media path and in order to synchronize 
> the SSRC  
> > and
> > timestamps on the RTP (streams) between the Phone 1 and Phone 2,  
> > the AS
> > needs to let the Phone1 to expect a new SSRC (namely 9999).
> >
> > My question is, can the AS send a reINVITE to the SIP Phone1 with a
> > version number increment in the o= line in the SDP? Is that 
> sufficient
> > for Phone 1 to expect a new SSRC on the incoming RTP packets?
> 
> The SSRC can change within a session, without explicit signalling.  
> Send an RTCP BYE for the old SSRC and start using the new SSRC.  
> Receivers will recognise the RTCP CNAME as being constant and  
> associate it with the original sender. See RFC 3550, in particular  
> sections 7 and 8.
> 
> Colin
> 
> _______________________________________________
> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments of core SIP
> 

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Sreedhar Pampati" <[email-masked]>
Date: Fri, 16 Dec 2005 10:20:51 -0800

That is a very good point. My question is in reference to the use of
SRTP with IVR. How do you think we can switch change the SSRC? Will a
reINVITE with change in the o= parameter work at all?
Thanks
Sreedhar

-----Original Message-----
From: Elwell, John [mailto:[email-masked]] 
Sent: Friday, December 16, 2005 12:53 AM
To: Colin Perkins; Sreedhar Pampati
Cc: [email-masked]
Subject: RE: [Sipping] how to change of SSRC in the media stream?

Colin,

John