Subject: RE: [Sipping] Re: draft-sawada-sipping-sip-offeranswer-01

From: "Christer Holmberg \(JO/LMF\)" <[email-masked]>
Date: Tue, 18 Jul 2006 23:09:27 +0200

Hi,

If we forget the UPDATE, is offer2/answer2 in effect after the reINVITE 4xx response?

IF so, I guess offer3/answer3 will be in effect after UPDATE 200 OK.

Also, isn't this related to target refresh discussion? If I send a re-INVITE with a new local Contact header value, receives a reliable 18x with a new remote Contact header value, and then a 4xx response to the re-INVITE? Now, are the new Contact header values in affect?

Regards,

Christer

-----Original Message-----
From: Paul Kyzivat [mailto:[email-masked]] 
Sent: 18. heinäkuuta 2006 19:55
To: [email-masked]
Cc: Takuya Sawada
Subject: [Sipping] Re: draft-sawada-sipping-sip-offeranswer-01

I just fielded a question on offer/answer that raised what seems like a new issue. Here is the case - Alice calling Bob:

- Alice calls Bob: INVITE w/offer1, 200ok w/answer1, ACK
- Alice reINVITE Bob w/offer2
- Bob respond reliable 18x w/answer2
- Alice PRACK the 18x
- Bob 200ok the PRACK
- Alice UPDATE w/offer3
- Bob 200ok the UPDATE w/answer3
- Bob respond 4xx to reINVITE
- Alice ACK the reINVITE

At this point, what SDP is in effect?
It seems like it should be offer1/answer1, but I think the various specs don't give guidance that would lead to that result. It is easy to conclude that according to the specs it should be offer3/answer3, because the failure of the reinvite doesn't necessarily influence the UPDATE.

Or do others think the result *ought* to be offer3/answer3?

I was thinking of this in the context of offer3 resolving preconditions initiated by offer2, but of course this can happen without preconditions as well.

	Paul

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP Use [email-masked] for questions on current sip Use [email-masked] for new developments of core SIP

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 18 Jul 2006 19:41:08 -0400

> If we forget the UPDATE, is offer2/answer2 in effect after the reINVITE 4xx response?

I'm not sure if I understand your question. Do you mean what is result 
of a call flow like mine, but with the UPDATE removed?

In that case IMO it is clear that offer1/answer1 are in effect.

> IF so, I guess offer3/answer3 will be in effect after UPDATE 200 OK.

I disagree above. Your conclusion here is apparently based on the same 
logic.

> Also, isn't this related to target refresh discussion? If I send a re-INVITE with a new local Contact header value, receives a reliable 18x with a new remote Contact header value, and then a 4xx re…

We could discuss the impact of a similar flow on target refresh. I'd 
like that to be a separate discussion. (It doesn't impact the 
offeranswer draft.) Maybe we can finish this one first.

	Paul