Subject: RE: [Sipping] Some thoughts on fixing early media

From: "Christer Holmberg \(JO/LMF\)" <[email-masked]>
Date: Wed, 19 Jul 2006 18:15:19 +0200

Hi Jeroen,

I may have missunderstood you, but are you saying that a UAS should request to send 200 OK? I think a UAS should be allowed to send 200 OK, even if another UAS currently has the "green light" to send early media.

But, again, I may have missunderstood you :)

Regards,

Christer

-----Original Message-----
From: Jeroen van Bemmel [mailto:[email-masked]] 
Sent: 19. heinäkuuta 2006 3:21
To: Dean Willis
Cc: 'sipping'
Subject: Re: [Sipping] Some thoughts on fixing early media

>> That is, if the UA would be doing it. A proxy would automatically  
>> CANCEL other branches once one of them sends 200 OK to the INVITE.  
>> So all that is needed is a way for the UAC to "invite" the selected  
>> UAS to do that (it implies that things break down once one of the  
>> contacted UAS sends 200 OK before being elected, unless the UAC  uses Request-Disposition:
>> no-cancel)
>>
>
> Yep. I'm still up in the air about whether it's the UAC or the  
> forking proxy that has to manage the cleanup. I suppose it would be  
> cleaner at the UA, but maybe there's a way to get backward  
> compatibility for old UAs just using the proxy . . .

I doubt we would manage to play this "red light / green light game" in a backwards compatible way. If this requires changes at the UAC anyway, the cleanup would become just a minor addition.

Some other considerations:
In the current PSTN, what you can have is the following early media "This call will be charged at international dialing rates. If you don't wish to be charged, please hang up now [delay] [charging starts]"

In other words: opt-out. In SIP, this would translate to the UAS automatically sending 2xx (and the proxy cancelling other branches) after a delay, after playing its early media.

If we want opt-in, the SIP equivalent would be to have the UAC explicitly say "accept", for example using an UPDATE request (containing an offer for the "late media", and some flag triggering the UAS to send 2xx). This would not be backwards compatible.

The only way I see to do such opt-in in a (kind of) backwards compatible way, is to use some "press 1 to accept" tune and INFO or RTP with DTMF (or SUBSCRIBE/NOTIFY with KPML if you consider that as backwards). It seems that all of these quickly become "backwards complexity"

Regards,

Jeroen

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP Use [email-masked] for questions on current sip Use [email-masked] for new developments of core SIP

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Jeroen van Bemmel" <[email-masked]>
Date: Wed, 19 Jul 2006 18:32:45 +0200

>Hi Jeroen,
>
>I may have missunderstood you, but are you saying that a UAS should request 
>to send 200 OK? I think a UAS should be allowed to send 200 OK, even if 
> >another UAS currently has the "green light" to send early media.
>

Not "request", but wait for the green light (both for early media and for 
proceeding to the confirmed state). Of course this would only apply to UAS 
that implement the trafficlights extension

Regards,
Jeroen

-----Original Message-----
From: Jeroen van Bemmel [mailto:[email-masked]]
Sent: 19. heinäkuuta 2006 3:21
To: Dean Willis
Cc: 'sipping'
Subject: Re: [Sipping] Some thoughts on fixing early media

> compatibility for old UAs just using the proxy . . .

I doubt we would manage to play this "red light / green light game" in a 
backwards compatible way. If this requires changes at the UAC anyway, the 
cleanup would become just a minor addition.

Some other considerations:
In the current PSTN, what you can have is the following early media "This 
call will be charged at international dialing rates. If you don't wish to be 
charged, please hang up now [delay] [charging starts]"

In other words: opt-out. In SIP, this would translate to the UAS 
automatically sending 2xx (and the proxy cancelling other branches) after a 
delay, after playing its early media.

If we want opt-in, the SIP equivalent would be to have the UAC explicitly 
say "accept", for example using an UPDATE request (containing an offer for 
the "late media", and some flag triggering the UAS to send 2xx). This would 
not be backwards compatible.

The only way I see to do such opt-in in a (kind of) backwards compatible 
way, is to use some "press 1 to accept" tune and INFO or RTP with DTMF (or 
SUBSCRIBE/NOTIFY with KPML if you consider that as backwards). It seems that 
all of these quickly become "backwards complexity"

Regards,

Jeroen

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP Use 
[email-masked] for questions on current sip Use 
[email-masked] for new developments of core SIP

---

From: "Christer Holmberg \(JO/LMF\)" <[email-masked]>
Date: Wed, 19 Jul 2006 23:22:37 +0200

Hi,

I think a UAS should be allowed to send a 200 OK without having to wait. Otherwise there IS risk of clipping.

Regards,

Christer 

-----Original Message-----
From: Jeroen van Bemmel [mailto:[email-masked]] 
Sent: 19. heinäkuuta 2006 19:33
To: Christer Holmberg (JO/LMF); Dean Willis
Cc: sipping
Subject: Re: [Sipping] Some thoughts on fixing early media

>Hi Jeroen,
>
>I may have missunderstood you, but are you saying that a UAS should 
>request to send 200 OK? I think a UAS should be allowed to send 200 OK, 
>even if

Not "request", but wait for the green light (both for early media and for proceeding to the confirmed state). Of course this would only apply to UAS that implement the trafficlights extension

Regards,
Jeroen

-----Original Message-----
From: Jeroen van Bemmel [mailto:[email-masked]]
Sent: 19. heinäkuuta 2006 3:21
To: Dean Willis
Cc: 'sipping'
Subject: Re: [Sipping] Some thoughts on fixing early media

> Yep. I'm still up in the air about whether it's the UAC or the forking 
> proxy that has to manage the cleanup. I suppose it would be cleaner at 
> the UA, but maybe there's a way to get backward compatibility for old 
> UAs just using the proxy . . .

Regards,

Jeroen