Subject: RE: [Sipping] Some thoughts on fixing early media

From: "GARCIN Sebastien RD-CORE-ISS" <[email-masked]>
Date: Tue, 18 Jul 2006 08:58:10 +0200

See below 

sébastien 

-----Message d'origine-----
De : Dean Willis [mailto:[email-masked]] 
Envoyé : mardi 18 juillet 2006 00:38
À : GARCIN Sebastien RD-CORE-ISS
Cc : sipping
Objet : Re: [Sipping] Some thoughts on fixing early media

Early media, as currently used in unidirectional UAS->UAC  cases, doesn't require that an answer be sent yet, or in fact, every sent at all.

[SG: I agree with this. What I said was that early media MAY be bidirectional. This depends on you service requirement (e.g playing a plane announcement, DTMF collection, or doing speech recognition...). ]

Want to "steal calls"?

Get two user agents that corroborate by sending initial INVITE messages with "offers", subsequent INVITE messages in the reverse direction with "answers", and use early media in both directions to simulate a bi-directional call.

[SG: There are "non-SIP" architecture solutions to these fraud problems.]

If done carefully, you can make a call with no 200 OK, no ACK, no BYE, and without even any 100-class provisional messages (although using provisionals as acknowledgements cuts down the error rate).

Will this fork and interwork with the PSTN correctly? No, but neither does regular SIP.

--
Dean

On Jul 17, 2006, at 1:28 AM, GARCIN Sebastien RD-CORE-ISS wrote:

> Although you said that the SDP answer would be typically sent in a 200 
> OK, early media by definition takes place before the 200 OK. So the 
> SDP answer is typically sent in the first reliable 18x.
>
> sébastien
>
> -----Message d'origine-----
> De : Dean Willis [mailto:[email-masked]]
> Envoyé : jeudi 13 juillet 2006 23:19
> À : GARCIN Sebastien RD-CORE-ISS
> Cc : sipping
> Objet : Re: [Sipping] Some thoughts on fixing early media
>
>
> On Jul 13, 2006, at 11:29 AM, GARCIN Sebastien RD-CORE-ISS wrote:
>
>> Dean,
>>
>> With regards to your proposal below, having a SIP indication is more 
>> effecient than having to do a entire new offer/answer exchange via 
>> "re-INVITE". Another comment is that early media can sometime be 
>> bidirectional (e.g. for collecting DTMF in the foward direction) so 
>> "sendonly" is not appropriate. The only way would be to indicate 
>> "inactive" in the reliable SDP answer for "non early-media" cases and 
>> then send re-INVITEs for setting up the media session...
>
> I'd argue that if you're engaging in "early media" using bidirectional 
> media flow, you really need to have delivered an SDP answer so that 
> the UAC knows what kind of media it can send.
>
> --
> Dean
>

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Juha Heinanen <[email-masked]>
Date: Tue, 18 Jul 2006 10:26:23 +0300

GARCIN Sebastien RD-CORE-ISS writes:

 > Get two user agents that corroborate by sending initial INVITE
 > messages with "offers", subsequent INVITE messages in the reverse
 > direction with "answers", and use early media in both directions to
 > simulate a bi-directional call. 
 > 

i don't see any fraud in dean's sip-sip example.  in sip-sip case, user
pays for signaling, not for media.

-- juha

---

From: <[email-masked]>
Date: Tue, 18 Jul 2006 18:21:33 +0530

IMHO , the capabillity to send early media or play received early media
is the user agent's choice ..
Can't something be done based on callee capabillities and caller
preferences to fix the forking with early media issue .. 
? 

For example let's say there is a mechanism for an user agent to indicate
that it can play early media during registration(a PSTN gateway will
always indicate this for example). 

Now when the INVITE comes in and the  the forking proxy looks up the
registered contacts , if it finds that there are more than one
registered contact which can play early media then it does a sequential
fork instead of a parallel one or not fork at all but send back a 3xx
with the contacts. This behavior can be programmed with something like a
CPL script.

Similarly , an originating UAC can mention that it does not want early
media to be played as a part of request-dispostion when sending out an
invite , and the forking proxy can ignore those contacts which has early
media capabillities . 

My two cents ...

-----Original Message-----
From: Juha Heinanen [mailto:[email-masked]] 
Sent: Tuesday, July 18, 2006 12:56 PM
To: GARCIN Sebastien RD-CORE-ISS
Cc: sipping; Dean Willis
Subject: RE: [Sipping] Some thoughts on fixing early media

GARCIN Sebastien RD-CORE-ISS writes:

 > Get two user agents that corroborate by sending initial INVITE  >
messages with "offers", subsequent INVITE messages in the reverse  >
direction with "answers", and use early media in both directions to  >
simulate a bi-directional call. 
 >
 > [SG: There are "non-SIP" architecture solutions to these fraud  >
problems.] 

-- juha

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP Use
[email-masked] for questions on current sip Use
[email-masked] for new developments of core SIP