Subject: RE: [Sipping] WGLC Review: draft-ietf-sipping-v6-transition-03.txt

From: "Drage, Keith \(Keith\)" <[email-masked]>
Date: Wed, 26 Jul 2006 17:57:37 +0200

A couple more NITS while we are at it.

1)	General: I would prefer that any sentences that start "Note..."
are new paragraphs and indented, rather than buried in text with
normative statements. This has been done in some places, but there are
some exceptions. At least we need to be consistent.

2)	Reference [2] to RFC 2327. I could see no reason why this is not
to the replacing RFC 3266.

Regards

Keith

> -----Original Message-----
> From: Mary Barnes [mailto:[email-masked]] 
> Sent: 26 July 2006 02:47
> To: [email-masked]
> Cc: Vijay K. Gurbani; Gonzalo Camarillo; Karim El Malki
> Subject: [Sipping] WGLC Review: 
> draft-ietf-sipping-v6-transition-03.txt
> 
> Draft:  draft-ietf-sipping-v6-transition-03.txt
> Reviewer: Mary Barnes
> Review Date: 25 July 2006
> Review Deadline: 20 July 2006
> Status: WGLC  
> 
> Summary: This draft is basically ready for publication as a 
> Proposed Standard, updating RFC 3264.  However, there is one 
> question and some nits that should be addressed before 
> publication, along with the clarifications requested by the 
> other reviewers (although I'm okay with
> keeping the textual redundancy between sections 3.1 and 3.2). 
>   Some of
> the nits are very picky, but I think it's better for the 
> SIPPING WG to produce a doc that minimizes the changes the 
> RFC editor might make for readability.  
> 
> Section 3.1:
> - first paragraph: add reference to DNS (i.e. [8]) (the 
> reference does not appear until later in the 4th paragraph). 
> - 3rd paragraph (for readability):  replace 
> "(which...domain)."  with ", which...domain." 
> 
> Section 3.1.1: 
> - second main paragraph (i.e., paragraph after the indented 
> text addressing 2543 issues), 2nd sentence: change 
> "...session since without it, the upstream..." to 
> "...session; otherwise, the upstream ..."
> - second main paragraph, last sentence:  change the use of 
> "will contain the proxy's" to "contains the proxy's" (2 occurences). 
> - 5th paragraph: "...sports an address..." - I would think 
> either "has"
> or "support" would be a good replacement for "sports".  
> - 1st pargraph after the example (Note: you might also want 
> to add a Figure reference for the example): I would suggest 
> rewriting that paragraph as present tense - it makes it less 
> wordy and more definitive.
> In addition, the second sentence reads very awkwardly, so I 
> suggest to change from:
> "  It's route set will include, as the first destination, the proxy's
> IPv6 interface."
> to: 
> "  Its route set includes the proxy's IPv6 interface as the 
> first destination.
> 
> Section 4:
> 
> - 8th paragraph (1st paragraph following the numbered list):  
> Dale had suggested that the "(i.e., TURN)" be changed to an 
> "e.g." since it is an example. However, I have a general 
> question as to whether the TURN reference should be normative 
> (it is listed as a normative reference in the Reference 
> section), which means the "i.e," (meaning) is more 
> appropriate?  I would also suggest adding an explicit 
> reference to the TURN document at this point.  (Note also the 
> suggestion below to update the TURN reference).  
> 
> - 9th paragraph, last sentence (a slightly different change than Dale
> suggested): 
> change "... likely deploy TURN relays as a NAT-traversal,..." 
>     to "... likely to deploy TURN relays as a NAT-traversal 
> solution, ..."
> 
> References:
> - TURN reference [10] should now be to the BEHAVE WG document:
> draft-ietf-behave-turn-01
> - IDNITS has a minor complaint about an extra space after 
> "Session" in reference [13].
> 
> _______________________________________________
> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP 
> Use [email-masked] for questions on current 
> sip Use [email-masked] for new developments of core SIP
> 

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Colin Perkins <[email-masked]>
Date: Wed, 26 Jul 2006 17:01:19 +0100

> A couple more NITS while we are at it.
...
> to the replacing RFC 3266.

Or even RFC 4566.

Colin