Subject: Re: [Sipping] Comments on draft-sawada-sipping-sip-offeranswer-01. txt

From: "Christer Holmberg" <[email-masked]>
Date: Fri, 7 Jul 2006 09:06:09 +0300

Hi,

A short question of clarif8cation:

If we specify what to send in an offer to an empty re-INVITE, is that simply a clarifcation, or it is new normative text (it doesn't exist anywhere today)?

Or, will we also simply mention that issue, and put normative text in another spec in future?

Regards,

Christer

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Gonzalo Camarillo <[email-masked]>
Date: Fri, 07 Jul 2006 10:35:56 +0300

Hi,

I assume that you would like to have a normative recommendation. 
Something using an RFC 2119-style SHOULD or RECOMMENDED. So, you would 
need a normative document.

Cheers,

Gonzalo

-- 
Gonzalo Camarillo         Phone :  +358  9 299 33 71
Oy L M Ericsson Ab        Mobile:  +358 40 702 35 35
Telecom R&D               Fax   :  +358  9 299 30 52
FIN-02420 Jorvas          Email :  [email-masked]
Finland                   http://www.hut.fi/~gonzalo

---

From: Takuya Sawada <[email-masked]>
Date: Fri, 7 Jul 2006 17:11:21 +0900

Hi,

I think it requires no extension and fully conforms to the existing
rules. How to build the offer in the response depends on the
context such as UI of UAS or hold/unhold status.
In my understanding, these consist of notes and cares, and requires
no normative statements.

If my understanding is correct, we can put the descriptions for this
issue in the draft and proceed as informational. Otherwise, we should
make another draft.

How do you think?

Regards,

Takuya

> If we specify what to send in an offer to an empty re-INVITE, is that simply a 
clarifcation, or it is new normative text (it doesn't exist anywhere today)?
> Or, will we also simply mention that issue, and put normative text in another spec
 in future?

--------
Takuya Sawada
KDDI Corporation (KDDI)
Garden Air Tower, 3-10-10, Iidabashi, 
Chiyoda-ku, Tokyo 102-8460, Japan
Tel: +81-3-6678-2997
Fax: +81-3-6678-0286
[email-masked]

---

From: "Christer Holmberg \(JO/LMF\)" <[email-masked]>
Date: Fri, 7 Jul 2006 10:49:58 +0200

Hi,

>Something using an RFC 2119-style SHOULD or RECOMMENDED. 
 
...or even a MUST.
 
>So, you would need a normative document.
 
I personally think that the offeranswer spec would be a good place to have this normative text (again, we wouldn't modify any existing rules, but add a missing one), but I realize the scope may change. 

Regards,
 
Christer

---

From: "Christer Holmberg \(JO/LMF\)" <[email-masked]>
Date: Fri, 7 Jul 2006 10:52:48 +0200

Hi,
 
I think we need normative statements. Because, the "rules" that e.g. me and Paul seem to agree upon are not written anywhere.
 
Of course, IF we can solve the issue without having to add normative text, that's fine, but I have some doubts :)
 
Regards,
 
Christer

________________________________

From: Takuya Sawada [mailto:[email-masked]]
Sent: Fri 07/07/2006 10:11
To: Christer Holmberg (JO/LMF); [email-masked]; Gonzalo Camarillo (JO/LMF); [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: [Sipping] Comments on draft-sawada-sipping-sip-offeranswer-01. txt

Hi,

How do you think?

Regards,

Takuya

--------
Takuya Sawada
KDDI Corporation (KDDI)

---

From: Gonzalo Camarillo <[email-masked]>
Date: Fri, 07 Jul 2006 12:24:37 +0300

Hi,

to be clear, there should be two efforts: one in SIPPING to document 
*examples and clarifications* of SIP usages of offer/answer that may be 
unclear to implementers (i.e., this draft); another in SIP to document 
normatively rules that do not exist so far or to modify rules known to 
be broken.

Cheers,

Gonzalo

Christer Holmberg (JO/LMF) wrote:
> Hi,
>  
> I think we need normative statements. Because, the "rules" that e.g. me 
> and Paul seem to agree upon are not written anywhere.
>  
> Of course, IF we can solve the issue without having to add normative 
> text, that's fine, but I have some doubts :)
>  
> Regards,
>  
> Christer
> 
> ------------------------------------------------------------------------
> *From:* Takuya Sawada [mailto:[email-masked]]
> *Sent:* Fri 07/07/2006 10:11
> *To:* Christer Holmberg (JO/LMF); [email-masked]; Gonzalo Camarillo 
> (JO/LMF); [email-masked]
> *Cc:* [email-masked]; [email-masked]
> *Subject:* Re: [Sipping] Comments on 
> draft-sawada-sipping-sip-offeranswer-01. txt
> 
> Hi,
> 
>  > Or, will we also simply mention that issue, and put normative text in 
> another spec
>  in future?
>  >
>  > Regards,
>  >
>  > Christer
>  >
>  >

---

From: Paul Kyzivat <[email-masked]>
Date: Fri, 07 Jul 2006 16:44:43 -0400

> issue in the draft and proceed as informational. Otherwise, we should

I agree, for two reasons:

- this is going to be a SIPPING document, and I think it cannot make
   normative changes to SIP. So we would need a different document
   to be progressed in SIP for any such thing.

- I agree with Takuya that there will be nothing but recommendations
   because in the end what is offered can vary based on local changes
   to the state of the UA, which isn't standardized.

(How would we make a normative statement that the UAS should offer what 
*it* wants, rather than what it thinks the UAC wants based on prior 
offer answer?)

	Paul