Subject: RE: [Sipping] Some thoughts on fixing early media

From: "Hadriel Kaplan" <[email-masked]>
Date: Fri, 14 Jul 2006 16:12:00 -0400

Sorry, accidentally sent the email before finishing - is that "early email"?
:)

> -----Original Message-----
> From: Hadriel Kaplan [mailto:[email-masked]]
In the field typically a UAC behind a NAT thinks there's bidirectional
post-answer early-media, but that doesn't mean the UAS will render it and
regardless the fraud problem is really orthogonal to that I think.  

-hadriel

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Christer Holmberg \(JO/LMF\)" <[email-masked]>
Date: Mon, 17 Jul 2006 18:52:09 +0200

Hi,
 
When we talk about pre-answer and post-answer early media I believe that in many people are ok to require an SDP answer before accepting early media. The accept-media-as-soon-as-you-have-sent-the-INVITE, i.e. the pre-answer early media, is something which I have heard people saying is part of "the spirit of SIP".
 
But, even if you do get an SDP answer, you will still have the problem with forking - because you may receive media from different places. And, I don't see how not-sending-media-before-200 and forwarding all 200 OKs to the UAC (please note that eventhough a forking proxy should do that I will normally CANCEL the other legs when it has received 200 OK on one leg).
 
An indicator (whether it's a P-header, an "inactive" attribute, or whatever) would of course help a little, because then the UAC would know from where it may, or may not, receive media. But, the problem with media from multiple destinations still remain.
 
At one point I also proposed a "190" provisional response code, which could be used to indicate to the UAC that one leg has been terminated, while the others still exist (a 4xx/5xx/6xx response would terminate all legs). That would also help a little, because the UAC would know that it doesn't need to worry about a specific leg anymore. But, again, the problem with media from multiple destination woulds still remain.
 
Regards,
 
Christer

________________________________

From: Hadriel Kaplan [mailto:[email-masked]]
Sent: Fri 14/07/2006 22:12
To: 'Hadriel Kaplan'; 'Jiri Kuthan'; 'Dean Willis'; 'GARCIN Sebastien RD-CORE-ISS'
Cc: 'sipping'
Subject: RE: [Sipping] Some thoughts on fixing early media

-hadriel