Subject: [Sipping] Comments on draft-poetzl-sipping-call-completion-00.txt

From: Gonzalo Camarillo <[email-masked]>
Date: Thu, 06 Jul 2006 16:19:51 +0300

Hi,

this draft defines a couple of SIP event packages and uses them to
perform queue management. Event packages are typically used to obtain
information about the state of a resource. However, this draft seems to
be using them in order to perform a set of operations on that resource.

It may not be a good design choice to embed those operations in the
event package. A more explicit method may be a better option. For
example, in a conference, when several user agents want to gain access
to a resource (the right to speak), they implement a floor control
protocol (which is not SIP).

In any case, as noted by other reviewers, the draft should try and do a
better job explaining the proposed mechanism. A couple of more detailed
examples would be beneficial.

Thanks,

Gonzalo

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Dolly, Martin C, ALABS" <[email-masked]>
Date: Thu, 6 Jul 2006 10:38:40 -0500

Gonzalo,

Your conferencing example seems to be an over kill to me, and that path
would seem to be a timely one to me.

Cheers, Martin 

-----Original Message-----
From: Gonzalo Camarillo [mailto:[email-masked]] 
Sent: Thursday, July 06, 2006 9:20 AM
To: [email-masked]; [email-masked]; Jesske, R
Cc: sipping
Subject: [Sipping] Comments on
draft-poetzl-sipping-call-completion-00.txt

Hi,

Thanks,

Gonzalo

---

From: Gonzalo Camarillo <[email-masked]>
Date: Fri, 07 Jul 2006 09:36:06 +0300

Hi Martin,

note that I am not proposing to use a floor control protocol for
conferences for this application. I was providing an example to clarify
what these event packages are trying to do beyond notifying changes in
the state of a resource.

Yes, I agree. Having a good solution in a timely fashion should be our
priority. That's why I have initiated discussions on this topic.

Cheers,

Gonzalo

Dolly, Martin C, ALABS wrote:
> Gonzalo,
> 
> Your conferencing example seems to be an over kill to me, and that
> path would seem to be a timely one to me.
> 
> Cheers, Martin
> 
> -----Original Message----- From: Gonzalo Camarillo
> [mailto:[email-masked]] Sent: Thursday, July 06, 2006
> 9:20 AM To: [email-masked]; [email-masked];
> Jesske, R Cc: sipping Subject: [Sipping] Comments on 
>  information about the state of a resource. However, this draft seems
> to be using them in order to perform a set of operations on that
> resource.
> 
> example, in a conference, when several user agents want to gain
> access to a resource (the right to speak), they implement a floor
> control protocol (which is not SIP).
> 
> In any case, as noted by other reviewers, the draft should try and do
> a better job explaining the proposed mechanism. A couple of more
> detailed examples would be beneficial.
> 
> Thanks,
> 
> Gonzalo
> 
> _______________________________________________ Sipping mailing list
> https://www1.ietf.org/mailman/listinfo/sipping This list is for NEW
> development of the application of SIP Use
> [email-masked] for questions on current sip Use
> [email-masked] for new developments of core SIP

-- 
Gonzalo Camarillo         Phone :  +358  9 299 33 71
Oy L M Ericsson Ab        Mobile:  +358 40 702 35 35
Telecom R&D               Fax   :  +358  9 299 30 52
FIN-02420 Jorvas          Email :  [email-masked]
Finland                   http://www.hut.fi/~gonzalo