Subject: RE: [Sipping] how to transfer hookflash event, e.g. in a 3-way conference call?

From: Jeroen Van Bemmel <[email-masked]>
Date: Thu, 23 Nov 2006 09:30:51 +0100

Alternatively, the answer could also be: have an application server subscribe to the KPML event package, and have the edge device convert hook flashes to NOTIFYs. Then the AS can interpret them. This model may be appropriate when interpretation of the flashes is complex and requires coordination.

Not 100% IETF, but...

Regards,
Jeroen

-----Oorspronkelijk bericht -----
Van: "Jeroen van Bemmel" <[email-masked]>
Aan: "Paul Kyzivat" <[email-masked]>; "Brian Stucker" <[email-masked]>
CC: [email-masked]
Verzonden: 23-11-06 09:01
Onderwerp: Re: [Sipping] how to transfer hookflash event,	e.g. in a 3-way conference call?

So in summary, the answer to the original question would be: don't 
"transfer" the event, but interpret/convert it to the SIP mechanism that is 
defined for the feature you are implementing (assuming there is an analog 
POTS device with naught but hook flashes and DTMF to do signalling / feature 
activation, and some kind of edge device that converts this into SIP). Does 
this "put the intelligence in the network"?

Regards,
Jeroen

Paul Kyzivat wrote:
> After having worked on this a bit, I began to see what the issue is:
>
> SIP assumes that the devices are a lot smarter than "traditional"
> devices were, and expects them to carry out features that previously
> had been carried out in the network. And that is fine if the feature
> implementation can be self contained in the device. That depends on
> the device being smart enough, which is easy, and that it have enough
> UI to manage and control the features.
>
> But consider a black phone adapter. Regardless of how smart it is, its
> UI is limited to that black phone. So it has DTMF and audio to work
> with as its UI. And its unlikely to be able to do a whole lot of good
> audio synthesis. Also, there is some expectation about how features
> should work on such a device. Generally they are expected to be
> invoked with star codes, and some of them may have audio feedback of

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: [email-masked]
Date: Thu, 23 Nov 2006 12:18:39 +0100

Jeroen,

Your correct indeed - What puzzles me however is that you state - Not 100%
IETF.
If I remember well it was pushed to  introduce in the kpml event package
the "reporting of the Recall Event" exactly for the purpose you mention
below.

Refer to ftp://ftp.rfc-editor.org/in-notes/rfc4730.txt  (Eric Burger)
(Became an official RFC this month ;-) )

The CPE suppliers should of course follow ;-)

Kind Regards,
Rudi van

                      Jeroen Van                                                                                                     
                      Bemmel                   To:      Paul Kyzivat <[email-masked]>, Brian Stucker <[email-masked]>       
                      <jbemmel@zonnet.         cc:      [email-masked]                                                             
                      nl>                      Subject: RE: [Sipping] how to transfer hookflash event,  e.g. in a 3-way conference   
                                               call?                                                                                 
                      23/11/2006 09:30                                                                                               

Alternatively, the answer could also be: have an application server
subscribe to the KPML event package, and have the edge device convert hook
flashes to NOTIFYs. Then the AS can interpret them. This model may be
appropriate when interpretation of the flashes is complex and requires
coordination.

Not 100% IETF, but...

Regards,
Jeroen

-----Oorspronkelijk bericht -----
Van: "Jeroen van Bemmel" <[email-masked]>
Aan: "Paul Kyzivat" <[email-masked]>; "Brian Stucker"
<[email-masked]>
CC: [email-masked]
Verzonden: 23-11-06 09:01
Onderwerp: Re: [Sipping] how to transfer hookflash event,          e.g. in
a 3-way conference call?

defined for the feature you are implementing (assuming there is an analog
POTS device with naught but hook flashes and DTMF to do signalling /
feature
activation, and some kind of edge device that converts this into SIP). Does

Regards,
Jeroen

---

From: [email-masked]
Date: Mon, 27 Nov 2006 14:18:20 -0500

From: Jeroen Van Bemmel <[email-masked]>

   Alternatively, the answer could also be: have an application server
   subscribe to the KPML event package, and have the edge device
   convert hook flashes to NOTIFYs. Then the AS can interpret
   them.

... and use third-party call-control to implement the features in
question.

That does sound like it fulfils all of the original poster's
requirements.

Dale