Subject: [Sipping] Comments on draft-hasebe-sipping-race-examples-02

From: Nils Ohlmeier <[email-masked]>
Date: Thu, 9 Nov 2006 07:35:39 +0100

Hello,

please find my comments below from reviewing 
draft-hasebe-sipping-race-examples-02.txt:

page 5, 1st diagram:
Their are arrows missing in the lines for 2xx:
|            |             +-------------+--+
should be
|            |             +------------>+<-+

page 6, 1st paragraph:
"The dialog which is to be terminated by BYE in
   Early state."
What does this sentense mean?

page 6, 1st diagram:
The same applies for the diagram above:
|            |             +-------------+--+
should be
|            |             +------------>+<-+

Section 2
The whole sections contains several references to 
subsections 2.x which do not exist. Probably they
should refer to subsections 3.x.

Page 10, 1st paragraph:
(UAs that do not deal with this bug still need to recognize the
   retransmission relying on its From-tag and Call-ID, even though it
   does not match the transaction.)
I think the UAS should recognize the request as a 
retransmission by the CSeq. The From-tag and Call-ID should
lead to the same dialog even if the To-tag is missing.

Page 11, 1st call flow:
I think their is no RTP flowing, at least not from Alice to Bob.
As it is described in the text below on page 12 Alice sends the
BYE immediately after sending out the ACK for the 200 (INVITE).
I would assume that their is no microphone turned on any more on
Alice's UA which could record audio for any RTP.
Thus I would recommend to reduce the RTP stream to a one way from
Bob to Alice.

Page 12, 1st paragraph:
I would add here once again that this way of terminating an early
dialog is not recommended (like it was pointed out earlier already
in the draft).

Page 48, 3rd paragraph:
Their is a small typo in the first line: 'transactiuon' should be
'transaction'.

Page 48, 4th paragraph:
'... BYE with an appropriate certificate' their is no certificate
involved in digest authentication. I think the word 'certificate'
should be replaced with 'authentication header' or with 'credentials'.

Regards
  Nils Ohlmeier

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Miki HASEBE <[email-masked]>
Date: Tue, 14 Nov 2006 14:06:56 +0900

Hi

Thank you for a lot of comments.
I will correct the editorial errors that you pointed out in the next revision. 
Other comments are replied in-line. 

> Their are arrows missing in the lines for 2xx:

I'm sorry that the meaning of the sentence is unclear.
The sentence is intended to explain the way that BYE works.
I will modify it.

> The same applies for the diagram above:

Surely, you are right.
(but, I think that the detailed description may not be necessary,
 because the sentence in parentheses is not needed if SIP-UA
 supports #769 bug fix.)

> Thus I would recommend to reduce the RTP stream to a one way from

I agree with you. Probably, Alice will not send RTP.
I will modify it to "one way".

> dialog is not recommended (like it was pointed out earlier already

You pointed the first sentence of "Page 13", didn't you?
(I understand that a sentence I should add is "sending BYE on Early dialog
 is not recommended", because BYE is sent on Early dialog on page 13.)
If my understanding is correct, I would add the sentence.

> should be replaced with 'authentication header' or with 'credentials'.

OK. I will modify it to "credential".

Thank you for the comments on the draft.
Any additional comments would be appreciated.

Miki,