Subject: RE: [Sipping] I-D ACTION:draft-ietf-sipping-capacity-attribute-02.txt

From: "Mary Barnes" <[email-masked]>
Date: Tue, 28 Nov 2006 14:18:39 -0600

I've done a delayed re-review of the updated document and it looks ready
to go, except for a few editorial nits that were introduced with the new
text, summarized below.

For folks in the WG, any additional feedback on this document should be
provided by December 5th, at which time the plan is to forward the doc
for AD/IESG review. 

There is also a diff available at:
http://tools.ietf.org/wg/sipping/draft-ietf-sipping-capacity-attribute/d
raft-ietf-sipping-capacity-attribute-02-from-01.diff.html

Regards,
Mary.
SIPPING WG co-chair

Editorial nits:
---------------
- Section 1, 3rd paragraph, 1st sentence: insert "a" before "list of
resources" or changes "list" to "lists":
OLD:
   Although the XML resource list [7] provides a powerful mechanism for
   describing list of resources, 
NEW: 
   Although the XML resource list [7] provides a powerful mechanism for
   describing a list of resources, 

- Section 1, 4th paragraph, 1st sentence, last word: "recipeint" ->
"recipient"

- Section 2, "Copy Control" definition, 2nd sentence: insert "to" before
"recipient"
OLD:
  Its purpose is to indicate the recipient whether
  he is getting a primary, carbon, or blind carbon copy of the SIP
  request.
NEW: 
  Its purpose is to indicate to the recipient whether
  he is getting a primary, carbon, or blind carbon copy of the SIP
  request.

- Section 3, 1st paragraph, 2nd sentence: "of intended recipients" is
redundant given the definition of "Recipient List" in section 2.
OLD:
   A SIP User Agent Client (UAC) issuer sends a SIP request
   (F1) to a URI-list server containing a recipient list of intended
   recipients. 
NEW: 
   A SIP User Agent Client (UAC) issuer sends a SIP request
   (F1) to a URI-list server containing a recipient list.

-----Original Message-----
From: Miguel Garcia [mailto:[email-masked]] 
Sent: Monday, October 09, 2006 3:03 AM
To: [email-masked]
Cc: Gonzalo Camarillo; Barnes, Mary (RICH2:AR00)
Subject: Re: [Sipping] I-D
ACTION:draft-ietf-sipping-capacity-attribute-02.txt

This version of the document captures the comments received during WGLC.

The main changes are:

- 'capacity' attribute renamed as 'copyControl'
- addition of two concepts that help to understand the draft: "recipient

list" and "recipient-history list".
- discussion of the commonalities of a bcc and an anonymize attribute

I have also created a diff version with respect -01:

http://people.nokia.net/~miguel/drafts/draft-ietf-sipping-capacity-attri
bute-01-to-02.html

BR,

      Miguel

[email-masked] wrote:
> A New Internet-Draft is available from the on-line Internet-Drafts 
> directories.
> This draft is a work item of the Session Initiation Proposal
Investigation Working Group of the IETF.
> 
> 	Title		: Extensible Markup Language (XML) Format
Extension for Representing Copy Control Attributes in Resource Lists
> 	Author(s)	: M. Garcia-Martin, G. Camarillo
> 	Filename	: draft-ietf-sipping-capacity-attribute-02.txt
> 	Pages		: 16
> 	Date		: 2006-10-6
> 	
> In certain types of multimedia communications, a Session Initiation
>    Protocol (SIP) request is distributed to a group of SIP User Agents
>    (UAs).  The sender sends a single SIP request to a server which
>    further distributes the request to the group.  This SIP request
>    contains a list of Uniform Resource Identifiers (URIs), which
>    identify the recipients of the SIP request.  This URI-list is
>    expressed as a resource list XML document.  This specification
>    defines an XML extension to the XML resource list format that
allows
>    the sender of the request to qualify a recipient with a copy
control
>    level similar to the copy control level of existing e-mail systems.
> 
> A URL for this Internet-Draft is:
>
http://www.ietf.org/internet-drafts/draft-ietf-sipping-capacity-attribut
e-02.txt
> 
> To remove yourself from the I-D Announcement list, send a message to 
> [email-masked] with the word unsubscribe in the body of

> the message. 
> You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce

> to change your subscription settings.
> 
> Internet-Drafts are also available by anonymous FTP. Login with the 
> username "anonymous" and a password of your e-mail address. After 
> logging in, type "cd internet-drafts" and then 
> "get draft-ietf-sipping-capacity-attribute-02.txt".
> 
> A list of Internet-Drafts directories can be found in
> http://www.ietf.org/shadow.html 
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> 
> Internet-Drafts can also be obtained by e-mail.
> 
> Send a message to:
> 	[email-masked].
> In the body type:
> 	"FILE
/internet-drafts/draft-ietf-sipping-capacity-attribute-02.txt".
> 	
> NOTE:	The mail server at ietf.org can return the document in
> 	MIME-encoded form by using the "mpack" utility.  To use this
> 	feature, insert the command "ENCODING mime" before the "FILE"
> 	command.  To decode the response(s), you will need "munpack" or
> 	a MIME-compliant mail reader.  Different MIME-compliant mail
readers
> 	exhibit different behavior, especially when dealing with
> 	"multipart" MIME messages (i.e. documents which have been split
> 	up into multiple messages), so check your local documentation on
> 	how to manipulate these messages.
> 
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
> 
> 
>
------------------------------------------------------------------------
> 
> _______________________________________________
> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments of core SIP

-- 
Miguel A. Garcia           tel:+358-50-4804586
sip:[email-masked]
Nokia Research Center      Helsinki, Finland

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Miguel Garcia <[email-masked]>
Date: Wed, 29 Nov 2006 17:43:32 +0200

Hi Mary:

Thanks for your comments. We will introduce then into a new version of 
the draft. We are targeting for producing this new version by mid next 
week, so if someone else want to add reasonable comments, we can accept 
them until December 5th.

BR,

        Miguel