Subject: [Sipping] confusion about SIP NAT traverse

From: CheungJenny <[email-masked]>
Date: Thu, 14 Dec 2006 01:52:41 +0000

Hi,
 
I'm a little bit confused about SIP NAT traverse. From my understanding, there are at least the following 3 methods for NAT traverse when putting a UA (SIP phone, soft phone, ATA) behind a router:
1. don't make any extra setting, just rely on the router's SIP ALG mechanism.
2. disable router's SIP ALG, set port mapping at the router (for both SIP and RTP port).
3. disable router's SIP ALG, don't set port mapping, but set STUN server at the UA.
4. disable router's SIP ALG, don't set port mapping, but set outbound proxy at the UA.
My questions are:
1. is my understanding right? If not, could anybody give me a correct and clear answer :-
)?
2. what's the use of outbound proxy? I heard that all the traffic (including both SIP message and RTP packets) will be transfered by outbound proxy when using it, is that right? Then if yes, the outbound proxy is something like an "RTP proxy"?
 
Thanks.

Jenny Cheung 
_________________________________________________________________
率先尝试 Windows Live Mail。
http://ideas.live.com/programpage.aspx?versionId=5d21c51a-b161-4314-9b0e-4911fb2b2e6d

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Gonzalo Camarillo <[email-masked]>
Date: Fri, 15 Dec 2006 11:11:15 +0200

Hi,

you may want to read the two following drafts:

http://www.ietf.org/internet-drafts/draft-ietf-mmusic-ice-12.txt
http://www.ietf.org/internet-drafts/draft-ietf-sip-outbound-06.txt

Cheers,

Gonzalo

CheungJenny wrote:
>  
> Hi,
>  
> I'm a little bit confused about SIP NAT traverse. From my understanding, 
> there are at least the following 3 methods for NAT traverse when putting 
> a UA (SIP phone, soft phone, ATA) behind a router:
> 2. what's the use of outbound proxy? I heard that all the traffic 
> (including both SIP message and RTP packets) will be transfered by 
> outbound proxy when using it, is that right? Then if yes, the outbound 
> proxy is something like an "RTP proxy"?
>  
> Thanks.
>  
>  
> Jenny Cheung
> 
> 
> ------------------------------------------------------------------------
> 通过 Windows Live Messenger 表达您自己！ Windows Live Messenger！ 
> <http://get.live.com/messenger/overview>
> 
> 
> ------------------------------------------------------------------------
>

---

From: Bill Zhang <[email-masked]>
Date: Fri, 15 Dec 2006 17:46:14 +0800

Hi,

You may be confused by the different nat traverse mechanism, they are: hosted nat traverse, nat alg, stun and midcom. What we discuss the function of SBC here is about hosted nat traverse.So you may need read more in hosted nat traverse to get answer.

Best regards,

Bill
  ----- Original Message ----- 
  From: CheungJenny 
  To: [email-masked] 
  Sent: Thursday, December 14, 2006 9:52 AM
  Subject: [Sipping] confusion about SIP NAT traverse

  Hi,

  My questions are:
   
  Thanks.

  Jenny Cheung 

------------------------------------------------------------------------------
  通过 Windows Live Messenger 表达您自己！ Windows Live Messenger！ 

------------------------------------------------------------------------------