Subject: [Sipping] RE: I-D ACTION:draft-ietf-sipping-race-examples-00.txt

From: Miki HASEBE <[email-masked]>
Date: Fri, 15 Dec 2006 14:18:57 +0900

Hi,

inline.

"Francois Audet" <[email-masked]> wrote:

> Date: Tue, 12 Dec 2006 19:32:05 -0600
> From: "Francois Audet" <[email-masked]>
> Subject: [Sipping] RE: I-D
> 	ACTION:draft-ietf-sipping-race-examples-00.txt
> To: <[email-masked]>
> Cc: [email-masked]
> Message-ID:
> 	<[email-masked]>
> Content-Type: text/plain;	charset="us-ascii"
> 
> Guys, in your example in 3.1.4, can you clarify what SHOULD be sent by
> the UAS
> if the Offer was in the INVITE and the Answer was in the 200 OK?
> 
> It would be helpful if the text in 3.1.4 would be more precise about 
> which cases are you looking at (i.e., Offer is in INVITE/answer in 200?)
> 
> because it is somewhat ambiguous.

OK. The sequence and text will be corrected to show offer and
answer more clearly.
The proposed changes are shown below.

  State  Alice                          Bob  State
         |                                |
         |    ini-INVITE w/offer1 F1      |
    Pre  |------------------------------->|  Pre
         |             180 F2             |
    Ear  |<-------------------------------|  Ear
         |                                |
         |   200(ini-INV) w/answer1 F3    |
   Mora  |<-------------------------------|  Mora
         |       ACK F4(packet loss)      |
    Est  |-------------------->x          |
         |                                |
         | re-INVITE F6      200(=F3) F5  |
         |   w/offer2         w/answer1   |
         |-------------     --------------|
         |              \ /               |
         |               X                |
         |              / \               |
         |<------------     ------------->|  *race*
         |                  200(re-INV) F8|
         | ACK(=F4) F7        w/answer2   |
         |-------------     --------------|
         |              \ /               |
         |               X                |
         |              / \               |
         |<------------     ------------->|  Est
         |             ACK F9             |
         |------------------------------->|
         |                                |
         |                                |

   This scenario illustrates the race condition which occurs when UAS
   receives re-INVITE request sent from the Established state, in the
   Moratorium state.
   UAS receives a re-INVITE (w/offer2) before receiving an ACK for
   ini-INVITE (w/offer1).  UAS sends a 200 OK (w/answer2) to the
   re-INVITE (F8) because it has sent a 200 OK (w/answer1) to the
   ini-INVITE (F3, F5) and the dialog has already been established.

Thanks,
Miki

> 
> 
>  
> 
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]] 
> > Sent: Monday, December 11, 2006 12:50
> > To: [email-masked]
> > Cc: [email-masked]
> > Subject: I-D ACTION:draft-ietf-sipping-race-examples-00.txt
> > 
> > A New Internet-Draft is available from the on-line 
> > Internet-Drafts directories.
> > This draft is a work item of the Session Initiation Proposal 
> > Investigation Working Group of the IETF.
> > 
> > 	Title		: Examples call flow in race condition 
> > on Session Initiation Protocol
> > 	Author(s)	: M. Hasebe, et al.
> > 	Filename	: draft-ietf-sipping-race-examples-00.txt
> > 	Pages		: 51
> > 	Date		: 2006-12-11
> > 	
> >    This document gives examples of the Session Initiation 
> > Protocol (SIP)
> >    call flows in race condition.  Call flows in race condition are
> >    confusing, and this document shows the best practice to handle
> >    them.  The elements in these call flows include SIP User Agents
> >    and SIP Proxies.  Call flow diagrams and message details are shown.
> > 
> > 
> > A URL for this Internet-Draft is:
> > http://www.ietf.org/internet-drafts/draft-ietf-sipping-race-ex
> > amples-00.txt
> > 
> > To remove yourself from the I-D Announcement list, send a 
> > message to [email-masked] with the word 
> > unsubscribe in the body of the message. 
> > You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce
> > to change your subscription settings.
> > 
> > Internet-Drafts are also available by anonymous FTP. Login 
> > with the username "anonymous" and a password of your e-mail 
> > address. After logging in, type "cd internet-drafts" and then 
> > "get draft-ietf-sipping-race-examples-00.txt".
> > 
> > A list of Internet-Drafts directories can be found in 
> > http://www.ietf.org/shadow.html or 
> > ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> > 
> > Internet-Drafts can also be obtained by e-mail.
> > 
> > Send a message to:
> > 	[email-masked].
> > In the body type:
> > 	"FILE /internet-drafts/draft-ietf-sipping-race-examples-00.txt".
> > 	
> > NOTE:	The mail server at ietf.org can return the document in
> > 	MIME-encoded form by using the "mpack" utility.  To use this
> > 	feature, insert the command "ENCODING mime" before the "FILE"
> > 	command.  To decode the response(s), you will need "munpack" or
> > 	a MIME-compliant mail reader.  Different MIME-compliant 
> > mail readers
> > 	exhibit different behavior, especially when dealing with
> > 	"multipart" MIME messages (i.e. documents which have been split
> > 	up into multiple messages), so check your local documentation on
> > 	how to manipulate these messages.
> > 
> > Below is the data which will enable a MIME compliant mail 
> > reader implementation to automatically retrieve the ASCII 
> > version of the Internet-Draft.
> > 
> 
> 
> 
> ------------------------------

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Francois Audet" <[email-masked]>
Date: Fri, 15 Dec 2006 15:12:03 -0600

Thanks. Yes, it is clearer.

I guess the key point is the processing of INVITE in those glare
conditions is tied to Offer/Answer.

With 3.1.4, the initial offer/answer exchange is completed, so Bob can
accept the new offer in the re-INVITE and thus uses a 200.

With 3.1.5, the initial offer/answer exchange is not complete, so Bob
can NOT accespt the new Offer in the re-INVITE. Boh therefore has to 
reject it with 491.

I assume that the exact same logic would apply if the second offer was
in 
UPDATE, right?

I think some text similar to what I have above would be useful. 

> From: Miki HASEBE [mailto:[email-masked]] 
> Sent: Thursday, December 14, 2006 21:19
> To: Audet, Francois (SC100:3055)
> Cc: [email-masked]; [email-masked]; 
> [email-masked]; 
> [email-masked]; [email-masked]
> > the UAS if the Offer was in the INVITE and the Answer was 
> in the 200 
> > OK?
> > 
> Protocol 
> > > (SIP)
> message to 
> > > [email-masked] with the word unsubscribe 
> in the body 
> > > of the message.
> > > You can also visit 
> > > https://www1.ietf.org/mailman/listinfo/I-D-announce
> > > Internet-Drafts are also available by anonymous FTP. 
> Login with the 
> > > username "anonymous" and a password of your e-mail address. After 
> > > logging in, type "cd internet-drafts" and then "get 
> > > draft-ietf-sipping-race-examples-00.txt".
> > > 
> > > 	a MIME-compliant mail reader.  Different MIME-compliant mail 
> > > readers
> > > Below is the data which will enable a MIME compliant mail reader 
> > > implementation to automatically retrieve the ASCII version of the 
> > > Internet-Draft.
> > > 
> > 
> > 
> >

---

From: Miki HASEBE <[email-masked]>
Date: Tue, 19 Dec 2006 11:39:03 +0900

Hi,

Thank you for your comment.
More inline.

> accept the new offer in the re-INVITE and thus uses a 200.

I agree.

> I think some text similar to what I have above would be useful. 

Right.
The description concerning UPDATE will be added to 3.1.5
according to your proposal.

Thank you,
Miki