Subject: Re: [Sipping] WGLC of draft-ietf-sipping-service-examples-10.txt

From: Alan Johnston <[email-masked]>
Date: Mon, 23 Apr 2007 09:04:01 -0500

Hi Vijay,

Thanks for your comments and review of the document.

I try to only use the <allOneLine> when there is no choice - if there is 
an option to use LWS then I use it as I think it is more clear.  I plan 
to leave it as is in the draft.

Thanks,
Alan

Vijay K. Gurbani wrote:
> Gonzalo Camarillo wrote:
>> Dear reviewers of the service examples draft,
>>
>> the authors have submitted yet another revision of the draft that is
>> supposed to address your last set of comments on revision 11. As in
>> previous occasions, could you please have a look at it and send a note
>> to the SIPPING mailing list, cc:ing the chairs, stating whether or not
>> you are now OK with the draft?
>
> In -12 I looked at sections 2.1 and 2.2 assigned to me.  They
> are fine.
>
> However, I did notice one thing - in many of the SIP signaling
> messages, the Via field is displayed as:
>
>      Via: SIP/2.0/TLS ss1.example.com:5061
>        ;branch=z9hG4bK83749.1
>        ;received=192.0.2.54
>
> Syntactically, this is perfect; no problem.  However, I will
> leave it to the editor to decide whether he should move the
> "received" parameter one line up, and whether, for the sake of
> orthogonality with other SIP*-documents, he should use the <allOneLine>
> directive established by RjS.
>
> Besides this minor feedback, which can the editor can choose to
> ignore in the interest of getting the draft out expeditiously,
> I am fine with my sections of the draft as they appear in -12.
>
> - vijay

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Alan Johnston <[email-masked]>
Date: Mon, 23 Apr 2007 09:08:42 -0500

Hi Jeroen,

Thanks for your comments - I will make the corrections.

Thanks,
Alan

Jeroen van Bemmel wrote:
> 2.12 find me (was 2.13):
>  
> all previous 6 comments resolved, 2 new ones introduced:
>  
> - F14 top Via is missing a 'received' parameter
> - F15 (ACK) has an incorrect Via branch (should be z9hG4bK83749.3)
>  
> Regards,
> Jeroen
>  
>
>     ----- Original Message -----
>     *From:* Ravipati, Chandra (Chandra) <mailto:[email-masked]>
>     *To:* [email-masked]
>     <mailto:[email-masked]> ; Gonzalo Camarillo
>     <mailto:[email-masked]> ; [email-masked]
>     <mailto:[email-masked]>
>     *Cc:* [email-masked] <mailto:[email-masked]> ;
>     [email-masked] <mailto:[email-masked]> ;
>     [email-masked] <mailto:[email-masked]> ;
>     [email-masked] <mailto:[email-masked]> ;
>     [email-masked] <mailto:[email-masked]> ; [email-masked]
>     <mailto:[email-masked]> ; [email-masked]
>     <mailto:[email-masked]> ; Mary Barnes
>     <mailto:[email-masked]> ; Alan Johnston
>     <mailto:[email-masked]> ; Robert Sparks
>     <mailto:[email-masked]> ; [email-masked]
>     <mailto:[email-masked]> ; Cullen Jennings
>     <mailto:[email-masked]> ; Jon Peterson
>     <mailto:[email-masked]>
>     *Sent:* Friday, March 09, 2007 12:05 AM
>     *Subject:* RE: [Fwd: WGLC of
>     draft-ietf-sipping-service-examples-10.txt]
>
>     2.10 and 2.11 look fine to me.
>
>      
>
>     Thanks,
>
>     -Chandra.
>
>     ------------------------------------------------------------------------
>
>     *From:* Joel Repiquet [mailto:[email-masked]]
>     *Sent:* Monday, March 05, 2007 6:41 AM
>     *To:* Gonzalo Camarillo
>     *Cc:* [email-masked] <mailto:[email-masked]>;
>     [email-masked] <mailto:[email-masked]>;
>     [email-masked]
>     <mailto:[email-masked]>; [email-masked]
>     <mailto:[email-masked]>; Ravipati, Chandra (Chandra);
>     [email-masked] <mailto:[email-masked]>;
>     [email-masked] <mailto:[email-masked]>; [email-masked]
>     <mailto:[email-masked]>; [email-masked]
>     <mailto:[email-masked]>; Mary Barnes; Alan Johnston;
>     Robert Sparks; [email-masked]
>     <mailto:[email-masked]>; Cullen Jennings; Jon
>     Peterson
>     *Subject:* Re: [Fwd: WGLC of
>     draft-ietf-sipping-service-examples-10.txt]
>
>      
>
>     Hi,
>     It is OK to me regarding examples 2.4, 2.5 and 2.6 related to
>     Transfer.
>     BR
>     Joel
>
>
>
>     *On Sam Mar 3 13:46 , Gonzalo Camarillo sent:
>
>
>     *
>
>     http://www.ietf.org/internet-drafts/draft-ietf-sipping-service-examples-12.txt
>
>     For your convenience, your reviews are stored at:
>
>     http://www.softarmor.com/sipping/process/wg-review/sipping-rt-wglc.html
>
>     The diff between revisions 11 and 12 is available at:
>
>     http://tools.ietf.org/wg/sipping/draft-ietf-sipping-service-examples/draft-ietf-sipping-service-examples-12-from-11.diff.html
>
>     Thanks,
>
>     Gonzalo
>
>
>     Gonzalo Camarillo wrote:
>     > the authors of the draft have submitted a new revision of the
>     draft that
>     > is supposed to address all your WGLC comments. Could you please
>     have a
>     > look at it and send a note to the SIPPING mailing list, cc:ing the
>     > chairs, stating whether or not you are now OK with the draft?
>     >
>     > http://www.ietf.org/internet-drafts/draft-ietf-sipping-service-examples-11.txt
>     <parse.pl?redirect=http%3A%2F%2Fwww.ietf.org%2Finternet-drafts%2Fdraft-ietf-sipping-service-examples-11.txt>
>     >
>     >
>     > For your convenience, your reviews are stored at:
>     > http://www.softarmor.com/sipping/process/wg-review/sipping-rt-wglc.html
>     <parse.pl?redirect=http%3A%2F%2Fwww.softarmor.com%2Fsipping%2Fprocess%2Fwg-review%2Fsipping-rt-wglc.html>
>     >
>     > Thanks,
>     >
>     > Gonzalo
>     >
>     > Gonzalo Camarillo wrote:
>     >> Hi,
>     >>
>     >> all of you in the 'To' field of this email have volunteered to
>     review
>     >> the service examples draft. Thanks a lot for agreeing to perform
>     this
>     >> review.
>     >>
>     >> This is how we would like to divide the work: in the list below,
>     I have
>     >> assigned a few sections to each of the reviewers. When you are
>     done with
>     >> your review, send it in a reply-to-all to the email below, which
>     was the
>     >> WGLC for this draft on the SIPPING mailing list. We would like
>     to have
>     >> all the reviews ready by the end of the WGLC, on July 1st.
>     >>
>     >>
>     >> <[email-masked]
>     <javascript:top.opencompose([email-masked]','','','')>>
>     >> 2.1. Call Hold
>     >> 2.2. Consultation Hold
>     >>
>     >> <[email-masked]
>     <javascript:top.opencompose([email-masked]','','','')>>
>     >> 2.3. Music On Hold
>     >> 2.18. Automatic Redial
>     >> 2.19. Click to Dial
>     >>
>     >> <[email-masked]
>     <javascript:top.opencompose([email-masked]','','','')>>
>     >> 2.4. Transfer - Unattended
>     >> 2.5. Transfer - Attended
>     >> 2.6. Transfer - Instant Messaging
>     >>
>     >> <[email-masked]
>     <javascript:top.opencompose([email-masked]','','','')>>
>     >> 2.7. Call Forwarding Unconditional
>     >> 2.8. Call Forwarding - Busy
>     >> 2.9. Call Forwarding - No Answer
>     >>
>     >> <[email-masked]
>     <javascript:top.opencompose([email-masked]','','','')>>
>     >> 2.10. 3-way Conference - Third Party is Added
>     >> 2.11. 3-way Conference - Third Party Joins
>     >>
>     >> <[email-masked]
>     <javascript:top.opencompose([email-masked]','','','')>>
>     >> 2.12. Single Line Extension
>     >>
>     >> <[email-masked]
>     <javascript:top.opencompose([email-masked]','','','')>>
>     >> 2.13. Find-Me
>     >>
>     >> <[email-masked]
>     <javascript:top.opencompose([email-masked]','','','')>>
>     >> 2.14. Call Management (Incoming Call Screening)
>     >> 2.15. Call Management (Outgoing Call Screening)
>     >>
>     >> <[email-masked]
>     <javascript:top.opencompose([email-masked]','','','')>>
>     >> 2.16. Call Park
>     >> 2.17. Call Pickup
>     >>
>     >>
>     >> Thanks,
>     >>
>     >> Gonzalo
>     >>
>     >>
>     >>
>     >> -------- Original Message --------
>     >> Subject: WGLC of draft-ietf-sipping-service-examples-10.txt
>     >> Date: Thu, 11 May 2006 20:37:40 +0300
>     >> From: Gonzalo Camarillo <[email-masked]
>     <javascript:top.opencompose([email-masked]','','','')>>
>     >> To: sipping <[email-masked]
>     <javascript:top.opencompose([email-masked]','','','')>>
>     >> CC: Samuli Pöykkö <[email-masked]
>     <javascript:top.opencompose([email-masked]','','','')>>,
>     Mary Barnes
>     >> <[email-masked]
>     <javascript:top.opencompose([email-masked]','','','')>>,
>     Alan Johnston <[email-masked]
>     <javascript:top.opencompose([email-masked]','','','')>>, Robert
>     >> Sparks <[email-masked]
>     <javascript:top.opencompose([email-masked]','','','')>>,
>     [email-masked]
>     <javascript:top.opencompose([email-masked]','','','')>
>     >>
>     >> Folks,
>     >>
>     >> we would like to working group last call (WGLC) the following draft:
>     >>
>     >>
>     http://www.ietf.org/internet-drafts/draft-ietf-sipping-service-examples-10.txt
>     <parse.pl?redirect=http%3A%2F%2Fwww.ietf.org%2Finternet-drafts%2Fdraft-ietf-sipping-service-examples-10.txt>
>     >>
>     >>
>     >> as you have probably noticed if you clicked on the link above,
>     this is a
>     >> very long draft. Therefore, we would like to get at least ten
>     volunteers
>     >> to review it. We will assign a couple of sections to each reviewer.
>     >>
>     >> If you are interested and willing to review this draft, please
>     send an
>     >> email to the SIPPING chairs.
>     >>
>     >> The email below should be considered as a WGLC comment:
>     >>
>     >>
>     http://www1.ietf.org/mail-archive/web/sipping/current/msg10886.html
>     <parse.pl?redirect=http%3A%2F%2Fwww1.ietf.org%2Fmail-archive%2Fweb%2Fsipping%2Fcurrent%2Fmsg10886.html>
>     >>
>     >> This is the output of the idnits tool:
>     >>
>     >> idnits 1.96
>     >>
>     >> tmp/draft-ietf-sipping-service-examples-10.txt:
>     >>
>     >>
>     >> Checking nits according to http://www.ietf.org/ID-Checklist.html
>     <parse.pl?redirect=http%3A%2F%2Fwww.ietf.org%2FID-Checklist.html>:
>     >>
>     >> Checking conformance with RFC 3978/3979 boilerplate...
>     >>
>     >> the boilerplate looks good.
>     >>
>     >> * There is 1 instance of too long lines in the document, the
>     longest
>     >> one
>     >> being 1 character in excess of 72.
>     >>
>     >> Checking nits according to
>     http://www.ietf.org/ietf/1id-guidelines.txt
>     <parse.pl?redirect=http%3A%2F%2Fwww.ietf.org%2Fietf%2F1id-guidelines.txt>:
>     >> Nothing found here (but these checks do not cover all of
>     >> 1id-guidelines.txt yet).
>     >>
>     >> Miscellaneous warnings:
>     >> - Line 1028 has weird spacing: '... /* Bob place...'
>     >> - Line 1404 has weird spacing: '... /* Bob takes...'
>     >> - Line 1732 has weird spacing: '... /* Bob place...'
>     >> - Line 2459 has weird spacing: '...and Bob have ...'
>     >> - Line 2597 has weird spacing: '... /* Bob puts ...'
>     >> - (4 more instances...)
>     >>
>     >> Experimental warnings:
>     >> - Unused Reference: [18] is defined on line 7860, but not referenced
>     >> - Unused Reference: [13] is defined on line 7839, but not referenced
>     >> - Unused Reference: [14] is defined on line 7842, but not referenced
>     >> - Unused Reference: [1] is defined on line 7795, but not referenced
>     >>
>     >>
>     >>
>     >>
>     >> This WGLC will end on July 1st, 2006 (a long draft needs a long
>     WGLC).
>     >>
>     >> Thanks,
>     >>
>     >> Gonzalo
>     >> SIPPING co-chair
>     >>
>     >>
>     >>
>     >
>     >
>
>
> ------------------------------------------------------------------------
>