Subject: [Sipping] FYI: I-D ACTION:draft-linyi-sipping-invite-with-conf-info-00.txt

From: Linyi Tian <[email-masked]>
Date: Sat, 14 Apr 2007 09:01:28 +0800

Dear all

We just submitted an I-D to IETF regarding conference. Please kindly review and feel free to give us any comments. Thank you in advance. 

Abstract & Requirements Anaylyze
   This specification defines a mechanism that allows a UAC to provide a
   conference server with the initial conference information and policy
   using an INVITE-contained conference info.

   some environments have tough requirements regarding conference
   establishment time.  This is true especially when a user wants to
   create a conference in ad hoc manner.  In addition user may only want
   very simple conference information and policy, for example the
   subject and maximum numbers of participants, to be provided for an ad
   hoc conference via only one operation.  In this case they rarely
   desire to manipulate the conference policy during the conference.

   In current art there is no mechanism for new participants to be aware
   of the conference information they are being invited to.  It causes
   difficulty for them to decide whether to accept this invitation which
   may not fall into their interest.

Best Regards,
Linyi

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Saturday, April 14, 2007 3:50 AM
To: [email-masked]
Subject: I-D ACTION:draft-linyi-sipping-invite-with-conf-info-00.txt

A New Internet-Draft is available from the on-line Internet-Drafts 
directories.

	Title		: Session Initiation Protocol (SIP) INVITE with Conference Info
	Author(s)	: L. Tian, Q. Sun
	Filename	: draft-linyi-sipping-invite-with-conf-info-00.txt
	Pages		: 24
	Date		: 2007-4-13

   This specification defines a mechanism that allows a UAC to provide a
   conference server with the initial conference information and policy
   using an INVITE-contained conference info.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-linyi-sipping-invite-with-conf-info-00.txt

To remove yourself from the I-D Announcement list, send a message to 
[email-masked] with the word unsubscribe in the body of 
the message. 
You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce 
to change your subscription settings.

Internet-Drafts are also available by anonymous FTP. Login with the 
username "anonymous" and a password of your e-mail address. After 
logging in, type "cd internet-drafts" and then 
"get draft-linyi-sipping-invite-with-conf-info-00.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-linyi-sipping-invite-with-conf-info-00.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.
ENCODING mime
FILE /internet-drafts/draft-linyi-sipping-invite-with-conf-info-00.txt
_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Henry Sinnreich" <[email-masked]>
Date: Sat, 14 Apr 2007 09:07:00 -0700

How would this compare with providing the conference info and policy
over a web page is now the 'standard procedure'?

Or is the assumption that there is no web and we live in a voice-only
world?

>'some environments have tough requirements regarding conference 
> establishment time'

Why is this a SIP issue?

What about users having predefined access to their conference service by
IT or by contract and just telling the participants to dial in?

Thanks, Henry

-----Original Message-----
From: Linyi Tian [mailto:[email-masked]] 
Sent: Friday, April 13, 2007 6:01 PM
To: [email-masked]
Cc: [email-masked]
Subject: [Sipping] FYI:
I-DACTION:draft-linyi-sipping-invite-with-conf-info-00.txt

Dear all

We just submitted an I-D to IETF regarding conference. Please kindly
review and feel free to give us any comments. Thank you in advance. 

Best Regards,
Linyi

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Saturday, April 14, 2007 3:50 AM
To: [email-masked]
Subject: I-D ACTION:draft-linyi-sipping-invite-with-conf-info-00.txt

	Title		: Session Initiation Protocol (SIP) INVITE with
Conference Info
	Author(s)	: L. Tian, Q. Sun
	Filename	:
draft-linyi-sipping-invite-with-conf-info-00.txt
	Pages		: 24
	Date		: 2007-4-13

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-linyi-sipping-invite-with-conf
-info-00.txt

Send a message to:
	[email-masked].
In the body type:
	"FILE
/internet-drafts/draft-linyi-sipping-invite-with-conf-info-00.txt".
	
	a MIME-compliant mail reader.  Different MIME-compliant mail
readers

---

From: Linyi Tian <[email-masked]>
Date: Mon, 16 Apr 2007 20:55:27 +0300

Dear Henry

Thank you very much for your comments. Some responses below:
In the mobile environment user may not desire to access the web site to create conf info for a conference especially when it is in ad hoc manner. So the assumption is that it is boring for user to create an ad hoc conference using two operations. 

This draft respects the same consideration like 'some environments have tough requirements regarding conference establishment time' in another I-D for uri list conferencing. In case of user only wants very simple conference information and policy, such as subject and maximum numbers of participants, to be provided for an ad hoc conference via only one operation. The SIP invite could be used to convey it to create a conference fulfilling this requirement.

Best Regards,
Linyi

-----Original Message-----
From: Henry Sinnreich [mailto:[email-masked]] 
Sent: Saturday, April 14, 2007 7:07 PM
To: Linyi Tian; [email-masked]
Cc: [email-masked]
Subject: RE: [Sipping] FYI: I-DACTION:draft-linyi-sipping-invite-with-conf-info-00.txt

Why is this a SIP issue?

Thanks, Henry

-----Original Message-----
From: Linyi Tian [mailto:[email-masked]] 
Sent: Friday, April 13, 2007 6:01 PM
To: [email-masked]
Cc: [email-masked]
Subject: [Sipping] FYI:

Dear all

Best Regards,
Linyi

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Saturday, April 14, 2007 3:50 AM
To: [email-masked]
Subject: I-D ACTION:draft-linyi-sipping-invite-with-conf-info-00.txt

Send a message to:
	[email-masked].
In the body type:
	"FILE

---

From: "Oscar Novo \(JO/LMF\)" <[email-masked]>
Date: Wed, 18 Apr 2007 10:26:10 +0200

Hi Linyi,

In the future, XCON WG will work in a protocol to create and manipulate
the conference information in a server. The use of that protocol may be
completely transparent for the mobile users. So, mobile users could
create ad hoc conferences in an easy way.

I think one important use cases to be describe in your draft would be
when the number of URIs in the URI-List exceeds the number specified in
<maximum-user-count> element send by the UAC.

Regards,

Oscar

-----Original Message-----
From: Linyi Tian [mailto:[email-masked]] 
Sent: 16. huhtikuuta 2007 20:55
To: 'Henry Sinnreich'; [email-masked]
Cc: [email-masked]
Subject: [XCON] RE: [Sipping] FYI:

Dear Henry

Thank you very much for your comments. Some responses below:
In the mobile environment user may not desire to access the web site to
create conf info for a conference especially when it is in ad hoc
manner. So the assumption is that it is boring for user to create an ad
hoc conference using two operations. 

This draft respects the same consideration like 'some environments have
tough requirements regarding conference establishment time' in another
I-D for uri list conferencing. In case of user only wants very simple
conference information and policy, such as subject and maximum numbers
of participants, to be provided for an ad hoc conference via only one
operation. The SIP invite could be used to convey it to create a
conference fulfilling this requirement.

Best Regards,
Linyi

-----Original Message-----
From: Henry Sinnreich [mailto:[email-masked]]
Sent: Saturday, April 14, 2007 7:07 PM
To: Linyi Tian; [email-masked]
Cc: [email-masked]
Subject: RE: [Sipping] FYI:

Why is this a SIP issue?

Thanks, Henry

-----Original Message-----
From: Linyi Tian [mailto:[email-masked]]
Sent: Friday, April 13, 2007 6:01 PM
To: [email-masked]
Cc: [email-masked]
Subject: [Sipping] FYI:

Dear all

Best Regards,
Linyi

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Saturday, April 14, 2007 3:50 AM
To: [email-masked]
Subject: I-D ACTION:draft-linyi-sipping-invite-with-conf-info-00.txt

Send a message to:
	[email-masked].
In the body type:
	"FILE

_______________________________________________
XCON mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/xcon

---

From: Linyi Tian <[email-masked]>
Date: Wed, 18 Apr 2007 16:39:12 +0300

Hi, Oscar

You are very much appreciated for the information and suggestion!

Yes, we are aware of the work ongoing in XCON. However we do not know when this protocol will be completed. There is much work to do with my guess. Maybe somebody can not wait, e.g. OMA is very interested in XCAP solution for pre-defined group communications. For ad-hoc conference, XCAP may not be suitable, but this draft will work well.

In addition to that, there is still no way to provide ad-hoc conference with conference information or policy in OMA. But we see some requirements within some ongoing work in other organizations. This I-D tries to provide the facility. It can be treated as a supplementary solution for existing arts which may particularly address some cases in a simple way.

Regarding maximum counts of participants, actually I have following sentence related in section 5:
The UAC MUST ensure the number of URIs in the URI-List will not exceed the number specified in <maximum-user-count> element if it presents.

Does it satisfy what you need? If not, could you give me some further explanation? If something needs to be changed, I can add them in the next version.

Again, much appreciated for your comments!

Thank you!

Best Regards,
Linyi

-----Original Message-----
From: Oscar Novo (JO/LMF) [mailto:[email-masked]] 
Sent: Wednesday, April 18, 2007 11:26 AM
To: Linyi Tian; Henry Sinnreich; [email-masked]
Cc: [email-masked]
Subject: RE: [XCON] RE: [Sipping] FYI: I-DACTION:draft-linyi-sipping-invite-with-conf-info-00.txt

Hi Linyi,

Regards,

Oscar

-----Original Message-----
From: Linyi Tian [mailto:[email-masked]] 
Sent: 16. huhtikuuta 2007 20:55
To: 'Henry Sinnreich'; [email-masked]
Cc: [email-masked]
Subject: [XCON] RE: [Sipping] FYI:

Dear Henry

Best Regards,
Linyi

-----Original Message-----
From: Henry Sinnreich [mailto:[email-masked]]
Sent: Saturday, April 14, 2007 7:07 PM
To: Linyi Tian; [email-masked]
Cc: [email-masked]
Subject: RE: [Sipping] FYI:

Why is this a SIP issue?

Thanks, Henry

-----Original Message-----
From: Linyi Tian [mailto:[email-masked]]
Sent: Friday, April 13, 2007 6:01 PM
To: [email-masked]
Cc: [email-masked]
Subject: [Sipping] FYI:

Dear all

Best Regards,
Linyi

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Saturday, April 14, 2007 3:50 AM
To: [email-masked]
Subject: I-D ACTION:draft-linyi-sipping-invite-with-conf-info-00.txt

Send a message to:
	[email-masked].
In the body type:
	"FILE

---

From: "Even, Roni" <[email-masked]>
Date: Thu, 19 Apr 2007 12:06:00 +0300

Linyi,

I read the draft and have some comments about this direction.

1. It is an advantage in letting the invitee know the subject of the conference but this is true also for a point to point call. This is not unique to conference.

2. letting the invitee know who the other participants in the conference and the conference information is better served by the event package.

3. The issue in the URI list was to replace multiple refers with on message for inviting participants, this was part of a general mechanism. The issue of defining the conference parameters and controlling the conference was not considered in scope for this work.

4. "In current art there is no mechanism for new participants to be aware of the conference information they are being invited to." This is what the conference event package is used for. When you get an Invite with isfocus you can subscribe to the conference event package and get notification before joining.

5. REQ 1 is covered by XCON while REQ 2 is covered by the event package.

6. Section 4.1.2 adds data from the XCON data model including the start time yet the requirements talk about ad-hoc conferences. 

7. Using this method for controlling the conference by sending re-Invite will cause a lot of traffic through the proxies in the middle and that is why XCON is the way to do it.

To summarize - I can see some value in being able to send some information to the conference factory for the ad-hoc case. The information will include the required media and user count but this draft has a wider scope.

Roni Even 

> Sent: Saturday, April 14, 2007 4:01 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [Sipping] FYI: I-DACTION:draft-linyi-sipping-invite-with-conf-
> info-00.txt
> 
> Dear all
>

---

From: "Oscar Novo \(JO/LMF\)" <[email-masked]>
Date: Thu, 19 Apr 2007 11:58:24 +0200

Hi Linyi,

I guess the XCON WG will start working on the conference control
protocol in a few IETF but my impression is that we'll need long time to
complete this protocol. So, your supplementary solution could be fine
before we don't define anything in XCON.   

Regarding the possible inconsistency between the URI-List and the
maximum number of users, I think it would be useful to described the
server behaviour in this case. At least, I can think in two different
solutions for that use case:

- The server REJECTS the INVITE and sends an error to the UAC.
- The server ACCEPTS the INVITE and changes the maximum user number of
the conference to the number of URIs in the URI-List.  

Cheers,

Oscar

-----Original Message-----
From: Linyi Tian [mailto:[email-masked]] 
Sent: 18. huhtikuuta 2007 16:39
To: Oscar Novo (JO/LMF); 'Henry Sinnreich'; [email-masked]
Cc: [email-masked]
Subject: RE: [XCON] RE: [Sipping] FYI:

Hi, Oscar

Yes, we are aware of the work ongoing in XCON. However we do not know
when this protocol will be completed. There is much work to do with my
guess. Maybe somebody can not wait, e.g. OMA is very interested in XCAP
solution for pre-defined group communications. For ad-hoc conference,
XCAP may not be suitable, but this draft will work well.

In addition to that, there is still no way to provide ad-hoc conference
with conference information or policy in OMA. But we see some
requirements within some ongoing work in other organizations. This I-D
tries to provide the facility. It can be treated as a supplementary
solution for existing arts which may particularly address some cases in
a simple way.

Regarding maximum counts of participants, actually I have following
sentence related in section 5:
The UAC MUST ensure the number of URIs in the URI-List will not exceed
the number specified in <maximum-user-count> element if it presents.

Does it satisfy what you need? If not, could you give me some further
explanation? If something needs to be changed, I can add them in the
next version.

Thank you!

Best Regards,
Linyi

-----Original Message-----
From: Oscar Novo (JO/LMF) [mailto:[email-masked]]
Sent: Wednesday, April 18, 2007 11:26 AM
To: Linyi Tian; Henry Sinnreich; [email-masked]
Cc: [email-masked]
Subject: RE: [XCON] RE: [Sipping] FYI:

Hi Linyi,

Regards,

Oscar

-----Original Message-----
From: Linyi Tian [mailto:[email-masked]]
Sent: 16. huhtikuuta 2007 20:55
To: 'Henry Sinnreich'; [email-masked]
Cc: [email-masked]
Subject: [XCON] RE: [Sipping] FYI:

Dear Henry

Best Regards,
Linyi

-----Original Message-----
From: Henry Sinnreich [mailto:[email-masked]]
Sent: Saturday, April 14, 2007 7:07 PM
To: Linyi Tian; [email-masked]
Cc: [email-masked]
Subject: RE: [Sipping] FYI:

Why is this a SIP issue?

Thanks, Henry

-----Original Message-----
From: Linyi Tian [mailto:[email-masked]]
Sent: Friday, April 13, 2007 6:01 PM
To: [email-masked]
Cc: [email-masked]
Subject: [Sipping] FYI:

Dear all

Best Regards,
Linyi

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Saturday, April 14, 2007 3:50 AM
To: [email-masked]
Subject: I-D ACTION:draft-linyi-sipping-invite-with-conf-info-00.txt

Internet-Drafts are also available by anonymous FTP. Login with the
username "anonymous" and a password of your e-mail address. After
logging in, type "cd internet-drafts" and then "get
draft-linyi-sipping-invite-with-conf-info-00.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html or
ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Send a message to:
	[email-masked].
In the body type:
	"FILE

---

From: Linyi Tian <[email-masked]>
Date: Thu, 19 Apr 2007 13:00:00 +0300

Dear Oscar

Thank you very much for your valuable comments. I will reflect them in next revision.

By the way, I was noticed that the I-D draft-ietf-xcon-common-data-model-05 was submitted to IETF. It affects our draft. So I need to dig into it and reflect the changes as well.

Best Regards,
Linyi

-----Original Message-----
From: Oscar Novo (JO/LMF) [mailto:[email-masked]] 
Sent: Thursday, April 19, 2007 12:58 PM
To: Linyi Tian; [email-masked]
Cc: [email-masked]
Subject: RE: [XCON] RE: [Sipping] FYI: I-DACTION:draft-linyi-sipping-invite-with-conf-info-00.txt

Hi Linyi,

Cheers,

Oscar

-----Original Message-----
From: Linyi Tian [mailto:[email-masked]] 
Sent: 18. huhtikuuta 2007 16:39
To: Oscar Novo (JO/LMF); 'Henry Sinnreich'; [email-masked]
Cc: [email-masked]
Subject: RE: [XCON] RE: [Sipping] FYI:

Hi, Oscar

Thank you!

Best Regards,
Linyi

-----Original Message-----
From: Oscar Novo (JO/LMF) [mailto:[email-masked]]
Sent: Wednesday, April 18, 2007 11:26 AM
To: Linyi Tian; Henry Sinnreich; [email-masked]
Cc: [email-masked]
Subject: RE: [XCON] RE: [Sipping] FYI:

Hi Linyi,

Regards,

Oscar

-----Original Message-----
From: Linyi Tian [mailto:[email-masked]]
Sent: 16. huhtikuuta 2007 20:55
To: 'Henry Sinnreich'; [email-masked]
Cc: [email-masked]
Subject: [XCON] RE: [Sipping] FYI:

Dear Henry

Best Regards,
Linyi

-----Original Message-----
From: Henry Sinnreich [mailto:[email-masked]]
Sent: Saturday, April 14, 2007 7:07 PM
To: Linyi Tian; [email-masked]
Cc: [email-masked]
Subject: RE: [Sipping] FYI:

Why is this a SIP issue?

Thanks, Henry

-----Original Message-----
From: Linyi Tian [mailto:[email-masked]]
Sent: Friday, April 13, 2007 6:01 PM
To: [email-masked]
Cc: [email-masked]
Subject: [Sipping] FYI:

Dear all

Best Regards,
Linyi

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Saturday, April 14, 2007 3:50 AM
To: [email-masked]
Subject: I-D ACTION:draft-linyi-sipping-invite-with-conf-info-00.txt

Send a message to:
	[email-masked].
In the body type:
	"FILE

---

From: Linyi Tian <[email-masked]>
Date: Thu, 19 Apr 2007 20:51:33 +0300

Dear Roni Even

Thank your for your kind review and feedback. Some responses inline with mark [Linyi]:)

Best Regards,
Linyi

-----Original Message-----
From: Even, Roni [mailto:[email-masked]] 
Sent: Thursday, April 19, 2007 12:06 PM
To: Linyi Tian; [email-masked]
Cc: [email-masked]
Subject: RE: [Sipping] FYI: I-DACTION:draft-linyi-sipping-invite-with-conf-info-00.txt

Linyi,

Linyi,

1. It is an advantage in letting the invitee know the subject of the conference but this is true also for a point to point call. This is not unique to conference.
[Linyi Tian] Good point! Do you mean that we need to use this mechanism for point to point scenario?

2. letting the invitee know who the other participants in the conference and the conference information is better served by the event package.
[Linyi Tian] Actually I guess in ad hoc manner the mechanism in this draft is more efficient.

3. The issue in the URI list was to replace multiple refers with on message for inviting participants, this was part of a general mechanism. The issue of defining the conference parameters and controlling the conference was not considered in scope for this work.
[Linyi Tian] Yes, that's true. But our draft does not have any intention to affect the URI-List work. Actually the mechanism in our draft can be used together with URI list. We just gave the example to address different scenarios: 1. without URI list; 2. with URI list. So when URI-List the conference server needs to perform more actions in addition to those defined in URI-List work.

4. "In current art there is no mechanism for new participants to be aware of the conference information they are being invited to." This is what the conference event package is used for. When you get an Invite with isfocus you can subscribe to the conference event package and get notification before joining.
[Linyi Tian] Good catch! I guess the sentence I wrote is not quite precise. I will modify it. 

5. REQ 1 is covered by XCON while REQ 2 is covered by the event package.
[Linyi Tian] According to the comments you mentioned, I will update REQs to better reflect our intention.

6. Section 4.1.2 adds data from the XCON data model including the start time yet the requirements talk about ad-hoc conferences. 
[Linyi Tian] Good catch. That is a mistake. Anyway I need to change something in next revision since that draft was updated.

7. Using this method for controlling the conference by sending re-Invite will cause a lot of traffic through the proxies in the middle and that is why XCON is the way to do it.
[Linyi Tian] Yes. What is stated in the draft is there is no semantics defined for re-INVITE. Actually it is recommended not using re-INVITE for controlling the conference in this draft. I can make it clearer.

To summarize - I can see some value in being able to send some information to the conference factory for the ad-hoc case. The information will include the required media and user count but this draft has a wider scope.
[Linyi Tian] I think in addition to subject and user count, we may find other information which could be useful as well. For example, <keyword> for search purpose, <service-uris> which provides complementary information such as URI for presentations:)

Roni Even