Subject: RE: [Sipping] Call Completion: In Defense of Explicit Operations

From: "Elwell, John" <[email-masked]>
Date: Wed, 11 Apr 2007 15:07:32 +0100

Adam,

OK, I agree with you there. Given that we have these requirements from
TISPAN that can't be satisfied by traditional SIP means such as dialog
package, presence, etc., then they are likely to be "expensive" to meet.

John

> -----Original Message-----
> From: Adam Roach [mailto:[email-masked]] 
> Sent: 11 April 2007 14:14
> To: Elwell, John
> Cc: Francois Audet; SIPPING WG
> Subject: Re: [Sipping] Call Completion: In Defense of 
> Explicit Operations
> 
> Elwell, John wrote:
> > Well, this can work both ways. In my case I  happen to 
> think the BFCP
> > solution will cost more so my sane way of looking at it is 
> to make do with
> > the event package method. 
> 
> You're arguing over the shape of the knob on the stick shift, not 
> whether it is there in the first place. My point is that we 
> would need 
> neither approach without the strict queuing requirement.
> 
> /a
> 
> > I have never been convinced that that is broken.
> >
> > John 
> >
> >   
> >> -----Original Message-----
> >> From: Adam Roach [mailto:[email-masked]] 
> >> Sent: 08 April 2007 16:29
> >> To: Elwell, John
> >> Cc: Francois Audet; SIPPING WG
> >> Subject: Re: [Sipping] Call Completion: In Defense of 
> >> Explicit Operations
> >>
> >> Elwell, John wrote:
> >>     
> >>> Francois,
> >>>
> >>> Clearly the TISPAN people want more than that.
> >>>
> >>>   
> >>>       
> >> I think we understand that they *want* it to behave that 
> way. What I 
> >> believe is getting lost is the cost imposed by the requirements as 
> >> written. In particular, there appears to be no dialog, only a 
> >> unidirectional declaration of requirements without 
> listening for any 
> >> feedback.
> >>
> >> To use an analogy: let's imagine that I wanted to buy a 
> car. I could 
> >> write down the list of features I wanted and then send a 
> >> representative 
> >> to the car dealer with that list. Now, imagine if the car dealer 
> >> explained that they have something on the lot that has all of my 
> >> features for $25,000, *except* it's not a stick shift -- 
> and that, in 
> >> fact, a model with those features *and* a stick shift would 
> >> be such an 
> >> odd special order that it would add $400,000 to the price 
> of the car 
> >> because of the need to re-tool the assembly line.
> >>
> >> A sensible representative would take this information back to 
> >> me and ask 
> >> whether the additional cost was warranted. Of course, I would 
> >> probably 
> >> say, "no."
> >>
> >> An insane representative would, without contacting me, 
> raise a stink 
> >> about the ridiculous cost for this feature and attempt to 
> stand their 
> >> ground, eventually imposing an additional $400,000 cost on me.
> >>
> >> What I'd like to know for certain is that TISPAN *understands* the 
> >> difficulty required to implement this one very small and 
> rarely-used 
> >> aspect of the feature, and that they have explicitly stated 
> >> that it is 
> >> important enough to justify the additional cost it imposes on 
> >> the solution.
> >>
> >> /a
> >>     
> 

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: [email-masked]
Date: Wed, 11 Apr 2007 10:24:30 -0400

From: "Elwell, John" <[email-masked]>

Correction:  TISPAN has these requirements, and *we* are considering
whether we want to implement to them.

Unless we have established a consensus that we *will* implement what
TISPAN says it needs...

Dale