Subject: [Sipping] Comments on draft-ietf-sipping-ipv6-torture-tests-01.txt

From: "B, Nataraju" <[email-masked]>
Date: Mon, 2 Apr 2007 12:39:46 +0530

Hi All, 

Here are few comments on the draft ipv6-torture-tests-01.txt.

1. Lets not allow IPV6 addresses with out [ & ], this is a deviation
from RFC 3261 also.
This would definitely lead to interoperability issues later.

		Snippet from rfc.3261

		IPv6reference  =  "[" IPv6address "]"
		Here "[" "]" means mandatory to have for this component

		Ref:
		IPv4address    =  1*3DIGIT "." 1*3DIGIT "." 1*3DIGIT "."
1*3DIGIT
		for instance we can't have IP address without . For an
IPv4 addresses

2. Replace all instances of umabiguous with unambiguous
Search for all the instances in the draft.

3. via-received not including delimiters [ & ] would make
implementations complex or why don't we make sure all IPv6 addresses
always accompany with delimiters [ & ]. This loop hole will definitely
lead to interoperability issues some time later....
	sec 4.5 of the draft ipv6-torture-tests-01.

Even though some implementations accept IPv6 addresses without [ ], that
is a deviation from standards, but that should not be the criteria to
allow IPv6 without [ ].

4. 
Sec 4.5 param-2 of draft ipv6-torture-tests-01 is not valid with respect
to 3261
	hence let us remove this test case

   The OPTIONS request below contains an IPv6 address in the Via
   received parameter without the adorning "[" and "]".  This request is
   valid according to the grammar in RFC3261.

The above statement is a deviation from what is mentioned in 3261.

   Message Details: param-2

     OPTIONS sip:[2001:db8::10] SIP/2.0
     To: sip:[email-masked]
     From: sip:[email-masked];tag=81x2
     <allOneLine>
     Via: SIP/2.0/UDP [2001:db8::9:1];received=2001:db8::9:255;
     branch=z9hG4bKas3
     </allOneLine>
     Call-ID: SSG95523997077@hlau_4100
     Max-Forwards: 70
     Contact: "Caller" <sip:caller@[2001:db8::1]>
     CSeq: 921 OPTIONS
     Content-Length: 0

5. 
Ref: 4.6.  SIP request with IPv6 addresses in SDP body

Even here also shall we mandate addresses are with [ & ]

This IPv6 address is definitely not inline with what is been specified
in 3261. 

I understand we would not receive IP:PORT in SDP, we can assume what is
been mentioned here is valid to accept, but this is a deviation from
RFC.3261. if we agree that we are deviating from 3261. Shall we mention
the same as a note in the draft? 

Thanks,
Nataraju A B
Technical Lead
[email-masked]
t +91 80 4190 2681
f +91 80 4190 2610
Unit 2, 8th Floor, Inventor Block
ITPL, Whitefield Road
Bangalore- 560066, India
www.sonusnet.com <http://www.sonusnet.com/>     

Deliver the Future First with Sonus Networks.

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Wed, 04 Apr 2007 11:13:45 -0500

> Here are few comments on the draft ipv6-torture-tests-01.txt.

Hi Nataraju: Thanks for reviewing the draft.  Please see inline.

> 1. Lets not allow IPV6 addresses with out [ & ], this is a deviation 

Pedantically speaking, rfc3261 only wants the "[" and "]"
delimiting tokens for the IPv6reference production rule.  It
does NOT require these for the IPv6address production rule.

There has not been WG consensus on mandating the "[" and "]"
delimiting tokens for the IPv6address production rule -- this
is reflected in the ipv6-torture-tests draft.  That is
why it takes the position that a receiving implementation must
be robust enough to parse the IPv6address symbols with and
without the delimiters.

> This would definitely lead to interoperability issues later.

Hopefully these will be mitigated if implementors followed the
Robustness Principle of rfc1122 (also referenced in S4.5 of
ipv6-torture-tests.)

> 2. Replace all instances of umabiguous with unambiguous

Ouch; thanks!  Will do.

> implementations complex or why don’t we make sure all IPv6 addresses 

See discussion above.

>         hence let us remove this test case

Actually, it is valid as per the ABNF in rfc3261.  The received
parameter contains an IPv6 address that follows the IPv6address
production rule, which does NOT require the delimiters.

> Even here also shall we mandate addresses are with [ & ]

Unfortunately, we cannot do that.  RFC4566 (SDP) does not require
that an IPv6 address be delimited by "[" and "]" (see IP6-address
production rule in the ABNF of rfc4566.)  Thus, rfc3261 cannot
over-ride it, and neither can this draft.

Thanks.

- vijay
-- 
Vijay K. Gurbani, Bell Laboratories, Alcatel-Lucent
2701 Lucent Lane, Rm. 9F-546, Lisle, Illinois 60532 (USA)
Email: vkg@{alcatel-lucent.com,bell-labs.com,acm.org}
WWW:   http://www.alcatel-lucent.com/bell-labs