Subject: [Sipping] question on draft-ietf-sipping-cc-transfer-08

From: "Rockson Li \(zhengyli\)" <[email-masked]>
Date: Sat, 18 Aug 2007 12:28:04 +0800

Hi,
 
Is there an error in "Figure 6.  Transfer Protecting Transfer Target."
 
dialog3        | REFER (Target-Dialog:1,                          |
                   |  Refer-To:sips:Transferee?Replaces=1) F5|
 
should Target-Dialog:1 be Target-Dialog:2 instead, since the
Target-Dialog here is used to 
associate Refer dialog with INVITE dialog between transferor and
transfer target.
 
And Messages detail looks like correct saying that.

Regards,
Rockson Li (Zhengyu Li)

Software Engineer
Cisco R&D Center, Shanghai, PRC
Phone(Office) : (8621) 24057003
Email: [email-masked]

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Rockson Li \(zhengyli\)" <[email-masked]>
Date: Sat, 18 Aug 2007 13:30:34 +0800

more questions,
 
2)sec 7.3.  Attended Transfer
 
   The Contact URI of the Transfer Target SHOULD be used by the
   Transferee as the Refer-To URI, unless the URI is suspected or known
   to not be routable outside the dialog.  Otherwise, the Address of
   Record (AOR) of the Transfer Target should be used.  That is, the
   same URI that the Transferee used to establish the session with the
   Transfer Target should be used.
 
>From the call-flow msg details, looks like the two "Transferee" above
should be "Transferor" ???

3)sec 7.7.  Attended Transfer Fallback to Basic Transfer
There're two figure 14 in this section, should we change the second one
to figure15?

And 

" Figure 13 shows the use of OPTIONS when the Transferee and Transfer
  Target do not explicitly indicate support for the REFER method
and...."

Should the Figure 13 be second Figure 14 instead?

Regards,
-Rockson
________________________________

From: Rockson Li (zhengyli) 
Sent: Saturday, August 18, 2007 12:28 PM
To: [email-masked]'
Subject: question on draft-ietf-sipping-cc-transfer-08

Hi,

 

Regards,
Rockson Li (Zhengyu Li)

Software Engineer