Subject: [Sipping] Question on dialog construction

From: "Rockson Li \(zhengyli\)" <[email-masked]>
Date: Fri, 31 Aug 2007 18:17:51 +0800

Hi, currently we have some disputes on routeset and remote target update
in early and confirmed dialog.
 
questions are,
 
1) can routeset and contact be updated with 1xx response to ini-INVITE
in early dialog?
     like 
 
      A                          B
              INVITE
        ------------------------->
             First  1xx with contact ,to tag and Record-Route
        <-------------------------
             Second  1xx with contact ,to tag and Record-Route
        <-------------------------
 
     can second 1xx update the early dialog's routeset and remote
target, which is created by first 1xx.
     From the 3261, looks not it can NOT
     Section 12.1.2:
 
        When a UAC receives a response that establishes a dialog, it
        constructs the state of the dialog. This state MUST be
maintained
        for the duration of the dialog.

        But why? If B is a mobile moving to somewhere else.....

2)         A                          B
              INVITE
        ------------------------->
             First  1xx with contact ,to tag and Record-Route
        <-------------------------
             Second  1xx with contact ,to tag and Record-Route
        <-------------------------
            2xx
        <-------------------------

When dialog change to confirmed state on receipt of 2xx,  3261 says

sec 13.2.2.4
If the dialog identifier in the 2xx response matches the dialog
identifier of an existing dialog, the dialog MUST be transitioned to
the "confirmed" state, and the route set for the dialog MUST be
recomputed based on the 2xx response using the procedures of Section
12.2.1.2. Otherwise, a new dialog in the "confirmed" state MUST be
constructed using the procedures of Section 12.1.2.

How about update remote target?
Does  2xx with different contact from previous 1xx make sense?

Regards,
Rockson Li (Zhengyu Li)

Software Engineer
Cisco R&D Center, Shanghai, PRC
Phone(Office) : (8621) 24057003
Email: [email-masked]

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Tanu Kapoor" <[email-masked]>
Date: Fri, 31 Aug 2007 17:12:32 +0530

Hi,

To my understanding, the 1xx response cannot update the dialog routeset. The
dialog routeset will be modified only with the 2xx reponse and further
requests within dialog will not update the routeset of the dialog, but the
target refresh request( Re-invite for a dialog established iwth Invite) can
update the remote target URI.

Regards,
-Tanu.

---

From: "Rockson Li \(zhengyli\)" <[email-masked]>
Date: Fri, 31 Aug 2007 22:08:20 +0800

Tanu,
 
Thanks, it's confirmed with my initial thoughts.
But I just wonder why the spec does not permit remote target change from
early dialog to confirmed dialog as route set?
which looks just like adding an extra sentence.
 
and in early dialog, as I said earlier, called UA could be moving
somewhere, why not permit remote target update there in spec,
I am not totally sure the rationale behind.
 
Regards,
-Rockson
 
________________________________

From: Tanu Kapoor [mailto:[email-masked]] 
Sent: Friday, August 31, 2007 7:43 PM
To: Rockson Li (zhengyli)
Cc: [email-masked]; [email-masked]
Subject: Re: [Sipping] Question on dialog construction

Hi,
 
To my understanding, the 1xx response cannot update the dialog routeset.
The dialog routeset will be modified only with the 2xx reponse and
further requests within dialog will not update the routeset of the
dialog, but the target refresh request( Re-invite for a dialog
established iwth Invite) can update the remote target URI. 
 
Regards,
-Tanu.

	Hi, currently we have some disputes on routeset and remote
target update
	in early and confirmed dialog. 
	
	questions are,
	
	1) can routeset and contact be updated with 1xx response to
ini-INVITE
	in early dialog?
	    like
	
	     A                          B
	             INVITE

	
	       When a UAC receives a response that establishes a dialog,
it
	       constructs the state of the dialog. This state MUST be 
	maintained
	       for the duration of the dialog.

	2)         A                          B
	             INVITE
	
	When dialog change to confirmed state on receipt of 2xx,  3261
says
	
	sec 13.2.2.4
	If the dialog identifier in the 2xx response matches the dialog 
	identifier of an existing dialog, the dialog MUST be
transitioned to
	the "confirmed" state, and the route set for the dialog MUST be
	recomputed based on the 2xx response using the procedures of
Section 
	12.2.1.2. Otherwise, a new dialog in the "confirmed" state MUST
be
	constructed using the procedures of Section 12.1.2.

	Regards,
	Rockson Li (Zhengyu Li)
	
	Software Engineer

	_______________________________________________
	Sipping mailing list
https://www1.ietf.org/mailman/listinfo/sipping
	This list is for NEW development of the application of SIP 
	Use [email-masked] for questions on current
sip
	Use [email-masked] for new developments of core SIP