Subject: [Sipping] Two Questions on draft-ietf-sipping-race-examples-04

From: "Rockson Li (zhengyli)" <[email-masked]>
Date: Sat, 8 Sep 2007 23:25:21 +0800

Hi,
 
I have two questions on draft-ietf-sipping-race-examples-04.
 
A. in section 2, it says
  Mortal (Mort):In this state, only BYE or its response can be handled,
and no other messages can be received.
   
  But in section 3.2.3, the title is "Receiving 200 OK for re-INVITE
(Established state) in  Mortal state", does this make sense?
 
B. is there a typo there in section 3.3.  Other race conditions?
"There are related each other, but have to be treated separately. " 
 
"There" should be "They"?

Regards,
Rockson Li (Zhengyu Li)

Software Engineer
Cisco R&D Center, Shanghai, PRC
Phone(Office) : (8621) 24057003
Email: [email-masked]

_______________________________________________
Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Miki HASEBE <[email-masked]>
Date: Mon, 10 Sep 2007 14:37:49 +0900

Hi,

Thank you for check over the draft.

"Rockson Li (zhengyli)" <zhengyli at cisco.com> wrote:

>   Mortal (Mort):In this state, only BYE or its response can be handled, and no other messages can be received.
>    
>   But in section 3.2.3, the title is "Receiving 200 OK for re-INVITE (Established state) in  Mortal state", does this make sense?

Thank you for your pointing them out.
It is an improper description.
This sentence is the same intention as the following description
in Appendix D, and is not contradictory to section 3.2.3.

   In the Mortal state, BYE can be accepted, and the other messages in
   the INVITE dialog usage are responded with an error.

> "There" should be "They"?

Yes, it is a typo as you pointed out.

Thank you,
Miki

> Email: zhengyli at cisco.com