Subject: [Sipping] I-D Action:draft-kaplan-sipping-pai-responses-00.txt

From: Hadriel Kaplan <[email-masked]>
Date: Sat, 29 Nov 2008 12:50:43 -0500

Howdy,
At the most recent IETF meeting in Minneapolis, we were informed that a WG decision regarding support for PAI in responses in draft-ietf-sipping-update-pai had been reached on the mailing list, and the decision was not to support them.  I was instructed to submit a new draft if I wished to propose any such support.  I have now done so.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-kaplan-sipping-pai-responses-00.txt

Of course any comments are welcomed and appreciated.

-hadriel
p.s. and thanks to John Elwell for (unknowingly) providing most of the text for this draft, since it is based on draft-ietf-sipping-update-pai.

_______________________________________________
Sipping mailing list  https://www.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: Cullen Jennings <[email-masked]>
Date: Sat, 29 Nov 2008 11:27:05 -0700

Please note the appropriate places to discuss  SIP security mechanisms  
such as authentication of responses is the SIP WG. Discussing  
requirements for PAI header field in responses is a fine thing to do  
in the SIPPING WG. I have not really looked at draft to see what sort  
of category it falls into - I suspect it is more SIPPING that SIP -  
but I wanted to provide clarity on where SIP security mechanisms were  
currently being done so the authors could choose the right WG.

Cullen <RAI AD>

On Nov 29, 2008, at 10:50 AM, Hadriel Kaplan wrote:

> Howdy,
> At the most recent IETF meeting in Minneapolis, we were informed  
> that a WG decision regarding support for PAI in responses in draft- 
> ietf-sipping-update-pai had been reached on the mailing list, and  
> the decision was not to support them.  I was instructed to submit a  
> new draft if I wished to propose any such support.  I have now done  
> so.
>
> p.s. and thanks to John Elwell for (unknowingly) providing most of  
> the text for this draft, since it is based on draft-ietf-sipping- 
> update-pai.
>

---

From: Hadriel Kaplan <[email-masked]>
Date: Sat, 29 Nov 2008 14:40:09 -0500

Cullen,
I don't believe this would fall in SIP, because it does not discuss a new mechanism to authenticate responses. (I thought about doing that, but that would have zero chance of getting deployed, whereas what I describe is basically already deployed)

If you mean discussion of allowing or asserting PAI for responses within a Trust Domain is out of SIPPING's purview in general, then I'll move it to SIP.  Though I'm not sure how that could be the case given the current update-pai draft is in SIPPING, and this whole thing is informational for private domain use anyway.

-hadriel

> -----Original Message-----
> From: Cullen Jennings [mailto:[email-masked]]
> Sent: Saturday, November 29, 2008 1:27 PM
>