Subject: [Sipping] FW: V.152 Fax?; RE: First SIP Forum Fax Interoperability Workshop

From: "Schwarz Albrecht" <[email-masked]>
Date: Wed, 5 Nov 2008 09:51:38 +0100

fyi.

Like also to recall that V.152 is for all kind of modem-based VBD
services:

a) fax/modem
b) data/modem &
c) text/modem.

The correspondent packet relay techniques for VBDoIP are
a) T.38 FoIP
b) V.150.1 MoIP &
c) V.151 ToIP.

SDP for V.152 is described in V.152.
SIP procedures for V.152, ditto.

Further:
any T.38 interoperability test needs to clarify also the used "T.38
version", which relates to the ITU-T release of T.38.
There are in the meanwhile five (?) T.38 "variants" AFAIK:

1) T.38 1998 release (Ref.: ITU-T T.38 (06/98)
2) T.38 2002 release (Ref.: ITU-T T.38 (03/02)
3) T.38 2004 release (Ref.: ITU-T T.38 (04/04)
4) T.38 2005 release (Ref.: ITU-T T.38 (09/05)
5) T.38 2007 release (Ref.: ITU-T T.38 (04/07)

The earlier releases missing e.g. the V.34 support.
The later releases do also cover all the corrections and amendments
made.

Albrecht

-----Original Message-----
From: Eric Burger [mailto:[email-masked]] 
Sent: Dienstag, 4. November 2008 13:24
To: Schwarz Albrecht
Subject: Re: [Sipping] V.152 Fax?; RE: First SIP Forum Fax
Interoperability Workshop

Can you take this issue to the [email-masked] list?
Thanks.

On Nov 4, 2008, at 3:23 AM, Schwarz Albrecht wrote:

> Eric,
>
> any reasons why the fax transport option Fax-over-VBDoIP according 
> ITU-T
> V.152 is out of scope of this workshop?
> We do see much more deployments of V.152 vs T.38 in public VoIP NGNs.
> And V.152 is also used in enterprise networks.
> It's basically a matter of GoS of the IP transport network.
>
> V.152 offers non-assured and assured transport options.
>
> It should be also pointed out that there is a difference between "Fax 
> over G.711" and "Fax over V.152 with G.711 as VBD codec"! G.711 is 
> used as voice codec in the first option, and as VBD codec in the V.152

> mode.
> The particular difference relates to the (G.168) EC handling and VBD 
> stimuli.
>
> The main benefits of V.152 fax vs T.38 fax are
> a) significant less GW resources required in terms of DSP/CPU time & 
> memory ("cheaper") and
> b) much simpler control/configuration parameters (thus, less inteop 
> issues).
>
> Furthermore:
> there is an interoperability topic concerning the peering of T.38 and
> V.152 IP domains.
> There is a new standard in progress for that, see Draft ITU-T 
> V.IP2IP-VxF "V.152 to T.38 peering / interworking"
> (http://www.itu.int/ITU-T/workprog/wp_search.aspx? 
> isn_sp=1&isn_sg=153),
> because neither T.38 nor V.152 does scope the IP-to-IP scenario.
>
>> this is a *Fax* Interoperability Workshop.
>
> Should be:  "this is a *T.38 Fax* Interoperability Workshop. :-)
>
> Also T.37 Fax is out of scope, right?
>
> BR, Albrecht
>
>
>
>> -----Original Message-----
>> From: [email-masked]
>> [mailto:[email-masked]] On Behalf Of Eric Burger
>> Sent: Montag, 3. November 2008 20:34
>> To: [email-masked]
>> Subject: [Sipping] First SIP Forum Fax Interoperability Workshop
>>
>> Yes, you read that right, this is a *Fax* Interoperability Workshop.
>>
>>
>> Location:
>> The W San Francisco Hotel -- (across the street from the Moscone 
>> Convention Center and the VoiceCon show) Workroom #2, 3rd Floor.
>> 181 Third Street, San Francisco CA 94103
>>
>> Date & Time: Monday, November 10, 2008 -- 11:00am - 3:00pm
>> Cost: FREE
>> Organizer: SIP Forum
>> Lead Sponsor: Dialogic
>>
>>
>> BACKGROUND
>> ==========
>> The demand for fax and fax services remains high. Fax Over IP
>> (FoIP) is gaining momentum in the industry, but a number of issues 
>> remain that seriously impact interoperability and reliability.
>>
>> Issue: G.711 Fax Reliability:
>>
>> The ITU-T T.38 FoIP protocol standard overcame many of the issues 
>> experienced when transmitting a fax over G.711.
>> However, many Service Providers use VoIP Gateways that do not support

>> T.38. These Carriers pass fax traffic through their network using 
>> G.711. Fax traffic is highly sensitive to packet loss. The loss of 
>> fax packets (from latency or jitter for example) results in faxes to 
>> fail and be re-transmitted which uses more bandwidth and lowers the 
>> end user's satisfaction. Many carriers desire a FoIP solution that 
>> allows them to utilize their non-
>> T.38 infrastructure to reliably carry fax traffic.
>>
>> Issue: T.38 Fax Interoperability:
>>
>> Many enterprises use T.38 for fax transmission. However, variations 
>> in the interpretation of the T.38 specification have lead to various 
>> interoperability challenges between vendors. There is speculation 
>> that improvements or profiles during session setup can alleviate many

>> of these problems.
>>
>>
>> WORKSHOP OVERVIEW
>> =================
>> The SIP Forum FoIP Interoperability Workshop will bring together 
>> researchers, engineers, and service providers to exchange ideas, 
>> share experiences, and propose approaches to address FoIP problems.
>> Particular focus will be on the use and applicability of SIP to 
>> address systemic or architectural problems. We will not be examining 
>> implementation errors.  If the workshop identifies concrete proposals

>> to improve FoIP that would require modifications to the underlying 
>> protocols, we will forward these proposals to the appropriate groups 
>> in the IETF, IEEE, or ITU- T.
>>
>> Topics of interest include but are not limited to:
>>
>>     * Interoperability failures seen in the field or lab
>>     * Reliability or quality issues seen in the field or lab
>>     * Deployment experiences
>>     * Development experiences
>>     * Architectural principals
>>     * Proposals for achieving a higher degree of FoIP 
>> interoperability and/or FoIP reliability
>>     * Proposals for soliciting additional real-world feedback from 
>> implementers and service providers
>>
>>
>>
>>
>> DISCUSSION MATERIALS
>> ====================
>> The purpose of having position papers for this workshop is purely to 
>> help focus discussion and allow participants to get a feel for what 
>> other participants are thinking about. This is not a scholarly 
>> conference. PowerPoint presentations are fine! The goal of the 
>> workshop is not to publish high-quality research papers. The goal of 
>> the workshop is to publish a workshop report discussing the technical

>> issues that are of the utmost importance to the industry, as well as 
>> a roadmap for how to address them.
>>
>> We encourage Individuals to submit position papers relevant to FoIP.
>> Acceptable formats are IETF Internet Draft style (in HTML or plain 
>> text), IEEE Computer Society Proceedings Manuscripts style (in PDF), 
>> ACM Transactions style (in PDF), or presentation style (in PDF). The 
>> papers should be no longer than 6 pages if in IEEE or ACM style or 10

>> pages of text in Internet Draft style. There is no minimum length 
>> requirement.
>> You may submit relevant, previously published works. If there is a 
>> copyright issue with the SIP Forum posting previously published 
>> papers, please give us a reference to the paper so we can direct 
>> participants to the appropriate publisher.
>>
>> Papers received by the submission deadline will be posted to the 
>> Workshop web site, unless the author(s) request withholding 
>> publication. The author(s) may retain copyright or assign it to the 
>> SIP Forum. If you are submitting a paper that already has a copyright

>> assignment, such as an IEEE or ACM conference or journal paper, 
>> please apply the appropriate self-publication disclaimers demanded by

>> those organizations.
>>
>> Submit your position paper using EasyChair at the following address:
>>
>> http://www.easychair.org/conferences/?conf=sffiw1
>>
>>
>> WORKSHOP FORMAT
>> ===============
>> The expectation is this will be a highly interactive workshop. In 
>> order to frame the conversation, the workshop chair will open the 
>> discussion. At the discretion of the workshop chair and dependent 
>> upon the quality and number of position papers received, the workshop

>> chair may request formal presentations. Note that all position papers

>> will be published on the SIP Forum web site, unless the author(s) 
>> request withholding publication.
>>
>>
>>
>>
>> WORKSHOP FEES
>> The workshop, including lunch, is free of charge to active 
>> participants.
>>
>> WORKSHOP CHAIR: Richard Shockey
>> PROGRAM WHIP: Max Schroeder
>> PROGRAM COMMITTEE: Eric Burger
>>
> _______________________________________________
> Sipping mailing list  https://www.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP Use 
> [email-masked] for questions on current sip Use 
> [email-masked] for new developments of core SIP

_______________________________________________
Sipping mailing list  https://www.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP

---

From: "Gunnar Hellstrom" <[email-masked]>
Date: Sat, 8 Nov 2008 22:17:25 +0100

This is an important topic.

However, more aspects than the IP transport itself needs to be studied.

I have made an investigation that tells that at least for ip transport of
V.21 text telephony, it is not the transport in the IP path that destroys
the modem signal.

Much more bad influence comes from echo cancellers and hybrid circuits in
VoIP gateways and ATA:s. 
They are nowadays usually tuned to give optimum performance for voice,
resulting in that they easily start oscillating when they meet the steady
tones of V.21 modems.

It does not help much to refine the transport over IP, when the modem
signals are destryed already at the entry to the IP network.

This is for V.21, that has steady tones in both directions. There are many
articles written in the 80-s and 90-s about the risk that this condition in
presence of echo causes a risk for self-oscillation in echo cancellers and
adaptive hybrids. Apparently today's conditions easily cause this problem to
appear.

I do not know how this observation relates to fax performance, since I made
the observations on full duplex V.21 operation for text telephony that is a
bit different from how fax is using modems with steady tones. 

But I recommend you to take the risk for ocscillating ECs and Hybrids into
the scope of your workshop. 

I have made a report about the experience with V.21. It was handled in the
latest ITU-T Q.16/16 meeting( about G.168 EC:s ) in September. I and can
provide that report to your workshop as well.

Gunnar 

-------------------------------------------------------------------
Gunnar Hellström
Omnitor
[email-masked]
Tel: +46708204288
www.omnitor.se

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Schwarz Albrecht
Sent: Wednesday, November 05, 2008 9:52 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: [SIPForum-techwg] FW: [Sipping] V.152 Fax?;RE: First SIP Forum Fax
Interoperability Workshop

fyi.

a) fax/modem
b) data/modem &
c) text/modem.

Further:

The earlier releases missing e.g. the V.34 support.
The later releases do also cover all the corrections and amendments made.

Albrecht

-----Original Message-----
From: Eric Burger [mailto:[email-masked]]
Sent: Dienstag, 4. November 2008 13:24
To: Schwarz Albrecht
Subject: Re: [Sipping] V.152 Fax?; RE: First SIP Forum Fax Interoperability
Workshop

_______________________________________________
techwg mailing list
Send mail to: [email-masked]
Unsubscribe or edit options at:  http://sipforum.org/mailman/listinfo/techwg

__________ NOD32 3584 (20081105) Information __________

Detta meddelande dr genomsvkt av NOD32 Antivirus.
http://www.nod32.com

---

From: "Gunnar Hellstrom" <[email-masked]>
Date: Sat, 8 Nov 2008 22:46:43 +0100

I am sorry this message went to Sipping even if you wanted this discussion
to continue only in SIP forum.
I will make an effort to strip Sipping of the thread.

I think sipping has enough of interesting material to cover without
bothering about self-oscillating echo cancellers.

/Gunnar 
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Gunnar Hellstrom
Sent: Saturday, November 08, 2008 10:17 PM
To: 'Schwarz Albrecht'; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: [Sipping] [SIPForum-techwg] FW: V.152 Fax?;RE: First SIP Forum
Fax Interoperability Workshop

Gunnar 

-----Original Message-----

fyi.

a) fax/modem
b) data/modem &
c) text/modem.

Further:

Albrecht

-----Original Message-----
From: Eric Burger [mailto:[email-masked]]
Sent: Dienstag, 4. November 2008 13:24
To: Schwarz Albrecht
Subject: Re: [Sipping] V.152 Fax?; RE: First SIP Forum Fax Interoperability
Workshop

__________ NOD32 3597 (20081108) Information __________

Detta meddelande är genomsökt av NOD32 Antivirus.
http://www.nod32.com