Subject: [Sipping] PRACK: Change MUST requirement to include SDP offer in first reliable provisional response

From: "Christer Holmberg" <[email-masked]>
Date: Mon, 30 Mar 2009 18:08:49 +0200

Hi,

One of the PRACK related issues presented in SFO is whether we should
change the requirement to include SDP offer in the first reliable
provisional response, if the INVITE does not contain SDP.
Two use-cases, which the current requirement affect, were presented:
1. H.323/SIP interworking, where an empty INVITE may have been received
and an SDP offer is not available when the first reliable 18x is to be
sent (please see meeting slides for details).
2. Call fowarding, when a 181 provisional is sent. The 181 may be sent
by an intermediate, and if the INVITE did not contain SDP a reliable 181
would be required to contain an SDP offer.
It was indicated that there may be backward compability issues. That of
course depends on the number of deployments where INVITE without SDP is
sent AND a reliable 18x without SDP offer would cause an error.
Some people indicated concern, so I would like to ask what people think?
Would changing the rules cause problems in existing deploymentnts?
Regards,
Christer

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 30 Mar 2009 16:55:28 -0400

> sent (please see meeting slides for details).

This is the issue I hear complaints about.

> would be required to contain an SDP offer.

This is only an issue if the INVITE contained Require:100rel. (And AFAIK 
that is rarely the case. If it was the case the 181 could simply be 
omitted.)

Otherwise, an unreliable 181 can be sent, which needn't have SDP.

Another possibility would be to send a 181 with bogus SDP. For instance 
it could have c=0 and port=0 for all the media. That could work even 
reliably. And it wouldn't affect any real answers because it will have a 
unique to-tag.

> Would changing the rules cause problems in existing deploymentnts?

I'll have to ask around.

	Paul

> Regards,
> Christer
> 
> 
> ------------------------------------------------------------------------
> 
> _______________________________________________
> Sipping mailing list  https://www.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments of core SIP

---

From: "Rockson Li (zhengyli)" <[email-masked]>
Date: Tue, 31 Mar 2009 13:29:15 +0800

Paul and Christer,

IMHO, I don't like the first-reliable-provisional-resp-with-sdp rule.
Implementation are required to accept first reliable response without
sdp by customer,
While must be prepared to follow this rule sending resp in case any
criticism of non-compliance from other vendors,
Which makes implemenation more complex.

BTW, what's the history on making this rule,could you please share with
me?

Thanks
Regards,
-Rockson
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Paul Kyzivat (pkyzivat)
Sent: Tuesday, March 31, 2009 4:55 AM
To: Christer Holmberg
Cc: [email-masked]
Subject: Re: [Sipping] PRACK: Change MUST requirement to include SDP
offer in first reliable provisional response

Christer Holmberg wrote:
> 1. H.323/SIP interworking, where an empty INVITE may have been 
> received and an SDP offer is not available when the first reliable 18x

> is to be sent (please see meeting slides for details).

> by an intermediate, and if the INVITE did not contain SDP a reliable 
> 181 would be required to contain an SDP offer.

> It was indicated that there may be backward compability issues. That 
> of course depends on the number of deployments where INVITE without 
> SDP is sent AND a reliable 18x without SDP offer would cause an error.
> 

I'll have to ask around.

	Paul

> This list is for NEW development of the application of SIP Use 
> [email-masked] for questions on current sip Use 
> [email-masked] for new developments of core SIP
_______________________________________________
Sipping mailing list  https://www.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP Use
[email-masked] for questions on current sip Use
[email-masked] for new developments of core SIP

---

From: Hisham Khartabil <[email-masked]>
Date: Tue, 31 Mar 2009 16:59:36 +1100

I thought it was already a MUST

RFC3261

"   If the INVITE does not contain a session description, the UAS is
   being asked to participate in a session, and the UAC has asked that
   the UAS provide the offer of the session.  It MUST provide the offer
   in its first non-failure reliable message back to the UAC.  In this
   specification, that is a 2xx response to the INVITE.

"

RFC3262

"If the UAC receives a reliable provisional response with an offer
   (this would occur if the UAC sent an INVITE without an offer, in
   which case the first reliable provisional response will contain the
   offer), it MUST generate an answer in the PRACK."

Can you point to the text that says SDP offer does not need to occur
in the 1st reliable response?

Hisham

2009/3/31 Christer Holmberg <[email-masked]>:
>
> Hi,
>
> One of the PRACK related issues presented in SFO is whether we should change
> the requirement to include SDP offer in the first reliable provisional
> response, if the INVITE does not contain SDP.
>
> 1. H.323/SIP interworking, where an empty INVITE may have been received and
> an SDP offer is not available when the first reliable 18x is to be sent
> (please see meeting slides for details).
>
> 2. Call fowarding, when a 181 provisional is sent. The 181 may be sent by an
> intermediate, and if the INVITE did not contain SDP a reliable 181 would be
> required to contain an SDP offer.
>
> course depends on the number of deployments where INVITE without SDP is sent
> AND a reliable 18x without SDP offer would cause an error.
>

---

From: "Sanjay Sinha (sanjsinh)" <[email-masked]>
Date: Tue, 31 Mar 2009 02:15:54 -0400

Pl. see inline .. 

>From: [email-masked] 
>[mailto:[email-masked]] On Behalf Of Paul Kyzivat (pkyzivat)
>Sent: Tuesday, March 31, 2009 2:25 AM
>To: Christer Holmberg
>Cc: [email-masked]
>Subject: Re: [Sipping] PRACK: Change MUST requirement to 
>include SDP offer in first reliable provisional response
>
>
>
>Christer Holmberg wrote:
>> 
>> Hi,
>> 
>This is only an issue if the INVITE contained Require:100rel. 
>(And AFAIK that is rarely the case. If it was the case the 181 
>could simply be
>omitted.)

That's true, but since 181 is a response code defined in rfc 3261, this
use case is valid when Invite has Require:100rel. And the solution
should take care of this use case.

>Another possibility would be to send a 181 with bogus SDP. For 
>instance it could have c=0 and port=0 for all the media. That 
>could work even reliably.

Problem is that bogus sdp interpretation varies depending on
implementation. Some use the method you describe above, some others use
media attributes, some other variations in m line.

> And it wouldn't affect any real 
>answers because it will have a unique to-tag.
>

As you suggested, maybe getting some feedback from upcoming SIPIt should
also help.

Thanks

>[email-masked] for questions on current sip

---

From: "Sanjay Sinha (sanjsinh)" <[email-masked]>
Date: Tue, 31 Mar 2009 02:19:07 -0400

Inline ..
>[mailto:[email-masked]] On Behalf Of Hisham Khartabil
>Sent: Tuesday, March 31, 2009 11:30 AM
>To: Christer Holmberg
>Cc: [email-masked]
>include SDP offerin first reliable provisional response
>
>"
>
>RFC3262
>
>Can you point to the text that says SDP offer does not need to 
>occur in the 1st reliable response?

Yeah the rule says that SDP offer is MUST in reliable provisional response and Christer's email is about relaxing that rule.

Sanjay

---

From: "Christer Holmberg" <[email-masked]>
Date: Tue, 31 Mar 2009 11:39:12 +0200

Hi,

I guess we could even say that the UAS SHOULD generate SDP offer in the first reliable response, unless it for whatever reason is not able to do so.

Regards,

Christer

> From: Sanjay Sinha (sanjsinh) [mailto:[email-masked]] 
> Sent: 31. maaliskuuta 2009 9:19
> To: Hisham Khartabil; Christer Holmberg
> Cc: [email-masked]
> Subject: RE: [Sipping] PRACK: Change MUST requirement to 
> >offerin first reliable provisional response
> >
> >"
> >
> >RFC3262
> >
> >Can you point to the text that says SDP offer does not need 
> to occur in 
> >the 1st reliable response?
> 
> Yeah the rule says that SDP offer is MUST in reliable 
> provisional response and Christer's email is about relaxing that rule.
> 
> Sanjay
> 
> >
> >Hisham
> >

---

From: Hadriel Kaplan <[email-masked]>
Date: Tue, 31 Mar 2009 09:50:11 -0400

Unfortunately we know of implementations that expect SDP in the first reliable provisional response.  I don't know how we can relax the normative language for that at this point, short of defining a new PRACK-ish thing, and I don't see how that could work either.
In hindsight I'm thinking we probably also shouldn't have made the SDP answer (or another offer) required or even possible in the PRACK either.  I think it should have been for one and only one purpose: to acknowledge receipt of the provisional response.

-hadriel

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Christer Holmberg
Sent: Monday, March 30, 2009 12:09 PM
To: [email-masked]
Subject: [Sipping] PRACK: Change MUST requirement to include SDP offer in first reliable provisional response

Hi,

One of the PRACK related issues presented in SFO is whether we should change the requirement to include SDP offer in the first reliable provisional response, if the INVITE does not contain SDP.

Two use-cases, which the current requirement affect, were presented:
1. H.323/SIP interworking, where an empty INVITE may have been received and an SDP offer is not available when the first reliable 18x is to be sent (please see meeting slides for details).

2. Call fowarding, when a 181 provisional is sent. The 181 may be sent by an intermediate, and if the INVITE did not contain SDP a reliable 181 would be required to contain an SDP offer.

It was indicated that there may be backward compability issues. That of course depends on the number of deployments where INVITE without SDP is sent AND a reliable 18x without SDP offer would cause an error.

Some people indicated concern, so I would like to ask what people think? Would changing the rules cause problems in existing deploymentnts?

Regards,
Christer

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 31 Mar 2009 09:56:02 -0400

> BTW, what's the history on making this rule,could you please share with

I don't know the reason for this rule. It seems excessively prescriptive 
to me. Absent an understanding of *why* it was imposed, I wish it hadn't 
been.

But whether it should be changed now is a different question.
There are pros (for devices that have difficulty following this rule) 
and cons (backward compatibility with any devices that might depend on 
it working this way.) I think we hear frequently from those in favor. I 
haven't really heard from anyone who might be negatively impacted by the 
change. That could be because nobody would be negatively impacted, or 
that some would and just haven't responded.

	Thanks,
	Paul