Subject: [Sipping] Examples in draft-ietf-sipping-config-framework-15

From: "Dale Worley" <[email-masked]>
Date: Tue, 24 Mar 2009 14:19:00 -0400

I've been looking at the examples in
draft-ietf-sipping-config-framework-15, and I suspect that one is not
correct.  Specifically, in section 7.1 is:

   SUBSCRIBE sip:urn%3auuid%3a00000000-0000-1000-0000-00FF8D82EDCB
             @example.com  SIP/2.0
   Event: ua-profile;profile-type=device;vendor="vendor.example.net";
          model="Z100";version="1.2.3";
   From: [email-masked];tag=1234
   To: sip:[email-masked]
   Call-ID: [email-masked]
   CSeq: 2131 SUBSCRIBE
   Contact: sip:urn%3auuid%3a00000000-0000-1000-0000-00FF8D82EDCB
      @192.168.1.44
      ;+sip.instance="<urn:uuid:00000000-0000-0000-0000-123456789AB0>"
      ;schemes="http,https"
   Via: SIP/2.0/TCP 192.0.2.41;
     branch=z9hG4bK6d6d35b6e2a203104d97211a3d18f57a
   Accept: message/external-body, application/x-z100-device-profile
   Content-Length: 0

As far as I can tell, 5.1.4.2, the user part of the request-URI must be
the "device identifier", which would be in this case
"urn:uuid:00000000-0000-1000-0000-00FF8D82EDCB".  The +sip.instance
parameter of the Contact field must be the same as that in the local
network profile SUBSCRIBE request, which 5.1.4.1 refers to sip-outbound.

But it seems to me that the +sip.instance value is expected to be the
device identifier.  And yet, in this example, it is different from the
device identifier in the request URI.  I suspect that I'm not
understanding the concept behind this.

Dale

---

From: "Francois Audet" <[email-masked]>
Date: Tue, 24 Mar 2009 13:25:11 -0500

I think you are correct. It should normally be the same. 

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Worley, Dale 
> (BL60:9D30)
> Sent: Tuesday, March 24, 2009 11:19
> To: SIPPING
> Subject: [Sipping] Examples in draft-ietf-sipping-config-framework-15
> 
> draft-ietf-sipping-config-framework-15, and I suspect that 
> one is not correct.  Specifically, in section 7.1 is:
> 
>    To: 
> sip:[email-masked]
> As far as I can tell, 5.1.4.2, the user part of the 
> request-URI must be the "device identifier", which would be 
> in this case "urn:uuid:00000000-0000-1000-0000-00FF8D82EDCB". 
>  The +sip.instance parameter of the Contact field must be the 
> same as that in the local network profile SUBSCRIBE request, 
> which 5.1.4.1 refers to sip-outbound.
> 
> But it seems to me that the +sip.instance value is expected 
> to be the device identifier.  And yet, in this example, it is 
> different from the device identifier in the request URI.  I 
> suspect that I'm not understanding the concept behind this.
> 
> Dale
> 
> 
> _______________________________________________
> Sipping mailing list  https://www.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP 
> Use [email-masked] for questions on current 
> sip Use [email-masked] for new developments of core SIP
>