Subject: [siprec] Requirements #65 (new): Extension of REQ-017 concerning preference to record/not record

From: "siprec issue tracker" <[email-masked]>
Date: Tue, 15 Feb 2011 08:21:14 -0000

#65: Extension of REQ-017 concerning preference to record/not record

 We have "REQ-017 The mechanism MUST support a means for an authorized
 participant involved in a CS to request, prior to the start of recording,
 that the CS not be recorded".

 Should this be extended to cover a request during a CS, and also the
 ability during a CS to request that recording be allowed? In other words,
 the ability for a participant to indicate a preference for recording or
 not recording, at the start of a CS or during a CS. Note that such a
 requirement would be realisable only from a siprec-aware UA.

 This is related to REQ-011 (pause/resume), but with the difference that it
 is the participant who expresses the preference (REQ-011 seems to imply
 the SRC decides). So in considering any possible rewording of REQ-017, we
 should perhaps consider its relationship to REQ-011.

 John

-- 
------------------------------------------------+---------------------------
 Reporter:  john.elwell@…                       |       Owner:  krehor@…        
     Type:  defect                              |      Status:  new             
 Priority:  major                               |   Milestone:                  
Component:  Requirements                        |     Version:                  
 Severity:  In WG Last Call                     |    Keywords:                  
------------------------------------------------+---------------------------

Ticket URL: <https://trac.tools.ietf.org/wg/siprec/trac/ticket/65>
siprec <http://tools.ietf.org/siprec/>

---

From: "Elwell, John" <[email-masked]>
Date: Tue, 15 Feb 2011 09:34:11 +0100

I think we need to cover the following cases:
- on establishing a CS, request it be recorded;
- on establishing a CS, request that it not be recorded;
- during a CS, request that recording be discontinued;
- during a CS, request that recording be started.

Concerning discontinuation, we could discuss whether this means stop or pause. With pause, you could later resume that same recording. With stop, you would effectively terminate the recording, such that you would need to start a new recording if you need to record later during the CS. The handling of metadata would differ - in the first case the metadata might tell you when the CS ends (as well as when recording is paused) - with the second case it might tell you when recording is stopped and nothing beyond that. I don't know which of these we want (perhaps both).

John (as individual)

> -----Original Message-----
> From: siprec issue tracker [mailto:[email-masked]] 
> Sent: 15 February 2011 08:21
> To: [email-masked]; Elwell, John
> Cc: [email-masked]
> Subject: [siprec] Requirements #65 (new): Extension of 
> REQ-017 concerning preference to record/not record
> 
>  Reporter:  john.elwell@...                       |       
> Owner:  krehor@...        
>      Type:  defect                              |      
> Status:  new             
>  Priority:  major                               |   
> Milestone:

---

From: Alissa Cooper <[email-masked]>
Date: Fri, 18 Feb 2011 17:56:01 +0000

> - during a CS, request that recording be started.

+1

>
> Concerning discontinuation, we could discuss whether this means stop  
> or pause. With pause, you could later resume that same recording.  
> With stop, you would effectively terminate the recording, such that  
> you would need to start a new recording if you need to record later  
> during the CS. The handling of metadata would differ - in the first  
> case the metadata might tell you when the CS ends (as well as when  
> recording is paused) - with the second case it might tell you when  
> recording is stopped and nothing beyond that. I don't know which of  
> these we want (perhaps both).

Seems like both might be useful, but I have no strong opinion here.

Alissa

> _______________________________________________
> siprec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/siprec
>

---

From: Leon Portman <[email-masked]>
Date: Sun, 20 Feb 2011 15:11:05 +0200

+1

We need both pause and stop. In both cases SRS need to know when CS is ended.

Leon

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Alissa Cooper
Sent: Friday, February 18, 2011 7:56 PM
To: Elwell, John
Cc: [email-masked]; siprec issue tracker
Subject: Re: [siprec] Requirements #65 (new): Extension of REQ-017 concerning preference to record/not record

+1

Alissa

>> participant involved in a CS to request, prior to the start of 
>> recording, that the CS not be recorded".
>>
>> ability during a CS to request that recording be allowed? In other 
>> words, the ability for a participant to indicate a preference for 
>> recording or not recording, at the start of a CS or during a CS. Note 
>> that such a requirement would be realisable only from a siprec-aware 
>> UA.
>>
>> This is related to REQ-011 (pause/resume), but with the difference 
>> that it is the participant who expresses the preference (REQ-011 
>> seems to imply the SRC decides). So in considering any possible 
>> rewording of REQ-017, we should perhaps consider its relationship to 
>> REQ-011.
>>
>> John
>>
>> --

---

From: "Dave Smith" <[email-masked]>
Date: Sun, 20 Feb 2011 09:23:09 -0800

+1, except I'd hope we could simplify this to one or the other (pause or
stop), not both, but I'm not sure which one is best.  

Regards,
Dave

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Leon Portman
Sent: Sunday, February 20, 2011 5:11 AM
To: Alissa Cooper; Elwell, John
Cc: [email-masked]; siprec issue tracker
Subject: Re: [siprec] Requirements #65 (new): Extension ofREQ-017
concerning preference to record/not record

+1

We need both pause and stop. In both cases SRS need to know when CS is
ended.

Leon

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Alissa Cooper
Sent: Friday, February 18, 2011 7:56 PM
To: Elwell, John
Cc: [email-masked]; siprec issue tracker
Subject: Re: [siprec] Requirements #65 (new): Extension of REQ-017
concerning preference to record/not record

+1

Alissa

-------------------------------------------------------------------------------------------------------------------
CONFIDENTIALITY NOTICE: This e-mail and any files attached may contain confidential and proprietary information of Alcatel-Lucent and/or its affiliated entities. Access by the intended recipient only is authorized. Any liability arising from any party acting, or refraining from acting, on any information contained in this e-mail is hereby excluded. If you are not the intended recipient, please notify the sender immediately, destroy the original transmission and its attachments and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Copyright in this e-mail and any attachments belongs to Alcatel-Lucent and/or its affiliated entities.

---

From: "Henry Lum" <[email-masked]>
Date: Tue, 22 Feb 2011 07:08:41 -0800

+1

> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Leon Portman
> Sent: Sunday, February 20, 2011 8:11 AM

---

From: "Elwell, John" <[email-masked]>
Date: Mon, 28 Feb 2011 16:37:13 +0100

There seems to be consensus to expand on REQ-017 along the lines proposed in my earlier message. Although one person preferred to pick either pause or stop for discontinuation, but others who responded preferred to keep both options.

Therefore I think REQ-017 can be replaced by two new requirements:
"REQ-yyy The mechanism MUST support a means for a recording-aware UA involved in a CS to request at session establishment time that the CS should be recorded or should not be recorded, the honoring of such a request being dependent on policy."
"REQ-zzz The mechanism MUST support a means for a recording-aware UA involved in a CS to request during a session that the recording of the CS should be started, paused, resumed or stopped, the honoring of such a request being dependent on policy."

In the interests of making progress, if I hear no objections to this by tomorrow (2011-03-01) I will ask the editor to include this in the next draft (there will still be time for a quick check of that before it goes to the IESG).

John (as chair).

> From: Henry Lum [mailto:[email-masked]] 
> Sent: 22 February 2011 15:09
> To: Leon Portman; Alissa Cooper; Elwell, John
> Subject: RE: [siprec] Requirements #65 (new): Extension 
> ofREQ-017 concerning preference to record/not record
> 
> +1
> 
> > Behalf Of Alissa Cooper
> > >> Ticket URL: 
> <https://trac.tools.ietf.org/wg/siprec/trac/ticket/65>
> --------------------------------------------------------------
> -----------------------------------------------------
> CONFIDENTIALITY NOTICE: This e-mail and any files attached 
> may contain confidential and proprietary information of 
> Alcatel-Lucent and/or its affiliated entities. Access by the 
> intended recipient only is authorized. Any liability arising 
> from any party acting, or refraining from acting, on any 
> information contained in this e-mail is hereby excluded. If 
> you are not the intended recipient, please notify the sender 
> immediately, destroy the original transmission and its 
> attachments and do not disclose the contents to any other 
> person, use it for any purpose, or store or copy the 
> information in any medium. Copyright in this e-mail and any 
> attachments belongs to Alcatel-Lucent and/or its affiliated entities.
> 					
>