Subject: [siprec] Apps advisor for SIPREC

From: "Elwell, John" <[email-masked]>
Date: Fri, 4 Feb 2011 09:32:51 +0100

I am very pleased to announce that Peter Saint-Andre has agreed to be the Apps advisor to SIPREC, with special focus on XML. The authors of the metadata format draft have already identified questions in this area, so please involve Peter.

John

---

From: "Parthasarathi R (partr)" <[email-masked]>
Date: Fri, 4 Feb 2011 15:36:49 +0530

John,

Thanks for identifying Peter as the app advisor for metadata format.

Peter,

Thanks to agree for app advisor for SIPREC. The strawhorse proposal of
Metadata XML format is available at
http://www.ietf.org/internet-drafts/draft-ram-siprec-metadata-format-00.
txt. Please provide your valuable comments.

Open items 1:
The current approach is to pass the complete metadata for each
transaction from SRC to SRS. The limitation is that SRS has to keep
track of the last metadata and identify the difference. There is need to
pass only the update of metadata through XML. IOW, partial data has to
be passed across in XML document. Some of the approaches which we comes
across are:

1) Create individual namespace for each XML element and pass it whenever
it is updated using its unique id.
2) RFC5261 which uses XPath to locate and make changes to the snapshot.
XCON event package uses this mechanism and the draft is expired.
3) REST Architecture for SIPREC XML
4) or any other ?

Please provide your valuable opinion which best fit for SIPREC metadata
document.

Thanks
Partha

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Elwell, John
Sent: Friday, February 04, 2011 2:03 PM
To: [email-masked]
Cc: [email-masked]
Subject: [siprec] Apps advisor for SIPREC

I am very pleased to announce that Peter Saint-Andre has agreed to be
the Apps advisor to SIPREC, with special focus on XML. The authors of
the metadata format draft have already identified questions in this
area, so please involve Peter.

John
_______________________________________________
siprec mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/siprec

---

From: "Elwell, John" <[email-masked]>
Date: Fri, 4 Feb 2011 15:30:05 +0100

Well, I should have mentioned it was Gonzalo who did the negotiation, so thanks to Gonzalo, not me, and also of course to Peter for taking on this task.

John

> From: Parthasarathi R (partr) [mailto:[email-masked]] 
> Sent: 04 February 2011 10:07
> To: Elwell, John; [email-masked]; [email-masked]
> Subject: RE: [siprec] Apps advisor for SIPREC
> 
> John,
> 
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf
> Of Elwell, John