Subject: [siprec] Requirements #64 (new): REQ-015/REQ-016 and cancelling a recording

From: "siprec issue tracker" <[email-masked]>
Date: Tue, 15 Feb 2011 08:05:55 -0000

#64: REQ-015/REQ-016 and cancelling a recording

 Do we need any requirement concerning cancelling a recording? We already
 have REQ-011 on pausing and resuming, and pausing without subsequently
 resuming can probably be considered to be cancelling the recording. If the
 resolution of ticket #63 results in no requirement for discarding a
 recording, and if REQ-011 is considered to cover cancelling a recording,
 can REQ-015 and REQ-016 be removed entirely?

 John

-- 
------------------------------------------------+---------------------------
 Reporter:  john.elwell@…                       |       Owner:  leon.portman@…       
     Type:  defect                              |      Status:  new                  
 Priority:  major                               |   Milestone:                       
Component:  Requirements                        |     Version:                       
 Severity:  In WG Last Call                     |    Keywords:                       
------------------------------------------------+---------------------------

Ticket URL: <https://wiki.tools.ietf.org/wg/siprec/trac/ticket/64>
siprec <http://tools.ietf.org/siprec/>

---

From: "Elwell, John" <[email-masked]>
Date: Tue, 15 Feb 2011 09:30:34 +0100

I think we don't need a special requirement on cancelling, given the existence of REQ-011 on pause/resume and REQ-017 on requesting no recording. Depending on the resolution of ticket #63, I believe REQ-015 and REQ-016 can be deleted.

John (as individual) 

> -----Original Message-----
> From: siprec issue tracker [mailto:[email-masked]] 
> Sent: 15 February 2011 08:06
> To: [email-masked]; Elwell, John
> Cc: [email-masked]
> Subject: [siprec] Requirements #64 (new): REQ-015/REQ-016 and 
> cancelling a recording
> 
>  Reporter:  john.elwell@...                       |       
> Owner:  leon.portman@...       
>      Type:  defect                              |      
> Status:  new                  
>  Priority:  major                               |   
> Milestone:

---

From: Leon Portman <[email-masked]>
Date: Wed, 23 Feb 2011 19:20:18 +0200

I am not very comfortable of treating pausing of the recording as a canceling of the recording. Pausing of the recording usually will keep recording channel allocated and not available for other recordings until end of the call. Canceling/stopping recording will release the channel.

So I may be we need a requirement for just stopping recording, like this:

"The mechanism MUST support a means to stop  the recording". I remember that we have multiple discussion about it

The actual request of discarding of the recording media and metadata is out of scope and should be handled by policy server (Ticket #63)

Leon

-----Original Message-----
From: Elwell, John [mailto:[email-masked]] 
Sent: Tuesday, February 15, 2011 10:31 AM
To: siprec issue tracker; Leon Portman
Cc: [email-masked]
Subject: RE: [siprec] Requirements #64 (new): REQ-015/REQ-016 and cancelling a recording

John (as individual) 

>  Do we need any requirement concerning cancelling a recording? We 
> already  have REQ-011 on pausing and resuming, and pausing without 
> subsequently  resuming can probably be considered to be cancelling the 
> recording. If the  resolution of ticket #63 results in no requirement 
> for discarding a  recording, and if REQ-011 is considered to cover 
> cancelling a recording,  can REQ-015 and REQ-016 be removed entirely?
> 
>  John
> 
> --

---

From: "Elwell, John" <[email-masked]>
Date: Mon, 28 Feb 2011 16:37:52 +0100

I heard no more proposals on this. Everyone who responded on tickets #63 and #64 was in favour of deleting REQ-015 and REQ-016, so the question remains whether we can add in place of REQ-015/REQ-016:
"REQ-xxx The mechanism MUST support a means to stop the recording",
as proposed by Leon.

In the interests of making progress, if I hear no objections to this by tomorrow (2011-03-01) I will ask the editor to include this in the next draft (there will still be time for a quick check of that before it goes to the IESG).

John (as chair).

> From: Leon Portman [mailto:[email-masked]] 
> Sent: 23 February 2011 17:20
> To: Elwell, John; siprec issue tracker
> Cc: [email-masked]
> I am not very comfortable of treating pausing of the 
> recording as a canceling of the recording. Pausing of the 
> recording usually will keep recording channel allocated and 
> not available for other recordings until end of the call. 
> Canceling/stopping recording will release the channel.
> 
> "The mechanism MUST support a means to stop  the recording". 
> I remember that we have multiple discussion about it
> 
> The actual request of discarding of the recording media and 
> metadata is out of scope and should be handled by policy 
> server (Ticket #63)
> 
> Leon
> 
> I think we don't need a special requirement on cancelling, 
> given the existence of REQ-011 on pause/resume and REQ-017 on 
> requesting no recording. Depending on the resolution of 
> ticket #63, I believe REQ-015 and REQ-016 can be deleted.
> 
> John (as individual) 
>