Subject: Re: [siprec] metadata model for participant that is not part of CS

From: "Elwell, John" <[email-masked]>
Date: Fri, 11 Feb 2011 15:28:39 +0100

I realise I was directly addressed earlier in this thread and I didn't reply (it was left sitting in my inbox).

I don't have anything further to add - I see both sides of the argument. Paul/Ram are looking for sufficient expressiveness to cover a wide range of situations, even though in many cases information available will be limited. Charles is concerned, I think, with it being misleading in some cases where limited information is available. So perhaps we need other opinions in order to close on this one.

John

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Paul Kyzivat
> Sent: 27 January 2011 18:58
> To: [email-masked]
> Subject: Re: [siprec] metadata model for participant that is 
> not part of CS
> 
> Charles,
> 
> I don't think we will be able (or should try) to design this so that 
> everything the SRC specifies is guaranteed to be as complete 
> as you wish 
> it to be. At the end of the day, the SRC will have to do what it can, 
> and some will be better at it than others. If the SRC you have chosen 
> isn't supplying the information it could have and wish it 
> had, then you 
> can complain and request upgrades, or you can choose a 
> different product.
> 
> As long as we have sufficient expressiveness to describe 
> things as you 
> wish for any given case then I think we are good. Lets ensure 
> we can at 
> least do that.
> 
> BTW, this is exactly the sort of discussion I have been 
> hoping we would 
> have over the model. I expected it would happen quite some 
> time ago. But 
> better now than never.
> 
> 	Thanks,
> 	Paul
> 
> On 1/27/2011 1:07 PM, Charles Eckel (eckelcu) wrote:
> > Hi Ram,
> >
> > If all CS participants are required to support the conference event
> > package and provide sufficient info about each non-CS participant in
> > order to be allowed to bring them in, then I am ok with it. 
> My concern
> > is that the SRS will not be able to get sufficient info about non-CS
> > participant in all cases. In such cases, it seems to me the media
> > streams should be associated with the CS participant 
> responsible for the
> > non-CS participant, rather than allowing media from incompletely
> > described non-CS participants to exist on its own.
> > You mention the case of the conference focus, in which 
> everything may be
> > fine, but there are other cases, as mentioned by Jon, for 
> which this may
> > not be the case.
> >
> > Cheers,
> > Charles
> >
> >
> >
> >> -----Original Message-----
> >> From: Ram Mohan R (rmohanr)
> >> Sent: Thursday, January 27, 2011 4:35 AM
> >> To: Elwell, John; Charles Eckel (eckelcu); [email-masked]
> >> Subject: RE: [siprec] metadata model for participant that 
> is not part
> > of CS
> >>
> >> Hi Charles/John,
> >>
> >> In the current model, a media stream is always associated with at
> > least one participant. Here is the
> >> snippet of the associations between CS and Participant and 
> Participant
> > and Media Streams taken from
> >> the draft
> >> https://datatracker.ietf.org/doc/draft-ram-siprec-metadata
> >>
> >> Section 4.3.2 has the associations between CS and Participant
> >> Section 4.4.2 has the associations between media stream and
> > participant
> >>
> >> The current model allows participants who are not part of CS to be
> > part of the model.
> >> A example of such a case is:
> >> - participants in a premixed media stream.  The SRC may 
> have knowledge
> > of such Participants, yet not
> >> have any signaling relationship with them.  This might arise if one
> > participant in CS is a conf focus.
> >>
> >> In those case, if the metadata for non-CS participants is 
> incomplete,
> > the SRC can use other mechanisms
> >> like subscribing to conference event package to retrieve the
> > information about non-CS participants.
> >>
> >> To summarize the model allows representing of non-CS 
> participants who
> > contribute media to CS.
> >>
> >> Charles,
> >> The use case section is at the end of this document
> >> https://datatracker.ietf.org/doc/draft-ram-siprec-metadata
> >>
> >> Please note the case where Focus is acting as SRC is simpler as all
> > participants of conference which
> >> are connected to focus will in turn become participants of CS too.
> >>
> >> Thanks,
> >> Ram
> >>
> >>> -----Original Message-----
> >>> From: [email-masked] [mailto:[email-masked]] On
> >>> Behalf Of Elwell, John
> >>> Sent: Thursday, January 27, 2011 1:09 PM
> >>> To: Charles Eckel (eckelcu); [email-masked]
> >>> Subject: Re: [siprec] metadata model for participant that is not
> > part
> >>> of CS
> >>>
> >>> I am starting to see Charles's point. For a participant behind a
> >>> bridge, you don't really know what media he is 
> contributing or what
> >>> media he is receiving. All you know for certain is that the bridge
> > is a
> >>> participant. Perhaps we could assign multiple user identities to a
> >>> bridge participant, thereby reflecting users behind the 
> bridge that
> > may
> >>> or may not be contributing to the media the bridge sends 
> and may or
> > may
> >>> not be recipients of media the bridge receives.
> >>>
> >>> Note that the model when the SRC is at the bridge, rather than
> > outside
> >>> the bridge, is quite different. Also the model where the bridge is
> >>> switching, rather than mixing, might be different.
> >>>
> >>> John (as individual)
> >>>
> >>>> -----Original Message-----
> >>>> From: [email-masked]
> >>>> [mailto:[email-masked]] On Behalf Of Charles Eckel
> > (eckelcu)
> >>>> Sent: 26 January 2011 18:56
> >>>> To: [email-masked]
> >>>> Subject: [siprec] metadata model for participant that is not
> >>>> part of CS
> >>>>
> >>>> This is to follow up on some questions I raised regarding the
> >>> metadata
> >>>> model during the interim meeting Tuesday.
> >>>> My initial concern was that I thought we were allowing media
> >>>> streams to
> >>>> be defined without any participant. I now understand that is not
> > the
> >>>> case; rather, a media stream is always associated with at least
> > one
> >>>> participant, but that participant need not necessary be
> >>>> associated with
> >>>> the CS.
> >>>> Now I have some concern about participants that are not part
> >>>> of the CS.
> >>>> My concern is that the level of metadata we have for such
> >>> participants
> >>>> will be inconsistent at best. If the metadata for a non-CS
> >>> participant
> >>>> is incomplete, what do we plan to do?
> >>>> Also, I believe there was reference to a document that contains
> > the
> >>>> model and some use cases. Which document is that?
> >>>>
> >>>> Thanks,
> >>>> Charles
> >>>> _______________________________________________
> >>>> siprec mailing list
> >>>> [email-masked]
> >>>> https://www.ietf.org/mailman/listinfo/siprec
> >>>>
> >>> _______________________________________________
> >>> siprec mailing list
> >>> [email-masked]
> >>> https://www.ietf.org/mailman/listinfo/siprec
> > _______________________________________________
> > siprec mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/siprec
> >
> _______________________________________________
> siprec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/siprec
>

---

From: Leon Portman <[email-masked]>
Date: Mon, 14 Feb 2011 00:39:43 +0200

Hello,

I agree with Paul statement that SRC should provide best effort to report complete metadata as possible. And we should model it as complete as possible as well. 
In cases where information is not complete or cannot be guaranteed to be correct, we should allow SRC to indicate it: maybe  we should add a parameter called: "Metadata Certainty"?

Leon

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Elwell, John
Sent: Friday, February 11, 2011 4:29 PM
To: Paul Kyzivat; [email-masked]
Subject: Re: [siprec] metadata model for participant that is not part of CS

John

> Subject: Re: [siprec] metadata model for participant that is not part 
> of CS
> 
> Charles,
> 
> everything the SRC specifies is guaranteed to be as complete as you 
> wish it to be. At the end of the day, the SRC will have to do what it 
> can, and some will be better at it than others. If the SRC you have 
> chosen isn't supplying the information it could have and wish it had, 
> then you can complain and request upgrades, or you can choose a 
> different product.
> 
> As long as we have sufficient expressiveness to describe things as you 
> wish for any given case then I think we are good. Lets ensure we can 
> at least do that.
> 
> BTW, this is exactly the sort of discussion I have been hoping we 
> would have over the model. I expected it would happen quite some time 
> ago. But better now than never.
> 
> 	Thanks,
> 	Paul
> 
> >>>> Subject: [siprec] metadata model for participant that is not part 
> >>>> of CS
> >>>>
> >>>> streams to be defined without any participant. I now understand 
> >>>> that is not
> > the
> >>>> associated with the CS.
> >>>> Now I have some concern about participants that are not part of 
> >>>> the CS.

---

From: "Elwell, John" <[email-masked]>
Date: Mon, 14 Feb 2011 08:36:01 +0100

Or we could have values "unknown" for certain things. 

John (as individual)

> From: Leon Portman [mailto:[email-masked]] 
> Sent: 13 February 2011 22:40
> To: Elwell, John; Paul Kyzivat; [email-masked]
> Subject: RE: [siprec] metadata model for participant that is 
> not part of CS
> 
> Hello,
> 
> I agree with Paul statement that SRC should provide best 
> effort to report complete metadata as possible. And we should 
> model it as complete as possible as well. 
> In cases where information is not complete or cannot be 
> guaranteed to be correct, we should allow SRC to indicate it: 
> maybe  we should add a parameter called: "Metadata Certainty"?
> 
> Leon
> 
> 
> [mailto:[email-masked]] On Behalf Of Elwell, John
> I realise I was directly addressed earlier in this thread and 
> I didn't reply (it was left sitting in my inbox).
> 
> I don't have anything further to add - I see both sides of 
> the argument. Paul/Ram are looking for sufficient 
> expressiveness to cover a wide range of situations, even 
> though in many cases information available will be limited. 
> Charles is concerned, I think, with it being misleading in 
> some cases where limited information is available. So perhaps 
> we need other opinions in order to close on this one.
> 
> John
> 
> [mailto:[email-masked]] On 
> > >>> Behalf Of Elwell, John

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Mon, 14 Feb 2011 11:25:44 -0800

I am ok with this best effort handling as in reality that is always the
case anyway. If we show two use cases, one with highly functionality and
cooperative participants and another with lower functioning
participants, and illustrate the resulting meta data population, I think
that will address my concerns.
For example:

1) Participant A within a CS conferences in another party that is not a
part of the CS via internal 3rd party conference feature. Participant A
does not provide any SIP signaling regarding this toward the SRS. What
is the resulting metadata?

2) MCU is used to host a multiparty conference that is part of a CS.
What is the resulting metadata at the SRS if the MCU supports the
conferencing package? How do things look if it does not.

Perhaps (1) is just a special case of (2), but I think going through the
metadata example will help determine that. 

Cheers,
Charles

Behalf Of Elwell, John
> Sent: Sunday, February 13, 2011 11:36 PM
> To: Leon Portman; Paul Kyzivat (pkyzivat); [email-masked]
of CS
> > > >>> Subject: Re: [siprec] metadata model for participant that is
not