Subject: [siprec] Requirements #66 (new): Clarification of REQ-018 on indications to participants

From: "siprec issue tracker" <[email-masked]>
Date: Tue, 15 Feb 2011 08:24:09 -0000

#66: Clarification of REQ-018 on indications to participants

 REQ-018 can be satisfied in general by playing media to participants, but
 do we need a more specific requirement, e.g., for siprec-aware UAs to know
 whether the CS is being recorded or not?

 John

-- 
------------------------------------------------+---------------------------
 Reporter:  john.elwell@…                       |       Owner:  leon.portman@…       
     Type:  defect                              |      Status:  new                  
 Priority:  major                               |   Milestone:                       
Component:  Requirements                        |     Version:                       
 Severity:  In WG Last Call                     |    Keywords:                       
------------------------------------------------+---------------------------

Ticket URL: <https://trac.tools.ietf.org/wg/siprec/trac/ticket/66>
siprec <http://tools.ietf.org/siprec/>

---

From: Leon Portman <[email-masked]>
Date: Wed, 23 Feb 2011 19:25:05 +0200

Because supporting of siprec-aware UA indication will require some additional protocol changes for CS, we probably should have a separate requirement for that

Leon

-----Original Message-----
From: siprec issue tracker [mailto:[email-masked]] 
Sent: Tuesday, February 15, 2011 10:24 AM
To: Leon Portman; [email-masked]
Cc: [email-masked]
Subject: [siprec] Requirements #66 (new): Clarification of REQ-018 on indications to participants

 REQ-018 can be satisfied in general by playing media to participants, but  do we need a more specific requirement, e.g., for siprec-aware UAs to know  whether the CS is being recorded or not?

 John

-- 
------------------------------------------------+-----------------------
------------------------------------------------+----
 Reporter:  john.elwell@…                       |       Owner:  leon.portman@…       
     Type:  defect                              |      Status:  new                  
 Priority:  major                               |   Milestone:                       
Component:  Requirements                        |     Version:                       
 Severity:  In WG Last Call                     |    Keywords:                       
------------------------------------------------+-----------------------
------------------------------------------------+----

---

From: "Elwell, John" <[email-masked]>
Date: Wed, 23 Feb 2011 21:36:24 +0100

My feeling too.

John (as individual) 

> From: Leon Portman [mailto:[email-masked]] 
> Sent: 23 February 2011 17:25
> To: siprec issue tracker; Elwell, John
> Cc: [email-masked]
> Subject: RE: [siprec] Requirements #66 (new): Clarification 
> of REQ-018 on indications to participants
> 
> Because supporting of siprec-aware UA indication will require 
> some additional protocol changes for CS, we probably should 
> have a separate requirement for that
> 
> Leon
> 
>  REQ-018 can be satisfied in general by playing media to 
> participants, but  do we need a more specific requirement, 
> e.g., for siprec-aware UAs to know  whether the CS is being 
> recorded or not?
> 
>  John
> 
> -- 
>  Reporter:  john.elwell@...                       |       
> Owner:  leon.portman@...       
>      Type:  defect                              |      
> Status:  new                  
>  Priority:  major                               |   
> Milestone:

---

From: "Elwell, John" <[email-masked]>
Date: Mon, 28 Feb 2011 16:35:24 +0100

There has been little discussion on this, apart from support from Leon. The existing text says:
"REQ-018 The mechanism MUST provide a means of indicating to the
   participants involved in a CS that their session is being recorded.

   Examples include: inject tones into the CS from the SRC, play a
   message at the beginning of a session, a visual indicator on a
   display, etc."

I would suggest the following text:
"REQ-018 The mechanism MUST provide a means of indicating to the participants involved in a CS that their session is being recorded. Although this can be accomplished using existing SIP techniques for playing an in-band tone, announcement or other media to participants, the mechanism is required also to provide an indication to recording-aware UAs for appropriate rendering at the user interface."

John (as individual) 

> From: Elwell, John 
> Sent: 23 February 2011 20:36
> To: 'Leon Portman'; siprec issue tracker
> Cc: [email-masked]

---

From: Leon Portman <[email-masked]>
Date: Mon, 28 Feb 2011 18:16:49 +0200

+1

Leon

-----Original Message-----
From: Elwell, John [mailto:[email-masked]] 
Sent: Monday, February 28, 2011 5:35 PM
To: Leon Portman; siprec issue tracker
Cc: [email-masked]
Subject: RE: [siprec] Requirements #66 (new): Clarification of REQ-018 on indications to participants

John (as individual) 

> Subject: RE: [siprec] Requirements #66 (new): Clarification of REQ-018 
> on indications to participants
> 
> My feeling too.
> 
> John (as individual)
> 
> > Subject: RE: [siprec] Requirements #66 (new): Clarification of 
> > REQ-018 on indications to participants
> > 
> > Because supporting of siprec-aware UA indication will require some 
> > additional protocol changes for CS, we probably should have a 
> > separate requirement for that
> > 
> > Leon
> > 
> > participants, but  do we need a more specific requirement, e.g., for 
> > siprec-aware UAs to know  whether the CS is being recorded or not?
> > 
> >  John
> > 
> > --