Subject: [siprec] Matters needing further discussion

From: "Elwell, John" <[email-masked]>
Date: Thu, 4 Aug 2011 11:32:54 +0200

The following issues discussed in Quebec need further list discussion.

Metadata:
- How to model and format associations between Participants and CSs, including times, and likewise between Media Streams and Participants.
- How to format Contact header field parameters in XML.
- How to deal with a Participant identifier marked as private.
- Whether to identify the source of a Participant identifier (From or PAI).
- Format of unique identifiers (text needed, probably based on option 3 proposed by Paul).

Protocol:
- Initiation of RS from SRS to SRC (John/Andy to provide a more concrete proposal).

RTP:
- I think this probably first needs a revision from Charles.

John

John Elwell
Tel: +44 1908 817801 (office and mobile)
Email: [email-masked]
http://www.siemens-enterprise.com/uk/

Siemens Enterprise Communications Limited.
Registered office: Brickhill Street, Willen Lake, Milton Keynes, MK15 0DJ.
Registered No: 5903714, England.

Siemens Enterprise Communications Limited is a Trademark Licensee of Siemens AG.

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 04 Aug 2011 11:02:01 -0400

> - Whether to identify the source of a Participant identifier (From or PAI).

I want to hear from others on whether this is important or not.
My default assumption is that we ought to provide a way to specify this. 
But I think we can still make it optional, for an SRC that doesn't want 
to provide it, as well as for participants whose identity is learned in 
some other way than via a sip header.

If so, then the question is: HOW?

I see a couple of approaches for use in xml:

- an explicit enumeration type covering all the known headers
   that could be the source

- a simple string element or attribute that is to contain the string
   form of the header name from which the value was obtained.

I'm reluctant to go with the enumeration, because it isn't conveniently 
extensible. So, while I am not especially fond of including the actual 
header name string, I'm inclined to propose that we do so as the lesser 
of evils.

	Thanks,
	Paul