Subject: [siprec] SRC decomposition figures in SIPREC architecture doc[FW: [rtcweb] Use cases - recording and voicemail]

From: "Ravindran Parthasarathi" <[email-masked]>
Date: Tue, 23 Aug 2011 00:16:51 +0530

FYI...

RTCWeb is an one another example where SRC/SRS decomposition
architecture has to be explained in detail. As Andy mentioned below, it
is better to add more SRC/SRS decomposition figure for future reference.

Thanks
Partha

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Hutton, Andrew
Sent: Monday, August 22, 2011 2:56 PM
To: Harald Alvestrand
Cc: [email-masked]
Subject: Re: [rtcweb] Use cases - recording and voicemail

> 
> RTCWEB doesn't seem to going in the direction of mandating SIP, but
> still, I would think that it is reasonable to say something along the
> lines of "the remote recording case is handled by connecting to a
> SIPREC-capable recorder" (with the usual degree of gatewaying help
from
> our signaling proxies).
[AndyH] - I agree this would just seem to be another example of how the
Session Recording Client can be decomposed and is similar to Figure 4 in
the SIPREC architecture draft
(http://tools.ietf.org/html/draft-ietf-siprec-architecture-02#section-3.
1.2) but in the case of RTCWEB the media server is the browser and the
application is the web server and of course RTCWEB will not use
mediactrl. I have been resisting attempts to add more diagrams to the
SIPREC architecture draft to show the multitude of ways the SRC and SRS
could be decomposed but maybe RTCWEB is a good reason to do this.

> That will, of course, require that the SIPREC recorder is capable of
> participiating in an RTCWEB session (that is, support ICE and the
> mandatory codecs), that the RTCWEB implementation be capable of
copying
> incoming media streams to an outgoing interface, and that negotiation
> can down-negotiate to something that is supported by both call
> participants and the recording device. Does SIPREC envision
> establishing
> minimum requirements for codec's and profiles?

[AndyH] - No the SIPREC requirements
(http://tools.ietf.org/html/rfc6341) don't include minimum codec
requirements.

> 
> Once we can satisfy ourselves that we have all the pieces required to
> send media off to a remote API, we should see if we can do something
> very similar for sending media off to some kind of local recorder; it
> seems less likely that we'll get into trouble with locking ourselves
> into a wrong model if we do things in that order.
> 
> My $0.02.
> 
>                Harald
> 
> 
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb
_______________________________________________
rtcweb mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/rtcweb

---

From: Leon Portman <[email-masked]>
Date: Tue, 23 Aug 2011 09:10:22 +0300

Partha Hi

I will prepare and propose some drawing to demonstrate such decomposition.

Leon

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Ravindran Parthasarathi
Sent: Monday, August 22, 2011 9:47 PM
To: [email-masked]
Subject: [siprec] SRC decomposition figures in SIPREC architecture doc[FW: [rtcweb] Use cases - recording and voicemail]

FYI...

RTCWeb is an one another example where SRC/SRS decomposition architecture has to be explained in detail. As Andy mentioned below, it is better to add more SRC/SRS decomposition figure for future reference.

Thanks
Partha

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Hutton, Andrew
Sent: Monday, August 22, 2011 2:56 PM
To: Harald Alvestrand
Cc: [email-masked]
Subject: Re: [rtcweb] Use cases - recording and voicemail

from
> our signaling proxies).
[AndyH] - I agree this would just seem to be another example of how the Session Recording Client can be decomposed and is similar to Figure 4 in the SIPREC architecture draft (http://tools.ietf.org/html/draft-ietf-siprec-architecture-02#section-3.
1.2) but in the case of RTCWEB the media server is the browser and the application is the web server and of course RTCWEB will not use mediactrl. I have been resisting attempts to add more diagrams to the SIPREC architecture draft to show the multitude of ways the SRC and SRS could be decomposed but maybe RTCWEB is a good reason to do this.

copying
> establishing minimum requirements for codec's and profiles?

[AndyH] - No the SIPREC requirements
(http://tools.ietf.org/html/rfc6341) don't include minimum codec requirements.

_______________________________________________
rtcweb mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/rtcweb
_______________________________________________
siprec mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/siprec