Subject: [siprec] Metadata schema - missing group element in element recording

From: Ofir Roth <[email-masked]>
Date: Wed, 10 Aug 2011 13:59:51 +0300

Hi,

My name is Ofir and I am a software developer in NICE Systems.
I have reviewed the XML schema defining the metadata (http://datatracker.ietf.org/doc/draft-ietf-siprec-metadata/?include_text=1) and noticed that "group" element is missing from the sequence of "recording" element. It is defined as a standalone element but should also be embedded in the recording element.

<xs:complexType name="recording">
       <xs:sequence>
           <xs:element name="datamode" type="dataMode"
                minOccurs="0"/>
           <xs:element name="session" type="session"
                minOccurs="0" maxOccurs="unbounded"/>
           <xs:element name="participant" type="participant"
                minOccurs="0" maxOccurs="unbounded"/>
           <xs:element name="stream" type="stream"
               minOccurs="0" maxOccurs="unbounded"/>
         <xs:element name="extensiondata" type="extensiondata"
               minOccurs="0" maxOccurs="unbounded"/>
       </xs:sequence>
   </xs:complexType>

Please advise.

Thanks,
Ofir.

---

From: "Elwell, John" <[email-masked]>
Date: Thu, 18 Aug 2011 12:47:55 +0200

Ofir,

Yes, there certainly seems to be an issue here, because there doesn't seem to be any place in the schema that a group element can appear. According to the example in 7.1 it can appear in the recording element, as you suggest. So can the metadata authors please attend to this?

John

John Elwell
Tel: +44 1908 817801 (office and mobile)
Email: [email-masked]
http://www.siemens-enterprise.com/uk/

Siemens Enterprise Communications Limited.
Registered office: Brickhill Street, Willen Lake, Milton Keynes, MK15 0DJ.
Registered No: 5903714, England.

Siemens Enterprise Communications Limited is a Trademark Licensee of Siemens AG.

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Ofir Roth
> Sent: 10 August 2011 12:00
> To: [email-masked]
> Subject: [siprec] Metadata schema - missing group element in 
> element recording
> 
> Hi,
> 
>  
> 
> I have reviewed the XML schema defining the metadata 
> (http://datatracker.ietf.org/doc/draft-ietf-siprec-metadata/?i
> nclude_text=1) and noticed that "group" element is missing 
> from the sequence of "recording" element. It is defined as a 
> standalone element but should also be embedded in the 
> recording element.
> 
>  
>

---

From: "Ravindran Parthasarathi" <[email-masked]>
Date: Thu, 18 Aug 2011 17:05:38 +0530

Ofir/John,

Thanks for your comment. As you expect, XML schema has to be enhanced to
include group element in recording element. Metadata example is given
correctly but not XML schema. We will update in the next revision. 

Thanks
Partha

> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Elwell, John
> Sent: Thursday, August 18, 2011 4:18 PM
> To: Ofir Roth; [email-masked]
> Subject: Re: [siprec] Metadata schema - missing group element
inelement
> recording
> 
> Ofir,
> 
> Yes, there certainly seems to be an issue here, because there doesn't
> seem to be any place in the schema that a group element can appear.
> According to the example in 7.1 it can appear in the recording
element,
> as you suggest. So can the metadata authors please attend to this?
> 
> John
> 
> John Elwell
> _______________________________________________
> siprec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/siprec