Subject: [siprec] recordpref and record SDP attributes

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Wed, 22 Feb 2012 13:22:42 -0800

My assumption is that these SDP attributes, when used at the session or
media level, apply to the media as stated by the media mode attribute,
meaning that if the mode is "sendrecv", recordpref=on is a request to
record both the media being sent to as well as the media being received
by the requestor. Similarly for record=on.
Is that correct?

Thanks,
Charles

---

From: "Ravindran, Parthasarathi" <[email-masked]>
Date: Thu, 23 Feb 2012 01:09:21 +0000

Hi Charles,

I got the same doubt by looking at your proposed usage in the another
mail thread. Till now, I'm seeing  recordpref attribute as an declarative 
SDP attribute wherein SRC comes to know whether media stream has to be 
recorded based on its policy. However, your proposal is to use this 
attribute for negotiation (offer/answer). The topology in my mind is 

           UA1 ----B2BUA (SRC) ----UA2

IMO, Recordpref offer/answer combination in B2BUA with UA1 as offerer and 
UA2 as answerer are as follows: 

UA1       UA2                  B2BUA/SRC
On        Off                     Off
Off       On                      Off
Off       Off                     Off
On        On		          On 
Empty     Off                     Off
Empty     On                      On
On	    Empty	                On
Off       Empty                   Off
Empty     Empty                   On   

The last row "On" indicates that both parties agrees for recording and it is
upto SRC to decide whether recording has to be done or not. Empty indicates the
absence of this attribute in SDP. Please correct me in case I misunderstand 
about this SDP attribute.

Thanks
Partha

>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]] On Behalf
>Of Charles Eckel (eckelcu)
>Sent: Thursday, February 23, 2012 2:53 AM
>To: [email-masked]
>Subject: [siprec] recordpref and record SDP attributes
>
>_______________________________________________
>siprec mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/siprec

---

From: "Hutton, Andrew" <[email-masked]>
Date: Thu, 23 Feb 2012 10:53:45 +0100

Hi Charles,

Actually the protocol draft states that these are media level attributes and says nothing about using them at the session level. I assume using them at the session level should be allowed so we would need to state this in the protocol draft.

My thinking is that your assumption is correct.

Regards
Andy

> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Charles Eckel (eckelcu)
> Sent: 22 February 2012 21:23
> To: [email-masked]

---

From: "Ravindran, Parthasarathi" <[email-masked]>
Date: Thu, 23 Feb 2012 10:08:10 +0000

Hi Andy,
 
Hope your mail is about only session level or media level recordpref query and not about the below snip.

<snip>
recordpref=on is a 
> request to record both the media being sent to as well as the media 
> being received by the requestor.
</snip>

As per the above statement, offerer in the CS always decide whether the call has to be recorded or not. Also, I could not think of the SDP parameter in the same line of understanding wherein controlling answerer using parameter. I have explained my understanding of the parameter at http://www.ietf.org/mail-archive/web/siprec/current/msg03080.html. Please correct me where I'm going wrong.

Thanks
Partha

>Of Hutton, Andrew
>Sent: Thursday, February 23, 2012 3:24 PM
>To: Charles Eckel (eckelcu); [email-masked]
>Subject: Re: [siprec] recordpref and record SDP attributes
>
>Hi Charles,
>
>Actually the protocol draft states that these are media level attributes
>and says nothing about using them at the session level. I assume using
>them at the session level should be allowed so we would need to state
>this in the protocol draft.
>
>> My assumption is that these SDP attributes, when used at the session
>> or media level, apply to the media as stated by the media mode
>> attribute, meaning that if the mode is "sendrecv", recordpref=on is a
>> request to record both the media being sent to as well as the media
>> being received by the requestor. Similarly for record=on.
>> Is that correct?
>>
>> Thanks,
>> Charles

---

From: "Hutton, Andrew" <[email-masked]>
Date: Thu, 23 Feb 2012 11:23:37 +0100

See below.

Regards
Andy

> From: Ravindran, Parthasarathi [mailto:[email-masked]]
> Sent: 23 February 2012 10:08
> To: Hutton, Andrew; Charles Eckel (eckelcu); [email-masked]
> Subject: RE: recordpref and record SDP attributes
> 
> Hi Andy,
> 

[AndyH] - I agree with this snip the recordpref=on is indicating a preference for the media to be recorded in both directions if it is a sendrecv stream.

> As per the above statement, offerer in the CS always decide whether the
> call has to be recorded or not. 

[AndyH - I don't think this is true the offerer and answerer have equal rights and in the end it is up to the SRC to decide depending on its local policy and I don't think we should say very much about that policy.

> Also, I could not think of the SDP
> parameter in the same line of understanding wherein controlling
> answerer using parameter. I have explained my understanding of the
> parameter at http://www.ietf.org/mail-
> archive/web/siprec/current/msg03080.html. Please correct me where I'm
> going wrong.
> 

[AndyH] Will respond to this mail separately.

> Behalf

---

From: "Ravindran, Parthasarathi" <[email-masked]>
Date: Thu, 23 Feb 2012 11:12:27 +0000

Hi Andy,

Please read inline.

Thanks
Partha

>From: Hutton, Andrew [mailto:[email-masked]]
>Sent: Thursday, February 23, 2012 3:54 PM
>To: Ravindran, Parthasarathi; Charles Eckel (eckelcu); [email-masked]
>[AndyH] - I agree with this snip the recordpref=on is indicating a
>preference for the media to be recorded in both directions if it is a
>sendrecv stream.
>
>
>> As per the above statement, offerer in the CS always decide whether
>> the call has to be recorded or not.
>
>[AndyH - I don't think this is true the offerer and answerer have equal
>rights and in the end it is up to the SRC to decide depending on its
>local policy and I don't think we should say very much about that
>policy.
>
<partha> I agree with SRC policy part. Assume, SRC has the policy to record
and in case recordpref=on send by offerer and answerer mention as recordpref=off,
Please let me know the expected behavior. Also, I'll wait for your another 
Mail for below discussion </partha>

>> >and says nothing about using them at the session level. I assume
>> >using them at the session level should be allowed so we would need to
>> >state this in the protocol draft.
>> >
>> >> My assumption is that these SDP attributes, when used at the
>> >> session or media level, apply to the media as stated by the media
>> >> mode attribute, meaning that if the mode is "sendrecv",
>> >> recordpref=on is
>> a

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 23 Feb 2012 11:48:42 -0500

IMO media level attributes should in general also be valid at session 
level, as a default for media that don't specify a value explicitly. But 
the way SDP is defined this needs to be specified explicitly for each 
newly defined attribute. So yes, language to this effect should be included.

	Thanks,
	Paul

---

From: "Hutton, Andrew" <[email-masked]>
Date: Thu, 23 Feb 2012 18:09:39 +0100

> Mail for below discussion </partha>

The resulting behavior I believe depends on SRC policy which we don't define. 

This I think is what is implied in section 10.2.2 of the siprec-protocol draft which states:

"When the SRC receives the a=recordpref SDP in an SDP offer or answer, the SRC MAY choose to honor such request to record the request based on local policy on the SRC".

Regards
Andy

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Thu, 23 Feb 2012 12:48:48 -0800

Hi Partha,

I understand both "record" and "recordpref" to be declarative
attributes.
The combinations you describe are what I consider to be policy decisions
at the B2BUA/SRC. As such, I think there are just fine.

Cheers,
Charles

> Sent: Wednesday, February 22, 2012 5:09 PM
> or

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Fri, 24 Feb 2012 14:18:45 -0800

Hi Henry,

The record and recordpref attributes may be used in the CS and RS. I am
not suggesting tying them together or requiring them to be related to
each other in any particular fashion. What I was hoping to clarify is if
when a UA adds a recordpref=on attribute to a sendrecv media stream,
that means that UA prefers that both the media it is sending as well as
the media it is receiving be recorded. What the SRC decides to do and it
related to the media streams between the SRC and the SRS is up to the
SRC.

Cheers,
Charles

> From: Henry Lum [mailto:[email-masked]]
> Sent: Friday, February 24, 2012 8:30 AM
> Subject: RE: [siprec] recordpref and record SDP attributes
> 
> I realized my message was sent by wasn't posted for some reason -
> reposting.
> 
> The attributes recordpref and record only declares whether you want to
> record and whether recording is happening at the session or media
> level.
> The attributes do not indicate or imply the directionality of the
> recording that is happening. The SRC may choose to mix multiple
streams
> in the session to record and I don't see an elegant way for the SRC to
> present that level of detail. Is there a specific reason for needing
> this level of detail?
> 
> Henry
> 
> > Sent: February-22-12 4:23 PM
> > To: [email-masked]