Subject: [siprec] Status of draft-ietf-siprec-architecture

From: "Hutton, Andrew" <[email-masked]>
Date: Wed, 27 Jun 2012 22:59:57 +0000

Hi All,

Following the previous WGLC and the resulting update to draft-ietf-siprec-architecture I believe that only one issue has been raised on the list.

This was raised by Partha and related to the text in section 3.2.2 which provides an overview of the procedures relating to SRS initiated recording. One of the bullets currently states:

"Identify the session that is to be recorded.  The actual mechanism of the identification depends on SRC policy".

As I understand it the issue with this is that it appears to close the door to any future protocol extensions for identifying the communication session to be recorded in this SRS initiated case.  I think Partha would prefer wording that leaves open the possibility of creating a new SIPREC related draft that defines such a mechanism.

Any comments, views or suggested text?

Regards
Andy (SIPREC Co-Chair).

---

From: Leon Portman <[email-masked]>
Date: Thu, 28 Jun 2012 09:15:18 +0300

May be something like this:

" Identify the session that is to be recorded.  The actual mechanism of the identification can be dependent on SRC policy or be defined by future SIPREC extensions"

Leon

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Hutton, Andrew
Sent: Thursday, June 28, 2012 2:00 AM
To: [email-masked]
Subject: [siprec] Status of draft-ietf-siprec-architecture

Hi All,

Regards
Andy (SIPREC Co-Chair).
_______________________________________________
siprec mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/siprec

---

From: "Ravindran, Parthasarathi" <[email-masked]>
Date: Thu, 28 Jun 2012 08:15:53 +0000

Andy/Leon,

I agree with the proposed text.

Thanks
Partha

>From: [email-masked] [mailto:[email-masked]] On Behalf
>Of Leon Portman
>Sent: Thursday, June 28, 2012 11:45 AM
>To: Hutton, Andrew; [email-masked]
>Subject: Re: [siprec] Status of draft-ietf-siprec-architecture
>
>" Identify the session that is to be recorded.  The actual mechanism of
>the identification can be dependent on SRC policy or be defined by
>future SIPREC extensions"
>
>Leon
>
>Following the previous WGLC and the resulting update to draft-ietf-
>siprec-architecture I believe that only one issue has been raised on the
>list.
>
>This was raised by Partha and related to the text in section 3.2.2 which
>provides an overview of the procedures relating to SRS initiated
>recording. One of the bullets currently states:
>
>"Identify the session that is to be recorded.  The actual mechanism of
>the identification depends on SRC policy".
>
>As I understand it the issue with this is that it appears to close the
>door to any future protocol extensions for identifying the communication
>session to be recorded in this SRS initiated case.  I think Partha would
>prefer wording that leaves open the possibility of creating a new SIPREC
>related draft that defines such a mechanism.
>

---

From: "Ram Mohan R (rmohanr)" <[email-masked]>
Date: Thu, 28 Jun 2012 09:28:35 +0000

My take on this is to say simply that the mechanism to identify a session
is outside the scope of current work. If we start to include text on some
methods to identify a session and leave out other means it would lead to
confusion.

Regards,
Ram

> On 28/06/12 11:45 AM, "Leon Portman" <[email-masked]> wrote:

>the identification can be dependent on SRC policy or be defined by future
>SIPREC extensions"
>
>Leon
>
>Of Hutton, Andrew
>Following the previous WGLC and the resulting update to
>draft-ietf-siprec-architecture I believe that only one issue has been
>raised on the list.
>

---

From: Leon Portman <[email-masked]>
Date: Thu, 28 Jun 2012 13:03:32 +0300

Also good option

-----Original Message-----
From: Ram Mohan R (rmohanr) [mailto:[email-masked]] 
Sent: Thursday, June 28, 2012 12:29 PM
To: Leon Portman; Hutton, Andrew; [email-masked]
Subject: Re: [siprec] Status of draft-ietf-siprec-architecture

My take on this is to say simply that the mechanism to identify a session is outside the scope of current work. If we start to include text on some methods to identify a session and leave out other means it would lead to confusion.

Regards,
Ram

>This was raised by Partha and related to the text in section 3.2.2 
>which provides an overview of the procedures relating to SRS initiated 
>door to any future protocol extensions for identifying the 
>communication session to be recorded in this SRS initiated case.  I 
>think Partha would prefer wording that leaves open the possibility of 
>creating a new SIPREC related draft that defines such a mechanism.
>

---

From: "Hutton, Andrew" <[email-masked]>
Date: Thu, 28 Jun 2012 17:34:44 +0000

Hi,

Personally I think I would prefer Leon's text as I don't believe that specifying such a mechanism is really out of scope of the charter it is just that we decided not to do it present. 

We don't really want to have to update the architecture draft again at some later date if such a mechanism is defined do we?

Regards
Andy

> From: Leon Portman [mailto:[email-masked]]
> Sent: 28 June 2012 06:04
> To: Ram Mohan R (rmohanr); Hutton, Andrew; [email-masked]
> Subject: RE: [siprec] Status of draft-ietf-siprec-architecture
> 
> Also good option
> 
> My take on this is to say simply that the mechanism to identify a
> session is outside the scope of current work. If we start to include
> text on some methods to identify a session and leave out other means it
> would lead to confusion.
> 
> Regards,
> Ram
>

---

From: "Ram Mohan R (rmohanr)" <[email-masked]>
Date: Fri, 29 Jun 2012 02:55:44 +0000

Sounds fine to me Andy.

Ram
> On 28/06/12 11:04 PM, "Hutton, Andrew"
><[email-masked]> wrote:

>Hi,
>
>Personally I think I would prefer Leon's text as I don't believe that
>specifying such a mechanism is really out of scope of the charter it is
>just that we decided not to do it present.
>
>We don't really want to have to update the architecture draft again at
>some later date if such a mechanism is defined do we?
>
>Regards
>Andy
>
>