Subject: [siprec] INSIPID Discussion on scope of session identifies, 3PCC etc.

From: "Hutton, Andrew" <[email-masked]>
Date: Tue, 7 Aug 2012 13:10:35 +0000

Hi All,

Have you seen the discussion in the INSIPID WG regarding the scope of this WG and the use cases for generating and end to end session identifier if not have a look at http://www.ietf.org/mail-archive/web/insipid/current/msg00255.html.

I am interested in the opinions of the SIPREC WG members on the following questions.

1. Does SIPREC still need such an end to end session identifier and if so how would we use it in the current metadata model as the communication session identifier or something else?
2. If SIPREC does need such an identifier is it important that the 3PCC case is covered so for example when an SRC is the 3rd party controller that such an end to end session identifier is generated?
3. If INSIPID cannot create such an identifier for the communication session do we need to create a communication session identifier for use in SIPREC?

Regards
Andy (SIPREC Co-Chair).

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Wed, 8 Aug 2012 03:57:57 +0000

I see two places in which the INSIPID work could apply to SIPREC.
1) if the SRC relies on inclusion of the INSIPID Session-ID as the actual identifier in the SIPREC metadata it send to the SRS to enable the SRS to correlate multiple RSs for the same CS, or for CSs for the same INSIPID session ID.
2) if the SRC uses the INSIPID Session-ID to help it determine when multiple CSs are in fact related to each other (i.e. corresponding to the same INSIPID Session-ID).

(1) could result in INSIPID being required for SIPREC.
(2) could result in INSIPID being valuable for SIPREC.

I do not think we have, or should, mandate (1) as it adds an unnecessary dependency for INSIPID within SIPREC.

Cheers,
Charles 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Hutton, Andrew
> Sent: Tuesday, August 07, 2012 6:11 AM
> To: [email-masked]
> Subject: [siprec] INSIPID Discussion on scope of session identifies, 3PCC etc.
> 
> Hi All,
> 
> Have you seen the discussion in the INSIPID WG regarding the scope of this
> WG and the use cases for generating and end to end session identifier if not
> have a look at http://www.ietf.org/mail-
> archive/web/insipid/current/msg00255.html.
> 
> 1. Does SIPREC still need such an end to end session identifier and if so how
> would we use it in the current metadata model as the communication
> session identifier or something else?
> 2. If SIPREC does need such an identifier is it important that the 3PCC case is
> covered so for example when an SRC is the 3rd party controller that such an
> end to end session identifier is generated?
> 3. If INSIPID cannot create such an identifier for the communication session
> do we need to create a communication session identifier for use in SIPREC?
> 
> Regards
> Andy (SIPREC Co-Chair).
> 
> _______________________________________________
> siprec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/siprec

---

From: "Hutton, Andrew" <[email-masked]>
Date: Wed, 8 Aug 2012 12:16:48 +0000

Hi Charles,

I agree we should not have any dependency on INSIPID so relying on the INSIPID Session-ID as the actions communication session identifier does not look like a good idea.

However I though the main use of the INSIPID Session-ID in SIPREC was for the SRS to be able to determine that it is receiving media relating to the same CS from different SRC's.  Again this would result in the INSIPID being valuable for SIPREC but no dependency but if this was the case we may want to specify where it appears in the metadata.

Regards
Andy 

> From: Charles Eckel (eckelcu) [mailto:[email-masked]]
> Sent: 08 August 2012 04:58
> To: Hutton, Andrew; [email-masked]
> Subject: RE: [siprec] INSIPID Discussion on scope of session
> identifies, 3PCC etc.
> 
> 1) if the SRC relies on inclusion of the INSIPID Session-ID as the
> actual identifier in the SIPREC metadata it send to the SRS to enable
> the SRS to correlate multiple RSs for the same CS, or for CSs for the
> same INSIPID session ID.
> 2) if the SRC uses the INSIPID Session-ID to help it determine when
> multiple CSs are in fact related to each other (i.e. corresponding to
> the same INSIPID Session-ID).
> 
> I do not think we have, or should, mandate (1) as it adds an
> unnecessary dependency for INSIPID within SIPREC.
> 
> Cheers,
> Charles
> 
> > I am interested in the opinions of the SIPREC WG members on the
> following
> > questions.
> >

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 08 Aug 2012 07:05:57 -0700

> However I though the main use of the INSIPID Session-ID in SIPREC was for the SRS to be able to determine that it is receiving media relating to the same CS from different SRC's.  Again this would…

Ideally we would provide an optional attribute in the metadata for this.
But the timing might prevent us from doing that. I expect that we will 
be publishing our metadata draft before insipid has finalized what it is 
going to do. So we may have to leave that as an extension.

(AFAIK it should even be possible to publish an extension to our 
metadata as part of the draft that comes out of INSIPID.)

	Thanks,
	Paul

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Wed, 8 Aug 2012 20:48:31 +0000

Works for me.

Thanks,
Charles

> Of Paul Kyzivat
> Sent: Wednesday, August 08, 2012 7:06 AM
> To: [email-masked]
> Subject: Re: [siprec] INSIPID Discussion on scope of session identifies, 3PCC
> etc.
> 
> > I agree we should not have any dependency on INSIPID so relying on the
> INSIPID Session-ID as the actions communication session identifier does not
> look like a good idea.
> >
> > However I though the main use of the INSIPID Session-ID in SIPREC was for
> the SRS to be able to determine that it is receiving media relating to the
> same CS from different SRC's.  Again this would result in the INSIPID being
> valuable for SIPREC but no dependency but if this was the case we may want
> to specify where it appears in the metadata.
>

---

From: "Ram Mohan R (rmohanr)" <[email-masked]>
Date: Thu, 9 Aug 2012 06:37:12 +0000

> On 08/08/12 7:35 PM, "Paul Kyzivat" <[email-masked]> wrote:

>>INSIPID Session-ID as the actions communication session identifier does
>>not look like a good idea.
>>
>> However I though the main use of the INSIPID Session-ID in SIPREC was
>>for the SRS to be able to determine that it is receiving media relating
>>to the same CS from different SRC's.  Again this would result in the
>>INSIPID being valuable for SIPREC but no dependency but if this was the
>>case we may want to specify where it appears in the metadata.
>

I also agree with this. We can leave it as extension data for now

Regards,
Ram