Subject: [siprec] Metadata draft - Communication Session Participants.

From: "Hutton, Andrew" <[email-masked]>
Date: Tue, 8 Jan 2013 18:29:52 +0000

Hi,

Just reading through draft-ietf-siprec-metadata-10 and I noticed that section 6.3.2 which related to CS linkages states "CS to have atleast zero or more participants" and I am not sure I understand this.

The architecture draft defines a CS as "A session created between two or more SIP User Agents (UAs) that is the subject of recording" 

I can imagine that a conference focus acting as a SRC could create a CS for a meet-me conference before any participants join the conference and therefore it would have zero participants is this the type of scenario the metadata draft refers to or is it something else and how does this relate to our definition of a CS?

More comments on the metadata draft will follow soon.

Regards
Andy

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Tue, 8 Jan 2013 19:26:24 +0000

Hi Andy,

Your example is a good one in my opinion. Another example would be the same conference once all the participants dropped but before the conference ends.

Cheers,
Charles

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Hutton, Andrew
> Sent: Tuesday, January 08, 2013 10:30 AM
> To: [email-masked]
> Subject: [siprec] Metadata draft - Communication Session Participants.
> 
> Hi,
> 
> Just reading through draft-ietf-siprec-metadata-10 and I noticed that section
> 6.3.2 which related to CS linkages states "CS to have atleast zero or more
> participants" and I am not sure I understand this.
> 
> The architecture draft defines a CS as "A session created between two or
> more SIP User Agents (UAs) that is the subject of recording"
> 
> I can imagine that a conference focus acting as a SRC could create a CS for a
> meet-me conference before any participants join the conference and
> therefore it would have zero participants is this the type of scenario the
> metadata draft refers to or is it something else and how does this relate to
> our definition of a CS?
> 
> _______________________________________________
> siprec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/siprec

---

From: "Hutton, Andrew" <[email-masked]>
Date: Tue, 8 Jan 2013 19:44:45 +0000

Ok so I am thinking that our definition of communication session in the draft-ietf-siprec-architecture does not match our usage in the metadata draft.

In the architecture we define a CS as: "A session created between two or more SIP User Agents (UAs) that is the subject of recording".  

Maybe we could do with something a bit more arbitrary which allows the session to be independent of the SIP Session.

What do people think do we need to change the definition of a CS in the architecture draft?

Regards
Andy

> From: Charles Eckel (eckelcu) [mailto:[email-masked]]
> Sent: 08 January 2013 19:26
> To: Hutton, Andrew; [email-masked]
> Subject: RE: Metadata draft - Communication Session Participants.
> 
> Hi Andy,
> 
> Your example is a good one in my opinion. Another example would be the
> same conference once all the participants dropped but before the
> conference ends.
> 
> Cheers,
> Charles
>

---

From: "Parthasarathi R" <[email-masked]>
Date: Wed, 9 Jan 2013 22:04:06 +0530

Andy,

Metadata draft CS definition is changed as per IETF 82 minutes
(http://www.ietf.org/proceedings/82/minutes/siprec.txt) and the exact
minutes is as follows:

"Issue 3
Any objections to allow a CS to have zero or more participants ?
Already discussed on list, --> Accepted."

I agree with you that SIPREC architecture has to be updated to make it
inline
With IETF82 decision but CS has to be SIP session. The reason for CS as SIP 
Session is that non SIP-session like H.323/WebRTC session will create more 
Complexity in SIPREC solution. 

Thanks
Partha

> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Hutton, Andrew
> Sent: Wednesday, January 09, 2013 1:15 AM
> To: Charles Eckel (eckelcu); [email-masked]
> Subject: Re: [siprec] Metadata draft - Communication Session
> Participants.
> 
> Ok so I am thinking that our definition of communication session in the
> draft-ietf-siprec-architecture does not match our usage in the metadata
> draft.
> 
> In the architecture we define a CS as: "A session created between two
> or more SIP User Agents (UAs) that is the subject of recording".
> 
> Maybe we could do with something a bit more arbitrary which allows the
> session to be independent of the SIP Session.
> 
> > > Just reading through draft-ietf-siprec-metadata-10 and I noticed
> that
> > section
> > > 6.3.2 which related to CS linkages states "CS to have atleast zero
> or
> > more
> > > The architecture draft defines a CS as "A session created between
> two
> > or
> > > I can imagine that a conference focus acting as a SRC could create
> a
> > CS for a

---

From: "Hutton, Andrew" <[email-masked]>
Date: Thu, 10 Jan 2013 11:01:09 +0000

Hi Partha,

Thanks for pointing this out I have no problem with the metadata definition.

Regarding the definition of a CS in the architecture draft the current text states:

"Communication Session (CS):  A session created between two or more SIP User Agents (UAs) that is the subject of recording".

I am not sure we really need to change this just because the metadata specification allows the communication session object to be created before the real SIP session is created. Could we not just add some explanation to the metadata draft.

Regards
Andy

> From: Parthasarathi R [mailto:[email-masked]]
> Sent: 09 January 2013 16:34
> To: Hutton, Andrew; 'Charles Eckel (eckelcu)'; [email-masked]
> Subject: RE: [siprec] Metadata draft - Communication Session
> Participants.
> 
> Andy,
> 
> > What do people think do we need to change the definition of a CS in
> the
> > architecture draft?
> >
> > Regards
> > Andy
> >
> >
> >
> > > Behalf
> > > > metadata draft refers to or is it something else and how does
> this
> > > relate to
> > > > our definition of a CS?
> > > >

---

From: "Parthasarathi R" <[email-masked]>
Date: Thu, 10 Jan 2013 23:26:22 +0530

Andy,

I'm fine with your approach of adding more explanation about Communication
session and its association with participants in the metadata draft itself.
The current architecture and metadata draft definition of communication
session is same for two or more participants. The information has to added
about zero and one participant associated with communication session. The
actual usecase is as follows:

1) Zero or One participant in CS is possible in case conference focus acts
as SRC and has only Zero or one participant is in the conference focus at
the given time. Here, conference focus is not considered as a participant of
the CS and also conference shall start without any participant.

2) Also, One Participant in CS is possible in case studio recorder acts as
SRC and forward RS to SRS. Here, studio recorder SRC is not considered as
participant of the CS.

Please let me know whether adding the above use case explanation as part of
CS to participant association linkage section will serve the purpose or you
wish to add some definition about CS to participant association.

Thanks
Partha

> From: Hutton, Andrew [mailto:[email-masked]]
> Sent: Thursday, January 10, 2013 4:31 PM
> To: Parthasarathi R; 'Charles Eckel (eckelcu)'; [email-masked]
> "Communication Session (CS):  A session created between two or more SIP
> User Agents (UAs) that is the subject of recording".
> 
> I am not sure we really need to change this just because the metadata
> specification allows the communication session object to be created
> before the real SIP session is created. Could we not just add some
> explanation to the metadata draft.
> 
> Regards
> Andy
> 
> 
> 
> > With IETF82 decision but CS has to be SIP session. The reason for CS
> as
> > SIP
> > > > Your example is a good one in my opinion. Another example would
> be
> > > the