Subject: [sixpac] SIP AOR/GRUU discovery for offline XMPP contacts.

From: Emil Ivov <[email-masked]>
Date: Thu, 10 Mar 2011 20:44:16 +0100

Hey folks,

I was wondering if we already had a position on how (and if) users would
be able to discover the SIP AOR of a jid they have in their roster and
that they are not currently seeing, or have never seen online.

Would it make sense to also allow uploading and retrieving that kind of
information within a vCard? Of course, if available, information in a
presence or a message stanza should always take precedence.

Cheers,
Emil

---

From: <[email-masked]>
Date: Fri, 11 Mar 2011 07:43:03 +0000

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of ext Emil Ivov
> Sent: 10 March, 2011 21:44
> To: SIXPAC
> Subject: [sixpac] SIP AOR/GRUU discovery for offline XMPP contacts.
> 
> Hey folks,
> 

This approach might be most straightforward. See http://xmpp.org/extensions/xep-0054.html which I believe will be superseded by http://xmpp.org/extensions/xep-0292.html

Simo
 
> Cheers,
> Emil
> _______________________________________________
> sixpac mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sixpac

---

From: Emil Ivov <[email-masked]>
Date: Fri, 11 Mar 2011 09:44:52 +0100

Hey Simo,

На 11.03.11 08:43, [email-masked] написа:
>> Would it make sense to also allow uploading and retrieving that
>> kind of information within a vCard? Of course, if available,
>> information in a presence or a message stanza should always take
>> precedence.
> 
> This approach might be most straightforward. See
> http://xmpp.org/extensions/xep-0054.html which I believe will be
> superseded by http://xmpp.org/extensions/xep-0292.html

Right, I was also thinking about them and I guess all that we need to do
is indicate the elements where the AOR/GRUU would need to be stored and
retrieved from.

Emil

---

From: Peter Saint-Andre <[email-masked]>
Date: Thu, 17 Mar 2011 13:07:20 -0600

> is indicate the elements where the AOR/GRUU would need to be stored and

Would we use the vCard4 IMPP property for this?

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: Emil Ivov <[email-masked]>
Date: Thu, 17 Mar 2011 21:07:08 +0100

> Would we use the vCard4 IMPP property for this?

Syntax-wise it looks right. Semantically RFC 4770 seems to be declaring
it as an IM or a presence address only.

So I am wondering if this could be source of confusion for non-sixpac
clients.

An example on page 2 seems to explicitly point that a SIP uri would be
used for SIMPLE chats and presence, and it is my understanding that most
sixpac clients would be unreachable this way.

Cheers,
Emil

---

From: Peter Saint-Andre <[email-masked]>
Date: Thu, 17 Mar 2011 14:46:37 -0600

> sixpac clients would be unreachable this way.

You have a point.

Perhaps the TEL property is appropriate, instead:

http://tools.ietf.org/html/draft-ietf-vcarddav-vcardrev-16#section-6.4.1

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: Emil Ivov <[email-masked]>
Date: Thu, 17 Mar 2011 23:13:35 +0100

> http://tools.ietf.org/html/draft-ietf-vcarddav-vcardrev-16#section-6.4.1

It seems to come with a "*" cardinality so how would one distinguish
between the sixpac SIP uri and the regular phones? Do we define a new
scheme?

Also, I am not sure how to read the following:

    It is expected that the URI scheme will be "tel", as
    specified in [RFC3966]

Does this mean that use with URI other than "tel" should be avoided?

Emil

---

From: Peter Saint-Andre <[email-masked]>
Date: Thu, 17 Mar 2011 17:38:52 -0600

> between the sixpac SIP uri and the regular phones? Do we define a new

Do you mean that we'd need a new URI scheme to identify sixpac-aware SIP
UAs? That seems unnecessary.

However, we could define a vcard extension for a special property.

> Does this mean that use with URI other than "tel" should be avoided?

I see no reason why a "sip" URI would be problematic, but we can ask the
vcard folks about that.

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: Emil Ivov <[email-masked]>
Date: Fri, 18 Mar 2011 00:47:18 +0100

На 18.03.11 00:38, Peter Saint-Andre написа:
> UAs? 

Nope, I was wondering if that's what you meant when you suggested using tel.

> That seems unnecessary.

+1

Cheers,
Emil