Subject: [Slim] Primary language tags (was "Re: draft-tomkinson comments")

From: Randall Gellens <[email-masked]>
Date: Sun, 1 Nov 2015 22:16:21 -0800

Extracting this one comment:

At 2:10 AM +0000 10/21/15, Addison Phillips wrote:

>  5. There is this recommendation:
>
>  --
>  While RFC 5646 provides a mechanism accommodating
>     increasingly fine-grained distinctions, in the interest of maximum
>     interoperability, each Content-Language value SHOULD be restricted to
>     the largest granularity of language tags; in other words, it is
>     RECOMMENDED to specify only a Primary-subtag and NOT to include
>     subtags (e.g., for region or dialect) unless the languages might be
>     mutually incomprehensible without them.
>  --
>
>  I think this text is potentially harmful, as it might interfere 
> with the needs of senders and clients to distinguish text based on 
> a variety of factors and ignores the fact that some language 
> variation is not mutually comprehensible at the primary language 
> level.

I am very confused.  The text explicitly says "unless the languages 
might be mutually incomprehensible without them" so how can you say 
that the text ignores cases where subtags are needed for mutual 
comprehensibility?

>
>  An implementation restriction to the primary language subtag would 
> be a disadvantage to languages that have important script, region, 
> or other variations such as extlang or variant. BCP 47 has a whole 
> section (http://tools.ietf.org/html/bcp47#section-4.1) about the 
> choice of language tag that basically recommends similar things and 
> I understand why it's important for senders not to add unnecessary 
> subtags. But I think you'd be better off not having quite so much 
> normative language in this specification and a more focused 
> recommendation that does not impinge on the needs of senders and 
> clients to provide adequate language information.

Please keep in mind that the text in question uses SHOULD and 
RECOMMENDED, not MUST.  That means that when there is a good reason 
to deviate, and the implications of deviating are well understood, it 
is acceptable and does not violate conformance.

I believe that the text in question does a good job of guiding 
implementations to maximally-interoperable behavior without forcing 
problematic behavior in those cases where subtags are needed.

-- 
Randall Gellens
Opinions are personal;    facts are suspect;    I speak for myself only
-------------- Randomly selected tag: ---------------
I'm not proud.... Our products just aren't engineered for security.
    --Brian Valentine, Senior Vice President, Microsoft Windows
    Development Team at the Microsoft 2002 .Net developer conference.

---

From: Gunnar Hellström <[email-masked]>
Date: Mon, 2 Nov 2015 08:12:38 +0100

Good reasoning, I agree with Randall that subtags should be included to 
the extent that it is important for distinguishing that the contents is 
suitable and understandable.

The same reasoning enable us to distinguish written from spoken language 
by using the Script subtag to indicate written, even if Suppress-Script 
is registered for the language tag.

RFC 5646 says about Script and Suppress-Script
"the script subtag SHOULD be omitted when it adds no distinguishing 
value to the tag or when the primary or extended language subtag's 
record in the subtag registry includes a 'Suppress-Script' field listing 
the applicable script subtag."

So, when it is clear from the context if the language tag represents 
written vs spoken language, then no Script subtag is needed, but if the 
tag is used in a place where it can be ambigous, then a tag without 
Script means spoken and a tag with Script means written.

Also where written is used in an unusual context, the Script subtag 
would be used to indicate that it is written. E.g. If captions are 
overlaid in video, a language tag for the video stream including the 
Script subtag would make the fact clear that that language is there in 
text form. ( as distinguished from seeing a person talking that language. )

/Gunnar

Den 2015-11-02 kl. 07:16, skrev Randall Gellens:
>>  I think this text is potentially harmful, as it might interfere with 
>> the needs of senders and clients to distinguish text based on a 
>> variety of factors and ignores the fact that some language variation 
>> is not mutually comprehensible at the primary language level.
>
>> be a disadvantage to languages that have important script, region, or 
>> other variations such as extlang or variant. BCP 47 has a whole 
>> choice of language tag that basically recommends similar things and I 
>> understand why it's important for senders not to add unnecessary 
> RECOMMENDED, not MUST.  That means that when there is a good reason to 
> deviate, and the implications of deviating are well understood, it is 
> acceptable and does not violate conformance.
>

---

From: Randall Gellens <[email-masked]>
Date: Mon, 2 Nov 2015 03:44:50 -0800

At 8:12 AM +0100 11/2/15, Gunnar Hellström wrote:

>  Good reasoning, I agree with Randall that 
> subtags should be included to the extent that 
> it is important for distinguishing that the 
> contents is suitable and understandable.
>
>  The same reasoning enable us to distinguish 
> written from spoken language by using the 
> Script subtag to indicate written, even if 
> Suppress-Script is registered for the language 
> tag.
>
>  "the script subtag SHOULD be omitted when it 
> adds no distinguishing value to the tag or when 
> the primary or extended language subtag's 
> record in the subtag registry includes a 
> 'Suppress-Script' field listing the applicable 
> script subtag."

I am concerned that overloading the use of 
'script' in this way is dangerous, and further, I 
am not convinced that we need to differentiate 
written from spoken language.  If it turns out 
that we do, we should choose a different 
mechanism where that is the only meaning.

>
>  So, when it is clear from the context if the 
> language tag represents written vs spoken 
> language, then no Script subtag is needed, but 
> if the tag is used in a place where it can be 
> ambigous, then a tag without Script means 
> spoken and a tag with Script means written.
>
>  Also where written is used in an unusual 
> context, the Script subtag would be used to 
> indicate that it is written. E.g. If captions 
> are overlaid in video, a language tag for the 
> video stream including the Script subtag would 
> make the fact clear that that language is there 
> in text form. ( as distinguished from seeing a 
> person talking that language. )
>
>  /Gunnar
>
>
>>>   I think this text is potentially harmful, as 
>>> it might interfere with the needs of senders 
>>> and clients to distinguish text based on a 
>>> variety of factors and ignores the fact that 
>>> some language variation is not mutually 
>>> comprehensible at the primary language level.
>>
>>  I am very confused.  The text explicitly says 
>> "unless the languages might be mutually 
>> incomprehensible without them" so how can you 
>> say that the text ignores cases where subtags 
>> are needed for mutual comprehensibility?
>>
>>>
>>>   An implementation restriction to the primary 
>>> language subtag would be a disadvantage to 
>>> languages that have important script, region, 
>>> or other variations such as extlang or 
>>> variant. BCP 47 has a whole section 
>>> (http://tools.ietf.org/html/bcp47#section-4.1) 
>>> about the choice of language tag that 
>>> basically recommends similar things and I 
>>> understand why it's important for senders not 
>>> to add unnecessary subtags. But I think you'd 
>>> be better off not having quite so much 
>>> normative language in this specification and 
>>> a more focused recommendation that does not 
>>> impinge on the needs of senders and clients 
>>> to provide adequate language information.
>>
>>  Please keep in mind that the text in question 
>> uses SHOULD and RECOMMENDED, not MUST.  That 
>> means that when there is a good reason to 
>> deviate, and the implications of deviating are 
>> well understood, it is acceptable and does not 
>> violate conformance.
>>
>>  I believe that the text in question does a 
>> good job of guiding implementations to 
>> maximally-interoperable behavior without 
>> forcing problematic behavior in those cases 
>> where subtags are needed.
>>
>
>  _______________________________________________
>  SLIM mailing list
>  [email-masked]
>  https://www.ietf.org/mailman/listinfo/slim

-------------- Randomly selected tag: ---------------
Cabbage:  A familiar kitchen-garden vegetable about as large and wise
as a man's head.