Subject: Re: [Slim] I-D Action: draft-ietf-slim-negotiating-human-language-02.txt

From: "Doug Ewell" <[email-masked]>
Date: Thu, 21 Jul 2016 08:05:18 -0700

Randall Gellens wrote:

>> You should correct the language tag in the 
>> example for American Sign Language in video . 
>> it is 'ase' , not 'sgn-US' ( sgn-US was used 
>> before but was depreciated in 2009 )
>
> My apologies, I looked in an outdated version of 
> the IANA registry by accident. I was actually 
> surprised to see it listed as 'sgn-US' rather 
> than 'ase' ('ase' was listed as a different 
> spoken language).

As an application of BCP 47, SLIM needs to use the current Language
Subtag Registry located at:

http://www.iana.org/assignments/language-subtag-registry/language-subtag-registry

The relevant records in the Registry are:

Type: language
Subtag: ase
Description: American Sign Language
Added: 2009-07-29

and

Type: redundant
Tag: sgn-US
Description: American Sign Language
Added: 2001-03-02
Deprecated: 2009-07-29
Preferred-Value: ase

The fields "Deprecated" and "Preferred-Value" in the latter record are
important.

--
Doug Ewell | Thornton, CO, US | ewellic.org

---

From: Randall Gellens <[email-masked]>
Date: Thu, 21 Jul 2016 08:24:37 -0700

At 8:05 AM -0700 7/21/16, Doug Ewell wrote:

>  Randall Gellens wrote: >> You should correct the language tag in 
> the >> example for American Sign Language in video . >> it is 'ase' 
> , not 'sgn-US' ( sgn-US was used >> before but was depreciated in 
> 2009 ) > > My apologies, I looked in an outdated version of > the 
> IANA registry by accident. I was actually > surprised to see it 
> listed as 'sgn-US' rather > than 'ase' ('ase' was listed as a 
> different > spoken language). As an application of BCP 47, SLIM 
> needs to use the current Language Subtag Registry located at: 
> The relevant records in the Registry are: Type: language Subtag: 
> ase Description: American Sign Language Added: 2009-07-29 and Type: 
> redundant Tag: sgn-US Description: American Sign Language Added: 
> 2001-03-02 Deprecated: 2009-07-29 Preferred-Value: ase The fields 
> "Deprecated" and "Preferred-Value" in the latter record are 
> important. -- Doug Ewell | Thornton, CO, US | ewellic.org

Yes, already fixed in -04, which is published.  I was accidently 
looking in an old version of the registry when I first added the 
example.

-- 
Randall Gellens
Opinions are personal;    facts are suspect;    I speak for myself only
-------------- Randomly selected tag: ---------------
100 blocks of crud on the disk,
100 blocks of crud!
You patch a bug, and dump it again:
101 blocks of crud on the disk!...