Subject: [Slim] Variations in display names

From: Brian Rosen <[email-masked]>
Date: Wed, 20 Jul 2016 16:49:23 +0200

I am trying to find folks to prototype and interop test -multilanguage.  I had some possible users look at the draft, and one of them observed that they would like to modify the display name in the From based on language, but the text expressly forbids From from being in the labeled part.

Do we have any appetite to allow this?

Brian

---

From: Nik Tomkinson <[email-masked]>
Date: Wed, 20 Jul 2016 17:04:39 +0100

Hi Brian,

Thanks very much for asking others to look at the draft.

The restriction was added in the latest version to attempt to avoid the
issue highlighted in the paragraph I added to the security considerations.
I don't mind either relaxing the restriction or removing it completely as
long as it is clear enough that the impersonation risk is there and that
the From values in the language message parts correspond to the same sender.

I am assuming that the differences that your user requires are cosmetic
rather than a different email address.

There may be confusion because the email listing (eg. inbox list of
summaries) is likely to show the top-level sender but the detail (when
clicked on) is likely to show the From value in the selected part.

Nik.

On 20 July 2016 at 15:49, Brian Rosen <[email-masked]> wrote:

> I am trying to find folks to prototype and interop test -multilanguage.  I
> had some possible users look at the draft, and one of them observed that
> they would like to modify the display name in the From based on language,
> but the text expressly forbids From from being in the labeled part.
>
> _______________________________________________
> SLIM mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/slim
>

-- 

-----------------------------------------------------------------
Multiple Language Content Type Internet Draft:

<http://datatracker.ietf.org/doc/draft-tomkinson-multilangcontent/>
https://datatracker.ietf.org/doc/draft-ietf-slim-multilangcontent/
<http://datatracker.ietf.org/doc/draft-tomkinson-slim-multilangcontent/>

-----------------------------------------------------------------

---

From: Brian Rosen <[email-masked]>
Date: Wed, 20 Jul 2016 18:11:43 +0200

Yeah, I’d like to at least relax it, stating that the email address has to be the same.
Yes, this is cosmetic.

I get your point about the top level sender

Brian

> On Jul 20, 2016, at 6:04 PM, Nik Tomkinson <[email-masked]> wrote:
> 
> Hi Brian,
> 
> The restriction was added in the latest version to attempt to avoid the issue highlighted in the paragraph I added to the security considerations. I don't mind either relaxing the restriction or removing it completely as long as it is clear enough that the impersonation risk is there and that the From values in the language message parts correspond to the same sender.
> 
> I am assuming that the differences that your user requires are cosmetic rather than a different email address.
> 
> There may be confusion because the email listing (eg. inbox list of summaries) is likely to show the top-level sender but the detail (when clicked on) is likely to show the From value in the selected part.
> 
> Nik.
> 
> On 20 July 2016 at 15:49, Brian Rosen <[email-masked] <mailto:[email-masked]>> wrote:
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/slim <https://www.ietf.org/mailman/listinfo/slim>
> 
> 
> 
> -- 
>  <http://datatracker.ietf.org/doc/draft-tomkinson-multilangcontent/>https://datatracker.ietf.org/doc/draft-ietf-slim-multilangcontent/ <http://datatracker.ietf.org/doc/draft-tomkinson-slim-multilangcontent/>

---

From: Nik Tomkinson <[email-masked]>
Date: Wed, 20 Jul 2016 18:27:54 +0100

Thanks Brian,

what about:

removing "and SHOULD NOT have a From field"

and

inserting "If there is a From field present, its value MUST/SHOULD include
the same email address as the top-level From header although the display
name MAY be a localised version."

If so, I would lean towards MUST rather than SHOULD seeing as we are
relaxing the part that is most useful.

Nik.

On 20 July 2016 at 17:11, Brian Rosen <[email-masked]> wrote:

>> I am trying to find folks to prototype and interop test -multilanguage.
>> I had some possible users look at the draft, and one of them observed that

--

---

From: Brian Rosen <[email-masked]>
Date: Wed, 20 Jul 2016 19:29:30 +0200

Works for me, and I’m happy with MUST

Brian

> On Jul 20, 2016, at 7:27 PM, Nik Tomkinson <[email-masked]> wrote:
> 
> Thanks Brian,
> 
> what about: 
> 
> inserting "If there is a From field present, its value MUST/SHOULD include the same email address as the top-level From header although the display name MAY be a localised version."
> 
> If so, I would lean towards MUST rather than SHOULD seeing as we are relaxing the part that is most useful.
> 
> Nik.
> 
> On 20 July 2016 at 17:11, Brian Rosen <[email-masked] <mailto:[email-masked]>> wrote:
>> On Jul 20, 2016, at 6:04 PM, Nik Tomkinson <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Hi Brian,
>>

---

From: Nik Tomkinson <[email-masked]>
Date: Wed, 20 Jul 2016 19:08:20 +0100

Thanks,

I have updated this but left the "SHOULD NOT have a From field" restriction
in the language independent part because for this use case it does not make
sense to allow localised version of the display name when the translation
was not matched by the email client. In this case both the Subject and From
values should be taken from the top level values.

I will submit a new version tomorrow when other people have had a chance to
comment too on this and any other parts of the draft.

Nik.

--