Subject: [Slim] I-D Action: draft-ietf-slim-multilangcontent-06.txt

From: [email-masked]
Date: Wed, 12 Oct 2016 09:35:43 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Selection of Language for Internet Media of the IETF.

        Title           : Multiple Language Content Type
        Authors         : Nik Tomkinson
                          Nathaniel Borenstein
	Filename        : draft-ietf-slim-multilangcontent-06.txt
	Pages           : 19
	Date            : 2016-10-12

Abstract:
   This document defines an addition to the Multipurpose Internet Mail
   Extensions (MIME) standard to make it possible to send one message
   that contains multiple language versions of the same information.
   The translations would be identified by a language tag and selected
   by the email client based on a user's language settings.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-slim-multilangcontent/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-slim-multilangcontent-06

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-slim-multilangcontent-06

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Nik Tomkinson <[email-masked]>
Date: Wed, 12 Oct 2016 17:49:33 +0100

Hi All,

as you will have seen there is a new I-D version for the non-real-time
document. This includes 2 updates:

Changing the Translation-Type parameter of the Content-Language field to be
a field in its own right. This is to reduce the risk to existing
implementations that deal with Content-Language because RFC 3282 for
Content-Language does not define the field as having parameters at all, so
adding a parameter may break existing code.

The inclusion of the IANA registration templates for the
multipart/multilingual type and the new Translation-Type field.

Please take a look and comment if you think there is anything left to do.

Nik.

On 12 October 2016 at 17:35, <[email-masked]> wrote:

> _______________________________________________
> SLIM mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/slim
>

-- 

-----------------------------------------------------------------
Multiple Language Content Type Internet Draft:

<http://datatracker.ietf.org/doc/draft-tomkinson-multilangcontent/>
https://datatracker.ietf.org/doc/draft-ietf-slim-multilangcontent/
<http://datatracker.ietf.org/doc/draft-tomkinson-slim-multilangcontent/>

-----------------------------------------------------------------

---

From: Natasha Rooney <[email-masked]>
Date: Thu, 13 Oct 2016 14:34:10 +0000

Thanks Nik!

Guys - please take a look when you can and post your comments to the list.

Natasha

Natasha Rooney | Internet Engineering Director | Internet and Web Team | Technology | GSMA | [email-masked]<mailto:[email-masked]> | +44 (0) 7730 219 765 | @thisNatasha | Skype: [email-masked]<mailto:[email-masked]>

On 12 Oct 2016, at 17:49, Nik Tomkinson <[email-masked]<mailto:[email-masked]>> wrote:

Hi All,

as you will have seen there is a new I-D version for the non-real-time document. This includes 2 updates:

Changing the Translation-Type parameter of the Content-Language field to be a field in its own right. This is to reduce the risk to existing implementations that deal with Content-Language because RFC 3282 for Content-Language does not define the field as having parameters at all, so adding a parameter may break existing code.

The inclusion of the IANA registration templates for the multipart/multilingual type and the new Translation-Type field.

Nik.

On 12 October 2016 at 17:35, <[email-masked]<mailto:[email-masked]>> wrote:

Abstract:

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org/>.

_______________________________________________
SLIM mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/slim

--

<http://datatracker.ietf.org/doc/draft-tomkinson-multilangcontent/>https://datatracker.ietf.org/doc/draft-ietf-slim-multilangcontent/<http://datatracker.ietf.org/doc/draft-tomkinson-slim-multilangcontent/>

_______________________________________________
SLIM mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/slim

This email and its attachments are intended for the above named only and may be confidential. If they have come to you in error you must take no action based on them, nor must you copy or show them to anyone; please reply to this email or call +44 207 356 0600 and highlight the error.